Jump to content

Specific vessels causing CTD on launch.

Recommended Posts

The AE-FF2 airstream pro and likely other fairings are causing CTD on launch when there is any clipping at all and can corrupt a save as well, 0ing out funds in career and  if the save manages to revert and saves to the persistent back up deleting the craft from the pad in the tracking center will result in a high pitch audible scream til the game ctds again.

Rigorously tested while live streaming on twitch. The episde link is provided below and provides about 2 hours of test data showing different configs it was tested in. Oddly, the configuration worked once, normally in a engineering sandbox mode, and then crashed again when almost the same exact vehicle was reloaded and the same modifications were made in career mode. All parts were rigorously tested to confirm it was not a part issue of any sort whether stock or mod as they would all load to the pad independently just fine it was just when they were brought together in a fairing in a particular combination that this very serious crash style occurred.

I suspect it has something to with fairing / engine interactions with colliders but even inverted the error still occurred. Submitting error reports generated by the game as well as a twitch tv link to the video where I attempted to diagnose the cause myself. I also suspect it may have something to do with the game thinking the craft is somewhere else for some bizarre reason other than the launch pad because it always switches scenes to space wtih 0 coms though still showing the stages on the left as if it never left the pad. The interaction is with KSP Intersetellar Extended Candle engines, but could conceivably happen with others though I ran out of time to test that theory.

Here is the logs, the save files associated with the repeated testing CTDs:


Here is the video on Twitch TV that contains the troubleshooting effort. It starts around 2:15 to 2:30 and runs until the end about 4:30, a full 2 hours of rigorously attempting to identify and troubleshoot the problem. Inverting the payload in the fairing hangar also did not solve the problem.


Craft file causing the CTD:

https://www.dropbox.com/s/7ywx2gx5uub7bgd/Micro Probe 2.craft?dl=0

update: An even more bizarre complication has arisen, this craft can be launched in sandbox, it only crashes in career. Repeatedly tested in career, with and without the decoupler, with and without the fairing, with and without it being at the bottom of the inter-staging rack. Unbelievably odd. It has to do something with the name and perhaps the initial game crash? Going to destroy the craft in this particular save, rebuild it from scratch, rename it and see what happens.

Rebuilt it exact to spec under a new name, still crashes in career only, new name Mun Micro Probe 2. The original craft that it was based on is also crashing. We're making progress in narrowing down cause. Updating title. Suspect previous deletion of a probe in space did not complete properly in the tracking center corrupting the save and possibly making it so that all probe cores of the same type launched now register at a random point in space rather than at launchpad.

Left the name unchanged, stripped down to probe core, launched. Stable with just Hecs core, went back reloaded primary craft file so that once again all parts were present, launched, ctd. Something is broken on the payload, still working out what. This craft launched before with no problem, something has changed.

Removed all parts from corrupted craft that were mod-based and only utilized its stock part elements, the craft deployed without crash. Adding back the navigatin light and launching, then adding back the candle engines and launching, will update again momentarily.

Navlights confirmed good. No crash. Re-add candle engines.. no crash? Craft is mysteriously stable again as a whole after re-add of parts. Possible issue with saved crafts from between KSP IE updates.

Removed and re-added candle engines to the full payload/delivery booster assembly and still crashing, so re-adding the engines does not always fix whatever is underlying this. Debugger menu will not open when the view is changed to space prior to ctd and funds are wiped.

The crash dumps are indicating some form of bizarre memory access error. Putting ksp into admin mode. But why only affecting this particular craft file and why only career?

Craft loaded without crash after 3 way coupler removed, landing gear, candle engines, and the nav lights were removed. Adding back only sm-3 mount and putting on the fairing rack and reloading. Still stable. Adding landing LT-1 gear back to the sm-3 mount, retracted as before. Normal launch. Adding back candle engines. Normal Launch? Adding back nav light. Normal launch!


Conclusion: KSP not running in admin mode was causing a random failure to access some part of the craft file for reasons that are unexplained as all the parts in this build have been utilized before. This began after the recent ksp ie mod update, so uncertain if interaction has been caused by updates. Solution: Run KSP in admin mode, this was not a part or apparent staging/physics error. Why it has chosen to randomly manifest a memory access error now remains undetermined, but launch is able to progress without error.

Edited by Maelstrom Vortex
Link to comment
Share on other sites

This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...