MOARdV

[1.3.0] Distant Object Enhancement bis v1.9.1 (8 July 2017)

518 posts in this topic

This is a maintenance release of Rubber Ducky's Distant Object Enhancement.

I've compiled it against KSP 0.25, and I've incorporated some bug fixes (courtesy Anatid and Valerian, as well as one of my own). I've also included a couple of enhancements (optional mouseover labels for visible flares, courtesy Anatid, and the ability to edit DOE settings in flight, instead of only in the Space Center scene).

No pix, no clix, so:

http://imagizer.imageshack.us/v2/xq90/540/1yP53F.png

Sorry it's dark - that's a quickie space plane, Moho, Duna, Eve, and Gilly, and the darkened sky. The original thread has much nicer pictures. I'm not so artistically inclined :) .

This version keeps v1.3.1's CC Attribution 4.0 International license.

Download v1.4.0 here: GitHub

Source code here: Github source

Thank you for doing this. I've been wanting to get it into the next release of EVE, but time is stretched very far for me right now.

Share this post


Link to post
Share on other sites

thank you thank you thank you! I am going to download this NOW and use it! I [censored] love the DOE mainly because I can look up and see my captured asteroid orbiting over the space center at 200k up... and as soon as I get it set up, I'm going to send up a few probes (after I get my RT2 network set up) with some ART (Asteroid recycling tech by USI, the Karbonite creators) stuff on them and turn that floating D class asteroid into a re-fueling station, and hopefully be able to grab a few more and set them up as well!

Share this post


Link to post
Share on other sites
are you talking about the config thing? if that's all I have to do then I think i'll do it... otherwise I could probably wait....

I have not fix that problem. There may be a fix in the works on the CactEye side of things. However, I did make it so you can switch flares on and off while in flight, provided you use Blizzy's Toolbar. It's a workaround, at least.

Share this post


Link to post
Share on other sites
No, they will not conflict (I use both). Even better, Valerian, who made PlanetShine, submitted a fix to DOE so that the planet shine doesn't affect the other planet flares.

Thank you for publishing that fixed version :D, I will link this thread on PlanetShine for DOE users ^^

Edited by Valerian

Share this post


Link to post
Share on other sites

so... had my first experience with the Sun... turns out- full zoom and random spinning causes explosions... hehe.... atleast it was pretty... but sadly I didn't get a good shot of the planet I wanted... maybe next time I'll just aim for the Mun or Minmus... maybe Kerbin!

oh, heres an Idea for the Cacti guy, your in contact with him right? anyway- Solar Telescope! for observing the magnetic fields around Kerbol, and for intentionally looking directly at the sun, can also be aimed at planets to see THEIR magnetic field, maybe even a radar dish to listen to the magneto-spheres

Share this post


Link to post
Share on other sites

I'm having a problem with this mod. Most of it works great, but it won't remember my chosen setting for maximum skybox brightness. I want to set it at .65 for recording videos, but I have to reset it for every single flight. Actually launch the flight, change the setting, exit out to the main menu, then load the saved flight; that's the only way my custom setting will work. Once that flight lands and is recovered, repeat the whole process for the next flight.

Share this post


Link to post
Share on other sites
I'm having a problem with this mod. Most of it works great, but it won't remember my chosen setting for maximum skybox brightness. I want to set it at .65 for recording videos, but I have to reset it for every single flight. Actually launch the flight, change the setting, exit out to the main menu, then load the saved flight; that's the only way my custom setting will work. Once that flight lands and is recovered, repeat the whole process for the next flight.

have you tried setting the skybox brightness at the space center? It clearly says on the main page "some features will not save during flight", so, try saving the skybox brightness at the space center and see if that works.

Edit: whats your youtube, I'm quriouse about your videos now

Share this post


Link to post
Share on other sites
have you tried setting the skybox brightness at the space center? It clearly says on the main page "some features will not save during flight", so, try saving the skybox brightness at the space center and see if that works.

Edit: whats your youtube, I'm quriouse about your videos now

It's in his signature, to the right :P

Share this post


Link to post
Share on other sites
have you tried setting the skybox brightness at the space center? It clearly says on the main page "some features will not save during flight", so, try saving the skybox brightness at the space center and see if that works.

Edit: whats your youtube, I'm quriouse about your videos now

Yes, that was the issue! I didn't RTFM properly. Again. :blush:

Share this post


Link to post
Share on other sites

I thank you for supporting this mod!

But I found the root of the issue with dynamic dimming.

It looks like bad copypaste (excuse me for code in thread. I might add an issue to github later):

if (skyboxBrightness.HasValue("debrisBrightness"))

{

SkyboxBrightness.maxBrightness = float.Parse(skyboxBrightness.GetValue("maxBrightness"));

}

Share this post


Link to post
Share on other sites
Anyone else seeing the phenomenon where, in map view, the flares for distant objects do not move with the objects themselves as you zoom in and out?

I'm having odd behavior in the map view as well. Zooming way out, and the flares reappear in the same spot no matter what. Zooming way out in external vessel view also causes the flares to shift position far more than they should on all flares, regardless of proximity. I also don't seem to have any mouse-over popups.

Share this post


Link to post
Share on other sites
I thank you for supporting this mod!

But I found the root of the issue with dynamic dimming.

It looks like bad copypaste (excuse me for code in thread. I might add an issue to github later):

if (skyboxBrightness.HasValue("debrisBrightness"))

{

SkyboxBrightness.maxBrightness = float.Parse(skyboxBrightness.GetValue("maxBrightness"));

}

Thank you for submitting that on GitHub. Yeah, it was sloppy copy/paste. It's fixed now, and I'll get a release out once I look at...

I'm having odd behavior in the map view as well. Zooming way out, and the flares reappear in the same spot no matter what. Zooming way out in external vessel view also causes the flares to shift position far more than they should on all flares, regardless of proximity. I also don't seem to have any mouse-over popups.

I've seen the flares in the wrong place in flight as well. I have not looked too closely at the code, but I want to get that fixed for the next release.

Dumb question: did you enable the mouse-over popups in the menu (required Toolbar)? If so, you should at the very least see planetary labels pop up.

The labels for debris / craft don't always appear, either. I know they won't show up if the flare is too dark, but there are other times I think they should be visible. I am going to look into that code, as well. Hopefully, I can get to the bottom of these this weekend.

Share this post


Link to post
Share on other sites
Thank you for submitting that on GitHub. Yeah, it was sloppy copy/paste. It's fixed now, and I'll get a release out once I look at...

I've seen the flares in the wrong place in flight as well. I have not looked too closely at the code, but I want to get that fixed for the next release.

Dumb question: did you enable the mouse-over popups in the menu (required Toolbar)? If so, you should at the very least see planetary labels pop up.

The labels for debris / craft don't always appear, either. I know they won't show up if the flare is too dark, but there are other times I think they should be visible. I am going to look into that code, as well. Hopefully, I can get to the bottom of these this weekend.

Last time I looked at the code I saw that flares were generated 750km from the ship, which is not an issue when your are close to the ship, but when you zoom out it's likely causing the reported issues.

I'm not sure, but it seems that game objects for some layers are only rendered when close to the camera, and my fix to set the layer to 10 instead of 0 might have "fixed" that as well: therefore you should try to set the flares much farther than 750km, I think it should work.

Share this post


Link to post
Share on other sites

Awesome, thanks for the update! Does this version still require Blizzy's Toolbar, or is its use optional?

Share this post


Link to post
Share on other sites

Awesome. The previous version was still working for me but I'm glad it's being updated to keep up with new releases!

Share this post


Link to post
Share on other sites
Awesome, thanks for the update! Does this version still require Blizzy's Toolbar, or is its use optional?

Still requires the toolbar to change settings. I've debated adding support for the in-game app launcher thing, or allowing either to be used. That requires me to get the time to look into it.

Share this post


Link to post
Share on other sites
Still requires the toolbar to change settings. I've debated adding support for the in-game app launcher thing, or allowing either to be used. That requires me to get the time to look into it.

Settings can be changed in settings.cfg. :) In most KSP installs prefer not to have the toolbar, because I never use it anyway.

However, since my previous post I've noticed that this mod doesn't work at all without the toolbar. No flares, no skybox dimming, no distant vessels, nothing. This was also the case in DOE 1.3 (the update that added toolbar support, or rather the requirement), which was the reason I asked in the first place.

Share this post


Link to post
Share on other sites
Settings can be changed in settings.cfg. :)

True, although not everyone is comfortable manually hacking text files :)

However, since my previous post I've noticed that this mod doesn't work at all without the toolbar. No flares, no skybox dimming, no distant vessels, nothing. This was also the case in DOE 1.3 (the update that added toolbar support, or rather the requirement), which was the reason I asked in the first place.

I didn't realize it didn't work at all without the Toolbar (I use the Toolbar, so I hadn't specifically tested without it). The mod needs to have some sort of in-game interface - either Toolbar or AppLauncher. Forcing players to find and edit config files by hand is not the best user experience. I'll put that on my short list of things to do for a sooner-rather-than-later update.

Share this post


Link to post
Share on other sites
Anyone else seeing the phenomenon where, in map view, the flares for distant objects do not move with the objects themselves as you zoom in and out?

I don't know if this will be helpful, but I captured a short little video that demonstrates the phenomenon. Obviously I have some mods installed, so I'm going to try it with only DOE and see if it behaves the same.

http://youtu.be/DE0oPU8V1pQ

Notice that the flare for Jool doesn't follow where Jool actually is, while zooming out in map mode.

Thanks for keeping this mod going!!!!!

Edit:

Same behavior when DOE and Toolbar are the only mods.

Edited by nukeboyt

Share this post


Link to post
Share on other sites

Has anyone reported issues with DOE and converting textures to DDS? I used DDS4KSP and DDSLoader, and it works with my other mods fine, but the flares in DOE have been rendered as squares, suggesting the textures didn't compress and load properly....

Share this post


Link to post
Share on other sites
I don't know if this will be helpful, but I captured a short little video that demonstrates the phenomenon. Obviously I have some mods installed, so I'm going to try it with only DOE and see if it behaves the same.

http://youtu.be/DE0oPU8V1pQ

Notice that the flare for Jool doesn't follow where Jool actually is, while zooming out in map mode.

Thanks for keeping this mod going!!!!!

Same for me but with every planet flare

Share this post


Link to post
Share on other sites
Same for me but with every planet flare

Right. It's every one for me, too. I just showed the one, though.

Share this post


Link to post
Share on other sites
Has anyone reported issues with DOE and converting textures to DDS? I used DDS4KSP and DDSLoader, and it works with my other mods fine, but the flares in DOE have been rendered as squares, suggesting the textures didn't compress and load properly....

If I read the description of DDS4KSP correctly, it converts RGBA images into DXT1, which does not have an alpha channel (well, it has an all-or-nothing alpha channel). The texture for the flare uses alpha, so it'd have to be converted to DXT5.

Share this post


Link to post
Share on other sites

Hey I just had a quick suggestion, I was thinking now that you have it so that you can see the name of a flare when you hover your mouse over it that it would be cool to have an option to turn on the names for all the flares in the scene, also with the ability to filter to show only celestials, vessels, or debris.

Thank you for updating and improving this mod! :)

Share this post


Link to post
Share on other sites

Dumb question: did you enable the mouse-over popups in the menu (required Toolbar)? If so, you should at the very least see planetary labels pop up.

Not a dumb question at all, I didn't realize it wasn't on by default, thanks.

If the flares are only being rendered at a 750km distance, then yes that would account for them shifting so much when zooming way out. Still wonder what's up with the map view though. While you zoom in and out, the flares disappear, but then as soon as you stop zooming they pop back up in the exact same position. I don't remember the original version of DOE showing flares in the map view, perhaps it's better to disable them there altogether?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now