Question

So I just bought a pair of Logitech T16000Ms and I was excited to have one stick for pitch and roll and a second for translation but I can't seem to get axis from the second joystick to assign.   It seems to be that the problem is related to the fact that both joysticks are identical and have the same name in windows.  I confirmed this with another joystick I have in my collection.  One that I don't really want to use.  I'd prefer not buying another controller if I don't have to.  

What I'm really asking about is if this is a problem that can be solved with a work around or future update.  

Any info would be appreciated.

Share this post


Link to post
Share on other sites

2 answers to this question

Recommended Posts

  • 0

Well ... i would like to know about this problem too. :D  only what I can imagine is put second Joystick through Arduino...

Share this post


Link to post
Share on other sites
  • 0

You could try the procedure described in the link below, which allows changing the 'friendly name' of each device (the name shown in the control panel/device manager). But this will only work if KSP also refers to the joysticks by that name... I don't know if that is the case.

Warning: note that it requires using regedit, so take precautions to ensure you can undo what you change, just in case (save the registry keys you're going to edit, make backups, take notes, etc)

https://www.avoiderrors.net/rename-devices-device-manager/

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now