• 0
Sign in to follow this  
Ron Devu

Undocking bug has returned

Question

  I'm building a small station at Minmus. On my last launch the stack was engines, fuel, a three man capsule, a pair of linked Clampotron Jrs and a 4 man habitat, an inverted decoupler and a nose cone. The intent was to deliver fuel and the habitat module. Docking was routine. When it came time to leave, one of the ports was offering the undock option and I clicked it. The ships remained docked. The option to undock was no longer present on either port I brought up an engineer but he can't fix the parts or remove them. I suspect both ports think they are attached to the 3 man capsule. After the failed undocking I noticed certain kinds of spacecraft drift caused by Kerbal helmets clipping into parts  were also causing this port linkage to rotate as if it were some kind of bearing. I had the entire crew on EVA simultaneously trying to grab the parts but alas I was one Kerbal short of the required six.  I have verified that all the tanks engines and command capsules have autostrut disabled. Identical docking ports on the opposite end of the habitat module are working normally.   I'm running version 1.7.3.2594 64 bit with KIS/KAS, no other mods.

 

Interesting fact: when an engineer tries to grab either of the docked ports, the game reports the weight as over 5 tons. Other identical docking ports are easily grabbed.

Share this post


Link to post
Share on other sites

7 answers to this question

Recommended Posts

  • 0

There have been maybe 18 different ways to invoke the same undocking bug in the past. Over time, many reproducible ways have been found to trigger it, those examples got reported to the devs, and the devs fixed those ones. So the undocking bug gets rarer and rarer to encounter over time. The devs need a savegame from just before you actually dock, that consistently reproduces the problem.

What happens is that the moment you dock, the two docking ports get set to the wrong state, which the game remembers. After it happens, the only way to fix it is to use the KML persistence file editor tool, as reported here: 

 

Share this post


Link to post
Share on other sites
  • 0
35 minutes ago, bewing said:

There have been maybe 18 different ways to invoke the same undocking bug in the past. Over time, many reproducible ways have been found to trigger it, those examples got reported to the devs, and the devs fixed those ones. So the undocking bug gets rarer and rarer to encounter over time. The devs need a savegame from just before you actually dock, that consistently reproduces the problem.

What happens is that the moment you dock, the two docking ports get set to the wrong state, which the game remembers. After it happens, the only way to fix it is to use the KML persistence file editor tool, as reported here:

I looked at the solution but it doesn't apply to my situation. He starts with one port offering an undick option that doesn't work, while neither of my ports offers the undock option. Worse yet, the docked assembly has two command modules, one of which is on a lander that was originally launched upside down on its booster and was merged into the build in the VAB. So there were all kinds of fiddles done to convince the VAB to allow this. Basically this deck o cards has been well and truly shuffled.

Welp, looks like my station just acquired some permanent tankage.

p.s I found the validation feature on Steam that you mentioned. First time it found four files it didn't like, next time it found two. No effect on docking tho. But thanks for a very useful suggestion. It also seems that KSP dislikes running for days at a time. My keyboard and mouse were cutting out, then burn calculations went bad and I was estimating burns by eye. I guess the game needs a restart every day or two!

Edited by Ron Devu
ps added

Share this post


Link to post
Share on other sites
  • 0

  What would happen if I planted explosives on the offending parts? How much damage would you expect?

Share this post


Link to post
Share on other sites
  • 0

Had undocking bug first time ever the other day too (and been playing since 0.23 or thereabouts).

2 craft assembled in VAB, docked to each other (via Corvus nose cones).  Launched, undocked, redocked, then couldn't undock again (no undock buttons on either craft). There may have been a load/save between the docking and the attempted second undocking. 
I did manage to get an undock button back after a reload, which worked, so no need to resort to save-file editing.

There may or may not have been autostrutting.

Will see if I have a save/autosave from before the docking to repro.

Share this post


Link to post
Share on other sites
  • 0
1 hour ago, Ron Devu said:

 It also seems that KSP dislikes running for days at a time. My keyboard and mouse were cutting out, then burn calculations went bad and I was estimating burns by eye. I guess the game needs a restart every day or two!

I have to restart the game after three hours at most, or it goes nuts. Gotta release that memory once in a while.

Share this post


Link to post
Share on other sites
  • 0
2 hours ago, Ron Devu said:

I looked at the solution but it doesn't apply to my situation

There are two solutions on that thread. One is old, and doesn't apply. The other is current and works perfectly. It's a little program called KML. You really ought to download it and try it.

Share this post


Link to post
Share on other sites
  • 0
8 hours ago, Ron Devu said:

  What would happen if I planted explosives on the offending parts? How much damage would you expect?

I don't expepct to suffer any damage.  Go ahead, I'll be fine thanks *grin*

Share this post


Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this