Jump to content

Dead mod idea


Recommended Posts

I do apologize for trying to do what I did.

I won't again. 

Your community needs to work out it's priorities in regards to whether it's licenses really mean anything in regards to the authors wishes.

Please close.

Edited by R-T-B
Download Removed Forever
Link to post
Share on other sites
34 minutes ago, zit said:

You're doing the lord's work my dude

KSP is literally unplayable without scatterer

I will supply you with bugs to iron out, thank you

lol I was hoping nobody noticed that case sensitivity issue.  The first release literally could not read configs.

 

Try again?  I did a hotfix.

52 minutes ago, King Arthur said:

Planetshine had its original dev, Valerian, show up earlier saying that he intends on releasing an update for 1.8, so I would hold off on you forking that for now to save everyone unnecessary confusion.

 

I'm reaching out to him as well as all of the above modders, and if they don't like what I'm doing releases will stop.  If I'm interpreting his post right, he's basically coming back because no one else is doing it, which I would happily do for him in his place.

At any rate there can't be much confusion because my builds don't even use the same name.  Heck they don't even look in the same place for configs.  You need my symbolic link tool just to make them work with the old configs, and it's hit and miss.  You know what you are getting into if you download these, and no dev is going to mistake a report on these for his own product.  It'd be pretty unthinkable when the name, configs, and even the logger warns him about every bit of this.

At any rate my planetshine build, named "MyPlanetIsShiny" just dropped.  Same instructions.

https://github.com/R-T-B/MyPlanetIsShiny

Edited by R-T-B
Link to post
Share on other sites
2 minutes ago, R-T-B said:

lol I was hoping nobody noticed that case sensitivity issue.  The first release literally could not read configs.

 

Try again?  I did a hotfix.

yeah i was gonna say this ain't working at all, lemme try again

Link to post
Share on other sites
2 minutes ago, zit said:

yeah i was gonna say this ain't working at all, lemme try again

Delete the old directories it created for good measure (Gamedata/scattererer and Skeedaddle), the old release made a bunch of case sensitivity mistakes and I'm not sure they'll be autocorrected if they already exist.

To be fair to me, it worked before the renaming...  complications lol.

Edited by R-T-B
Link to post
Share on other sites
8 minutes ago, R-T-B said:

Delete the old directories it created for good measure (Gamedata/scattererer and Skeedaddle), the old release made a bunch of case sensitivity mistakes and I'm not sure they'll be autocorrected if they already exist.

To be fair to me, it worked before the renaming...  complications lol.

So I used the 0.6.1 version and ran the CMD file, and it created a folder named "scatterer". I go inside it, and I see shortcuts to scatterer's config...

Click on one, and I get the error:

C:\Program Files (x86)\Steam\steamapps\common\Kerbal Space Program\GameData\scatterer\config (or icon/shaders) is not accessible.

The name of the file cannot be resolved by the system.

Do I need to have scatterer already installed?

(Keep in mind I am not a mod developer by any means and have exactly zero idea how I would even begin to code for Unity/KSP. I just find bugs.)

Edited by zit
Link to post
Share on other sites

Looks like my symbolic links are broken.

It's my renaming tools that's causing all of this, the one that attempts to link the new system to the old configs.

I'll have a fix in a moment.  I hate symbolic links in windows but they really are the best way to do this.

3 minutes ago, zit said:

 

Do I need to have scatterer already installed?

 

No.

Edited by R-T-B
Link to post
Share on other sites
1 minute ago, R-T-B said:

Looks like my symbolic links are broken.

It's my renaming tools that's causing all of this, the one that attempts to link the new system to the old configs.

I'll have a fix in a moment.  I hate symbolic links in windows but they really are the best way to do this.

No.

yeah KSP is blackscreening now

Link to post
Share on other sites
11 minutes ago, zit said:

yeah KSP is blackscreening now

Yeah, broken symbolic links'll do that.  It's looking for files that don't exist, kinda like a black hole.

 

The issue wasn't my compile but rather my linking tool making broken symbolic links (shortcuts).  I run a linux build server and unfortunately, linux uses a different syntax for shortcuts/symbolic links than windows and it screwed me up.

The irony is, I did not detect this because linux works fine.  That's a first.  All my builds were affected too.

Please redownload latest hotfixes, everything is good now though you will have to delete the old directories (scatterer/Skedaddle and Planetshine/MyPlanetIsShiny, both).

Let's get this to actually run on Windows.  Just having Linux support is a little lackluster.

 

PS:  Thanks for being my first bugtester.  You don't know it, but you just saved about 6 repos I am managing from a very embarassing mistake... lol.

Edited by R-T-B
Link to post
Share on other sites

I just wish Squad would implement a stock version of scatterer. Because it just looks so much better when the atmosphere hazes all around the planet and not just on the edges.

Planets look like this:

187_1003705_americas_dxm.png

 

Not this!

google-earth.jpg

Link to post
Share on other sites

Scatterer and planetshine and my complete mod stack just loaded on my windows box.  I guess that's a good sign?  Must've fixed the path bug.  Try the latest.

 

EDIT: Well dang.  Now they are loading but failing to find the configs.  When will the pain from this rename end?  It was working lol.

EDIT:  This is the issue:

hey.png

 

I guess I can't do my config inporter afterall.  Damn.  Let me think on this.

For right now, you might try deleting the "scatterer" directory and seeing if maybe it just works anyways.

Edited by R-T-B
Link to post
Share on other sites
5 minutes ago, zit said:

yeah it still isn't working

Probably the same result?  Loads but no configs?

If so, try deleting the scatterer folder and leaving just the "Skeddaddler" folder.  I am new to modding and the error indicates that maybe the link idea I had is confusing the game.  I have a hunch though it might not even be needed.

If so, that's just one less step to install, so that'd be fine.  I could delete that major PITA finally.

Also, it looks like the first line in scatterer's config.cfg file needs to be capitalized.  I'll make a relase correcting that, but you could also just try it yourself while you wait.

Edited by R-T-B
Link to post
Share on other sites
1 minute ago, DaniDE said:

Dunno what you guys are talking about, but I downloaded this as v 0.61 and it worked out of the box - that or I have a mild stroke and just perceive things that are not there.

 

Lol.  You didn't run my "config linker" tool as instructed, did you?

LOL.  That confirms what I thought.  My tool is breaking things rather than working as intended and...  doing anything good.  I'm, removing it.

Good job not reading the manual, it saved you today.

Edited by R-T-B
Link to post
Share on other sites
1 minute ago, DaniDE said:

Nah sorry, I did not. I should have known I was doing something wrong when everything worked. :)

Thanks for joining the bleeding edge today.

 

Builds updated, tool removed.  I will update the instructions above.  It appears to work now.

Edited by R-T-B
Link to post
Share on other sites

Just a heads-up: in your posts you talk about skedaddle, skeedaddle, and skedaddler. Is this for a specific reason or hype-typos? (Hypos?)

ps. I petition to rename MyPlanetIsShiny to GlowyBall :D 

Link to post
Share on other sites
1 minute ago, Jognt said:

Just a heads-up: in your posts you talk about skedaddle, skeedaddle, and skedaddler. Is this for a specific reason or hype-typos? (Hypos?)

ps. I petition to rename MyPlanetIsShiny to GlowyBall :D 

I can see skedaddle with two ee's.  I think that'd just be a typo as I work off a coding frenzy.  Skedaddler is probably because someone told me I should've named it that and now I can't get it out of head.

Link to post
Share on other sites
19 minutes ago, R-T-B said:

Probably the same result?  Loads but no configs?

If so, try deleting the scatterer folder and leaving just the "Skeddaddler" folder.  I am new to modding and the error indicates that maybe the link idea I had is confusing the game.  I have a hunch though it might not even be needed.

If so, that's just one less step to install, so that'd be fine.  I could delete that major PITA finally.

Also, it looks like the first line in scatterer's config.cfg file needs to be capitalized.  I'll make a relase correcting that, but you could also just try it yourself while you wait.


cheers. Thanks for confirming :) 

 

Link to post
Share on other sites

To be fair I use intentionally bizzare names to make it hard to miss in the logs when these things inevitabily get reported upstream.

Trying to spell them over and over and over is... hard.

Link to post
Share on other sites

At any rate, it's broken right now.  DO not download until morning.  The machine renaming has introduced so many bugs, I can't begin to fix them all. I need to see if there's a better way to tackle this.

Link to post
Share on other sites
1 hour ago, DaniDE said:

Dunno what you guys are talking about, but I downloaded this as v 0.61 and it worked out of the box - that or I have a mild stroke and just perceive things that are not there.

 

Think I might do this once I uninstall my other mods, they could be interfering with it.

Edit: nope.

Edited by zit
Link to post
Share on other sites

Nah, it's the renaming.  It's looking for config nodes that don't exist.  I have a build that might work, but I'm not uploading it this time until I'm sure.

 

I'll post a link with screenshot proof soon.  I never imagined a name change could be so hard.

Link to post
Share on other sites
Guest
This topic is now closed to further replies.
×
×
  • Create New...