BahamutoD

[1.0+] B.Dynamics - Retracting/vectoring engines etc. v1.2.0 (May 6)

Recommended Posts

I recently updated to .24.2 and found that the game crashes whenever I try to load a saved game or start a new one. I've narrowed it down to three mods causing the issue and the BahamutoD pack is one of them (the others are KAX and spaceplanes plus). I've got a crashlog here specific to loading the BD folders into gamedata, any chance you can tell me what's going on?

error.log

https://dl.dropboxusercontent.com/u/19357711/error.log

output_log.txt

https://dl.dropboxusercontent.com/u/19357711/output_log.txt

I never even got to use those retracting RCS jets.

Share this post


Link to post
Share on other sites

Here's a crazy suggestion.

Can a mid-sized docking port with a retractable engine built in be created? (Probably not the most realistic since it couldn't allow for crew transfer, but for docking & resource transfer it's a little more feasible.)

Share this post


Link to post
Share on other sites

It'd be awesome if a few of these parts got TweakScale compatibility. :)

Share this post


Link to post
Share on other sites
I recently updated to .24.2 and found that the game crashes whenever I try to load a saved game or start a new one. I've narrowed it down to three mods causing the issue and the BahamutoD pack is one of them (the others are KAX and spaceplanes plus). I've got a crashlog here specific to loading the BD folders into gamedata, any chance you can tell me what's going on?

error.log

https://dl.dropboxusercontent.com/u/19357711/error.log

output_log.txt

https://dl.dropboxusercontent.com/u/19357711/output_log.txt

I never even got to use those retracting RCS jets.

I didn't see any errors from my plugins. I see some NRE's when loading "US_Core" parts, and the crash was during a FAR operation, check whats up with those first.

Share this post


Link to post
Share on other sites
It'd be awesome if a few of these parts got TweakScale compatibility. :)

You can add TweakScale features to pretty much any parts. Take a look at the cfg files in the GameData/TweakScale folder. Make your own folder under gamedata with your own .cfg. Just copy the format used in the previously mentioned files.

Share this post


Link to post
Share on other sites

I'm not sure if is just me, or what, but i can't get to Kerbalstuff site at all from any of the download links on the forums that link to it. I had this mod before and would like to again, but there's no alternate DL link on the first page... little help?

Share this post


Link to post
Share on other sites

With the animated engines module, it is immediately turning my engine off after its been turned on...any ideas why?

Share this post


Link to post
Share on other sites
I'm not sure if is just me, or what, but i can't get to Kerbalstuff site at all from any of the download links on the forums that link to it. I had this mod before and would like to again, but there's no alternate DL link on the first page... little help?

Sorry for the lateness; I'll put up an alt download link soon.

edit: http://kerbal.curseforge.com/ksp-mods/223741-bdynamics

With the animated engines module, it is immediately turning my engine off after its been turned on...any ideas why?

Is the animation for the engines playing? The way it works is that when you turn it on, it should turn off and play the animation, then turn back on again once the animation has reached a certain point. I can only suggest trying to reinstall it.

Edit: Are you having this problem with engines I made or with a different engine using my plugin?

Edited by BahamutoD

Share this post


Link to post
Share on other sites

Is the animation for the engines playing? The way it works is that when you turn it on, it should turn off and play the animation, then turn back on again once the animation has reached a certain point. I can only suggest trying to reinstall it.

Edit: Are you having this problem with engines I made or with a different engine using my plugin?

It is with an engine I have made myself - No the animation is not playing. So do you think it is having trouble loading the animation/any ideas why?

Share this post


Link to post
Share on other sites

Make sure the animation name you put in the config file is the name of the animation in Unity.

Share this post


Link to post
Share on other sites

BahamutoD, I fell in love with your CritterCrawler. I messed with it a lot and found few weird occurences:

Critter seems to accelerate indefinitely if on even terrain but ONLY if "forward" key is not pressed. If I hold it, it doesn't gain velocity. I release and it's like constant 0.5m/s^2. I don't really know which of these is intended (if it should be like wheel accelerating or like legs having max velocity) but looks like something is off :)

If I retract legs on my vessel (was a little probe), it nicely sits on the bottom. But if I then switch to tracking station vessel disappears on my eyes within like 0.5s and there is one line added in log: "[WRN 20:26:03.141] Vessel Pioneer Moonfarer crashed through terrain on Minmus". Nothing more is related to that in log so I don't think there's reason to post it all. If vessel is left with legs extended, it's all ok.

These are minor issues but I just wanted to let you know if anyone haven't ran into this before.

And second thing, that "Sticky feet" option is awesome! From what I was able to read from source, it works by applying downward force to the CoM, right? There's also line of comment on adding or actually reducing angular momentum but I couldn't find it in code. Anyway, would it be possible to wrap this all into a separate module or using what there already is create a new part that has "sticky feet" option? Would it work with normal wheels? A reaction-wheel-like part that dampens all this tilting for rovers would be incredibly useful I think.

Anyway, thanks for all this great stuff :)

Share this post


Link to post
Share on other sites
Make sure the animation name you put in the config file is the name of the animation in Unity.

I have...that was the first thing I checked. I even tried, instead of using the imported animation, re-animating the part within unity but that didn't work either.

Share this post


Link to post
Share on other sites

BahamutoD, Or someone else with the knowledge

I was messing around with a RATHER large craft that has your engines on them and when i dropped my anchor to slow down to land, The anchor jumped up and took out one of the 4 engines I have. What is needed to make your engines KAS attachable So I'd be able to run another engine out there and have a Kerbal replace the destroyed engine? It is a Loooong way form KSP and I do not want to have to take the hour to get there once more.

I am also going to post this into the KAS thread also, They might know how to make it happen better than here. but it is your mod that I'd like to adjust and was seeing if you might have a clue how to do it.

Share this post


Link to post
Share on other sites
BahamutoD, Or someone else with the knowledge

I was messing around with a RATHER large craft that has your engines on them and when i dropped my anchor to slow down to land, The anchor jumped up and took out one of the 4 engines I have. What is needed to make your engines KAS attachable So I'd be able to run another engine out there and have a Kerbal replace the destroyed engine? It is a Loooong way form KSP and I do not want to have to take the hour to get there once more.

I am also going to post this into the KAS thread also, They might know how to make it happen better than here. but it is your mod that I'd like to adjust and was seeing if you might have a clue how to do it.

you need to add something like this to the cfg of the engine you want it on

	MODULE
{
name = KASModuleGrab
evaPartPos = (0.0, 0.0, -0.15)
evaPartDir = (0,0,-1)
storable = True
storedSize = 4
attachOnPart = True
attachOnEva = False
attachOnStatic = False
}

Share this post


Link to post
Share on other sites

Hello to all.

Has anyone made a mm.cfg mod file for these parts so that they can use real fuels for engines and rcs blocks??

I 'looked' through the posts and did no see and my search showed none.

thanks.

Share this post


Link to post
Share on other sites

I noticed that the gimbal won't work unless you stage the engine.

Bug: Engine Gimbal not workings

steps:

  • Attach XJ-48k to vesel & launch
  • right-click engine and click "activate", throttle up
  • gimbal doesn't respond to inputs

to fix:

  • Add XJ-48k to Staging diagram
  • stage
  • gimbal responds

Not sure if this is also true for the radial ones. Haven't tested it yet.

If you need better data, I can provide screenshots, craft and log files, if you have trouble reproducing it.

Share this post


Link to post
Share on other sites
you need to add something like this to the cfg of the engine you want it on

	MODULE
{
name = KASModuleGrab
evaPartPos = (0.0, 0.0, -0.15)
evaPartDir = (0,0,-1)
storable = True
storedSize = 4
attachOnPart = True
attachOnEva = False
attachOnStatic = False
}

this is not working, It will not place the engine on the surface of the connection, it is wanting to place it with about a inch inside the engine. It does still work but it id not lined up perfect dead center and may case thrust issues. I tried to take off and go back with the 3 engines but when i dropped the anchors to stop myself from moving the bounced around and destroyed my craft and the 40 or so kerbals withing it. Since i went to the space center then went back tot he craft I have lost all them. I am going to remove the anchors and go with another method of slowing down.

Share this post


Link to post
Share on other sites

I think The Crawler works well together with a capsule from Beale's Tantares pack to make a cute little mobile lander for low-grav moons.

I call this The EGG :D

2014-08-29_EGG2.jpg

Share this post


Link to post
Share on other sites
Please, make more jet engines and intake parts, pleaseeee ... God job sir!

Retracktable intakes would be awesome intakes tat in high speed on in vacum u would like to close

Share this post


Link to post
Share on other sites

Anyone know if it'd be possible to make a bipedal version of the Critter Crawler?

'Cause I really wanna make some Mech-suits for my kerbals.

Share this post


Link to post
Share on other sites

Does anyone have any details on how to use multiple critter crawlers in a craft? I had an awesome idea for a vtol that uses them as landing gear, but unless I make the critter crawler the base part it tends to just lock up and refuse to move....

- - - Updated - - -

Anyone know if it'd be possible to make a bipedal version of the Critter Crawler?

'Cause I really wanna make some Mech-suits for my kerbals.

I second the biped request!

Share this post


Link to post
Share on other sites

@Arron

I tried really hard and it never worked :(

I also would like to see more variations of Critter and while we're on topic, did anyone try to make StickyFeet stabilization work without Critter movement (like with stock wheels or whatever)? I couldn't get that to work either.

Share this post


Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.