magico13

[1.4] StageRecovery - Recover Funds+ from Dropped Stages - v1.8.0 (March 11, 2018)

Recommended Posts

Do deployable control surfaces like air brakes affect any SR calculations like terminal velocity?

Share this post


Link to post
Share on other sites
On 2/17/2018 at 6:27 PM, Starwaster said:

Do deployable control surfaces like air brakes affect any SR calculations like terminal velocity?

If they're deployed and you're not using RealChute then it might get counted, but if there's a RealChute parachute on the stage it definitely won't. I haven't tested that situation and it wasn't necessarily designed with that in mind.

Share this post


Link to post
Share on other sites
55 minutes ago, magico13 said:

If they're deployed and you're not using RealChute then it might get counted, but if there's a RealChute parachute on the stage it definitely won't. I haven't tested that situation and it wasn't necessarily designed with that in mind.

I've since tested it out and  it does change terminal velocity so it could make a difference with regards to powered recoveries in that it reduces the speed it has to slow down from... Possibly even enough to make a difference between recovery and no-recovery, but I guess the amount of propellant would have to be really low for that to happen.

Also, if you're interested in replacing the Pound sign with the Kerbal Fund sign, then use this: <sprite=\"CurrencySpriteAsset\" name=\"Funds\" tint=1>. Replace all uses of Pound with that. (tested it out and it works)

Share this post


Link to post
Share on other sites
Album d0zu9bt.jpg will appear when post is submitted

Shortly after downloading this great mod which is working as intended I found a bug which might not be from this mod.

As I was landing on Kerbin Highlands, I sped up time, which surprisingly went all the way to 100x, and then I was notified of successful fly-by of the sun. I haven't even been to the mun yet.

What's that about you think?

Share this post


Link to post
Share on other sites
5 hours ago, kerbini said:
Album d0zu9bt.jpg will appear when post is submitted

Shortly after downloading this great mod which is working as intended I found a bug which might not be from this mod.

As I was landing on Kerbin Highlands, I sped up time, which surprisingly went all the way to 100x, and then I was notified of successful fly-by of the sun. I haven't even been to the mun yet.

What's that about you think?

Not this mod. It just responds to events fired by the game when vessels are going to be destroyed so it can intercept, determine if the vessel can be recovered and award you funds for the recovery.

It doesn't move parts or vessels around or fire any of the game's stock events. That progress event happens because the stock game thinks that debris or vehicle is in solar space. So assuming there is not such in solar space then there's a logic error in the stock game triggering the wrong progress node or body.  (note that even a piece of debris flung out of Kerbin's SOI by some physics bug would probably qualify for the milestone)

 

Share this post


Link to post
Share on other sites

Most of the time I never recieve a crash report for my 2nd stage which I always decouple in sub-orbit of Kerbin. I tried putting aerobrakes on it but made no difference.

Edited by kerbini

Share this post


Link to post
Share on other sites
56 minutes ago, kerbini said:

Most of the time I never recieve a crash report for my 2nd stage which I always decouple in sub-orbit of Kerbin. This last I tried it it could be seen from 29km away. I tired putting aerobrakes on it but made no difference.

I find this happens to me occasionally. I *THINK* it happens only if I am in the tracking station. Not always, but consistently enough that if a stage is important enough for me to recover, then I make sure not to be in the tracking station. (if I really wan to be sure then I put a simple craft on the launch pad for observational purposes) Can you confirm or deny that to be the case for you as well? 

Share this post


Link to post
Share on other sites
9 minutes ago, Starwaster said:

I find this happens to me occasionally. I *THINK* it happens only if I am in the tracking station. Not always, but consistently enough that if a stage is important enough for me to recover, then I make sure not to be in the tracking station. (if I really wan to be sure then I put a simple craft on the launch pad for observational purposes) Can you confirm or deny that to be the case for you as well? 

Tracking station? is that the space center vessel overview? I never use it.

Share this post


Link to post
Share on other sites
1 hour ago, kerbini said:

Tracking station? is that the space center vessel overview? I never use it.

Then how do you switch vessels when you are in the Space Center?

Share this post


Link to post
Share on other sites
8 hours ago, Starwaster said:

Then how do you switch vessels when you are in the Space Center?

I'm new, I've only been to Mun and Minmus, yet to do any kind of satellite or station stuff. I always land before I fly another vessel.

Edited by kerbini

Share this post


Link to post
Share on other sites
1 hour ago, kerbini said:

I'm new, I've only been to Mun and Minmus, yet to do any kind of satellite or station stuff. I always land before I fly another vessel.

Ah so you don't yet have multiple missions going at one time. At some point you'll want to pick up Kerbal Alarm Clock. Helps you focus on individual missions while having multiples going on. (alerts you to important events like maneuver nodes, SOI changes, launch windows for other planetary transfers)

Share this post


Link to post
Share on other sites
14 hours ago, kerbini said:

Most of the time I never recieve a crash report for my 2nd stage which I always decouple in sub-orbit of Kerbin. I tried putting aerobrakes on it but made no difference.

It might be that your second stage is staying too close to the main stage and it isn't being unloaded, the range for that is about 22km. StageRecovery only acts on stages that are unloaded (or about to be unloaded) so it won't help in that case. If you think a bug is occurring you could upload the log file to dropbox/google drive/etc and I can check it out.

Share this post


Link to post
Share on other sites
14 hours ago, kerbini said:

Most of the time I never recieve a crash report for my 2nd stage which I always decouple in sub-orbit of Kerbin. I tried putting aerobrakes on it but made no difference.

Note that if the periapsis of the stage is above 22km it will remain in "orbit" even though it's actually in the atmosphere--game bug, not a Stage Recovery bug.  Careful--if this is what is going on and you switch to the offending stage while it's in the atmosphere it's impossible to switch away until it's either down or destroyed.

Share this post


Link to post
Share on other sites
44 minutes ago, Loren Pechtel said:

Note that if the periapsis of the stage is above 22km it will remain in "orbit" even though it's actually in the atmosphere--game bug, not a Stage Recovery bug.  Careful--if this is what is going on and you switch to the offending stage while it's in the atmosphere it's impossible to switch away until it's either down or destroyed.

It should be noted that the limit is actually based on static pressure (1 kPa) and so the destruction altitude can be different for scaled star systems which may have custom atmosphere curves. For RSS this is somewhere around an altitude of 34km. 

Edited by Starwaster

Share this post


Link to post
Share on other sites

I'm getting the message "x was recovered x km from KSP station". Is that the stock recovery system doing that or this mod? Getting a fraction of my engine's worth back.

Share this post


Link to post
Share on other sites
9 minutes ago, kerbini said:

I'm getting the message "x was recovered x km from KSP station". Is that the stock recovery system doing that or this mod? Getting a fraction of my engine's worth back.

That's Stage Recovery at work.  And yes, you don't get back full value.

1)  The fuel is gone, of course you don't get anything back for it.

2)  Unless you put something down on the launch pad or runway you don't get 100% value for it.  This is stock, Stage Recovery simply uses the same system.

Share this post


Link to post
Share on other sites
On 3/7/2018 at 2:41 PM, Starwaster said:

@kerbini think of it as transportation fees for barges or Super Guppies or something similar

The costs are way too high but that's what the game does.  It doesn't really cost most of the value of a rocket to haul it halfway around Kerbin.  And it certainly doesn't cost 2% of the value of a rover to recover it in front of the hanger rather than on the runway which is farther away.

Edited by Loren Pechtel

Share this post


Link to post
Share on other sites
On 3/10/2018 at 2:24 PM, KerbalBob said:

1.4? as well as KCT cant get it to work

 

3 hours ago, Mark Kerbin said:

I Don't think this works for 1.4

Eta On update?

The ETA is right now. I just put out 1.8.0 with the following changes:

1.8.0 (2018-03-11)
- Built against KSP 1.4.0. Might be backward compatible.
- Pre-recovery now fully recovers vessels and not just kerbals
- Add distance restriction to pre-recovery to prevent it from firing at the wrong time
- Recovery now fires the OnVesselRecovered event but forcibly removes the funds handling and scene changes associated with it
    - The above changes make contracts that require recovering vessels/crew work much better, but keep your timewarp down to 10x or so
- Removed explicit ScrapYard support due to the above changes not requiring it anymore
- Kerbals and Science are now recovered by default and cannot be turned off
- Use funds symbol in stock recovery messages (thanks @Starwaster)

Share this post


Link to post
Share on other sites
3 minutes ago, magico13 said:

 

The ETA is right now. I just put out 1.8.0 with the following changes:

1.8.0 (2018-03-11)
- Built against KSP 1.4.0. Might be backward compatible.
- Pre-recovery now fully recovers vessels and not just kerbals
- Add distance restriction to pre-recovery to prevent it from firing at the wrong time
- Recovery now fires the OnVesselRecovered event but forcibly removes the funds handling and scene changes associated with it
    - The above changes make contracts that require recovering vessels/crew work much better, but keep your timewarp down to 10x or so
- Removed explicit ScrapYard support due to the above changes not requiring it anymore
- Kerbals and Science are now recovered by default and cannot be turned off
- Use funds symbol in stock recovery messages (thanks @Starwaster)

Noiceeeeeeee

A+ Timing

Share this post


Link to post
Share on other sites

I cant seem to get it to work. The window is there but the icon is white-out. When I do launch and separate the stage with parachute, it landed but did not show up in the recovery panel (the same with destroyed parts). There is also no pop up when I press the stagerecovery button in VAB.

Share this post


Link to post
Share on other sites
1 hour ago, Jack Conor said:

I cant seem to get it to work. The window is there but the icon is white-out. When I do launch and separate the stage with parachute, it landed but did not show up in the recovery panel (the same with destroyed parts). There is also no pop up when I press the stagerecovery button in VAB.

Sounds like it could be installed wrong. Make sure there's a StageRecovery folder in GameData and the .dll is in that folder (KSP->GameData->StageRecovery->StageRecovery.dll). If it's installed correctly then I'll need a log file. It moved recently, but I believe that on Windows it's under {User}/AppData/Local

Share this post


Link to post
Share on other sites

Alright the whiteout icon is due to me iinstalling it into the squad folder. Now the icon it normal, but there doesnt seem to be any notification for recovered/destroyed stage even though I had it enabled. And I cant access the stagerecovery tab in the VAB.

I found this iin the output log files

(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

TypeLoadException: Could not load type 'BaseFieldList`2' from assembly 'Assembly-CSharp, Version=0.0.0.0, Culture=neutral, PublicKeyToken=null'.
  at StageRecovery.EditorGUI.BreakShipIntoStages () [0x00000] in <filename unknown>:0 
  at StageRecovery.SettingsGUI.EditorCalc () [0x00000] in <filename unknown>:0 
  at StageRecovery.SettingsGUI.ShowWindow () [0x00000] in <filename unknown>:0 
  at (wrapper delegate-invoke) Callback:invoke_void__this__ ()
  at KSP.UI.Screens.ApplicationLauncherButton.OnTrue (UnityEngine.EventSystems.PointerEventData data, CallType callType) [0x00000] in <filename unknown>:0 
  at UnityEngine.Events.InvokableCall`2[UnityEngine.EventSystems.PointerEventData,KSP.UI.UIRadioButton+CallType].Invoke (System.Object[] args) [0x00000] in <filename unknown>:0 
  at UnityEngine.Events.InvokableCallList.Invoke (System.Object[] parameters) [0x00000] in <filename unknown>:0 
  at UnityEngine.Events.UnityEventBase.Invoke (System.Object[] parameters) [0x00000] in <filename unknown>:0 
  at UnityEngine.Events.UnityEvent`2[UnityEngine.EventSystems.PointerEventData,KSP.UI.UIRadioButton+CallType].Invoke (UnityEngine.EventSystems.PointerEventData arg0, CallType arg1) [0x00000] in <filename unknown>:0 
  at KSP.UI.UIRadioButton.SetState (State state, CallType callType, UnityEngine.EventSystems.PointerEventData data, Boolean popButtonsInGroup) [0x00000] in <filename unknown>:0 
  at KSP.UI.UIRadioButton.ToggleState (CallType callType, UnityEngine.EventSystems.PointerEventData data) [0x00000] in <filename unknown>:0 
  at KSP.UI.UIRadioButton.UnityEngine.EventSystems.IPointerClickHandler.OnPointerClick (UnityEngine.EventSystems.PointerEventData eventData) [0x00000] in <filename unknown>:0 
  at UnityEngine.EventSystems.ExecuteEvents.Execute (IPointerClickHandler handler, UnityEngine.EventSystems.BaseEventData eventData) [0x00000] in <filename unknown>:0 
  at UnityEngine.EventSystems.ExecuteEvents.Execute[IPointerClickHandler] (UnityEngine.GameObject target, UnityEngine.EventSystems.BaseEventData eventData, UnityEngine.EventSystems.EventFunction`1 functor) [0x00000] in <filename unknown>:0 
UnityEngine.DebugLogHandler:Internal_LogException(Exception, Object)
UnityEngine.DebugLogHandler:LogException(Exception, Object)
UnityEngine.Logger:LogException(Exception, Object)
UnityEngine.Debug:LogException(Exception)
UnityEngine.EventSystems.ExecuteEvents:Execute(GameObject, BaseEventData, EventFunction`1)
UnityEngine.EventSystems.StandaloneInputModule:ProcessMousePress(MouseButtonEventData)
UnityEngine.EventSystems.StandaloneInputModule:ProcessMouseEvent(Int32)
UnityEngine.EventSystems.StandaloneInputModule:ProcessMouseEvent()
UnityEngine.EventSystems.StandaloneInputModule:Process()
UnityEngine.EventSystems.EventSystem:Update()
 
(Filename:  Line: -1)

 

Edited by Jack Conor

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.