pjf

The Comprehensive Kerbal Archive Network (CKAN) Package Manager; v1.18.0 [19 June 2016]

Recommended Posts

I get these errors too but I've no idea where this GUIConfig.xml is. All I have is the ckan.exe file that I downloaded. Where do I get the .xml from? computer noob here :(

You should have a ./CKAN/ folder in your ckan.exe directory.

Share this post


Link to post
Share on other sites

I just installed CKAN on a .90 windows 32 program. I'm getting an error on start up of CKAN.

Microsoft .net framework

Unhandled exception has occurer in your application....

The remote server returned an error: (401) Unauthorized

If I hit continue the program does come up but there does not seem to be a list of mods or any thing. I don't know if it's the error or if I just don't know how to use it.

Help?

Lee

Share this post


Link to post
Share on other sites
I just installed CKAN on a .90 windows 32 program. I'm getting an error on start up of CKAN.

Microsoft .net framework

Unhandled exception has occurer in your application....

The remote server returned an error: (401) Unauthorized

If I hit continue the program does come up but there does not seem to be a list of mods or any thing. I don't know if it's the error or if I just don't know how to use it.

Help?

Lee

Same issue here. Github is still up, so that's not causing it...

Share this post


Link to post
Share on other sites
Same issue here. Someone opened an issue on GitHub this morning - https://github.com/KSP-CKAN/CKAN-support/issues/113.

Any chance this has something to do with KSP launching on Monday? I have no idea what servers CKAN checks, so don't know if the launch/update could cause this.

-Patrick

I see that you posted a workaround in the issue and I recommend people use that for now until we've gotten a hold on the situation. This is not due to anything about KSP updating but might be related to github tokens and/or something changing on the github side of things.

For now it seems commandline client is also working without errors so a temporary workaround is to use that as a fallback for now.

Share this post


Link to post
Share on other sites
I see that you posted a workaround in the issue and I recommend people use that for now until we've gotten a hold on the situation. This is not due to anything about KSP updating but might be related to github tokens and/or something changing on the github side of things.

For now it seems commandline client is also working without errors so a temporary workaround is to use that as a fallback for now.

Thanks, Daz. Do you have any clue as to why the AutoUpdate flag changes to true even if you tell it not to?

Share this post


Link to post
Share on other sites
I just installed CKAN on a .90 windows 32 program. I'm getting an error on start up of CKAN.
You should have a ./CKAN/ folder in your ckan.exe directory.

WORKAROUND:

Go to your CKAN folder in your ksp directory, right click on the GUIConfig.xml file and select edit. You will see the auto-update flags as this: <CheckForUpdatesOnLaunch>true</CheckForUpdatesOnLaunch>

<CheckForUpdatesOnLaunchNoNag>true</CheckForUpdatesOnLaunchNoNag>

Change the first line to false and the second line to true if it ins't already.

if the auto-update dialog still pops up, hit the red "x" button in the top right corner (don't choose one of the options).

It should now work.

Share this post


Link to post
Share on other sites
Thanks, Daz. Do you have any clue as to why the AutoUpdate flag changes to true even if you tell it not to?

All I can say is that it shouldn't happen. The auto-update system is supposed to be opt-in and this is a bug which we'll hunt down.

Share this post


Link to post
Share on other sites
All I can say is that it shouldn't happen. The auto-update system is supposed to be opt-in and this is a bug which we'll hunt down.

Thanks! And thank you for CKAN, too - now that it works, I can't believe I've gone this long without it!

Share this post


Link to post
Share on other sites
You just fixed the problem in those 10 minutes? :0.0:

Wow, thanks!

Some things are easier to fix than others, esspecially since I was the one responsible and knew what I'd done to break it from the start :)

im getting a lot of access forbidden errors, that stop the install, and occasionally corrupt the download. this can be a pain with rural internet (1.3Mbps)

this didn't happen on previous versions, what happened? how can i fix it?

- - - Updated - - -

ah, ive discovered why CIT active struts is "currupting" "https://ksp.marce.at/Home == Mods have been permanently taken down due to inappropriate behavior of a community member.

Which mod are you attempting to download that depends on it and I'll have a look to see if I can find a workaround for now. We're aware of the ksp.marce.at problem, see https://github.com/KSP-CKAN/NetKAN/issues/932

Share this post


Link to post
Share on other sites
You should have a ./CKAN/ folder in your ckan.exe directory.

I'm sorry but I don't actually know what you mean here. I click the link to download the latest stable release, I click the ckan.exe download link and it downloads a single file. I have no folder. I don't know what you mean by directory. I have the single ckan.exe file in my download folder which starts up ckan

Share this post


Link to post
Share on other sites
I'm sorry but I don't actually know what you mean here. I click the link to download the latest stable release, I click the ckan.exe download link and it downloads a single file. I have no folder. I don't know what you mean by directory. I have the single ckan.exe file in my download folder which starts up ckan

The CKAN folder should be in your KSP root directory, check there :)

Share this post


Link to post
Share on other sites

Help I can't use this

Error:See the end of this message for details on invoking just-in-time (JIT) debugging instead of this dialog box.

************** Exception Text **************

System.Net.WebException: The remote server returned an error: (401) Unauthorized.

at System.Net.WebClient.DownloadDataInternal(Uri address, WebRequest& request)

at System.Net.WebClient.DownloadString(Uri address)

at CKAN.AutoUpdate.MakeRequest(Uri url)

at CKAN.AutoUpdate.FetchLatestCkanVersion()

at CKAN.Main.Main_Load(Object sender, EventArgs e)

at System.Windows.Forms.Form.OnLoad(EventArgs e)

at System.Windows.Forms.Control.CreateControl(Boolean fIgnoreVisible)

at System.Windows.Forms.Control.CreateControl()

at System.Windows.Forms.Control.WmShowWindow(Message& m)

at System.Windows.Forms.Control.WndProc(Message& m)

at System.Windows.Forms.Form.WndProc(Message& m)

at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

************** Loaded Assemblies **************

mscorlib

Assembly Version: 4.0.0.0

Win32 Version: 4.0.30319.18444 built by: FX451RTMGDR

CodeBase: file:///C:/Windows/Microsoft.NET/Framework64/v4.0.30319/mscorlib.dll

----------------------------------------

ckan

Assembly Version: 0.0.0.0

Win32 Version: 0.0.0.0

CodeBase: file:///C:/Users/Amber/Desktop/ckan%20(3).exe

----------------------------------------

System.Windows.Forms

Assembly Version: 4.0.0.0

Win32 Version: 4.0.30319.18408 built by: FX451RTMGREL

CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Windows.Forms/v4.0_4.0.0.0__b77a5c561934e089/System.Windows.Forms.dll

----------------------------------------

System.Drawing

Assembly Version: 4.0.0.0

Win32 Version: 4.0.30319.18408 built by: FX451RTMGREL

CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Drawing/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.Drawing.dll

----------------------------------------

System

Assembly Version: 4.0.0.0

Win32 Version: 4.0.30319.34238 built by: FX452RTMGDR

CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System/v4.0_4.0.0.0__b77a5c561934e089/System.dll

----------------------------------------

System.Core

Assembly Version: 4.0.0.0

Win32 Version: 4.0.30319.18408 built by: FX451RTMGREL

CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Core/v4.0_4.0.0.0__b77a5c561934e089/System.Core.dll

----------------------------------------

System.Configuration

Assembly Version: 4.0.0.0

Win32 Version: 4.0.30319.18408 built by: FX451RTMGREL

CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Configuration/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.Configuration.dll

----------------------------------------

System.Xml

Assembly Version: 4.0.0.0

Win32 Version: 4.0.30319.34234 built by: FX452RTMGDR

CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Xml/v4.0_4.0.0.0__b77a5c561934e089/System.Xml.dll

----------------------------------------

Microsoft.GeneratedCode

Assembly Version: 1.0.0.0

Win32 Version: 4.0.30319.34234 built by: FX452RTMGDR

CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Xml/v4.0_4.0.0.0__b77a5c561934e089/System.Xml.dll

----------------------------------------

Microsoft.CSharp

Assembly Version: 4.0.0.0

Win32 Version: 4.0.30319.18408

CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/Microsoft.CSharp/v4.0_4.0.0.0__b03f5f7f11d50a3a/Microsoft.CSharp.dll

----------------------------------------

************** JIT Debugging **************

To enable just-in-time (JIT) debugging, the .config file for this

application or computer (machine.config) must have the

jitDebugging value set in the system.windows.forms section.

The application must also be compiled with debugging

enabled.

For example:

<configuration>

<system.windows.forms jitDebugging="true" />

</configuration>

When JIT debugging is enabled, any unhandled exception

will be sent to the JIT debugger registered on the computer

rather than be handled by this dialog box.

- - - Updated - - -

Help I can't use this

Error:See the end of this message for details on invoking just-in-time (JIT) debugging instead of this dialog box.

************** Exception Text **************

System.Net.WebException: The remote server returned an error: (401) Unauthorized.

at System.Net.WebClient.DownloadDataInternal(Uri address, WebRequest& request)

at System.Net.WebClient.DownloadString(Uri address)

at CKAN.AutoUpdate.MakeRequest(Uri url)

at CKAN.AutoUpdate.FetchLatestCkanVersion()

at CKAN.Main.Main_Load(Object sender, EventArgs e)

at System.Windows.Forms.Form.OnLoad(EventArgs e)

at System.Windows.Forms.Control.CreateControl(Boolean fIgnoreVisible)

at System.Windows.Forms.Control.CreateControl()

at System.Windows.Forms.Control.WmShowWindow(Message& m)

at System.Windows.Forms.Control.WndProc(Message& m)

at System.Windows.Forms.Form.WndProc(Message& m)

at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

************** Loaded Assemblies **************

mscorlib

Assembly Version: 4.0.0.0

Win32 Version: 4.0.30319.18444 built by: FX451RTMGDR

CodeBase: file:///C:/Windows/Microsoft.NET/Framework64/v4.0.30319/mscorlib.dll

----------------------------------------

ckan

Assembly Version: 0.0.0.0

Win32 Version: 0.0.0.0

CodeBase: file:///C:/Users/Amber/Desktop/ckan%20(3).exe

----------------------------------------

System.Windows.Forms

Assembly Version: 4.0.0.0

Win32 Version: 4.0.30319.18408 built by: FX451RTMGREL

CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Windows.Forms/v4.0_4.0.0.0__b77a5c561934e089/System.Windows.Forms.dll

----------------------------------------

System.Drawing

Assembly Version: 4.0.0.0

Win32 Version: 4.0.30319.18408 built by: FX451RTMGREL

CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Drawing/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.Drawing.dll

----------------------------------------

System

Assembly Version: 4.0.0.0

Win32 Version: 4.0.30319.34238 built by: FX452RTMGDR

CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System/v4.0_4.0.0.0__b77a5c561934e089/System.dll

----------------------------------------

System.Core

Assembly Version: 4.0.0.0

Win32 Version: 4.0.30319.18408 built by: FX451RTMGREL

CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Core/v4.0_4.0.0.0__b77a5c561934e089/System.Core.dll

----------------------------------------

System.Configuration

Assembly Version: 4.0.0.0

Win32 Version: 4.0.30319.18408 built by: FX451RTMGREL

CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Configuration/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.Configuration.dll

----------------------------------------

System.Xml

Assembly Version: 4.0.0.0

Win32 Version: 4.0.30319.34234 built by: FX452RTMGDR

CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Xml/v4.0_4.0.0.0__b77a5c561934e089/System.Xml.dll

----------------------------------------

Microsoft.GeneratedCode

Assembly Version: 1.0.0.0

Win32 Version: 4.0.30319.34234 built by: FX452RTMGDR

CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Xml/v4.0_4.0.0.0__b77a5c561934e089/System.Xml.dll

----------------------------------------

Microsoft.CSharp

Assembly Version: 4.0.0.0

Win32 Version: 4.0.30319.18408

CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/Microsoft.CSharp/v4.0_4.0.0.0__b03f5f7f11d50a3a/Microsoft.CSharp.dll

----------------------------------------

************** JIT Debugging **************

To enable just-in-time (JIT) debugging, the .config file for this

application or computer (machine.config) must have the

jitDebugging value set in the system.windows.forms section.

The application must also be compiled with debugging

enabled.

For example:

<configuration>

<system.windows.forms jitDebugging="true" />

</configuration>

When JIT debugging is enabled, any unhandled exception

will be sent to the JIT debugger registered on the computer

rather than be handled by this dialog box.

Share this post


Link to post
Share on other sites

You didn't have to post the entire thing. Everything is said in this line:

System.Net.WebException: The remote server returned an error: (401) Unauthorized.

The server refused the connection.

Share this post


Link to post
Share on other sites
Help I can't use this

Error:

************** Exception Text **************

System.Net.WebException: The remote server returned an error: (401) Unauthorized.

at System.Net.WebClient.DownloadDataInternal(Uri address, WebRequest& request)

at System.Net.WebClient.DownloadString(Uri address)

at CKAN.AutoUpdate.MakeRequest(Uri url)

at CKAN.AutoUpdate.FetchLatestCkanVersion()

at CKAN.Main.Main_Load(Object sender, EventArgs e)

at System.Windows.Forms.Form.OnLoad(EventArgs e)

at System.Windows.Forms.Control.CreateControl(Boolean fIgnoreVisible)

at System.Windows.Forms.Control.CreateControl()

at System.Windows.Forms.Control.WmShowWindow(Message& m)

at System.Windows.Forms.Control.WndProc(Message& m)

at System.Windows.Forms.Form.WndProc(Message& m)

at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

Workaround found here https://github.com/KSP-CKAN/CKAN-support/issues/113#issuecomment-96232753

Share this post


Link to post
Share on other sites

So, I've just come home from a month at away with work and started updating all the various things that need updating.

Naturally, one of those was CKAN and my installed mods. Unfortunately, that's where something seems to have gone wrong.

I updated CKAN to the latest version from the OP, but it was asking for my KSP install directory. I keep CKAN in the KSP root directory so thought this a bit odd, but manually pointed to this location anyway but it failed to recognise that path.

I then noticed that KSP had received an update through Steam. I thought this was odd as 1.0 isn't quite out yet, so I'm a bit confused about what the Steam update actually is.

Is it possible this update is affecting CKAN's ability to find the .exe?

Share this post


Link to post
Share on other sites
So, I've just come home from a month at away with work and started updating all the various things that need updating.

Naturally, one of those was CKAN and my installed mods. Unfortunately, that's where something seems to have gone wrong.

I updated CKAN to the latest version from the OP, but it was asking for my KSP install directory. I keep CKAN in the KSP root directory so thought this a bit odd, but manually pointed to this location anyway but it failed to recognise that path.

I then noticed that KSP had received an update through Steam. I thought this was odd as 1.0 isn't quite out yet, so I'm a bit confused about what the Steam update actually is.

Is it possible this update is affecting CKAN's ability to find the .exe?

Without any information about what that update did that's an extremely impossible question to answer. What is your OS and where do you store KSP? Are you able to manually add the installation through commandline?

Share this post


Link to post
Share on other sites

@Dazpoet

Yeah, my bad. I really should have added the other useful info!

OS is Windows 7, KSP is installed in my default Steam location (/Program Files/Steam/SteamApps/common/Kerbal Space Program)

I've tried a KSP version rollback through Steam, and CKAN picked that up as normal (KSP v0.25)

I've just undone the rollback and now CKAN seems to be working correctly.

Very odd!

Share this post


Link to post
Share on other sites
@Dazpoet

Yeah, my bad. I really should have added the other useful info!

OS is Windows 7, KSP is installed in my default Steam location (/Program Files/Steam/SteamApps/common/Kerbal Space Program)

I've tried a KSP version rollback through Steam, and CKAN picked that up as normal (KSP v0.25)

I've just undone the rollback and now CKAN seems to be working correctly.

Very odd!

If the update you experienced somehow altered your readme.txt file that could affect your CKAN experience. Sometimes CKAN also dislikes Program Files folder because it doesn't generally allow changes without administrator priviliges. However if its working again I'll scratch this down to a hiccup somewhere in the matrix.

Share this post


Link to post
Share on other sites

Yeah, not sure what happened!

On an unrelated note, is it worth deprecating/removing the CIT selection of mods from CKAN as they aren't available for download anymore?

Share this post


Link to post
Share on other sites
Yeah, not sure what happened!

On an unrelated note, is it worth deprecating/removing the CIT selection of mods from CKAN as they aren't available for download anymore?

We have an issue report opened about it https://github.com/KSP-CKAN/NetKAN/issues/932

The problem with removing CIT mods is that other mods depend on them so for CKANs sake an alternate mirror would be the best solution. Once I have the time I might start looking at filesize of mods that bundle CIT stuff and then extract them from those as a workaround. It's not a good solution though which has put it on the backburner for now.

Share this post


Link to post
Share on other sites
Hi, after launching CKAN i see next window:

If only i know, I would hide all under a spoiler.

And i have already installed microsoft net frimework? but the error appears again and again.

Same answer as everybody else who reported this in the last few pages. Workaround can be found here https://github.com/KSP-CKAN/CKAN-support/issues/113#issuecomment-96232753

Share this post


Link to post
Share on other sites

I noticed a (I assume) false positive on one virus scanning engine when I sent the latest version of ckan through virus total:

https://www.virustotal.com/en/file/fb3567155ae9d2f4d3b3cdd0aa2c5d37954e855e20c3897487b56dd9798c4f1a/analysis/1430092711/

Tencent shows a result matching the signature "Trojan.Win32.YY.Gen.18".

Thought I'd report it so you could get it sorted out with the company that makes that virus scanning engine.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.