Jump to content

[PC] New PC Build Issues


Recommended Posts

Hello all! Ive just finished building my first PC which I'm pretty happy about. Ive run into some issues. My specs are Asrock H87 Pro4 Mobo, Intel Quad I5-4570s, 2x8gb Vengance, WD Seagate 1TB HDD, Samsung SH-224DB/BEBE DVD/CD Writer, Corsair CX600M PSU, and my GTX 660 should be coming on monday.

My issue is that I've set up everything correctly and powered it on right after I finished building it to test it. It worked fine, but I didn’t connect it to a monitor. I turned it off and took it into my office to set it up. I plugged it in and plugged my monitors in. I then switched on the PSU from the rear switch and my front Molex fan spun up and the LEDs came on. It then turned off. I then pressed the power button on my case which which didn’t do anything neither did the reset button. I switched it off at the PSU then switched it on at the PSU again and it still happens.

I have already tried booting without RAM and removing everything from the mobo apart from the boot button. None of these worked. I will do the paper clip test for my PSU tonight and I will reseat everything.

Anybody got any suggestions about whats wrong and how to fix it?

Ill post a reply to this thread and edit this original post to include the results of the paper clip test once I’ve don’t it.

Also, thanks in advance for any replies/ideas.

Edited by hotmailcompany52
Link to comment
Share on other sites

Did you check to make sure everything is plugged into the motherboard correctly? A picture may help.

I suspect it's a power supply or motherboard problem. If your motherboard came with a speaker, i'd recommend plugging that in to get any possible POST codes.

Edited by ZedNova
Link to comment
Share on other sites

I rewired it. It works :D. Not sure why it didn't in the first place. I'll edit this/maybe post depending on how its going.

EDITZ: Welp, it works fine. My GPU works and all but windows installer isnt reading my HDD. I know it works and I saw it in the UEFI of the MOBO. Any tips/ideas?

EDIT2: Turns out it was that the sata cable wasnt headed properly. I think my 24pin is a little loose.

EDIT3: Its all up and running well. Everything is well I think. DLing my games now.

Edited by hotmailcompany52
Link to comment
Share on other sites

This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...