Sign in to follow this  
Followers 0
vector253

Space Shuttle (possibly a dying mod)

48 posts in this topic

Hi this is my first post so please don't be to harsh on me if its in the wrong place.

I wanted a working shuttle for KSP so i made one (or i thought i did) turns out getting all the rcs thrusters and engines to work is beyond me and I'm in over my head.

But on the bright side I have a completely modeled shuttle with textures based off of a modified nasa model, collsion nodes and animations.

If anyone is interested in helping I'm happy to share my files and you of course will have credit.

So far I have the Shuttle cabin and nose working in ksp minus landing gear and rcs. The cargo bay needs node work and it should be done.

i3tapw.jpg

beside the buran.

I hope thats linked to the picture, if not ill try and figure out how to post pics too :)

http://www./folder/h8qstqud458qw/shuttle_parts

v2 files

http://www./download/72exssi8dxe3br4/shuttle_V2_download.zip

the files I have so far, both parts and meshes.

Thanks for viewing

Edited by vector253
add files, add nasa model credit

Share this post


Link to post
Share on other sites

You should also make the shaders for the top three parts in the cabin more seamless so they look like their in one piece.

Share this post


Link to post
Share on other sites

I can help with CFGs one the models are ready.

Share this post


Link to post
Share on other sites

I can test for compatability with a variety of plugins.

Share this post


Link to post
Share on other sites
I can help if need.

I would be honored to have your help, the soviet pack is one of my favorite mods.

my big problem is I cant figure out how to add rcs to the parts, and couldnt find a guide on how to do that either.

I uploaded all the meshes and are now in zip files in my first link

Thank you, and let me know what you need ill try to respond as quick as i can

Share this post


Link to post
Share on other sites

Thank you Dragon01 I will let you know when I have more parts ready for CFGs

DarthVader as far as I know what I have works with mechjeb, but there are many other plugins out there and ill send you the new parts to test as i get them work

also ill look into changing the shaders

Share this post


Link to post
Share on other sites

How to do RCS...

RCS

Empty GameObjects with Y axis (green arrow) pointing in the direction of thrust, with one for each direction.

Share this post


Link to post
Share on other sites
my big problem is I cant figure out how to add rcs to the parts,

Add empty gameobject and named "RCSthruster"

Y+ axis (green arrow in Unity) its thrust direction.

3af408e29f32efa3e1d2c57ea1c08410

Edited by BobCat

Share this post


Link to post
Share on other sites

Please put an edgesplit on your models to get rid of the horrific shadows.

Share this post


Link to post
Share on other sites
...the files I have so far, both parts and meshes. let me know if there is a better way to share files...

Dropbox...

Share this post


Link to post
Share on other sites

Or just pack them into a single archive and upload it to Mediafire as one file.

Share this post


Link to post
Share on other sites

Ill get a Dropbox and add it there, and they should now be in two compressed folders on mediafire.

I will be up all night tonight and all day tomorrow working on this so hopefully I can make some real progress :)

Thanks everyone for the tips and ill update the files as I fix things and get more stuff working

Edited by vector253

Share this post


Link to post
Share on other sites

Okay I'm having problems in unity, my model appears correct and textured but when I convert it to a .mu and put it in ksp half of the part is clear but the oms pods and thrusters are prefect, what am I doing wrong?

also in unity it looks fine on the main screen but in the small window (when clicking on the model) the model is see through, I've checked blender everything is normal and all the textures work right

Edited by vector253

Share this post


Link to post
Share on other sites

I tried that to before and doesn't seem to have any change on it. I've also tried scaling it to -1 in unity and it fixes it in the preview but is made see through in the main unity screen.

this is the file that is giving me problems, can someone please look at it and tell me whats wrong, or fix it?

http://www./download/593a395k1dsl8an/Engine_assembly.zip

Thanks

Edited by vector253
added problem file

Share this post


Link to post
Share on other sites

I'm giving up on this mesh, my brother is going to help me with a new one since he is infinitely better at blender than I am so this new version will hopefully work and look better.

Ill post pics as we get further into modeling, hopefully I can have this out soon, I pretty much understand the config and unity so modeling is the current hold up. I will most likely need help with the wing and getting it to fly right.

Thanks for all the support and help

Share this post


Link to post
Share on other sites

almost done with new model

Pics

2gwz5tv.jpg

dqrs6q.jpg

zul2cy.jpg

2qsrkox.jpg

2e36dma.jpg

2rr6q8m.jpg

Texture should be done tomorrow then my brother will cut it up and I will handle the unity setup

Share this post


Link to post
Share on other sites

Remember about adding radiators to the front bay doors:

orbiter-22890.jpg

Until it's possible to animate them separately (they are sometimes left folded), just make them open when the cargo bay opens. And don't forget the airbrake and the landing chute!

_41898756_parachute416ap.jpg

BTW, can we get a shot of it with bay doors open?

Also, could you get rid of the "Atlantis" logo or even better, make a set of textures matching the 5 other Shuttles? It'd be nice to have some flexibility here.

Regarding cutting it up, here's my suggestion:

Separate the cargobay doors from the bay itself like Buran does. The payload bay could be a single part. Split off the airlock, but unlike on Buran, it shouldn't extend. Leave OMS thrusters attached to the engine mount, SSMEs (if you modeled them) should be done as a single cluster, but separate from the mount itself (so that 3 SSMEs are mounted as one part). The nose needs to have two parts, one for the ASAS module and the other to produce lift. I suggest doing it like on Buran, but you may also go with the CSS-style approach. The tail fin control surface can be attached to the rest of the fin (unless that prevents animating the airbrake, in which case do it like on the Buran). You certainly may leave control surfaces attached to the wings.

Edited by Dragon01

Share this post


Link to post
Share on other sites

nice work so far... really looking forward to this vessel.

Share this post


Link to post
Share on other sites

I didn't even think of the air brake thanks for reminding me, and ill edit the textures to have no name, I think I found all 5 textures but ill just leave a area where you can add your own name.

As far as the division go I'm just gonna cut it up like the buran but use only a single cargo part, the bay doors are separated but haven't been animated yet. Also the elovons and rudder are separated I need to add the airbrake feature and I also need to figure out lift.

Ssme's are done because my brother wanted to do them for some reason but there are separated so I can add the thrustTransform.

I doubt much gets done during the day, it being the 4th I have to deal with family. But tonight I should have made some amazing progress.

Anymore suggestions while its to edit the mesh?

Share this post


Link to post
Share on other sites

brilliant! can't wait to see this finished :)

Share this post


Link to post
Share on other sites

The current progress of the model (almost finished, the window color will be changed)

4ns7r.jpg

jj9r3q.jpg

animations are next :)

Share this post


Link to post
Share on other sites

Where are the OMS thrusters? They need to be fused with the engine mount, remember? Otherwise they won't be able to compensate for the Shuttle's COM.

Share this post


Link to post
Share on other sites

They will be fused in unity, for them to be able to gimbal they have to be a different part slaved to the thrustTransform empty and then attached to the mount in the unity hierarchy, or that's how I had them working before anyway.

I can physically attach them to the part though if that is what's needed for the COM to work I just don't know how to vector them that way

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0