AlonzoTG

Members
  • Content Count

    234
  • Joined

  • Last visited

Community Reputation

23 Excellent

About AlonzoTG

  • Rank
    Spacecraft Engineer

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. It was fixed in 1.4.5 but the fixes from that release have never been ported to any later release, they forked 1.5.x off of 1.4.2 or something and never looked back. =((( So there are many regressions and Squad/TT are out to lunch on this issue. =( The current PM brags that he's been playing since 1.0, I've played since 0.23 so I out rank him and I want to take over this project.
  2. My install is not even slightly sane right now, north of 20GB running 15+ minute load time, I think the planet packs I have right now are what's really killing it. I'm happy with the 3 launch sites provided by the DLC so I'm not using KK.
  3. It is clear that more than a few bugfixes in the 1.4.x line have NOT been ported to the 1.5 branch. some examples: -> inventory icon alignment in the editor. -> crashes related to crew assignment validations, triggered on larger ships/more complex missions. Both had been broken in early 1.4.x and had been fixed in 1.4.5.
  4. Squad had reported that they had fixed this problem later in the 1.4 series, but in 1.5 I'm noticing more than a few regressions, someone really messed up over there. =| Notice the inventory list isn't lined up anymore, it had been fixed in 1.4.5... So apparently 1.5 had been forked early in 1.4 and more than a few fixes were not back-ported. =0 Damnit, why doesn't the best game ever made have more careful developers?
  5. Yeah, I have like 5,000 hrs+ in this game. =P I have over 250 craft in my active fleet. With this one, the total mass comes out to about 700 tons even on the pad... You have a VERY tall 5M stack and a total of three decouplers, additionally the bottom of the rocket is ringed with an absurd number of tailfins... Solution? Attach the boosters near the top so there is less total stress on the stack and less possibility for the joints to buckle... I kick the thing up to hypersonic ASAP and then kick off the boosters. This is shockingly non-problematic... At 40-50km there are two kinds of rockets, fast rockets and slow rockets... A fast rocket would be getting significant atmospheric heating, even though the density is about 0.02 at that altitude and needs the fairing up until about 51km. A slow rocket, such as this one, is just lumbering along wondering why it needs a fairing when the atmo is so thin at this altitude, so just go ahead and dump it, it's just weight... In the most extreme case I ever launched, a surface sailing ship for Laythe on a 10M stack, I actually had to shut down the engines at 50km, dump the fairings, and then light everything up again. The solution for this rocket is to spin the hell out of it and hope the fairings clear... Mechjeb can then recover and the launch continues as normal. On orbit, I think I'm going to have to retract that telescope thingy before dumping my upper stage otherwise I get killed by that hexagonal cover every time. =\
  6. Okay, I deleted the incompatibility patch directory and the mod is essentially working again. Procedural Parts is not working 100% at this time but I had to use what it claimed to be a 50cm tube to extend the location of the attach node up to where the stock #1 docking port needed to be. I had to use monstrously huge tail fins on the rocket to get it to do anything but cartwheel. =\ (no FAR). I also moved the boosters to near the top of the rocket to compensate for the CoM issue. I get it to about 40km when I want to dump the nose fairings, I found that I have to roll the thing violently to get the fairings to separate without destroying the telescope thingy... Mechjeb deploys it on orbit anyway... When I dump the engine on orbit, it kicks off a hexagonal piece of debris which never fails to score a direct hit on that telesope thingy. I tried to send Bill out to fix it but he can't.
  7. I found a shroud in KW rocketry that should work, but when I loaded the part up in 1.5.1, it loaded as a 3.75m part, with nodes in the wrong position. Also, the docking ports do not seem to follow Kerbal node placement conventions so I can't swap the realistic ports with ordinary kerbal-style ports. =\ The "top" node should be level with the mating surface, and the back port should be flush with the apparent back-plate of the part. For a cone style docking thing, it should be the outer ring that would be brought into contact as the probe is retracted. There seemed to be a shroud like mesh clipped inside the station, not sure what that was for...
  8. Running the game out of tree hasn't worked since 1.4 because of all the "phone home" functions Take Two added. =(
  9. I'm mostly mad at Squad right now for just dumping this on us without really advertising a release date and breaking my career game BAD while changing far more than they should have at this point in the game's life. Also the major change in the game's underlying aesthetic.... -- beat up junky parts -> sleek modern parts. Give the mod authors 2-3 weeks on this one, Squad really did a number on the game this time. =\
  10. Performance is too suck still. =( I installed a beyond kerbin planets mod and I have like 20 experiments at each site to make sure I'm not grinding all month to get a FTL capable ship... Well, it takes literally 9 seconds to do basically anything.... Switch SOI? -> 9 seconds; run an experiment -> 9 seconds; transmit an experiment -> 9 seconds, Get out of the pod -> 9 seconds; let go of a ladder -> 9 seconds, FOR EACH EXPERIMENT!!! It's basically unplayable. Plz get yourself an algorithms textbook and a pot of coffee. =\ I can try to help, plz do e-mail me with stuff you want me to fix or look at...
  11. Hey, I was working the orbital telescope contract and it was very unclear about the requirements. Why aren't you using the stock requirements checklist so I can check whether my vessel matches by just rolling it out? Also, I thought you meant a stock like science lab so I had station parts extended 3.75 M lab on the thing, when I actually needed a ** station science ** lab, apparently... Also still, my instinct for launching this was to send it directly to a graveyard orbit of 4,000km at 10% inclination so it wouldn't pose a risk to anything... Really, the contract needs to spell this out. =|
  12. urk, that just killed loading the parts, going to go through them in groups of ~4 and see if I can nail down the fail tighter than just the R7 directory...
  13. Seems to be an overly nested directory issue in the R7 set, taking out that extra nesting layer seems to prevent it from crashing the game on load... (game ver 1.4.2 )
  14. Yeah, unless you can find a coupler that actually is hollow on the inside (actual collider is hollow, not just appearance, I installed SpaceY to launch this and it's decoupler is NOT compatible...), or re-purpose an engine interstage, there will be a collision when the decoupler fires and it will not separate cleanly because it will be processing collisions between the station's superstructure. On my most recent flight, the launcher was kinda caught on the thing and wouldn't actually separate.
  15. AlonzoTG

    [1.4.5] Global Construction

    The single biggest issue in making a working spaceship is joint stability. There are two factors that directly impact the stability of a joint: The inherent strength of the joint, and the diameter of the joint. Joint strength is always negatively impacted by having miss-matched node sizes too. (assuming the colliders are well aligned with the node positions..) As coupling solutions are available for everything up to #8 (10M) nodes, as well as several alternate form factors such as Mk2, Mk3, and several mod truss profiles... My latest generation tug, for example, supports #2, #3 and #4 payloads on the bow end, and #3 and #4 payloads on the stern end. Having a #3 node allows me to jettison the #2 adaptor, saving both weight and improving the matching.