sirkut

1.1.2 Magic Smoke Industries Infernal Robotics 2.0.2

Recommended Posts

Guest
21 hours ago, Ziw said:

Because latest version is 2.0.10 and it is available in the first link in my signature.

First link - Github repoz tells that 2.0.10 was updated 14 days ago, so it about 15DEC2016

But you gave me dll which have timestamp 20DEC2016.

Was it incorporated, or it was experimental and I should roll back to 20.0.10 from Github?

I'd prefer to keep it, because IR works for me now, "Classic Tall Hinge" excluded.

Share this post


Link to post
Share on other sites
Just now, WildLynx said:

First link - Github repoz tells that 2.0.10 was updated 14 days ago, so it about 15DEC2016

But you gave me dll which have timestamp 20DEC2016.

Was it incorporated, or it was experimental and I should roll back to 20.0.10 from Github?

I'd prefer to keep it, because IR works for me now, "Classic Tall Hinge" excluded.

that DLL was experimental, but ofc keep it if it works for you. I need to do more fixes and post a small maintenance release

Share this post


Link to post
Share on other sites

First, I just have not had the addon button on the toolbar. Reinstalled the addon . Appeared, lost all the parts (initially version was 2.0.2. Now installed 2.0.7) Searched for categories is empty, there is no nothing from the addon. Not found anywhere the solution to this problem

Screenshot

Share this post


Link to post
Share on other sites
On 12/25/2016 at 2:35 PM, CraftyDwarf said:

Not sure if this is a known issue, or I got the wrong build, but for 1.2.2, neither stock or blizzy button show, no other signs for the control interface. 

Also, because of some of the other mods I am using, if the above could be of course addressed, I am looking for ultra fine control positioning to aim another mod's telescopes. Looking at a order of magnitude smaller than when I had this mod (IR) working, so I am thinking 1/10000 of a degree or better on hinge and same on rotatron. Suggestions?

Wait 1.2.2?

Share this post


Link to post
Share on other sites
On 12/13/2016 at 10:11 AM, kcs123 said:

You are fighting with different kind but yet similar animals(kraken) here.

MuMechToggle  - in KJR configs should recognize when IR parts and similar started/stoped animation and KJR should release stiffnes to allow them to move.

multiPartAttachNodeReinforcement - that is new feature in KJR - quite similar in behaviour as stock autostruts. It will create invisible strut from some other part to IR part that should be able to move on demand.

So, if you set multiPartAttachNodeReinforcement to zero, it means parts were no longer stiffened trough "autostruts", you need to add regular struts between parts to strength out your constructions.

Gallery with example of varialble geometry wings is good example how it is possible to strength out your craft design.
To be more specific, use stackable extendratrons instead of full sized, so you can put additional struts and still allow IR parts to move:

EbCuYBI.jpg

When properly designed, your crafts would still be strong enough despite using IR parts. Of course there is limits somewhere if you wish to create something with unreasonable size and weight, like this one:

BDKycTw.jpg

You have to find weak spots on your crafts and strength them out with regular struts and being careful that those won't limit IR parts to move.

How did you obtain those parts?

Share this post


Link to post
Share on other sites
On 2016-12-19 at 0:00 PM, kcs123 said:

This imgur galery shows workaround for wheel autostruting.

....

However, as shown on picture, when you put wheels in symetry mod, wheels put autostrut to their symetry counterpart too. That create wierd things if you try to move powered hinges.

...

So, you need to place wheels on craft without symetry.

 

Hi all.  I'm interested in IR and have been following the topic, although I'm not in a position to test IR.

@kcs123, you said you needed to use parts without symmetry to have the workaround work.

Well, there's a KSP 1.2.2 version of Part Wizard available.  With it you can break up symmetry groups.  Perhaps you could test it to see if it makes doing the workaround easier and gives a functional result.

 

 

Share this post


Link to post
Share on other sites

Guys, I'm an idiot. It was kerbal joint reinforcement the whole time. I was so confused, because I never installed it. I was lost, but then after a fresh ksp install I noticed that so many mods just casually shove kerbal joint reinforcement into the game. Damn. Now everything works, thanks for the help.

Share this post


Link to post
Share on other sites
Guest
On 1/1/2017 at 5:11 AM, DamianDrazhar said:

Guys, I'm an idiot. It was kerbal joint reinforcement the whole time. I was so confused, because I never installed it. I was lost, but then after a fresh ksp install I noticed that so many mods just casually shove kerbal joint reinforcement into the game. Damn. Now everything works, thanks for the help.

What is dll name of redistributable version of KJR they add? I want to check my install too.

Share this post


Link to post
Share on other sites

is persistent rotation breaking this? I thought i read something somewhere but I can't find it now.

Edited by Agustin

Share this post


Link to post
Share on other sites
On ‎12‎/‎29‎/‎2016 at 10:28 AM, Ziw said:

that DLL was experimental, but ofc keep it if it works for you. I need to do more fixes and post a small maintenance release

I've been following this mod for a long time (last time I had time to play was KSP v1.0.4) and have recently returned to KSP and am looking to get a new playthrough started here on KSP v1.2.2.  CKAN lists your mod as being keyed to KSP v1.1.3, and I cannot tell if the GH download of 2.0.10-Final-Core is for v1.2.2 or not, but I suspect that it might be.

I run KJR as a reco or a dependency for other mods, and I see chatter here that KJR is presenting some issues for IR.  Would you suggest I simply not attempt to run IR with KJR installed for now, or does your most recent GH download attempt to address the KJR issues?  Is there a changelog I can look through to see if my question is already answered?

Thanks, great mod!

Share this post


Link to post
Share on other sites

I have gotten back to building with this and have run into an old problem. 

What is the fix for the VTOL rotor and rotatron MK2 being too weak and flexing around when an engine is thrusting?

The use case is a heavy space fighter with twin rotate-able antimatter powered thermal rockets.

When I manually use struts it does not move at all and when I use the autostrut feature it destroys the vehicle.

I am also having the problem with Kerbal Joint Reinforcement which I have removed.  I have been having unbelievable problems with random vehicle explosions as well which may be related.  I strut the part the log says "collided" with another part and on the next launch a different part explodes and I strut that and so on seemingly forever.

edit:

Denko's workaround a couple pages back mostly worked for me.  It did not eliminate the joint flex but it did allow me to use the plugin again because joint movement is no longer blocked with KJR loaded.  KJR has the effect of vastly strengthening the joints which is required with the heavy and compact KSPI-E based vehicle I am building.

Edited by Jason_25

Share this post


Link to post
Share on other sites

I got big issue when i detach parts from the contraption

basically when i detach a rover from the main base i get all my IR devices go crazy
the fixed part became the mobile part and vice versa

i am not very good to explain, please check the image

I use IR-2.0.10-Final-Core

Please help me

thx

9GFeUs.jpg

Edited by omar

Share this post


Link to post
Share on other sites

btw Ziw and Zodius i noticed something wierd with IR few weeks ago and i cannot seem to get past this default setting that every servo is imidiatly locked and have to be manualy unlocked to get them working everytime i spawn my creations, not significant problem but time consuming when dealing with mechs : D oh and btw happy new year to you guys and i shall start my Fifth season of mech walkers with this...

 

 

Share this post


Link to post
Share on other sites
5 hours ago, Greystripe3 said:

stock

One word answers will only bring more one word answers....

Versions?

mods?

Most of us enjoy helping people. But help us help you.

So recap you are using IR 2.0.10

KSP 1.2.2

and module manager 7.5 correct?

Share this post


Link to post
Share on other sites

Having issues with IR...

Parts will not move, and the GUI for IR does not appear. Right clicking on parts in SPH of VAB will only bring up Tweakscale Menu. In flight, no menu appears when any IR part is right-clicked.

Here is the LOG.

 

EDIT:

I have a lot of mods installed, not to mention that I still need to post in the Kethane thread that the grid is not pink, but any deposits do not show up... Anyway, I will have to post after IR has been fixed up...

Edited by Astrofox

Share this post


Link to post
Share on other sites
15 minutes ago, Astrofox said:

Having issues with IR...

Parts will not move, and the GUI for IR does not appear. Right clicking on parts in SPH of VAB will only bring up Tweakscale Menu. In flight, no menu appears when any IR part is right-clicked.

Here is the LOG.

 

EDIT:

I have a lot of mods installed, not to mention that I still need to post in the Kethane thread that the grid is not pink, but any deposits do not show up... Anyway, I will have to post after IR has been fixed up...

Seems like you don't have proper install of IR. Have you grabbed 2.0.10 dll from Ziws post couple of pages before ?

There is bunch of other data available too, although buried very quickly in thread.

Share this post


Link to post
Share on other sites

Right now, it seems to work properly again...

Share this post


Link to post
Share on other sites
17 hours ago, PtothaG said:

hey guys, is there a way to get infernal robotics to work on my 1.2.1 game ?

thx

Please read above. It has been explained at least three times while I watched, likely more.

Share this post


Link to post
Share on other sites

73 pages dude..

i just tried to install the link givven at the start of the thread and it didnt work

Share this post


Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.