Chaosratt

[WIP] Z_thing ZZZ's Part Collection

Recommended Posts

I've taken it upon myself to collect up all of ZZZ's parts and update them to the best of my ability and release them here for everyone else.

Phase one will be getting each part to minimum functionality. By that I mean, It loads into the game and can be attached/assembled. It doesn't mean it actually *does* anything.

Phase two will be to try and get each part to have some use or purpose within Stock KSP, but I fear some of the parts such as the Antimatter reactors and warp drives will only be useful when used with other mods.

[TABLE=width: 1000, align: center]

[TR]

[TD=align: center][1.04] Radial Mount[/TD]

[TD]Last Updated Aug 30th, 2015[/TD]

[/TR]

[TR]

[TD=width: 600]

Javascript is disabled. View full album
[/TD]

[TD]A Radial engine mount specifically designed for the LV-N engine, thought it can fit a LV-t30/35 as well. Comes in a single, and two double variants.

Known issues:

  • None at this time

Future Plans:

  • None at this time

[/TD]

[/TR]

[TR]

[TD=width: 600]Dropbox download[/TD]

[TD][/TD]

[/TR]

[TR]

[/TR]

[/TABLE]

[TABLE=width: 1000, align: center]

[TR]

[TD=width: 600, align: center][1.04] Thermal Rocket Nozzle[/TD]

[TD]Last updated Aug 30th 2015[/TD]

[/TR]

[TR]

[TD]

Javascript is disabled. View full album
[/TD]

[TD]A rocket engine designed for KSPI to go along with its thermal power system. Currently runs fine out of the box on LOX and is frankly a bit OP right now, but its horrible atmo Isp keeps it from being used from the ground.

Known issues:

  • Doesn't actually work off any kind of thermal power
  • A bit OP in stock KSP
  • Seems like it thrusts Off-center

Future Plans:

  • Balancing

[/TD]

[/TR]

[TR]

[TD]Dropbox Download[/TD]

[TD][/TD]

[/TR]

[/TABLE]

[TABLE=width: 1000, align: center]

[TR]

[TD=width: 600, align: center][1.04] Merlin Engine[/TD]

[TD]last updated Sep 1st 2015[/TD]

[/TR]

[TR]

[TD]

Javascript is disabled. View full album
[/TD]

[TD]What happens when you scale up the LV-T45 up to 2.5M and keep the same stats? A very pretty poodle replacement that's what.

Known issues:

  • No "shroud" when stacked.

Future Plans:

  • None at this time

[/TD]

[/TR]

[TR]

[TD]Dropbox Download[/TD]

[TD][/TD]

[/TR]

[/TABLE]

[TABLE=width: 1000, align: center]

[TR]

[TD=width: 600, align: center][1.04] Crosswalk[/TD]

[TD]Last updated Sep 1st 2015[/TD]

[/TR]

[TR]

[TD]

Javascript is disabled. View full album
[/TD]

[TD]A very interesting crosswalk/passageway. While it looks like kerbals can walk inside of it, they regrettably cannot. Looks pretty, though. Could be used as structural members on a station to give it a more authentic look, or a ground base. Unknown if it allows kerbal transfer, someone test and get back?

Can be tricky to assemble, there are two main sectional types, with two lengths. The only difference I can discern is the "A" type has retractable skylights, where as the "B" type does not.

"To place "docking adapter" by right way is really tricky (maybe need to make something with node direction, but at least it's works) - main rule is to have "long horns" on top and in direction of docking. It's working dock module to dock with standart(medium size) clamp-o-tron. Intended mostly for construction" -zzz

Known Issues:

  • None

Future Plans:

  • None at this time

[/TD]

[/TR]

[TR]

[TD]Dropbox Download[/TD]

[TD][/TD]

[/TR]

[/TABLE]

[TABLE=width: 1000, align: center]

[TR]

[TD=width: 600, align: center][1.04] Habitat/Hub[/TD]

[TD]Last updated Sep 1st 2015[/TD]

[/TR]

[TR]

[TD]

Javascript is disabled. View full album
[/TD]

[TD]Two very nice habitat domes. One armored and one glass (cosmetic only). Stack nodes in the expected locations top & bottom only (nothing on the sides for example) but it is surface attachable. Works well alongside the Catwalks.

Known Issues:

  • The lighting animations can get stuck sometimes

Future Plans:

  • None at this time

[/TD]

[/TR]

[TR]

[TD]Dropbox Download[/TD]

[TD][/TD]

[/TR]

[/TABLE]

ZZZ's post here essentially puts all his parts in the public domain. In keeping with that, all of his parts released by me are released under the MIT license.

Github repository here.

Post layout blatantly stolen from NFT because I liked the look.

Edited by Chaosratt
dl link for thermal rocket
  • Like 1

Share this post


Link to post
Share on other sites

I will look if I can integrate them all in KSPI. They show promise as radial thermal/electric engines. They will fit well with existing KSPI which also made by ZZZ

Edited by FreeThinker

Share this post


Link to post
Share on other sites
I will look if I can integrate them all in KSPI. They show promise as radial thermal/electric engines. They will fit well with existing KSPI which also made by ZZZ

- - - Updated - - -

I will look if I can integrate them all in KSPI. They show promise as radial electric engines.

I'll be adding more parts (he had a lot!), but most are already in KSPI. Just keep in mind the radial mounts are just that, mounts. You'll need to do further work with them to make them an engine. In my screenshots I've loaded LV-N's into them, which is what they were designed to use.

Share this post


Link to post
Share on other sites

mm, it appears they have air intakes. They might be implemented as thermal turbojet with integrated air intake

Share this post


Link to post
Share on other sites

The old KSPI had those too, from what I know. Most of KSPI assets are zzz's parts.

Share this post


Link to post
Share on other sites
The old KSPI had those too, from what I know. Most of KSPI assets are zzz's parts.

The rocket nozzle or the engine mount? I haven't used KSPI in a while but I don't recall the engine mounts being in it.

Share this post


Link to post
Share on other sites

Both, but the engine mounts are used as radial atmosphere collectors, and doesn't have any mounting nodes.

Share this post


Link to post
Share on other sites

Do you plan on adding the Dome habitats, they are great habs, I still use them but I don't know how to fix the placement nodes in the .cfg, but it can still be radially attached.

Share this post


Link to post
Share on other sites
Do you plan on adding the Dome habitats, they are great habs, I still use them but I don't know how to fix the placement nodes in the .cfg, but it can still be radially attached.

I plan on adding all his parts. I have the dome, catwalks, antimatter tanks, & antimatter reactor ready to go right now. I just got distracted last night posting, I fired up KSP to take some screen shots .... and just started playing.

Share this post


Link to post
Share on other sites
I just got distracted last night posting, I fired up KSP to take some screen shots .... and just started playing.

Haha Completely understandable lol ;P And that's good to hear, always loved ZZZ's parts.

Share this post


Link to post
Share on other sites

I downloaded the original z_thing crosswalk and it has given me fits. So, I removed the files and grabbed your updated files. Thanks, but I'm still having the same issue. In VAB everything works great. Save. Send the ship to launch. Everything is good. Exit all the way out of KSP and come back later to find the TypeB_S is gone. I cannot figure this out. Same thing is happening with the Spheres which you haven't updated yet. Someone try to duplicate the problem and see if it is a part issue or something else. I don't use part mods as a rule but the hab/hub and crosswalk are too cool not to use.

Share this post


Link to post
Share on other sites

Is the part missing completely, like from the VAB/SPH, or does it just disappear from your ships?

Share this post


Link to post
Share on other sites

Gone from VAB/SPH, and craft won't load. I ran my craft file through the craft repair app on the craftkitchen page and it shows no errors. My mods are of the Scatterer, Chatterer, EVE, Edge of Oblivion, Distant objects, OPM type. I did remove Texture Replacer to see if it might help. It didn't. No other part mods except the z_thing ones. Is it possible the mu file is glitched?

Share this post


Link to post
Share on other sites

Crosswalk issue - This morning I used a KSP copy with no mods except the z_things. I could build with the crosswalk. Saved. Exit program. Restart. Craft won't load. The crosswalk TypeB_S is gone from SPH. If you have no ideas it looks like I'll have to make this part go bye bye.

Share this post


Link to post
Share on other sites

I've replicated the issue, but I do not know where to even begin to debug this.

@Virtualgeniu:

I'll add the greenhouse shortly, just understand that by itself it doesnt do anything, you'll need to edit the config and/or make a mod manager patch to give it a function.

Share this post


Link to post
Share on other sites

I've thing I've noticed is that they have not been added to the tech tree, its not hard for one to fix. Just though I'd let you know. :D

Share this post


Link to post
Share on other sites
I've thing I've noticed is that they have not been added to the tech tree, its not hard for one to fix. Just though I'd let you know. :D

I'm not adding them to the tech tree at the moment.

Share this post


Link to post
Share on other sites

Re: Type B cross walk. I think I have that fixed but I forget what the issue is. I'll go check my personal files and get back to you

Edit:

I think this was the problem: Missing TechRequired and entryCost. I gave it these values in my local copy.


TechRequired = advRocketry
entryCost = 1000

Also, there is a space in the file name. That doesn't seem to be a problem at the moment, but spaces in URLs is always a potential problem, especially if something changes with Unity updates. (IIRC, it only works because of workarounds or fallback code). It'd be worth fixing now before it becomes an issue later.

Edit: #2

Nope... that wasn't the problem... none of them had those entries... Hrrrm. I know I had to do something to get it working but I don't remember what it was.

Edited by Starwaster

Share this post


Link to post
Share on other sites
Re: Type B cross walk. I think I have that fixed but I forget what the issue is. I'll go check my personal files and get back to you

Edit:

I think this was the problem: Missing TechRequired and entryCost. I gave it these values in my local copy.


TechRequired = advRocketry
entryCost = 1000

Also, there is a space in the file name. That doesn't seem to be a problem at the moment, but spaces in URLs is always a potential problem, especially if something changes with Unity updates. (IIRC, it only works because of workarounds or fallback code). It'd be worth fixing now before it becomes an issue later.

Edit: #2

Nope... that wasn't the problem... none of them had those entries... Hrrrm. I know I had to do something to get it working but I don't remember what it was.

I've noticed if you open the cfg and save it without making changes, it will work the next time you enter SPH. Then the part will be gone again on the next start up. Very Weird.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now