GregroxMun

[1.7.3] Alternis Kerbol Rekerjiggered v2.5.0 August 8th 2019

Recommended Posts

@GregroxMun  I've been exploring Laythe lately and have noticed a couple of things.  I'd like to know if they're bugs or intentional:

1.  Animated Ground Texture:  At least in the vicinity of the Monolith, the mossy-looking green-striped ground texture sloshes back and forth.  It's got the same sort of motion as water textures usually have.  It's certainly an interesting effect if intentional, although somewhat unnerving :) However, I now wonder if it's related to the issue below.

2.  Disappearing Trees:  When I originally found the Monolith, it was on the edge of a fairly substantial grove of "eyeball trees".  Next time I went to that area, however, the trees along the ridgeline just north of the Monolith had disappeared completely (making a long clear-cut area) and the remaining forested area had considerably fewer trees in it than before (as if thinned out by selective logging).  The next time I returned to this area, all the trees were gone.  In fact, I flew over about 90^ of latitude and 60^ of longitude from west and north of the Monolith and didn't see a single tree anywhere.  Is that supposed to happen (as if trees are seasonal things or short-lived mushrooms) or some sort of glitch?

Share this post


Link to post
Share on other sites
1 hour ago, Geschosskopf said:

@GregroxMun  I've been exploring Laythe lately and have noticed a couple of things.  I'd like to know if they're bugs or intentional:

[snip]

Both things you describe are bugs, and I know how to solve none of them. I suspect disappearing trees is some form of stock bug, but I seem to remember the other one was fixed by some other mod. For now just...uh... assume it's laythequakes?

Share this post


Link to post
Share on other sites
49 minutes ago, GregroxMun said:

Both things you describe are bugs, and I know how to solve none of them. I suspect disappearing trees is some form of stock bug, but I seem to remember the other one was fixed by some other mod. For now just...uh... assume it's laythequakes?

OK.  At present, they just make Laythe more mysterious, although I do hope the trees come back :wink:

 

Share this post


Link to post
Share on other sites

@GregroxMunI've been giving the issue of disappearing Laythe trees some more thought......

First, an observation.  I have 2 separate save games in the KSP installation in which I'm using AK.  One is career with BARIS turned on, the other is sandbox with BARIS turned off.  The idea is, I use the sandbox game to test designs, determine dV requirements, etc., then copy the craft files to the career save.

But here's the thing....  Laythe has different geography in these 2 saves.  I'm talking a completely different arrangements of land and sea.  The maps look nothing alike.  Which is a cool feature, to enhance replay value, although it rather limits my ability to test certain things in the sandbox.  The main thing, however, is that I'm beginning to suspect that having different parameters at the save level is causing conflicts at the game installation level.

So I got rid of the sandbox save, and the trees came back in my career save.

I have no idea how any of this stuff works under the hood, just reporting observations.

Edited by Geschosskopf

Share this post


Link to post
Share on other sites

Can anyone assist with this? Anyone familiar with my Mission Post Trekking Through Alternis will know that when I installed the modification over a 1.2.1 game the clouds of Jool were the wrong colour. Yesterday in an effort to fix that I copied the Scatter files over for Alternis. The Jool clouds are now blue as they should be but the view of Kerbin is a mess, as per the images below. In the tracking station Kerbin looks correct with the ground visible through lovely clouds, however from orbit the planet - day and night side looks like a Blue Titan! Can anyone let me know what I have done?

Thanks,

AUvIndh.png

4wRvfD3.png

HeV2OXS.png

Share this post


Link to post
Share on other sites

Had an annoying thing happen here.  I had stuff in orbit around all of Jool's moons.  When I opened the save this time, all the stuff orbiting Minmus, Lathe, and Mun had been removed from those SOIs and put in Jool's SOI.  Stuff on the ground at Laythe, already in Jool orbit, and stuff orbiting Kerbin and Pol were unaffected.  The probe that had been in Minmus orbit was now in a circular orbit essentially the same as but 180^ away from Minmus.  The stuff from Laythe and Mun orbit was now in highly elliptical Jool orbits, some of which were escape trajectories and 2 things were on collision courses with Jool.

The stuff that got moved was in a variety of orbits to start with.  Highly eccentric polar orbits, equatorial orbits of various heights, and stuff in between.  They were also all kinds of ships:  probes, relays, crewed vehicles.

On 11/18/2017 at 1:44 AM, DDRocketsInc said:

Can anyone assist with this? Anyone familiar with my Mission Post Trekking Through Alternis will know that when I installed the modification over a 1.2.1 game the clouds of Jool were the wrong colour. Yesterday in an effort to fix that I copied the Scatter files over for Alternis. The Jool clouds are now blue as they should be but the view of Kerbin is a mess, as per the images below. In the tracking station Kerbin looks correct with the ground visible through lovely clouds, however from orbit the planet - day and night side looks like a Blue Titan! Can anyone let me know what I have done?

The Scatterer mod is NOT recommended with AK.  Says so in the OP.

If you use EVE, there's a special AK set of clouds available in the OP.  Don't use the stock EVE config files.

Share this post


Link to post
Share on other sites

@Geschosskopf thank you, amazingly following instructions on the original post solved the problem! I removed scatter and now can see the planet, yea. :o

Trekking Through Alternis can now continue. Interestingly in trying to solve the problem I loaded an old save file before Picard tried to link with the Bop station. This time just by selecting it to look at made the space craft explode into a million pieces!

 

Share this post


Link to post
Share on other sites

2.2.0:

https://i.imgur.com/8dCCTuB.png

  • Kerbin's materials have been darkened so that the deserts are no longer apparently glowing white-hot in local space, and PQS matches scaled space.
  • Clouds are also now enabled in the Mod Compatibility settings of the mod, so YOU DO NOT NEED THE ALTERNIS CLOUDS DOWNLOAD, YOU JUST NEED TO INSTALL E.V.E.

As always, be sure to delete old versions of the mod before installing a new version (and this time, make sure you delete the BoulderCo folder if you were using the old Alternis Clouds)

Share this post


Link to post
Share on other sites
On 11/23/2017 at 8:55 PM, GregroxMun said:

2.2.0:

  • Clouds are also now enabled in the Mod Compatibility settings of the mod, so YOU DO NOT NEED THE ALTERNIS CLOUDS DOWNLOAD, YOU JUST NEED TO INSTALL E.V.E.

Thanks for the update.  Somehow I missed it until now.

Anyway, just to be clear on this.....  Do I need the stock configs for EVE as well as EVE itself, or just EVE?

Share this post


Link to post
Share on other sites
15 hours ago, Geschosskopf said:

Thanks for the update.  Somehow I missed it until now.

Anyway, just to be clear on this.....  Do I need the stock configs for EVE as well as EVE itself, or just EVE?

No stock configs. Just EVE Plugin.

Share this post


Link to post
Share on other sites

This bug happens whenever I accept a contract to save one kerbal stranded in orbit of Bop (it does not occur when they are at the surface of Bop). As soon as I take the contract, it is automatically marked as failed. 

 

 

XbQXbMb4TBu-YGJFCP7pgg.png

KSP version is 1.3.1.1891, with no mods other than Alternis itself and the mod recommendations (Windows Transfer Planner, KER,  Kopernicus) plus KAC

 

Any ideas or solutions? 

Edited by Lucas Germano

Share this post


Link to post
Share on other sites

I'm not able to get any progression contracts other than ones in Kerbin or Bop. Anyone has a similar issue? How do I get contracts for further planets?

 

Thanks in advance.

Share this post


Link to post
Share on other sites

Due to the close to stock nature of this pack is it low RAM? I cannot use packs like gameslinx or galileo because the ram use in ksp goes into the 5000mb range.

Share this post


Link to post
Share on other sites

I have just uncovered a forum bug where edits to image links do not save. So anyone who downloaded through Github has been getting the wrong version since 2.1.1 came out. I have now remedied this problem by setting it to link to the generic releases. Make sure you've downloaded the latest version.

Semi-relatedly

2.3.0 is released! https://github.com/GregroxMun/Alternis-Kerbol-Rekerjiggered/releases

68747470733a2f2f692e696d6775722e636f6d2f

  • Scatterer compatibility for Eve, Jool, Laythe, Kerbin, Tylo, and Duna.
  • Principia patch has been fixed and extended to include axial tilts for Eve, Pol, Tylo, Dres, and Duna, as well as stabilizing the Jool system. The exact details of this patch are subject to change, as I, to quote "makes strange systems that are stable but completely confuse our default symmetric linear multistep method with its default step size," which can be fixed with the next Principia update.
  • City Lights for Kerbin, made by Poodmund. (EVE compatibility)
  • Volcano Lighting for Laythe. (EVE compatibility)

68747470733a2f2f692e696d6775722e636f6d2f

Edited by GregroxMun

Share this post


Link to post
Share on other sites
6 hours ago, GregroxMun said:

City Lights for Kerbin, made by Poodmund. (EVE compatibility)

How easy is it to edit this out?

Share this post


Link to post
Share on other sites
30 minutes ago, Geschosskopf said:

How easy is it to edit this out?

remove AlternisKerbolRekerjiggered/ModCompatibility/EVE_Clouds/lights.cfg. This will remove lava from Laythe and city lights on Kerbin. Or you can open that config and remove the entire OBJECT node named Kerbin_Lights if you want to keep the lava.

Share this post


Link to post
Share on other sites
7 minutes ago, GregroxMun said:

remove AlternisKerbolRekerjiggered/ModCompatibility/EVE_Clouds/lights.cfg. This will remove lava from Laythe and city lights on Kerbin. Or you can open that config and remove the entire OBJECT node named Kerbin_Lights if you want to keep the lava.

Thanks!

Some of us envision Kerbals as troglodytes so city lights don't fit.  But active volcanism on Laythe would still be fitting.

Edited by Geschosskopf

Share this post


Link to post
Share on other sites

My screen goes black and the KSP loading symbol is spinning forever when trying to run this mod (in the menu this happens) cannot go ingame or anything

Share this post


Link to post
Share on other sites
On 1/7/2018 at 2:01 PM, GregroxMun said:

2.3.0 is released

Just noticed something strange....  Kerbin has rotated a bit relative to Jool in the new version.  Jool used to be always right there on the western horizon from KSC.  Now Jool is just west of the zenith when seen from KSC.  Was this intentional?

Share this post


Link to post
Share on other sites
22 hours ago, Geschosskopf said:

Just noticed something strange....  Kerbin has rotated a bit relative to Jool in the new version.  Jool used to be always right there on the western horizon from KSC.  Now Jool is just west of the zenith when seen from KSC.  Was this intentional?

No it wasn't! I should have notice this! Let me look into this.

@Geschosskopf Go into AlternisKerbolRekerjiggered/KopernicusFiles/3-Jool/4-Kerbin.cfg and change tidallyLocked to true. I had disabled this while troubleshooting a principia compatibility bug.

I'll be fixing this in the main release, as version 2.3.0.2.

Edited by GregroxMun

Share this post


Link to post
Share on other sites
2 hours ago, GregroxMun said:

No it wasn't! I should have notice this! Let me look into this.

Thanks!

Share this post


Link to post
Share on other sites
17 minutes ago, Geschosskopf said:

Thanks!

OK right so it looks like Alternis Kerbol is currently broken in many ways and I don't know why, or how I missed it, or when it started. This is tremendously stressful because I don't feel like bug fixing right now.

Minmus and Dres at least are not showing up in PQS.

 

EDIT: No wait I just teleported into Minmus by accident. Only Dres is not showing up.

EDIT2: but the rocks are the wrong color and I hate everything.

EDIT3: Fix Dres by copying Dres_Color from Textures to PluginData

 

I think I'm gonna remove the download for now and find broken things to fix.

Edited by GregroxMun

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.