IgorZ

[1.7+] Surface Mounted Lights - v1.13

Recommended Posts

Is there any way to have the lens remain colour when changing the brightness of the lens? It feels unrealistic to see a bright white lens with a coloured light pool, and turning the brightness of the lens down to 0.3 or 0.4 also feels "wrong." If not, no biggie; I'm mostly using this mod for the three (fantastic) lights you're adding, it'd just be nice for consistency.

Share this post


Link to post
Share on other sites
2 hours ago, JH4C said:

Is there any way to have the lens remain colour when changing the brightness of the lens?

It's tricky and won't work as expected in all the cases. Unity uses the RGB scheme to set a color, and if you're familiar with this model, you should know that the light intensity depends on the color components. E.g. "red" (1,0,0) is only 33% of intensity of the white light (1,1,1). In the professional engines the color definition has a special component - intensity, which let's the renderers to mix the lights correctly, but in Unity we have what we have. I think there can be some formula invented to keep the lens intensity looking realistically most of the time, but I chose to simply let people defining what they want. This thing isn't worth the efforts.

That said:

2 hours ago, JH4C said:

and turning the brightness of the lens down to 0.3 or 0.4 also feels "wrong."

...is a wrong statement. You're free to setup any values which you feel are good, and it won't be a cheat :)

Share this post


Link to post
Share on other sites
14 hours ago, sibaar said:

It would be nice if you could add your mods to spacedock.

This is on github and available through CKAN.

Share this post


Link to post
Share on other sites
1 hour ago, LlamasAreNeat_ said:

How do I access the lights? I looked for them but I couldn't find them.

Do you mean how to install the mod or how to use the lights in flight? The installation process is explained in the OP.

Share this post


Link to post
Share on other sites
Quote

Do you mean how to install the mod or how to use the lights in flight? The installation process is explained in the OP.

Thanks for responding. I meant how do I use the lights?

Edited by LlamasAreNeat_
First edit is because I forgot the "T". 2nd edit is because I forgot to quote IgorZ

Share this post


Link to post
Share on other sites
44 minutes ago, LlamasAreNeat_ said:

Thanks for responding. I meant how do I use the lights?

You use them the same way as you would use the stock lights. Attach them to a vessel in the editor, launch, and activate either thru the part's menu or by pressing "L" (turn on/off all the lights on the vessel). Keep in mind, that if you have more than 4 light parts on the vessel, you need to adjust your game video settings to let the video card properly rendering them (see notes in OP).

Share this post


Link to post
Share on other sites
5 hours ago, IgorZ said:

You use them the same way as you would use the stock lights. Attach them to a vessel in the editor, launch, and activate either thru the part's menu or by pressing "L" (turn on/off all the lights on the vessel). Keep in mind, that if you have more than 4 light parts on the vessel, you need to adjust your game video settings to let the video card properly rendering them (see notes in OP).

Nvm, I'm blind. I found them, Thanks for the attention though.

Share this post


Link to post
Share on other sites

1.8 (July 8th, 2018)

  • [Change] Upgrade the ModuleManager dependency version.
  • [Enhancement] Add Italian localization (IT_it).
  • [Enhancement] Add Spanish localization (ES_es).

Share this post


Link to post
Share on other sites

1.9 (OCtober 16th, 2018)

  • [Change] KSP 1.5 compatibility.

Share this post


Link to post
Share on other sites
8 hours ago, Cubivore said:

Just wanted to say thanks for maintaining this mod, I never play without it.

You're welcome!

Share this post


Link to post
Share on other sites

1.10 (December 22nd, 2018)

  • [Change] KSP 1.6 compatibility.

Share this post


Link to post
Share on other sites
15 hours ago, IgorZ said:

1.10 (December 22nd, 2018)

  • [Change] KSP 1.6 compatibility.

Previous version is 1.9. So I would suggest changing the version number to something else as to squash any confusion that could arise. If its just a ksp version change perhaps something like 1.91 or 1.9.1 would be better.

Ckan normally does pretty good with versioning but it likes to act weird with some mods that have strange version numbers(example: it thinks 0.12 is an updated version over 0.2, or..1.8.06 is an updated version over 1.8.3.4) I think it has something to do with the extra numeric values.

I only know this shows a correct update because I check ckan regularly after a ksp update, and then came here to confirm(thanks to your update post) but others might be a bit confused to see the version go from 1.9 to 1.1 especally when they dont check ckan often.

 

Cheers!

Share this post


Link to post
Share on other sites
43 minutes ago, Jesusthebird said:

Previous version is 1.9. So I would suggest changing the version number to something else as to squash any confusion that could arise. If its just a ksp version change perhaps something like 1.91 or 1.9.1 would be better.

Ckan normally does pretty good with versioning but it likes to act weird with some mods that have strange version numbers(example: it thinks 0.12 is an updated version over 0.2, or..1.8.06 is an updated version over 1.8.3.4) I think it has something to do with the extra numeric values.

I only know this shows a correct update because I check ckan regularly after a ksp update, and then came here to confirm(thanks to your update post) but others might be a bit confused to see the version go from 1.9 to 1.1 especally when they dont check ckan often.

 

Cheers!

Not sure what do you mean. 1.10 (one-ten) is a logical increase to 1.9 (one-nine). There is no rule to have the minor number of the version to be in a range of [0; 9]. And I never seen any issues with CKAN in this matter.

Share this post


Link to post
Share on other sites
16 hours ago, IgorZ said:

1.10 (December 22nd, 2018)

  • [Change] KSP 1.6 compatibility.

I have a problem... The lights in my vessels lost their color after installing your mod. Do you know if there's a way around it?

Share this post


Link to post
Share on other sites
1 hour ago, Jesusthebird said:

it thinks 0.12 is an updated version over 0.2, or..1.8.06 is an updated version over 1.8.3.4

0.12 would be an update over 0.2 though, and 1.8.06 - or rather 1.8.6 (because the 0 is implied) - would be an update over 1.8.3.4, so that shows that CKAN is working as intended. It also shows that it should cope just fine with 1.10 coming after 1.9.

Share this post


Link to post
Share on other sites
2 hours ago, rfelipe200 said:

I have a problem... The lights in my vessels lost their color after installing your mod. Do you know if there's a way around it?

Are you playing KSP 1.6.0? Have you updated ModuleManager to the latest version? Which parts specifically have lost their colors and how does it look now? Have their light color reverted to white or it's just the lens color that changed?

Share this post


Link to post
Share on other sites
21 minutes ago, IgorZ said:

Are you playing KSP 1.6.0? Have you updated ModuleManager to the latest version? Which parts specifically have lost their colors and how does it look now? Have their light color reverted to white or it's just the lens color that changed?

Yes, yes, both stock lights and they looks as default, and the light color reverted to a hot-white... It seems to have reverted to the mods default, come to think of it.

This is how it looks like right now:
 

Spoiler

ZfMGCmA.png

That's how it did before:

Spoiler

uoxugmJ.png

 

Share this post


Link to post
Share on other sites
11 minutes ago, rfelipe200 said:

Yes, yes, both stock lights and they looks as default, and the light color reverted to a hot-white... It seems to have reverted to the mods default, come to think of it.

Hmm, it looks something has changed in 1.6.0. The stock lights adjustment was always a hack, not a big surprise it eventually stopped working. Please, share the log too. I'll take a look when at home.

Share this post


Link to post
Share on other sites
Just now, rfelipe200 said:

Wrong log file. I gave a link to the troubleshooting Wiki with purpose :) Please, give me the right one. Btw, Just checked in my setup - no issues found. The light color and the lens works fine for me. I have only a few mods in my game, though.

Share this post


Link to post
Share on other sites
1 minute ago, IgorZ said:

Wrong log file. I gave a link to the troubleshooting Wiki with purpose :) Please, give me the right one. Btw, Just checked in my setup - no issues found. The light color and the lens works fine for me. I have only a few mods in my game, though.

I'm trying to find it, but there's no log file in my KSP_Data folder. How do I generate it?

Share this post


Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.