RoverDude

[1.8.x] - Modular Kolonization System (MKS)

Recommended Posts

21 hours ago, dlrk said:

Are more details available anywhere? This doesn't seem to be in the Wiki

I believe the critical thing is that you must have a Pioneer Module (presumably powered / crewed...).  That has a command called 'Check colony rewards', which when used gives you the science / funds / reputation that's been generated since the last time you did it.  How that's calculated, though, I have little idea...

Share this post


Link to post
Share on other sites

Hello, I looked on the MKS Lite post, and it said there's now a config option for MKS Lite in the main MKS, but I can't find it.

If someone knows what I'm talking about and could help me out that would be appreciated :)

Share this post


Link to post
Share on other sites
31 minutes ago, The Spac said:

Hello, I looked on the MKS Lite post, and it said there's now a config option for MKS Lite in the main MKS, but I can't find it.

If someone knows what I'm talking about and could help me out that would be appreciated :)

Just need to turn off the option to consume machinery in the kolonization options (you can find it with other game options).  This removes the entire machine consumption mechanic and supply chain, which makes stuff pretty simple :)

Share this post


Link to post
Share on other sites
31 minutes ago, RoverDude said:

Just need to turn off the option to consume machinery in the kolonization options (you can find it with other game options).  This removes the entire machine consumption mechanic and supply chain, which makes stuff pretty simple :)

I see, thank you

Share this post


Link to post
Share on other sites

Matter of "perform maintenance" lacking in MKS 1.1.0.0

EDITED on Saturday 23rd of March 2019 to update with a further development (proposed solution with initially successful testing).

This post has been updated since being written on Thursday, as I have found a potential fix after much comparing of config files, I found a module entry difference that seems to have led to the observed behaviour of the "problem". I had, when making the original posting been looking through config files and source code for "maintenance" - but it appears to have been a slightly different word needed!

Am keen for feedback from anyone who may have been having similar issues and this may help fix, or if there are potential side effects I don't yet understand to what I have done to resolve the problem. I have tweaked a system of which I only have surface knowledge, so if there is something I have not considered, I would not be surprised.

In my initial testing, the expected behaviour has been restored in the limited test cases. See the section at the bottom "Tried solution". I have put it as a new section at the bottom so that people can see the background in getting to the solution. If you have already read the original posting, please scroll straight down.

 

Summary:
Maintenance function appears to have disappeared on updating from MKS 0.55.0.0 to MKS 1.1.0.0.

Version info:

KSP 1.6.1.2401 (with Making History 1.6.1),

MKS 1.1.0.0 (augmented by Ground Construction from GC2.2 to overcome the ground assembly line closure malfunction)

Other mods used
KAS 1.1
KIS 1.16
kOS 1.1.5.2
Karbonite 1.1.0.0
GroundConstruction 2.2
VTS_USIpack 3.1.1
DockingPortAlignmentIndicator6.8.2
MechJeb2 2.8.1.0
USI-LS 1.1.0.0

Detail:

I have been having some trouble lately with performing maintenance. By lately I mean this appears to be since updating to MKS1.1.0.0

Expected behaviour:

With MKS 0.55.0.0 I would get a list of automatic maintenance performed when a craft with an engineer staffed workshop was present when it loaded or if in focus, apparently after a time, and a "perform maintenance" button when engineers are on EVA near a qualified part. 

As part of my trying to find where the problem lies, I have tested, removing all mods and reinstalling MKS 0.55.0.0, and the expected button appears in the right click menu. (this was to ensure my memory of the expected behaviour was correct)

Observed behaviour:

Since I have updated to MKS 1.1.0.0, my career game has moved along to needing to refuel reactors. The symptom was first noticed trying to refuel a 1.25m reactor, and a Duna class Power Distribution Unit. I cannot see a perform maintenance button in the right click menu for either of the reactor/power distribution units. The automatic maintenance notifications also have gone.

Attempts to resolve:

In order to try and figure out what I have done to break this functionality, I have been trying to find where the maintenance functionality gets coded, but have not been able to find reference to it on looking through KolonyTools source code at GitHub. Admittedly, I don't understand much of it,  so may well have missed the "how".

I have also tried removing all non-Squad mods (leaving only the Squad and SquadExpansion folders), and tested with just the MKS 1.1.0.0 folders/files (plus Squad and SquadExpansion folders). The perform maintenance button is also missing with neat MKS 1.1.0.0 (when tried with neat MKS0.55.0.0 for the above "expcted behaviour test", the symptom disappeared.)

From reading over changelogs, I haven't found any reference to removing the maintenance functionality.

I have not seen any chatter about such a matter on the forum, so I suspect it's something I'm doing wrong.

I am out of ideas, so if anyone has any insight, please let me know (my Kerbals on the Mun may face a cold night soon if I can't refuel the reactors;.;!)

Thank you.

 

Tried solution: (this section was added in the Saturday 23rd of March update)

After much eyeballing of config files, comparing between MKS 0.55.0.0 and MKS 1.1.0.0, the following lines were a difference (present in the former, omitted in the latter).

    MODULE
    {
        name = USI_ModuleFieldRepair
    }    

To try out the idea that this may be causing the observed behaviour....

I inserted these lines into the config file for the 125 reactor then loaded up KSP and the savefile. I sent out my engineer to see if there was a "perform maintenance" button on the part's right click menu, and yes there was. before clicking the perform maintenance button, I focused the craft with the reactor to verify it was empty beforehand, but it was full. This was unexpected, I can only estimate that the engineers who were in the workshop had performed auto maintenance, but I hadn't seen the message due to an open window occluding that part of the screen.

To test the aspect of automatic maintenance, I took the engineers out of the workshops before closing.

I then closed KSP back down, and updated the DunaPDU and RangerWorkshop config files with the same lines identified above.

On reloading KSP and the save file, when focusing on the ship, all was well. I got my engineer out, and was able to do a perform maintenance on the Duna PDU which was also down on Enriched Uranium, and the perform maintenance button was available also on the RangerWorkshop's right click menu. Rather than test clicking it, I put the engineer into the workshop to test the automatic maintenance function, and I got the (hoped for) multiple parts automatic maintenance notification (for the three parts that I have updated with the above module. The RangerWorkshop is now filled with machinery, so things seem to be working well, and I anticipate that other parts should follow suit.

I am writing this now to seek feedback on this (I fear I am breaking something else somewhere by doing it) solution, and see if anyone else is having issues like this. As I put in the original posting, I haven't seen any chatter about such a matter, so I fear it is just me!

Thanks for your time. 

P.S. further to my comment above about a cold Munar night for the Kerbals.... Jebediah was starting to look out of the cupola window longingly at the RTGs on the rover as the cold night was falling on the Mun, after having recently screened "The Martian" in the Ranger Hab module using the last few atoms of Enriched Uranium in the PDU!;)

Edited by PotatoAndBeanHarvester
Have tried a solution which I seek feedback on.

Share this post


Link to post
Share on other sites

Is this currently working under 1.6.0?  It looks like people are using it in 1.6.1 so I'm guessing yes.  But it doesn't show up in the compatible list for 1.6.0 in CKAN.  Do I just need to install it manually?

Share this post


Link to post
Share on other sites

Hello, does this mod work with the latest version of KSP, or do I have to downgrade to 1.3? Thanks.

Share this post


Link to post
Share on other sites
1 hour ago, techgamer16 said:

Hello, does this mod work with the latest version of KSP, or do I have to downgrade to 1.3? Thanks.

See the post right above you.

Share this post


Link to post
Share on other sites

Okay so I had a big long post ready to go, but uh... I figured it out. (A long story that essentially boils down to "Don't manually install mods or bad things happen")

Here's a better question: Why does MKS still list ground construction as a dependency in CKAN?

Ground construction is bundled with the github download, being a dependency and all. It's also labeled as a dependency on CKAN... which is fine, because normally it would automatically grab it. Except that ground construction on CKAN is only listed as being compatible with 1.4.5, although we know otherwise. Of course, MKS itself says it's compatible with 1.6.9, so why would you think to check otherwise? This leads to the counter-intuitive situation where you cannot ask CKAN to install MKS unless you specifically dig through its dependencies, notice that ground construction asks for 1.4.5, and then manually tell CKAN that 1.4.5 mods are okay (just for this one).

I guess this is technically just a CKAN UI problem, but I don't see why the ground construction dependency can't just be shoved into the CKAN repository to bypass this problem. Assuming that the mod author of ground construction isn't already working on resolving it, of course.

Share this post


Link to post
Share on other sites
1 hour ago, johnnstokes99 said:

Okay so I had a big long post ready to go, but uh... I figured it out. (A long story that essentially boils down to "Don't manually install mods or bad things happen")

Here's a better question: Why does MKS still list ground construction as a dependency in CKAN?

Ground construction is bundled with the github download, being a dependency and all. It's also labeled as a dependency on CKAN... which is fine, because normally it would automatically grab it. Except that ground construction on CKAN is only listed as being compatible with 1.4.5, although we know otherwise. Of course, MKS itself says it's compatible with 1.6.9, so why would you think to check otherwise? This leads to the counter-intuitive situation where you cannot ask CKAN to install MKS unless you specifically dig through its dependencies, notice that ground construction asks for 1.4.5, and then manually tell CKAN that 1.4.5 mods are okay (just for this one).

I guess this is technically just a CKAN UI problem, but I don't see why the ground construction dependency can't just be shoved into the CKAN repository to bypass this problem. Assuming that the mod author of ground construction isn't already working on resolving it, of course.

Ahhhh....  Thanks!  That is very helpful.  So, in CKAN you "just" have to go into Settings -> Compatible KSP versions.  Then add 1.4.5 to the list (it wasn't in the list originally).  Then check the box for 1.4.5 and hit accept.  Now CKAN will offer MKS/OKS as a compatible mod for 1.6.0.

Share this post


Link to post
Share on other sites
On 3/20/2019 at 7:41 PM, PotatoAndBeanHarvester said:

Matter of "perform maintenance" lacking in MKS 1.1.0.0

Detail:

I have been having some trouble lately with performing maintenance. By lately I mean this appears to be since updating to MKS1.1.0.0

 

I'm having the same problem! Have you filed a bug report on the GitHub for MKS?

Share this post


Link to post
Share on other sites

 

3 minutes ago, jzroth said:

I'm having the same problem! Have you filed a bug report on the GitHub for MKS?

Thank you for your note jzroth,

In light of it being more than just me, I do now plan to put this into GitHub (hence my thanks for your words that I am not alone in this problem - until your post, I had no evidence of it being beyond my system). 

I will give it a couple of days more to see if anyone with more insight has ideas about possible side effects of my proposed fix, then hopefully I can provide some more value in the post in the Github issues area, as I would like to help RoverDude with the best evidence that I can find.

If no indication from forum members of side effects being introduced, I'll  try updating other industrial pieces to verify if that all works too, and also it gives are a couple of days of game time movement for glitches to appear with the parts I have already altered as outlined in my updated earlier post (from yesterday).

In the meantime, there is a note on the matter here if people are having problems, as this is the forum that GitHub refers across to, so people should be able to see that it is an active topic.

To update... nearly a day later and my modified parts have not yet caused any detected issues, so... so far so good.

As an option... If you would like to try the proposed solution on some other parts too and record any issues that arise (or if no issues arise) and their context and let me know how you go in a couple of days I'll be able to add that to the case.

Many thanks again.

Share this post


Link to post
Share on other sites

It would be really awesome if these pieces came in a wedge form factor like Universal Storage so that we could slot in the modules into larger cylinders (3.75 to 7.5 metres) for big ships and bases. Otherwise, I'm loving all of your great work.

Share this post


Link to post
Share on other sites

I have a few questions, and would be appreciative of any help. For the record I'm playing 0.55.0 for ksp 1.4.5, but idk if that really matters.

1. How do bays decide which specialist they get? For example if you have an industrial refinery and 3 engineers of different ranks onboard(elsewhere in the base), which one will buff which process? 

2. Is the part efficiency reciever bonus on a per-part or per-bay basis? For example, if I have 1 MPU(3.75m) with all three bays set to smelter, and 1 Tundra industrial refinery with 3 bays active, is the bonus for all TIR bays (1+(3*3.767/4.48)) or is it instead (1+(3.767*3/(3*4.48)))?

3. Why does the last bay on the Tundra Industrial Refinery say "B3 Active Separator" despite the first two saying active bay?

4. I think this is just a bug but all the drills in the VAB info panel just list multiple resource harvesters for dirt. You can still toggle the separators when the drill is placed in a craft.

5. What are the maximum kolony statistics percentages? Will max productive rate increase indefinitely? Does the rate of increase slow down over time? I couldn't find much info about this on the wiki.

6. If I have an effectively infinite supply of ColonySupplies and enough Tundra Colonization modules to support the base population, is there any benefit at all of having habitation modules?

Thanks for the mod, this is one of the best.

 

EDIT: as an add on to the last question, when the kolonisation module 3.75m wiki page says it is rated for 12 kerbals in its life support extender module, what does that mean exactly?

Edited by Jumberlack

Share this post


Link to post
Share on other sites
3 hours ago, ljcolasanto said:

It would be really awesome if these pieces came in a wedge form factor like Universal Storage so that we could slot in the modules into larger cylinders (3.75 to 7.5 metres) for big ships and bases. Otherwise, I'm loving all of your great work.

Check out Stockalike Station Parts.  They have some storage units that can hold MKS resources that are in a wedge-like form factor.  (Not quite the same as US - but you could build something similar using them.)

Share this post


Link to post
Share on other sites
6 hours ago, DStaal said:

Check out Stockalike Station Parts.  They have some storage units that can hold MKS resources that are in a wedge-like form factor.  (Not quite the same as US - but you could build something similar using them.)

Yeah, that's a great mod! I use a lot of its parts. I was more suggesting wedge shaped modules, like logistics, pioneer, agriculture, etc. But all of the USI mods are pretty great so far so no complaints from me lol.

Share this post


Link to post
Share on other sites

Guys I have a qustion.

I se t MKS Tundra Agriculture module to Agrophonics in VAB.   And can I change it to something different like Cultivate when the module is already in sapce docked with station ?   

Or I have to bring another MKS Tundra Agriculture module with this Cultivate setting set ? 

I must say I am quuite bit confused here with those different modes of some MKS modules :(

Share this post


Link to post
Share on other sites
11 hours ago, Jovzin said:

Guys I have a qustion.

I se t MKS Tundra Agriculture module to Agrophonics in VAB.   And can I change it to something different like Cultivate when the module is already in sapce docked with station ?   

Or I have to bring another MKS Tundra Agriculture module with this Cultivate setting set ? 

I must say I am quuite bit confused here with those different modes of some MKS modules :(

Hi Jovzin,

Yes you can change its converter settings in the field.

Send an engineer on EVA nearby the Tundra Agriculture module (or other MKS converter), right click the module with the engineer in focus  standing (floating if in space) right nearby, and there should be options e.g. Bay 1 Agriculture (S) => Agriculture (D)  (The left side is what the current setting is, the right side is the "change converter to"). Below this are a couple of buttons for Next bay and Previous bay, which selects the next and previous type available from the options for this module in the "change converter to" area above. This is available across the MKS converters, and allows selection of the desired option from the full set available before committing to the change, as it costs Specialised parts and Materials kits and electricity to do so (depending on which module one is doing the change on).

I hope that helps.

Kind regards, P&BH

Edited by PotatoAndBeanHarvester

Share this post


Link to post
Share on other sites

Is the karbonite converter and distiler still working? I'm playing on a fresh instalation, with the latest versions of mks and ksp 1.6, and either the distiler or converter aren't working anymore. In the VAB, the parts doesn't show any information from the converters, and on game, there aren't any option available to convert anything.

Share this post


Link to post
Share on other sites
1 hour ago, Danilo Coelho said:

Is the karbonite converter and distiler still working? I'm playing on a fresh instalation, with the latest versions of mks and ksp 1.6, and either the distiler or converter aren't working anymore. In the VAB, the parts doesn't show any information from the converters, and on game, there aren't any option available to convert anything.

Dear Danilo,

Sawyerap has started a note on the on the Karbonite Github issues page concerning karbonite conversion. I was also having trouble similar to what it sounds like you are having, and I found that post. I tried the fix, and recorded the results in my note on that thread (as user Chempipeline).

You can find the fix at the following url.

https://github.com/BobPalmer/Karbonite/issues/274

I hope that gets you back on track.

Kind regards, P&BH

Share this post


Link to post
Share on other sites

so, i found an interesting bug with the drills, the maximum cooling on the larger drills is far less than they need at 100k, at that level only a single separator can be activated at once. coupled with having a higher energy needed for the same amount of extraction as a smaller drill, its completely better in every way to ignore all larger drills and just use multiple small ones

 

Share this post


Link to post
Share on other sites
7 hours ago, lunaris69 said:

so, i found an interesting bug with the drills, the maximum cooling on the larger drills is far less than they need at 100k, at that level only a single separator can be activated at once. coupled with having a higher energy needed for the same amount of extraction as a smaller drill, its completely better in every way to ignore all larger drills and just use multiple small ones

 

it's a known bug and can be fixed with a simple cfg file edit like here:

 

Edited by alien_wind

Share this post


Link to post
Share on other sites
23 hours ago, lunaris69 said:

so, i found an interesting bug with the drills, the maximum cooling on the larger drills is far less than they need at 100k, at that level only a single separator can be activated at once. coupled with having a higher energy needed for the same amount of extraction as a smaller drill, its completely better in every way to ignore all larger drills and just use multiple small ones

 

If using wordpad, make a .txt file and paste that comment's hidden contents into it. Save the file as drillfix.txt somewhere within your game data folder. Rename file to be .cfg instead of .txt. Resume playing ksp

Share this post


Link to post
Share on other sites
On 3/28/2019 at 1:52 PM, PotatoAndBeanHarvester said:

Hi Jovzin,

Yes you can change its converter settings in the field.

Send an engineer on EVA nearby the Tundra Agriculture module (or other MKS converter), right click the module with the engineer in focus  standing (floating if in space) right nearby, and there should be options e.g. Bay 1 Agriculture (S) => Agriculture (D)  (The left side is what the current setting is, the right side is the "change converter to"). Below this are a couple of buttons for Next bay and Previous bay, which selects the next and previous type available from the options for this module in the "change converter to" area above. This is available across the MKS converters, and allows selection of the desired option from the full set available before committing to the change, as it costs Specialised parts and Materials kits and electricity to do so (depending on which module one is doing the change on).

I hope that helps.

Kind regards, P&BH

Thank you for the tip. Did not know about this function :)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.