sarbian

[1.3.0] Anatid Robotics / MuMech - MechJeb - Autopilot - [2.6.1] [27 May 2017]

Recommended Posts

3 hours ago, sarbian said:

I actually have no idea which part of MJ works or does not work when out of comm. range. As for the Scripting module it is a contribution by @SPD13 and I did not take the time to look at all its features, yet.

Throttling does not work. Other commands such as attitude control do. I *think* that if auto-RCS is enabled that it can also turn on RCS but I'm not 100% sure on that.

I think it should be changed such that MJ2 can throttle and do everything else while out of range or when occluded but only if those things were set up prior. In other words, if the craft is behind a planet, you can't  set up a Maneuver Plan or use Smart ASS, etc but I haven't had the time to look into HOW to go about doing it. I think definitely we need better compatibility with the comms system so that MJ2 cant be used to outright bypass it (they can always enable limited control if that's what they want). And so that all features will work if they were set up before going out of comms.

Maybe after finishing with everything else I'm involved with I can look at that.

Share this post


Link to post
Share on other sites
4 hours ago, Starwaster said:

I think definitely we need better compatibility with the comms system so that MJ2 cant be used to outright bypass it (they can always enable limited control if that's what they want). And so that all features will work if they were set up before going out of comms.

Maybe after finishing with everything else I'm involved with I can look at that.

Is there a way I can disable being able to control a probe when out of comms range until you guys provide a permanent fix? Maybe somewhere in the .cfg file or something like that?

Share this post


Link to post
Share on other sites
1 hour ago, Voodoo8648 said:

Is there a way I can disable being able to control a probe when out of comms range until you guys provide a permanent fix? Maybe somewhere in the .cfg file or something like that?

No, you're stuck with showing restraint and not using MJ2 to control with until it gets back in comms range :P

 

Share this post


Link to post
Share on other sites
1 hour ago, Voodoo8648 said:

Is there a way I can disable being able to control a probe when out of comms range until you guys provide a permanent fix? Maybe somewhere in the .cfg file or something like that?

Well, you can turn off Comm Network in the settings menu. 

It's the first thing I do with a new play-through cos it adds nothing to KSP for me. 

Share this post


Link to post
Share on other sites

Hello guys! Im having a small problem with mechjeb lately! My manouver planner button does not show up! I already have the tech and everything! Any fixes? 

 

Its not that important, but its good to have a little more of precision when doing manouvers!

Share this post


Link to post
Share on other sites

Is there a way to make mechjeb automatically execute burns at half the estimated burn time?  

Share this post


Link to post
Share on other sites
1 hour ago, Foxster said:

Well, you can turn off Comm Network in the settings menu. 

It's the first thing I do with a new play-through cos it adds nothing to KSP for me. 

That sounds like the opposite of what he wants.

2 minutes ago, KSPNoob said:

Is there a way to make mechjeb automatically execute burns at half the estimated burn time?  

Do you mean to start the burn ahead of time so that half occurs before the scheduled time and half after? (such as for long burns?)

If so, it already does that.

Share this post


Link to post
Share on other sites
Posted (edited)
1 hour ago, Starwaster said:

That sounds like the opposite of what he wants.

Do you mean to start the burn ahead of time so that half occurs before the scheduled time and half after? (such as for long burns?)

If so, it already does that.

NVM figured it out Thnx though

Edited by KSPNoob

Share this post


Link to post
Share on other sites
31 minutes ago, KSPNoob said:

Yeah and when I do a burn it always seems to just do it for whatever the lead time is set to.  Am I missing a setting someplace to change that?

I'm not understanding what you mean. Can you be more detailed?

Share this post


Link to post
Share on other sites

MechJeb completely throws my craft out of control when it starts it's gravity turn. It just tumbles head first spinning and eventually crashes into the ocean or ground. My friend gave me these craft, and he said when you tell Ascent Guidance to fly these crafts to a orbit of 180-300km, it works fine. Even with Smart A.S.S it doesn't work. 

I'm running MechJeb for 1.2.2.

Does anybody know what I can do to try to get MechJeb to not tip my rocket over?

 

(I have no log because this isn't really a crash or a bug)

Share this post


Link to post
Share on other sites

without seeing your craft and without a craft file it will be a little hard to diagnose could you take a video and post it up

Share this post


Link to post
Share on other sites
Posted (edited)
2 hours ago, Virtualgenius said:

without seeing your craft and without a craft file it will be a little hard to diagnose could you take a video and post it up

lP3SHJGdTUuyG-I2gnIHBQ.png

(the ascent guidance settings)

BlAr6MPbQTKRDXek8Hp8sA.png

(the rocket on the launchpad, both sides are identical)

The rocket also starts spinning once it get's into the air, I assume MJ is trying to do the regular spin once in the air, but it just keeps doing it, not stopping.

 

I don't have time to make a video right now, I'm doing some things.

Edited by Quarkz

Share this post


Link to post
Share on other sites
3 hours ago, Quarkz said:

MechJeb completely throws my craft out of control when it starts it's gravity turn. It just tumbles head first spinning and eventually crashes into the ocean or ground. My friend gave me these craft, and he said when you tell Ascent Guidance to fly these crafts to a orbit of 180-300km, it works fine. Even with Smart A.S.S it doesn't work. 

I'm running MechJeb for 1.2.2.

Does anybody know what I can do to try to get MechJeb to not tip my rocket over?

 

(I have no log because this isn't really a crash or a bug)

Here's what I do and what works for me:

Set your Angle of Attack limit to no more than 3 or 4 degrees. 4 should be okay.

 

Limit your acceleration to 30m/s/s

Make sure you have a good reaction wheel installed on the rocket

If you have any fins, make sure they are mounted as low as possible on the rocket.

Share this post


Link to post
Share on other sites
9 minutes ago, Voodoo8648 said:

Here's what I do and what works for me:

Set your Angle of Attack limit to no more than 3 or 4 degrees. 4 should be okay.

 

Limit your acceleration to 30m/s/s

Make sure you have a good reaction wheel installed on the rocket

If you have any fins, make sure they are mounted as low as possible on the rocket.

Would that work with FAR?

Share this post


Link to post
Share on other sites
5 hours ago, Quarkz said:

Would that work with FAR?

It should, yes.

One thing I'd like to add to what @Voodoo8648, limiting acceleration to 30m/s is a good value for Kerbin if you have a high thrust rocket so you don't waste fuel. But, I notice you have solid boosters on your rocket. If those aren't gimballed (and if they are the stock boosters then they are not unless they've been patched to add gimbals) I foresee a problem where if you've limited your thrust to a given acceleration value, MJ2 very well might throttle all the way down to zero and then you will have no control authority. The way around that is to set a minimum throttle limit (Keep limited throttle over) that prevents other limiters from setting the throttle below the percentage that you set.

Right now though, there's a bug that prevents keeps the minimum from kicking in when it's supposed to but there's a pull request in to fix that.

Share this post


Link to post
Share on other sites

The rocket still tips over even when I limit the thrust and everything. Is there like a video recording mod that I can use?

Share this post


Link to post
Share on other sites
2 hours ago, Quarkz said:

The rocket still tips over even when I limit the thrust and everything. Is there like a video recording mod that I can use?

Lots of people use bandicam 'cause free.

Is you CoL below your CoM?  I would add a couple of small fins to the outsides of the solids and airbrakes(Pitch&Yaw turned on) or small control surfaces as low as possible on the main rocket. Set the control authority on them to ~30% (less for roll to eliminate rocking). If your TWR is above 2 reduce the thrust on the solids in VAB.  Like real life you want to limit you throttle until after max Q, keep below mach 1 if possible, 15km and up give it the gas. Make sure that engine has gimble capability you only need 3% range so engines like the vector commonly need to be limited or you get oscillation.

Share this post


Link to post
Share on other sites
2 hours ago, Quarkz said:

The rocket still tips over even when I limit the thrust and everything. Is there like a video recording mod that I can use?

You could also try setting the Limit Q option to somewhere like 15000. I haven't tested it with FAR but it has helped get some of my really unaerodynamic payloads to orbit. If nothing else helps, you could fly straight up for about 20km and only then start the gravity turn. Yes, it's really inefficient but sometimes the craziest payloads require it.

Share this post


Link to post
Share on other sites

Share the craft file and mods it uses and the gurus will soon figure out why it doesnt fly straight

Share this post


Link to post
Share on other sites

See, I'm recreating the Ares V, so I can't really add fins or any other design change, because then it wouldn't look like the original design.

Share this post


Link to post
Share on other sites
Posted (edited)
4 hours ago, Quarkz said:

See, I'm recreating the Ares V, so I can't really add fins or any other design change, because then it wouldn't look like the original design.

I just looked at the pictures of your rocket.

#1: you have Limit Angle of Attack set to 10 degrees! Lower this to 3 or 4 MAXIMUM!

#1: Lower your Limit Q down to 20000.

#2: Limit acceleration is NOT checked. Check it.

 #3: You probably don't have enough or powerful enough Reaction Wheels. MJ2 is fighting to compensate for the drag, but in the end, your rocket is losing due to not having enough counteracting force and it's accelerating too fast. You need to add a bigger or more SAS modules. 

 

NO WONDER YOUR SHIP KEEPS FLIPPING AROUND!

Edited by Voodoo8648

Share this post


Link to post
Share on other sites
6 minutes ago, Voodoo8648 said:

 #3: You probably don't have enough or powerful enough Reaction Wheels. MJ2 is fighting to compensate for the drag, but in the end, your rocket is losing due to not having enough counteracting force and it's accelerating too fast. You need to add a bigger or more SAS modules. 

I agree with everything except this... I use the following patch and don't have a problem with flipping except when it's my fault (poor design)

Spoiler

@PART[*]:HAS[@MODULE[ModuleReactionWheel]]
{
    @MODULE[ModuleReactionWheel]
    {
        @PitchTorque *= 0.1
        @YawTorque *= 0.1
        @RollTorque *= 0.1
    }
}

Also, @Quarkz not sure logs would help in this situation so not asking for any but I just noticed you saying a few posts back that you didn't have any because there weren't errors or crashing. Sorry but that is WRONG. You always have logs unless you explicitly disable logging. Remember that.

Share this post


Link to post
Share on other sites
1 minute ago, Starwaster said:

I agree with everything except this... I use the following patch and don't have a problem with flipping except when it's my fault (poor design)

  Hide contents

 

What does that patch do?

3 minutes ago, Starwaster said:

I agree with everything except this... 

If you ever have issues with a rocket flipping, watch the lower left corner of the screen of the pitch/roll/yaw inputs and watch as the needles are maxed out.... when that happens there is not enough force. Add a React wheel and your flipping problem will stop. more torque is just as important as the ascent guidance settings... especially if there are no fins present or enough gimble in the engines on large rockets. 

Share this post


Link to post
Share on other sites
1 minute ago, Voodoo8648 said:

What does that patch do?

Scales reaction wheel torqueing down to 10% of their stock values since reaction wheels are overpowered.

It's a little brute force and I can't say with 100% certainty that I haven't limited something too far but the attachable wheels work ok and things that I want to be limited are limited (command pods...)

Share this post


Link to post
Share on other sites
Posted (edited)
7 minutes ago, Starwaster said:

Scales reaction wheel torqueing down to 10% of their stock values since reaction wheels are overpowered.

It's a little brute force and I can't say with 100% certainty that I haven't limited something too far but the attachable wheels work ok and things that I want to be limited are limited (command pods...)

I dunno man. That patch is counter-intuitive to his problem. If anything he needs MORE TORQUE, not less and certainly not 90% less. 

Bottom line, his top 3 problems are too steep AoA, too high acc and not enough SAS torque.... That why he be trippin

Edited by Voodoo8648

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now