Avera9eJoe

[1.10] Spectra Visual Compilation 1.4.0 "Jewel" (2nd July 2020, Force 1.8/1.9 compatibility in CKAN)

Recommended Posts

This is actually amazing. I've never seen this game look this good. Thanks a ton to you and the people whose mods you configured for this mod. 

Edited by Rel52

Share this post


Link to post
Share on other sites

First time trying a new install with Spectra and it looks amazing!

I do have one issue. On the day side of an orbit there is a hard separation between what look to be two different shades of skyboxes. Been away from KSP a while so this might be a well known issues with one of the mods, but I don't know what to check.

This happens with the default Spectra skybox and with a modified skybox. The effect is much more noticeable in-game due to motion so I increased the contrast for this image to highlight the effect 

gTsl0wz.jpg

Edited by skandervr

Share this post


Link to post
Share on other sites

Maybe someone knows what is causing this, but when I go into my map around the beginning of a full kerbin orbit, kerbin will start flickering blue. It fixes it self for the remainder of the mission if I just reload a quicksave. Has anyone have this happen and fixed it? I'm gonna upload my modlist and my log.txt https://imgur.com/a/81ytO That is my modlist and my log.txt is here. (It's a dropbox link it was far to big to paste in pastebin) https://www.dropbox.com/s/xq8dyvw5jb7s48t/KSP.log?dl=0

 

Share this post


Link to post
Share on other sites
17 hours ago, Rel52 said:

This is actually amazing. I've never seen this game look this good. Thanks a ton to you and the people whose mods you configured for this mod. 

Thank you so much!! I really poured my heart into this mod with the critique and suggestions from a number of other community members like Stratzenblitz, CupcakeLanders, HatBat, and Million_Lights it became what you see today. It really makes my day to hear back from comments like you :) Thank you, and Merry Christmas!

12 hours ago, skandervr said:

First time trying a new install with Spectra and it looks amazing!

I do have one issue. On the day side of an orbit there is a hard separation between what look to be two different shades of skyboxes. Been away from KSP a while so this might be a well known issues with one of the mods, but I don't know what to check.

This happens with the default Spectra skybox and with a modified skybox. The effect is much more noticeable in-game due to motion so I increased the contrast for this image to highlight the effect 

gTsl0wz.jpg

You mean the abrupt line at the end of Kerbin's atmosphere? That's a visual bug I'm aware of and am trying my best to pin down and fix. I've been too busy to make any improvements on it in recent past though, sorry :(

4 hours ago, Rel52 said:

Maybe someone knows what is causing this, but when I go into my map around the beginning of a full kerbin orbit, kerbin will start flickering blue. It fixes it self for the remainder of the mission if I just reload a quicksave. Has anyone have this happen and fixed it? I'm gonna upload my modlist and my log.txt https://imgur.com/a/81ytO That is my modlist and my log.txt is here. (It's a dropbox link it was far to big to paste in pastebin) https://www.dropbox.com/s/xq8dyvw5jb7s48t/KSP.log?dl=0

 

Sad to say but I know exactly what causes this and I'm afraid I can't do much to fix it. It's caused by Scatterer and WindowShine interfering with each other. Removing one of those two removes the bug :/

Share this post


Link to post
Share on other sites
32 minutes ago, Avera9eJoe said:

 

Sad to say but I know exactly what causes this and I'm afraid I can't do much to fix it. It's caused by Scatterer and WindowShine interfering with each other. Removing one of those two removes the bug :/

Ah, Okay yeah I'll just uninstall the windowshine then because I also noticed it made some parts see through. Thank again for the quick response, especially on the holidays. Have a great Christmas.

Share this post


Link to post
Share on other sites
4 hours ago, Avera9eJoe said:

You mean the abrupt line at the end of Kerbin's atmosphere?

Actually no. Surprisingly that does not bother me :)

Let me increase the contrast again and highlight what I mean. I know it might seem small but at least to me it's quite visible in-game. Anyway thanks for all your work.

zFHJhJK.jpg

Share this post


Link to post
Share on other sites
6 hours ago, skandervr said:

Actually no. Surprisingly that does not bother me :)

Let me increase the contrast again and highlight what I mean. I know it might seem small but at least to me it's quite visible in-game. Anyway thanks for all your work.

zFHJhJK.jpg

Ooohh.... I see that line now. Do you see it as a fixed point in the skybox or is it only visible near kerbin/other planets?

Share this post


Link to post
Share on other sites
53 minutes ago, Avera9eJoe said:

Ooohh.... I see that line now. Do you see it as a fixed point in the skybox or is it only visible near kerbin/other planets?

I think that happens at the angle of the camera I have seen that happen with out you mod even in just stock now far off the runway if you look down at the water and move the camera around see it right under the plane 

1RUU6M2.png

Share this post


Link to post
Share on other sites

I'm not getting any terrain textures when using this mod. The clouds and atmospheres work fine, but it's not showing any of the textures when orbiting or landed.

0jrjyzv.png

Share this post


Link to post
Share on other sites
2 hours ago, TaintedLion said:

I'm not getting any terrain textures when using this mod. The clouds and atmospheres work fine, but it's not showing any of the textures when orbiting or landed.

0jrjyzv.png

Looks like you didn't install them. You need to download KSPRC from the link in the install zip, and follow the instructions to copy the terrain folder in KSPRC/KSPRC to GameData/KSPRC in your install.

Edited by Avera9eJoe

Share this post


Link to post
Share on other sites

(In the OP) Mun texture on the flight mode should be like this:

Qx0fa1I.png

But I get horrible Mun textures on the flight mode (worse than stock textures, maybe stock textures with lowest setting). Why?

3hUalWN.png

sxIjuMi.png

 

My mod list:

YlHBmZv.png

Edited by CanOmer

Share this post


Link to post
Share on other sites
1 hour ago, CanOmer said:

(In the OP) Mun texture on the flight mode should be like this:

Qx0fa1I.png

But I get horrible Mun textures on the flight mode (worse than stock textures, maybe stock textures with lowest setting). Why?

3hUalWN.png

sxIjuMi.png

 

My mod list:

YlHBmZv.png

That picture you linked was taken from the dayside of the Mun. The one you took was during the night. Does it look better in daylight?

On ‎12‎/‎24‎/‎2017 at 2:22 PM, TaintedLion said:

I was EVAing in Mun orbit and my screen started flashing blue.

That's a glitch caused by WindowShine (TextureReplacerReplaced) and Scatterer I'm afraid :/

Share this post


Link to post
Share on other sites
On 12/24/2017 at 5:52 PM, Avera9eJoe said:

Ooohh.... I see that line now. Do you see it as a fixed point in the skybox or is it only visible near kerbin/other planets?

Back with info on the line/discontinuity

I finally managed to make a gif that shows it throughout an orbit. At first it seems to be skybox fixed but once you orbit you actually see it's tied to the planet's orientation.

It only happens on the dayside of the orbit, and only at below approx 120k altitude. This is on a fresh 1.3.1 install with only Spectra and its dependencies (no Windowshine) 

Also, at the exact moment/altitude this appears there are these lines in the log. The log entries below are between the screenshot without the line and the first screenshot with the line from the gif below. There is also the noticeable loading hiccup/glitch when getting closing to a planet between those two shots

[LOG 20:14:18.297] SCREENSHOT!!
[LOG 20:14:18.414] [EVE CloudsManager]: CloudsPQS: (EVE Clouds: Kerbin-Main) OnSphereActive
[LOG 20:14:18.414] [EVE CloudsManager]: Clouds2D is now MACRO
[LOG 20:14:18.423] [EVE CloudsManager]: CloudsPQS: (EVE Clouds: Kerbin-High) OnSphereActive
[LOG 20:14:18.423] [EVE CloudsManager]: Clouds2D is now MACRO
[LOG 20:14:18.423] [EVE] Applying _MainTex Cubemap
[LOG 20:14:18.424] [EVE CloudsManager]: CloudsPQS: (EVE Clouds: Kerbin-Aurora) OnSphereActive
[LOG 20:14:18.424] [EVE CloudsManager]: Clouds2D is now MACRO
[LOG 20:14:18.519] [Scatterer] Sky switched to local mode
[LOG 20:14:19.149] [Scatterer] Mapping EVE volumetrics for planet: Kerbin
[LOG 20:14:19.150] [Scatterer] Volumetric clouds error on planet: KerbinSystem.NullReferenceException: Object reference not set to an instance of an object
  at scatterer.SkyNode.mapEVEvolumetrics () [0x00000] in <filename unknown>:0 
[LOG 20:14:19.150] [Scatterer] Volumetric clouds error on planet: KerbinSystem.NullReferenceException: Object reference not set to an instance of an object
  at scatterer.SkyNode.mapEVEvolumetrics () [0x00000] in <filename unknown>:0 
[LOG 20:14:19.151] [Scatterer] Detected 1 EVE volumetric layers for planet: Kerbin
[LOG 20:14:19.417] SCREENSHOT!!

y5ZptBK.gif

Edited by skandervr

Share this post


Link to post
Share on other sites
8 minutes ago, skandervr said:

Back with info on the line/discontinuity

I finally managed to make a gif that shows it throughout an orbit. At first it seems to be skybox fixed but once you orbit you actually see it's tied to the planet's orientation.

It only happens on the dayside of the orbit, and only at below approx 120k altitude. This is on a fresh 1.3.1 install with only Spectra and its dependencies (no Windowshine) 

Also, at the exact moment/altitude this appears there are these lines in the log. The log entries below are between the screenshot without the line and the first screenshot with the line from the gif below. There is also the noticeable loading hiccup/glitch when getting closing to a planet between those two shots


[LOG 20:14:18.297] SCREENSHOT!!
[LOG 20:14:18.414] [EVE CloudsManager]: CloudsPQS: (EVE Clouds: Kerbin-Main) OnSphereActive
[LOG 20:14:18.414] [EVE CloudsManager]: Clouds2D is now MACRO
[LOG 20:14:18.423] [EVE CloudsManager]: CloudsPQS: (EVE Clouds: Kerbin-High) OnSphereActive
[LOG 20:14:18.423] [EVE CloudsManager]: Clouds2D is now MACRO
[LOG 20:14:18.423] [EVE] Applying _MainTex Cubemap
[LOG 20:14:18.424] [EVE CloudsManager]: CloudsPQS: (EVE Clouds: Kerbin-Aurora) OnSphereActive
[LOG 20:14:18.424] [EVE CloudsManager]: Clouds2D is now MACRO
[LOG 20:14:18.519] [Scatterer] Sky switched to local mode
[LOG 20:14:19.149] [Scatterer] Mapping EVE volumetrics for planet: Kerbin
[LOG 20:14:19.150] [Scatterer] Volumetric clouds error on planet: KerbinSystem.NullReferenceException: Object reference not set to an instance of an object
  at scatterer.SkyNode.mapEVEvolumetrics () [0x00000] in <filename unknown>:0 
[LOG 20:14:19.150] [Scatterer] Volumetric clouds error on planet: KerbinSystem.NullReferenceException: Object reference not set to an instance of an object
  at scatterer.SkyNode.mapEVEvolumetrics () [0x00000] in <filename unknown>:0 
[LOG 20:14:19.151] [Scatterer] Detected 1 EVE volumetric layers for planet: Kerbin
[LOG 20:14:19.417] SCREENSHOT!!

y5ZptBK.gif

Huh... :L if you aren't seeing it on other planets then it's possible it's tied to Kerbin's bad orbital fade. I'll look into it

Share this post


Link to post
Share on other sites
1 hour ago, Avera9eJoe said:

That picture you linked was taken from the dayside of the Mun. The one you took was during the night. Does it look better in daylight?

I landed, no texture at all:

FSX3oY4.png

No texture on Minmus too:

Is5n3Kp.png

Edited by CanOmer

Share this post


Link to post
Share on other sites
13 minutes ago, CanOmer said:

I landed, no texture at all:

FSX3oY4.png

No texture on Minmus too:

Is5n3Kp.png

Ah. You didn't install the surface textures. If you go back into the download and read through the steps you'll see you need to download KSPRC and copy the terrain folder from there into the KSPRC folder in Spectra. That's why it looks so bad.

Share this post


Link to post
Share on other sites

When I download Spectra in CKAN, it automatically installed KSPRC as well because KSPRC is on the depends list of Spectra. I didn't find any steps on the download link. So if I copy terrain folder, will it disrupt CKAN?

Edited by CanOmer

Share this post


Link to post
Share on other sites

Ok, I downloaded Spectra independent from CKAN and checked the steps. It seems CKAN installed KSPRC with Textures only. But in your steps Spectra needs its Terrain folder, not Textures. So I added Terrain folder in it. Now surface terrains is back. A quick CKAN update for this would be great.

Edited by CanOmer

Share this post


Link to post
Share on other sites
3 hours ago, CanOmer said:

Ok, I downloaded Spectra independent from CKAN and checked the steps. It seems CKAN installed KSPRC with Textures only. But in your steps Spectra needs its Terrain folder, not Textures. So I added Terrain folder in it. Now surface terrains is back. A quick CKAN update for this would be great.

Hm, @N70 was the one who added it to CKAN - It's likely that it linked the wrong version of KSPRC - Proot changed the filepaths at one point and it causes a bit of confusion when installing the folder.

Edited by Avera9eJoe

Share this post


Link to post
Share on other sites

Thank you for this wonderful mod !

I have one question, I can't find the scatterer window config anymore when I am in the main menu of the game it is normal ? I would like to change the brightness of the sky box and disable the auto brightness.

Share this post


Link to post
Share on other sites
5 hours ago, Grabakr said:

 I would like to change the brightness of the sky box and disable the auto brightness.

That is not a scatterer feature. You are thinking of Distant Objects Enhancements.

Edited by Galileo

Share this post


Link to post
Share on other sites
On 19.04.2017 at 6:26 PM, Avera9eJoe said:

Spectra also works with SVT - there are instructions inside the download on how to set it up.

It says "Spectra also works with SVT (Install it normally)" in the Terrain Instructions of Spectra. But it doesn't work. Surface terrain is not exist on the Mun when I checked. (I think SVT terrain is better than KSPRC terrain. So I wanted to use Spectra with SVT.)

Edited by CanOmer

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.