Sign in to follow this  
PTGFlyer

Add-on to make antennas required for unmanned vehicles?

Recommended Posts

I recall some Scott Manley thing where you needed to have an antenna to use a drone core, or something of the sort. Does anybody know which mod this is?

Share this post


Link to post
Share on other sites

The game already allows this as of version 1.2.  By default you can use SAS, full and zero throttle, plus the right click menus with "limited probe control", but WASD and fine throttle require a connection to KSC.  In the difficulty settings the game has a toggle to require a connection to KSC for ANY probe control as well.  There is also a toggle for Enable Comm Network which makes all the control stuff active, so make sure it is toggled too.

The CommNet available in KSP is a decent analogue, but if you want a more realistic version, requiring multiple antennas, power for said antennas at all times and comms delay based on distance from the controller (usually KSC, but local control is possible with a command ship), then you want Remote Tech.  This is probably what Scott Manley was using.

Edited by overkill13

Share this post


Link to post
Share on other sites

Thanks. I think that's it.

I'm using 1.1.3 because I just came back to KSP, tried to get the latest version and add all my mods, but for some reason it isn't loading, just giving me a black screen.

Well that was a lot of clicking through Github to get to what version I needed.

Edited by PTGFlyer

Share this post


Link to post
Share on other sites
45 minutes ago, PTGFlyer said:

tried to get the latest version and add all my mods, but for some reason it isn't loading, just giving me a black screen.

Install it stock, verify it works.  Then install your mods one by one, verifying that you have the right version for your version of the game and all of the dependencies are installed.

You're not on a 32bit computer, are you?  The latest version is 64 bit only.

Share this post


Link to post
Share on other sites
9 hours ago, Geonovast said:

Install it stock, verify it works.  Then install your mods one by one, verifying that you have the right version for your version of the game and all of the dependencies are installed.

You're not on a 32bit computer, are you?  The latest version is 64 bit only.

64bit.

From what I can tell, BDArmory isn't compatible with the new versions, so I don't see much of a reason to update.

What makes 1.4 better than 1.1? I'm not getting Making History, so that's irrelevant.

Edited by PTGFlyer

Share this post


Link to post
Share on other sites
21 minutes ago, PTGFlyer said:

From what I can tell, BDArmory isn't compatible with the new versions, so I don't see much of a reason to update.

It's good up to at least 1.4.5.

24 minutes ago, PTGFlyer said:

What makes 1.4 better than 1.1? I'm not getting Making History, so that's irrelevant. 

I can't say much about 1.1 vs 1.4, as I started with 1.3 and have played 1.3.1 for most of my time.  But, as point of interest, you just asked about a mod to do something that was made stock awhile ago.  I only suggested you install it and the mods one at a time, since the fact that you tried it at all implied you wanted to update.

 

There's nothing wrong with sticking with an older version, I wasn't saying you had to upgrade.  But it might be a good idea to mention it in your OP when asking for support since you're 4 major releases behind what's current.

Share this post


Link to post
Share on other sites
1 hour ago, Geonovast said:

It's good up to at least 1.4.5.

I can't say much about 1.1 vs 1.4, as I started with 1.3 and have played 1.3.1 for most of my time.  But, as point of interest, you just asked about a mod to do something that was made stock awhile ago.  I only suggested you install it and the mods one at a time, since the fact that you tried it at all implied you wanted to update.

 

There's nothing wrong with sticking with an older version, I wasn't saying you had to upgrade.  But it might be a good idea to mention it in your OP when asking for support since you're 4 major releases behind what's current.

Huh. It said somewhere on the thread that it wasn't being maintained or something. I just came back to KSP after a couple years, and figured I might as well update, but it didn't work the first time, and 1.1.3 is working fine, so I don't really want to put in the effort unless it's noticeably better.

And yeah, probably should have mentioned that.

  • Like 1

Share this post


Link to post
Share on other sites
Just now, PTGFlyer said:

Huh. It said somewhere on the thread that it wasn't being maintained or something

I think I know the post you're talking about, and it was a mistake.  It was corrected with a link to the new thread, I believe it got a new maintainer, which is why it got a new thread.

1 minute ago, PTGFlyer said:

so I don't really want to put in the effort unless it's noticeably better.

I get that.  I held onto 1.3.1 all the way through 1.5 being announced, I only went to 1.4.5 because there was a mod I wanted that didn't have a 1.3.1 version.

Share this post


Link to post
Share on other sites
29 minutes ago, Geonovast said:

I think I know the post you're talking about, and it was a mistake.  It was corrected with a link to the new thread, I believe it got a new maintainer, which is why it got a new thread.

I get that.  I held onto 1.3.1 all the way through 1.5 being announced, I only went to 1.4.5 because there was a mod I wanted that didn't have a 1.3.1 version.

Thanks. Might update. How hard is it to move a save file?

Share this post


Link to post
Share on other sites
5 minutes ago, PTGFlyer said:

Thanks. Might update. How hard is it to move a save file?

Literally as easy as copying and pasting the folder.  KSP Folder/game/saves/folderwithnameofyoursave

Just copy the whole thing.  If everything blows up on load your original won't be touched.

Remember you can install the two versions at the same time (Just in different folders) and your operating system won't know the difference.  I have like... somewhere between 8 and 12 installs right now.

Edited by Geonovast

Share this post


Link to post
Share on other sites

'course, I'd need to make sure all the mods work, or some of my rockets will be invalid.

I don't care about that for Sandbox, but Career is hard and I don't want to have wasted Science on parts I no longer have.

Share this post


Link to post
Share on other sites

Yeah, stock 1.4.5 isn't working.

Share this post


Link to post
Share on other sites
1 hour ago, PTGFlyer said:

Yeah, stock 1.4.5 isn't working.

At all? Is it the same issue mentioned previously or a new one?

Maybe try a full uninstall and reinstall if you haven't already, its a good way to clean out shenanigans.

Share this post


Link to post
Share on other sites

Same issue. Instead of the loading screen with Jeb, Bob, and Bill, I get just black.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this