• 0
PonderS

KSP freezes during loading on Mac, previous work arounds do not help

Question

I have installed KSP 1.5.1 on a Mac (Sierra 10.12.6, MBP). No language package nor mods.

When running from an administrator account KSP works fine. When running KSP from an account without admin privileges it stalls during loading. "Loading Asset Bundle Definitions" is displayed and loading does not proceed any further. (To be precise: In the admin account loading pauses for about three seconds at that stage, too, but then goes on; in the non-admin account loading stalls for minutes until I quit the program.)

I have searched the forum and found the suggestion to move the KSP.app to the desktop (or any other place, I suppose) and back in order to avoid the Gatekeeper issue which has been mentioned. This does not help for the non-admin accounts. The problem persists. All other suggestions to similar problems did not seem to fit our situation. (Sorry if I missed something.)

The log file says basically the same as what was reported in other posts and indicates that part of the contents within the KSP.app package as well as some files in subfolders could not be opened. (I can provide more log file info if needed, but I am on a different Computer now.)

I have tried setting the permissions of the KSP.app for everyone from read-only to read&write, but that did not change anything either (same freeze). Changing the permissions of all the subfolders and the files seems to be unpractical (could only do it one by one).

Does anybody have any ideas or suggestions beyond moving the KSP.app? Any help would be deeply appreciated!

Share this post


Link to post
Share on other sites

5 answers to this question

Recommended Posts

  • 0

It seems like I have stumbled across a possible solution. Here it is in case somebody else experiences the same issue. The solution may actually apply to all kinds of load freeze issues ("Loading Asset Bundle Definitions"), but I cannot verify this.

 

The problem seems to be the permissions. It is necessary to set the permissions of all (?) files and folders within the KSP_osx folder to read, write, AND execute.

The solution can be found on the page "Known Issues & Self Help" (http://forum.kerbalspaceprogram.com/index.php?/topic/83211-known-issues-amp-self-help/) if you scroll down to the section "Mac OSX Specific Issues".

Please note, however, that apparently you have to use the terminal command as it is given there ["open a Terminal, change the directory to where the KSP_osx is and type: "sudo chmod -R 777 KSP_osx" (without the quotes)"]. Setting the file permissions from the graphical user interface (as suggested on that page and in the referenced link there) does not work, at least for me. We had already tried that without success. The reason may be that the graphical user interface does not give you an option for setting--or even just viewing--the execute permission.

Possibly just the KSP.app needs the execute permission while read&write may be sufficient for all others, but this is just speculation on my part. Why this would not be set to "everyone" for an executable by default upon installation I do not know nor understand.

One final note of caution: We have not extensively tested the program with the new permissions, yet. It does load completely and it does start. Still, there may be other issues with this path during gameplay.

 

Share this post


Link to post
Share on other sites
  • 0

@PonderS

As you mentioned, it seems like a permission error.

Try going to the folder enclosing the KSP application (It should be called "Kerbal Space Program") and pulling up the "Get Info" window. Click on the little lock in the corner to unlock it if you haven't already. Change the permissions for "everyone" to "Read & Write" and then click on the gear at the bottom. There should be a box that says "apply to enclosed items." Try pressing that and confirming. That'll apply free permissions to all of the files in the GameData folder, including the AssetBundles.

If that doesn't work, you can always try making a clean install; maybe it can't load them because they don't exist.

 

Enjoy!

Edited by GearsNSuch

Share this post


Link to post
Share on other sites
  • 0

@GearsNSuch

Thank you, that is a good point. In general I would expect that to be the solution but in my case it seemed that read & write permissions alone were not enough. The account had to have execute permission as well which apparently cannot be assigned through the graphical user interface (i.e. the "Get info" window that you mentioned).

But your suggestion--changing permissions for all folders and files in the Kerbal folder to read&write--may help in other cases when moving the KSP.app out of the folder and back is not enough to solve the problem. The information window, after all, is a bit easier to handle for most users than the command line in the terminal.

Thanks again, and I hope this helps if any other mac user runs into a similar problem!

Share this post


Link to post
Share on other sites
  • 0

Changing the perms in the command line did not work for me (High Sierra). I can open the package contents of the KSP App: KSP.app/Contents/MacOS/KSP, and double-click the unix executable and it runs (and did even without perm changes). Can't get the application ton run, however. None of these are acceptable work-arounds, they need to fix this for users who will simply give up. Double-clicking KSP needs to run the bloody program, they MUST have a Mac running KSP at their office, what do they do to run it? (Anyone tried in Mojave?).

Share this post


Link to post
Share on other sites
  • 0
On 11/12/2018 at 6:35 AM, GearsNSuch said:

@PonderS

As you mentioned, it seems like a permission error.

Try going to the folder enclosing the KSP application (It should be called "Kerbal Space Program") and pulling up the "Get Info" window. Click on the little lock in the corner to unlock it if you haven't already. Change the permissions for "everyone" to "Read & Write" and then click on the gear at the bottom. There should be a box that says "apply to enclosed items." Try pressing that and confirming. That'll apply free permissions to all of the files in the GameData folder, including the AssetBundles.

If that doesn't work, you can always try making a clean install; maybe it can't load them because they don't exist.

 

Enjoy!

it works! thank you

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.