Sign in to follow this  
Georodin

Question about nodes: How do I set it up properly?

Recommended Posts

Hey Guys,
im currently creating a very simple return mission with a SpaceShuttle to the KSC runway. 
Now I have a question: How do I setup the end node properly?
When I land in the water the success event is not firing sadly.
When I land next to the KSC only the 333points are firing.

The setup I thought of is: 
Gold: Land within 2km of the runway (999Points)
Silver: Land within 5km of the runway (666Points)
Bronze: Land somewhere on Kerbin (333Points)


Here is my node-setup:
oVlLTdR.png

I hope you guys can easily spot my mistake :)
Best regards, Georodin

Edited by Georodin
minor mistakes

Share this post


Link to post
Share on other sites

Hello, and welcome to the forums! :)

Moving to Making History Support.

13 minutes ago, Georodin said:

Here is my node-setup:
1xyQdfo7cs8-X45NjGaKtd4YBb65yV6q-?e=down

FYI, not sure where you're hosting your file, but whatever you've done, it's not something that's coming through as downloadable-- you'll want to fix your link.

Share this post


Link to post
Share on other sites
3 minutes ago, Snark said:

Hello, and welcome to the forums! :)

Moving to Making History Support.

FYI, not sure where you're hosting your file, but whatever you've done, it's not something that's coming through as downloadable-- you'll want to fix your link.

Hi dude, fixed it. I tried google drive before but its kinda weird :)

Share this post


Link to post
Share on other sites

Okay I can see a couple of things!

1. You seem to have entered the distances in kilometres but the nodes are expecting metres. Multiply them by 1000.

2. Select the "Landed Vessel" node, and in the action pane on the right, select "Options" and then "Node Connections Order". The more specific Test Distance (the 2km one) needs to be first, then the less specific Test Distance, and the Change Score node without a test needs to be last. (You may need to rename the two Test Distance nodes so that you can tell them apart).

3. IIRC the "Landed Vessel" node doesn't trigger when you splash down, so you may need a separate "Splashed Vessel" node for that.

Edited by arctangent

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this