Jump to content

Roll Authority Maxes Out - Have I got a setting wrong ?


Recommended Posts

I notice that ailerons on my aircraft max out long before my roll meter(or joystick) gets to the end.  Like about half way, seriously short of the mark.  I use analogue joystick and am used to fine control/movements which is why I havent noticed, it could well have always been this way I just now noticed it.

I can increase to full fidelity if I use a KAL and assign to roll and aileron deploy angles.  This is not a good solution for numerous reasons.  It lets me confirm, however that there is indeed a problem.

But I am thinking this cant be right.  Surely there is a problem somewhere.  My KSP install has grandfathered since couple years now, and I have had literally hundreds of mods installed and un installed.

Could there be a setting somewhere that is adding a hidden multiplier to my roll?  

Would be VERY nice if I had full authority on roll.  Pitch and Yaw are perfect, it is ONLY roll.  Only roll is assigned to the offending control surfaces, pitch and yaw are disabled.

Anyway question is there a multiplier or setting somewhere that might be wrong in my install, like for example making my roll 2x sensitive or such ?  Or is this just standard behaviour I just havent noticed till now ?

I have already went through my settings.cfg and found nothing.

Thank you fellow KerboNauts,

Gavin786

Edited by Gavin786
Link to post
Share on other sites

The only adjustments I'm aware of are the tweakables in the right-click-menu for control surfaces that change the limiters for "deployment" and "authority." You may need to have advanced tweakables turned on in the game settings.

The deployment slider changes the maximum travel of the control surfaces when they are toggled to "deploy on." The authority slider changes the maximum travel of the control surfaces via pilot or SAS input. I also believe that no matter how high you set the authority it will still be limited by the deployment setting. In other words, set the "deploy" slider to maximum and then whatever you set the "authority" slider to should give you the range of travel you are looking for.

Edited by HvP
Link to post
Share on other sites
3 hours ago, HvP said:

The only adjustments I'm aware of are the tweakables in the right-click-menu for control surfaces that change the limiters for "deployment" and "authority." You may need to have advanced tweakables turned on in the game settings.

The deployment slider changes the maximum travel of the control surfaces when they are toggled to "deploy on." The authority slider changes the maximum travel of the control surfaces via pilot or SAS input. I also believe that no matter how high you set the authority it will still be limited by the deployment setting. In other words, set the "deploy" slider to maximum and then whatever you set the "authority" slider to should give you the range of travel you are looking for.

I actually am quite an experienced player, so am well aware of control authority limits, etc.  Problem is no matter what I might set limit to, when the roll gets to about 1/3 the aileron will max out to that value.  So if I set my authority limit to 20 degrees for example, when my joystick gets to 1/3 or so that aileron is at its 20 degrees.  Behaviour I would expect and prefer is for the aileron only to max out to 20 when joystick gets to full +1 or -1.

Good question 1 is : IS this normal behaviour for KSP ?  That is if one makes a plane, puts ailerons on end of wings where they should be, then sets roll to 50% on their joystick, is it normal that those ailerons would be maxed out(at the maximum angle that authority limiter is set to?  That would answer question if it is just me or it is normal for this to happen.  I might double check with couple other designs to see if it is also happening, I think I have seen it before, however, it has just never "twigged" that it is a problem until now.  *** Just confirmed its happening across all aircraft and also at about the same point in my roll input - screen shot attached ***  

pY6XOPG.jpg

Link to post
Share on other sites
On 9/21/2020 at 5:21 AM, Gavin786 said:

I have already went through my settings.cfg and found nothing.

Have you actually looked at the settings inside the game? If you go to the 'Input' section, under the 'Flight' and 'Vessel' tabs, you'll see on te right that you can adjust the sensitivity and dead zones of all the input axes individually.

Link to post
Share on other sites

@Gavin786 Sorry, I misunderstood your question at first. So, it's not the extent of the travel, but the how well it maps to your joystick controls that is the issue.

Now that you bring it up, I'd like to experiment with this myself. I use a PS3 gamepad controller for my game that gives me analog control for flight that I can test with.

I know that the mod Advanced Fly-by-Wire claims to do a better job of capturing and mapping analog inputs from joysticks and gamepads. It might be time to try that and see if it makes a difference.

Edited by HvP
Link to post
Share on other sites

@Gavin786 So I conducted an experiment that I think you'll find interesting.

At first I tried the normal setup for a plane and found the exact same issue you found. The elevons were hitting the maximum travel with about four clicks left on the roll meter. Changing the sensitivity or dead-zone in the settings didn't help. For clarity, they were fully deploying but they were just doing so in a compressed time and before I had used the whole sweep of my gamepad paddle buttons.

So I decided to try something. I placed two pairs of elevons on the wing of a craft, one inner pair and one outer pair. For the outer pair I set them up just like normal, with only the "Roll" actuation on. For the inner pair I disabled the toggles for roll as well as pitch and yaw. But I went into the action groups and in the "Axis Groups" I assigned the "Roll" action group to the inner pair of elevons, making sure to select the "Deploy Angle" function and setting it to "Absolute Control" instead of "Incremental Control."

Now the inner pair of elevons should still respond to the roll input on my gamepad but it bypasses the normal roll assignment. If you remove one of those elevons from symmetry and invert the direction then they will function like normal ailerons without having to use the KAL controller. And indeed it did. The inner pair of elevons used the full width of the roll meter to reach the end of their travel, when the normally assigned outer pair would stop before the inner pair did.

I don't know exactly what this means, and it's not ideal, but at least there is a way to gain full range of the axis without having to program a KAL controller. Unfortunately, they won't respond to SAS control in this configuration which severely limits its functionality.

Edited by HvP
Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...