Jump to content
  • 0

KSP last update is very slow! High GPU


Question

Hello guys.

I am writing here as I can't find solution by myself. Also did not find solution over internet.

I am playing KSP over Steam - no mods. I updated game to 1.11.1 last week and it's extreamly slow. I can't build even a simple ship. Game is loading for 20min. Menu has like 5FPS, in game is same, even in builder. Totally unplayable. Game did not crash, it's just slow.

I updated all Invidia drivers, PC is updated, I did make sure that game runs with nvidia etc. I tried installing it on SSD and it's same.

PC is laptop HP Pavillion,  i5-6300HQ CPU 2.30GHz, Geforce GTX 950M, 8GB RAM, fresh win10 64 install, bought not cracked.

When game is running slow it's at about 2500MB CPU and 95% GPU.

I found out that if I downgrade game to version 1.5 it works smooth as it was working before (CPU same 2500MB and GPU at 20%). Tried downgrading to 1.10 and it is also slow. Did not try other betas.  I tried all settings on lowest possible setting, V-Sync on/off, and it's same. It's something that overloads GPU.

Please help, I just want to play.

Thank you all for your help and answers. 

 

Link to post
Share on other sites

13 answers to this question

Recommended Posts

  • 0
On 2/17/2021 at 12:48 PM, The_Sledge_Hammer said:

Hi.

Thanks for fast reply.

Here is the link to the Player.log file:

https://drive.google.com/file/d/15RDqJXjFaR6HLZ8w7lfSUPsUCsau0fTG/view?usp=sharing

Nothing strange in that log.

Could you upload the KSP.log too, it might contain some hints.

But in general it really sounds like there's something odd with your drivers or install.

It simply shouldn't be that slow,

Link to post
Share on other sites
  • 0
On 2/17/2021 at 11:22 AM, The_Sledge_Hammer said:

2500MB CPU

I don't understand this, CPU MB???

I you mean that KSP takes 2500 MB RAM, that's not much at all.

What is, per Taskmanager, the KSP memory consumption, and how much RAM does your PC have? Quite possible that your PC is low on memory and needs to use the pagefile a lot, which naturally slows things down a lot. And yes, the newer KSP versions do need more memory than the older ones, new textures, new part models, it all adds up.

As @Curveball Anders said, we'll need the logfiles to get a better idea what is going on.

Edited by VoidSquid
Link to post
Share on other sites
  • 0

Here is the link for KSP.log      https://drive.google.com/file/d/1UiFmeNGogCC6LfGR9tND08VHu_0BJvvb/view?usp=sharing

And link for output_log:            https://drive.google.com/file/d/19iDGGgVb8ARLfzKalrxmrePAskVkkewR/view?usp=sharing

Last time I was playing in August 2020 and it worked super fine, it was updated and it was version 1.10.1 or 1.10

I formated my comp and made fresh win10 install one month back.

My PC has 8GB ram.

And here are few pictures:

Running KSP:

running-ksp-high-gpu-2.jpg

Running KSP:

running-ksp-high-gpu-1.jpg

When loading KSP:

loading-ksp-high-gpu.jpg

Nvidia driver for GTX:

gtx-driver.jpg

KSP is running on GTX not on integrated GPU:

ksp-gtx-gpu.jpg

 

Thank you for investigating.

 

 

Link to post
Share on other sites
  • 0

Hello.

After further investigation I downgraded KSP version over Steam version by version.

Latest version that is working good is 1.7.3

I compared GPU usage, and found out, that dedicated GPU usage is extremly high (3,3/8GB) in not working versions.

In working version 1.7.3, dedicated GPU usage is 0,2/8GB) 

See picture for easier interpretation.

I can also see that GPU engine under Processes bar, is GPU 0 - 3D with working version 1.7.3 and with new unworking version there is no GPU 0 - 3D displayed. What does that mean? Is game running on integrated GPU instead on GTX?

I don't say it's game fault, maybe is my computer setting. Still something does not go together with new version. How can I investigate that, any ideas?

ksp-high-dedicated-gpu-m.jpg

Thanks for any help.

Link to post
Share on other sites
  • 0

Interesting... from 1.7.3 to 1.8 Squad changed the Unity version, pretty big change, take a look here https://wiki.kerbalspaceprogram.com/wiki/Version_history

3 hours ago, The_Sledge_Hammer said:

Is game running on integrated GPU instead on GTX?

Almost looks like that, yes. Which also would explain why the game is so laggy. Then: why would KSP not use GPU RAM if it runs on the dedicated GPU???

For comparison, this is how the workload on my graphics card in my PC looks:

System-Information-2021-02-23-13-07-48.p

Edited by VoidSquid
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...