Snjo

Firespitter propeller plane and helicopter parts v7.1 (May 5th) for KSP 1.0

Recommended Posts

That looks awesome ahahhpydude! Let me know if the module set up causes problems. If you want to use the rotorTrim module to make a steering engine, it might be enough to name the thrustTransform as the targetPartObject. Not sure anymore.

Share this post


Link to post
Share on other sites
Snjo, got a suprise coming up haha

edit

Basic animation for the propelers in. Now i need to find out how i can use your propeler module to get some lift :D haha cheers

What I'm doing to generate "lift" with my autocopter blades is taking a normal helicopter part and scaling its min and max thrust with speed so that the same thrust is generated at a given speed irrespective of throttle. This is the first use I've found for setting minimum thrust to non-zero numbers. I could post the source if you want.

Share this post


Link to post
Share on other sites
That looks awesome ahahhpydude! Let me know if the module set up causes problems. If you want to use the rotorTrim module to make a steering engine, it might be enough to name the thrustTransform as the targetPartObject. Not sure anymore.

Thanks:) Its not a safe ride withg two minfueltanks bwlow seat but its is fun! Will be good for landing at other planets to i below, it need a glas bouble of somekind

Thanks that sounds like a good start to get a good thrust. I will try that thing with the cheers

Share this post


Link to post
Share on other sites

You can make one that attach to kerbal kas style, or do it commandpod style, a fake commandpod but then the kerbal is stuck in internalseat. So best way is to make it and use kas, add two thrusttransformers and voila;)

Share this post


Link to post
Share on other sites

Two users on the spaceport have reported not finding the seaplane floats in v4. They work for all the rest of you, right?

Also, if they don't, what OS are you running?

Share this post


Link to post
Share on other sites

I've tried elsewhere on the forums but I guess I will come here;

I really suck at building helicopters with this addon and would really appreciate it if someone could share their helicopter designs with me so I could figure out what I am doing wrong. I am trying to build a heavy lift helo that could use KAS to lift some payloads but I can't even just build a working Helicopter so thats the first hurdle. Thanks so much if anyone can help! Just PM me with any .crafts you have.

Share this post


Link to post
Share on other sites

the biggest thing is making sure the center of thrust is aligned on the center of mass, this is true for all helicopters and vtols, however ksp really dosent have a flight model so as far as i can tell it basically models the vehicle being pushed from the bottom, not lifted by is rotors like RL so making a lifting heli is kinda impossible, the cargo ends up swinging back and forth wildly and its an overall bad time

Share this post


Link to post
Share on other sites
Can you make propellers stackable. I want a pogo.

4561385423_1f90cfb965_z.jpg

I managed to stack them using the debug menu's part collision in editor feature, and adding a tiny truss out front of the first prop, attaching the second, then adding a fuel line to compensate.

However, it'd be better if they were stackable by default. Also make a pusher-style red prop. The yellow one is too small, and I want to make a proper TU-95.

Share this post


Link to post
Share on other sites
I've tried elsewhere on the forums but I guess I will come here;

I really suck at building helicopters with this addon and would really appreciate it if someone could share their helicopter designs with me so I could figure out what I am doing wrong. I am trying to build a heavy lift helo that could use KAS to lift some payloads but I can't even just build a working Helicopter so thats the first hurdle. Thanks so much if anyone can help! Just PM me with any .crafts you have.

Honestly, the best way to build is keep referring to center of mass. Ensure that the main rotor is dead center every time you add parts. When you add the tail rotor, the arrow is facing down. You won't need any sas addons. If you give me an hour or so, I'll remake one of my heavy lift choppers.

ZhpGf5x.jpgWE9EUHc.jpgiWzvp0B.jpg

https://www.dropbox.com/s/9jol9e38nj6yuim/Seosamh%20Heavy%20lift%20helo.craft

Edited by Capt.Joseph Kerbertson

Share this post


Link to post
Share on other sites
I managed to stack them using the debug menu's part collision in editor feature, and adding a tiny truss out front of the first prop, attaching the second, then adding a fuel line to compensate.

However, it'd be better if they were stackable by default.

Thanks. tencharacterlimt

Share this post


Link to post
Share on other sites

Can somebody post a picture that shows how the swiveling helicopter landing gear are supposed to be oriented in the SPH? I've tried every possible angle, I think, and have found no useful orientation that doesn't put them at crazy angles.

Share this post


Link to post
Share on other sites
I fully admit they are crazy and confusing :)

X3qLp20.png

How are you attaching those? When attached as you have in the image above, mine both deploy to the same side...

Share this post


Link to post
Share on other sites

Might have figured out what's going on. I think that it's possible to 'corrupt' the left/right state of the command pods.I got the legs to deploy properly on the huey style pit, but after making changes to the craft (without touching the gear) I went to load the flight and found that they had suddenly 'changed their mind' and gone back to deploying to the left. I Placed them further back on the fuselage, not directly attached to the command pod) and they worked fine.

Update: More details. It appears things get wonky when I use the Orbital Industries Capsule clamp (the version that's also a decoupler). The non de-coupler version didn't cause any issues (it's what's holding the batteries on in the below pic). When I first added it, the gear 'corrupted' as mentioned above, and I moved them further back on the fuse, solving the problem. When I removed them, the issue came back, and now I can't place them anywhere with them properly deploying asymmetrically.

screenshot489.jpg

Edited by aggressorblue

Share this post


Link to post
Share on other sites
Might have figured out what's going on. I think that it's possible to 'corrupt' the left/right state of the command pods.I got the legs to deploy properly on the huey style pit, but after making changes to the craft (without touching the gear) I went to load the flight and found that they had suddenly 'changed their mind' and gone back to deploying to the left. I Placed them further back on the fuselage, not directly attached to the command pod) and they worked fine.

Update: More details. It appears things get wonky when I use the Orbital Industries Capsule clamp (the version that's also a decoupler). The non de-coupler version didn't cause any issues (it's what's holding the batteries on in the below pic). When I first added it, the gear 'corrupted' as mentioned above, and I moved them further back on the fuse, solving the problem. When I removed them, the issue came back, and now I can't place them anywhere with them properly deploying asymmetrically.

The wheels check which side of the vessel they are on, so if things aren't aligned as expected, or there is an extra command module in there messing up the expected vessel center line and direction when it is first launched, you might get some problems.

(If they are on the left side, they use a set of transforms pointing left to rotate, and on the right side they use an opposite set of transforms to rotate to. This is done by using a Vector3 dot comparison to the vessel.transfrom.right at first launch)

Share this post


Link to post
Share on other sites
The wheels check which side of the vessel they are on, so if things aren't aligned as expected, or there is an extra command module in there messing up the expected vessel center line and direction when it is first launched, you might get some problems.

(If they are on the left side, they use a set of transforms pointing left to rotate, and on the right side they use an opposite set of transforms to rotate to. This is done by using a Vector3 dot comparison to the vessel.transfrom.right at first launch)

When do they do the check? At the start of the flight?

Share this post


Link to post
Share on other sites

The check happens the very first time the vessel is launched, then the left/right value is written to a persistent value.

(otherwise you'll get weird behavior when loading a nearby vessel before the one with the wheels)

Share this post


Link to post
Share on other sites

I noticed a bug that I don't think has been brought up before.

On all of the non-helicopter engines, there is a throttle input delay for the thrust value and the engine sound, but not the prop animation.

What is the cause of this, and will it be fixed?

Share this post


Link to post
Share on other sites
I noticed a bug that I don't think has been brought up before.

On all of the non-helicopter engines, there is a throttle input delay for the thrust value and the engine sound, but not the prop animation.

What is the cause of this, and will it be fixed?

I guess you are referring to the fact that at the lowest few percent of the throttle, there is no sound at all. That's because there should be an idle sound playing at that level, but I've only made an Power sound, which starts just above that, and is altered by thrust percentage. I don't want to make two conflicting engine sounds, so I need to find a good idle sound that can play along the normal engine sound.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.