Kreuzung

[1.0]Vanguard Technologies | EVA parachutes | still works

Recommended Posts

Alright, I'm still a bit confused. I got the eject part, the chute box part, those were easy enough to install. The evaloading addon doesn't have any file structure to it though, it's just two files. Where should I stick these? Gamedata/what/?

Share this post


Link to post
Share on other sites
Alright, I'm still a bit confused. I got the eject part, the chute box part, those were easy enough to install. The evaloading addon doesn't have any file structure to it though, it's just two files. Where should I stick these? Gamedata/what/?

Refer to the directory structure shown here - the path prefix D:\_Debug_KSP should obviously be replaced by the path prefix to whereever you have KSP installed, e.g. C:\ProgramFiles\Steam\SteamApps\common \Kerbal_Space_Program - the .cs file is just the source code, you don't need that, only the DLL

Share this post


Link to post
Share on other sites
Refer to the directory structure shown here - the path prefix D:\_Debug_KSP should obviously be replaced by the path prefix to whereever you have KSP installed, e.g. C:\ProgramFiles\Steam\SteamApps\common \Kerbal_Space_Program - the .cs file is just the source code, you don't need that, only the DLL

Thanks for the heads up!

Is there any way to use the stock parachute model? I'm not a big fan of the square blue one...seems overly complicated and not very kerbish to me :)

I tried grabbing the files out of the parachute parts in the squad files...but um...hahah it just deployed the "undeployed" parachute model...Jeb looked like he was inside a mini flying saucer!!! Fun for the LULZ but not for avoiding hitting the ground. Oh wait...actually it did slow him down...reeeediculous.

Edited by Vladthemad

Share this post


Link to post
Share on other sites
Is there any way to use the stock parachute model? I'm not a big fan of the square blue one...

No, because the stock one is an embedded model, not a separate part. I'm working on a replacement based on RealChute models.

Share this post


Link to post
Share on other sites

RealChute support isn't so much about the better auto-deployment system, so much as the more realistic deployment, plus the improved parachute sounds and graphic options. (Animated deployment with cool sound.)

However, building in a built in emergency auto-deploy for when Jeb gets too daring playing chicken with Kerbin's surface (or Duna, Eve and Laythe's surface for that matter) wouldn't be a bad idea. Real life parachutes have those for if the person passes out during the freefall.

RealChutes also gives you the ability to anchor two chutes in the parachute bag. Supposedly it gives a lot of hidden attaches and libraries for parachute developers too.

Edited by Ruedii
Paragraph separation.

Share this post


Link to post
Share on other sites
RealChute support isn't so much ...

Yes, I know that, and I'm not going to try replacing or augmenting it, it's great, all I want to do is have an alternative conventionally-shaped chute model to the vanguard cute but funky boxy one :)

Share this post


Link to post
Share on other sites

New to this mod so forgive me if I am missing something obvious.

I've added enough ejection seats for all my Kerbals on board. I eject a dozen little green men moments before a rather unpleasant encounter with the ground in a desperate attempt to save them. Even though they all have chutes the majority of them still died as there was not nearly enough time to open the chutes on each and every one of them manually.

How can I have the chutes on ALL my ejected Kerbals open automatically?

Share this post


Link to post
Share on other sites

Thanks. Will give that a try soon.

Edit: Awesome. [space]+[F] works. :D

Edited by Tex_NL

Share this post


Link to post
Share on other sites

VNG Ejection seats are still not working for me on Linux.

I updated the plugin, removed it, tried reinstalling:

Mods that could interact installed (Any that include Mono DLLs, in order of most likely to interact, grouped by author.):

BoulderCo Active Texture Management

BoulderCo Visual Enhancements (Clouds only)

Module Manager

B9

Kerbal Joint Reinforcement

Procedural Fairings

Stretchy SRBs (Improved Stretch Tanks)

FAR

MechJeb

Flight Engineer

Toolbar Plugin

Edited by Ruedii
List was missing some

Share this post


Link to post
Share on other sites

How are you meant to get this to work? I installed the auto parachute thing but the only way i can get it to do anything is by mashing the keys. space+f dosent do anything

Edit: never mind got it to work, seems like the auto chute thing gives you two if you eject or something... also just realized there's long delays for the chute.

Edited by montyben101

Share this post


Link to post
Share on other sites

>Ruedii

I'd be quite surprised if these mods (in particular ModuleManager, B9, FAR and MechJeb since I've used them myself) whould cause conflicts.

If nothing works, try searchingyour Addons for dublicate VanguardTechnologies.dll's, especially if you have some HooliganLabs mods installed (second most common issue, after using it wrong).

If that doesn't help, plz give a more accurate description ("does not work and I have other mods as well" is not that meaningful :P) of what you did and what the logfile says about it. That usally makes it very easy to determine what's wrong.

Share this post


Link to post
Share on other sites

I can't get the parachutes to deploy, I had jeb and bill in a crazy spin, so i ejected them and pressed space+f, but it did nothing and they went splat. :P

I do have hooligan labs but I don't see any vanguard plugin in the folder

This is my folder layout is this correct?

ErcVSVu.png

Share this post


Link to post
Share on other sites

This mod seems to summon the kraken at times as well (kerbals hitting floor to hard im guessing) any way to fix this?

Share this post


Link to post
Share on other sites

@Kreuzung: this plugin seems great but I think ModuleKrAnimation need a bit more of doc as if I understand everything right

this:

// Vanguard plugin

name = ModuleKrAnimation

extendAnim = animtest1

extendGUI = start part

retractGUI = stop part

energyConsumptionExtend = 0.1

energyConsumptionRetract = 0

energyConsumptionExtended = 0.2

Knowing: my part don't need to be extended (I just need the usual ON/OFF switch) and include a loop animation is set with

add loop frame checked

wrap mode loop

(anim compression: keyframe reduction and 0.5 for all three values)

rig type = legacy

in Unity (4.3.3)

Should:

1. don't start animation automatically,

2. the extend/retract commands should start/stop anim resp.,

3. energy might be used for this

but it's not.

Default KSP ModuleAnimateGeneric module start anim only on demand, but can't stop it and unless playing dirty with something like adding a ModuleReactionWheel with no torque but energy consumption, I didn't find a way yet to use some of the batteries for it (great I get a device which work for free :D)

What am I doing wrong ?

EDIT: feature request

add non extension anim type (the start/stop type), as looking in the source code, I see retract is playing anim backward.

+little doc issue:

controllableInside state "controllable from inside the spacecraft?"

but code looks like to consider "controllableInside" = "iscontrollable" (=part can be or can't be controllable, whatever is inside/outside)

Edited by Justin Kerbice

Share this post


Link to post
Share on other sites

I'm having the exact issue is the same as people experienced before the patch. The ejection seat module model still appears over the hatch after launch, and it reports that the hatch is blocked whether you try to exit manually or by ejecting.

I don't really think it's a mod conflict. I think it's likely a Linux issue, possibly experienced by OS X users too. (It appears to have something to do with the way the model is handled). The only mod that I honestly think might mess with the collision system is the memory reduction mod, because it changes the way materials, textures and models are handled, preventing reading and writing to them by certain methods. If you want I can mess around and see what the conflict is, but if you have a list of known conflicts, it would be nice to see.

I don't have hooligan labs installed so that shouldn't be an issue, unless it's another mod included with it.

Edited by Ruedii
Grammar and linguistics. A few details left out.

Share this post


Link to post
Share on other sites
The ejection seat module model still appears over the hatch after launch, and it reports that the hatch is blocked whether you try to exit manually or by ejecting.

Are you placing the thing in a way that it blocks the hatch? If yes, that's your problem.

>Boamere

What does the log say about it?

>montyben101

Umh... can you be a bit more specific about this?

>Justin Kerbice

Well, the module is not intended for loop animations. However, you can create a loop anim and then another one which animates the loop animation's parameters to make it start/stop. The only problem whould be that the rotated object's position whould not be kept during save/load cycles, but that shouldn't be much of an issue in most cases.

Sorry that it took a bit long for me to reply, I was a mix of lazy, ill, and not at home.

Share this post


Link to post
Share on other sites
Are you placing the thing in a way that it blocks the hatch? If yes, that's your problem.

>Boamere

What does the log say about it?

>montyben101

Umh... can you be a bit more specific about this?

>Justin Kerbice

Well, the module is not intended for loop animations. However, you can create a loop anim and then another one which animates the loop animation's parameters to make it start/stop. The only problem whould be that the rotated object's position whould not be kept during save/load cycles, but that shouldn't be much of an issue in most cases.

Sorry that it took a bit long for me to reply, I was a mix of lazy, ill, and not at home.

Aggh that was a long time ago, let me test again in a bit!

Share this post


Link to post
Share on other sites
Are you placing the thing in a way that it blocks the hatch? If yes, that's your problem.

Thanks for the clarification, so it's suppose to go on the pod, but not the hatch. You might want to add that detail.

As a note, what do I do about it being visible on the craft since 0.23. I was thinking it might be ideal to simply reduce the size until a better model can be built. That can be done in the config file. That might be something that it would be worth learning modeling to build a model for. The question is what it should look like. I'm thinking a small module with a compressed air cylinder and a big warning label.

Share this post


Link to post
Share on other sites
Thanks for the clarification, so it's suppose to go on the pod, but not the hatch. You might want to add that detail.

As a note, what do I do about it being visible on the craft since 0.23. I was thinking it might be ideal to simply reduce the size until a better model can be built...

You may have reasons for not doing it this way, but personally I just use a modulemanager patch to add the eject and parachute modules to cockpits by default, so there's no part to stick on anyway. These things are generally internal to the cockpit for convenience and safety reasons :)

Share this post


Link to post
Share on other sites

I think I have a problem:

Whenever I click on "Full deploy" the parachute does not launch/deploy (I've killed far too many Kerbals to know if this is a bug or not).

Any help will be much appreciated.

Thanks in advance

Share this post


Link to post
Share on other sites
Whenever I click on "Full deploy" the parachute does not launch/deploy...

Check your installation against the detail in this post - especially check the ksp directory subtree for a stray additional (outdated) copy of the DLL that was bundled with another addon. As you're getting the deploy menu option, this is the most likely issue. You could also view the KSP log file and search for references to the parachute or vanguard plugin in error messages which may help identify the problem.

Share this post


Link to post
Share on other sites

So it turns out that Backspace ejects the Kerbals, unfortunately this is the same key that returns to normal flight mode with Hullcam VDS, Is there a way to change this, or is it hard coded?

(for those of you who are wondering I am trying

)

Edit: Never-mind. I fund the HullCam settings and changed those.

Edited by Taki117

Share this post


Link to post
Share on other sites
This is a n00b question, but how do I deploy a parachute?

Spacebar!

No, but seriously -- if they're staged properly, they should just "work" in the default configuration

Alternatively, you can assign "arm" or "deploy" to an action group, or right-click the part and do it by hand.

EDIT! Ha-- I had mistaken this for the real-chutes thread. Sorry about that.

Space-f is the command to deploy the 'chute, but you can still alternatively right-click the kerbal in quesiton to select partial/full deploy.

You also have to make sure you grab one from the parachute case, or use the "kerbals always have an EVA 'chute" sub-mod (which I can't find the link to).

Edited by Beetlecat

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.