blizzy78

[1.2.0] Precise Node 1.2.4 - Precisely edit your maneuver nodes

Recommended Posts

Heh no need for thanks, thank the creator of this mod who put all the work into it. <3

Share this post


Link to post
Share on other sites
10 hours ago, micha said:

Nice, did you have to do any fixes or just recompile?

it was just a recompile i think or maybe some minor editing since KSPUtils got merged back in. I did a few mods so not sure which were which.

Share this post


Link to post
Share on other sites

Oh man.... Been playing 1.2pre-release for some weeks without mods.  This was one of those mods I've been missing most.  I had to build rockets with an additional % of dV to compensate for inaccurate node planning.  Without a doubt, top 5 KSP mods imo!

Share this post


Link to post
Share on other sites

Precise Node 1.2.4 is now available for download.

Note: If your browser is showing an older version on the download page, please refresh.

Share this post


Link to post
Share on other sites

Thanks for both updates Blizzy :) Both should be stock.

Share this post


Link to post
Share on other sites

Hi, I found a bug, when I was using DN button to set up a maneuver node in the descending node. The maneuver node was way off actual DN.

Edit: A maneuver in DN when target is set is ok, no errors in KSP log and Precise Node 1.2.4 is only mod installed.

Edited by maja

Share this post


Link to post
Share on other sites

Hey.  Love the mod. 

When I DL this version it needs me to DL some strange zip company that some part of my computing machine sees as malicious.  Can anyone expln. pls.?

 

Share this post


Link to post
Share on other sites
8 minutes ago, Aethon said:

Hey.  Love the mod. 

When I DL this version it needs me to DL some strange zip company that some part of my computing machine sees as malicious.  Can anyone expln. pls.?

 

The link and download is fine. Its possible your virus checker is picking up the dll as a false positve, or you may have virus/malware.

Share this post


Link to post
Share on other sites

I checked and the download page does seem to load scripts that my browser blocks from being from unauthorized sources. It's probably some sort of monitization/ad delivery the site has set up that isn't up to par, rather than the download itself. But you can't be too careful when it comes to file sharing sites.

Share this post


Link to post
Share on other sites

Ah yeah chrome is blocking some stuff on the download site that I didn't notice sorry. Still the file itself is safe.

Edited by Torih

Share this post


Link to post
Share on other sites

Can you push an update to CKAN for this?  It's still not showing up in the list for 1.2.0 compatible mods.

Share this post


Link to post
Share on other sites
4 minutes ago, Leo_G. said:

Can you push an update to CKAN for this?  It's still not showing up in the list for 1.2.0 compatible mods.

I've already mentioned it to the ckan guys, sure they will get around to it soonish(tm)

Share this post


Link to post
Share on other sites

Thanks for updating!

Possible bug, though: I no longer can change keyboard shortcuts.  I open the keys popup, click Set for some action, and then hit a key.  The "Press a key to bind X" message appears.  When I press a key the Set button loses focus for a moment if I'm mousing over it, but the change doesn't take.  The listed assigned key remains KeypadFoo, and the new key doesn't work.

I've tried with many kinds of key combinations.  No dice.

I'm on a Mac, for what it's worth.

 

For anyone else hitting this: I managed to change them by manually editing GameData/PreciseNode/plugins/PluginData/PreciseNode/config.xml.  Key names can be found at https://docs.unity3d.com/ScriptReference/KeyCode.html.

Share this post


Link to post
Share on other sites

Hi @blizzy78, can you tell, if this exception is stock or from your mod?

ArgumentOutOfRangeException: Argument is out of range.
Parameter name: index
  at System.Collections.Generic.List`1[PatchRendering].get_Item (Int32 index) [0x00000] in <filename unknown>:0 
  at OrbitTargeter.ReferencePatchSelect () [0x00000] in <filename unknown>:0 
  at OrbitTargeter.LateUpdate () [0x00000] in <filename unknown>:0 
 
(Filename:  Line: -1)

It happened twice, as of today, when I was executing a transfer maneuver to the Mun. I have patched conics set to 5 and draw mode to 0 and this error was generated when Mun periapsis was moving toward  periapsis of planned maneuver.

Share this post


Link to post
Share on other sites
5 hours ago, maja said:

Hi @blizzy78, can you tell, if this exception is stock or from your mod?


ArgumentOutOfRangeException: Argument is out of range.
Parameter name: index
  at System.Collections.Generic.List`1[PatchRendering].get_Item (Int32 index) [0x00000] in <filename unknown>:0 
  at OrbitTargeter.ReferencePatchSelect () [0x00000] in <filename unknown>:0 
  at OrbitTargeter.LateUpdate () [0x00000] in <filename unknown>:0 
 
(Filename:  Line: -1)

It happened twice, as of today, when I was executing a transfer maneuver to the Mun. I have patched conics set to 5 and draw mode to 0 and this error was generated when Mun periapsis was moving toward  periapsis of planned maneuver.

Did you generate the initial maneuver node with MechJeb? I noticed that maneuver node created by MJ "Maneuver Planner" generate exception when edited with Precise Node. Manually created ones are okay. Since MJ is not officially out yet for KSP 1.2.0, maybe this well get fixed by Sarbian.

Share this post


Link to post
Share on other sites
1 hour ago, Galenmacil said:

Did you generate the initial maneuver node with MechJeb? I noticed that maneuver node created by MJ "Maneuver Planner" generate exception when edited with Precise Node. Manually created ones are okay. Since MJ is not officially out yet for KSP 1.2.0, maybe this well get fixed by Sarbian.

No. I created the maneuver node by hand and used Precise Node to fine tune it.

Share this post


Link to post
Share on other sites
8 hours ago, blizzy78 said:

Unfortunately I can't tell from the stack trace.

I'll try to do some tests and narrow it down. There is nothing else in the error or output log.

Share this post


Link to post
Share on other sites

Update: I can't repeat this error reliably. Sometimes it's there, sometimes not. I think, it has something to do with multiple encounters with a moon and leaving SOI of the parent in the future. It seems, that this is a stock bug when more patched conics are rendered and maneuver editors (Precise Node, MJ etc.) just pronounce it, because they can tweak nodes better. It's not gamebreaking, so I'm leaving it as is.

Share this post


Link to post
Share on other sites

I have a problem with precise node. When I create a node for example to encounter a vessel with the Mun, there is no 'focus on the target' button in the Precise Node window. This worked in the past but in this version I do not have this :(

Edited by strozyk85

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.