Sign in to follow this  
NathanKell

Modular Fuel System Continued v3.3 (OBSOLETE)

Recommended Posts

Huh. I'll check it out. Guess v3.1 is delayed again. :\

Starwaster: I don't have IonCross handy; did it replicate for you?

i didnt get to try yet, got sidetracked. sorry :( will test ir later tho

Share this post


Link to post
Share on other sites

No problem.

For now, I'm releasing 3.1, finally--it's about time, even if there's still more bugs to fix. amsi, I couldn't replicate either of your issues (unfillable symmetric parts or non-persistent tech-levels) in my current code; doesn't mean they're not there, because my playtesting was limited from all the RSS work.

v3.1 = \/

*Changed zip's path structure.

*Redid StretchyTanks support again. Get StretchySRB v5.

*Added new engines and tanks thanks to Chestburster's hard work

-Added missing tanks from FASA

-Added support for SDHI Service Module (take some Oxidizer and Liquid Fuel with you for the built-in FuelCell)

-Added support for "new" Spherical Tanks

-Added dtobi's Space Shuttle Engines

*Internal tweaks

*Added localCorrectThrust, in the ModuleEngineConfigs module. Set to false if MFS should not alter thrust due to Isp change (like for jets).

*Added useConfigAsTitle. Will change part title to config name when setting configuration, if true.

*Added new resources: UDMH (same as monopropellant but set to STACK_PRIORITY_SEARCH not ALL_VESSEL), Hydrazine, Aerozine, and Methane.

EDIT: Edited changelog (oops, missed a couple lines). OP updated.

Edited by NathanKell

Share this post


Link to post
Share on other sites
I've got a problem. Launch clamp fuelling towers don't seem to work. I'm using plenty of mods (see Realism Overhaul thread and my Soyuz plugin list), but the only one that also modifies the clamps is Ioncross Crew Support. Could anyone check this combination?

ok I'm not seeing this on my end. using latest ICS aka dev release 4.

Ioncross's modification of the clamp is via ModuleManager; just adds a stock ModuleGenerator that adds oxygen and subtracts CO2. Do other ModuleManager files work ok? Are you also using Sarbian's MM extensions? If so, try using this version of MM: https://www.dropbox.com/s/dr3wd3up88yizra/ModuleManager.dll

It's the most recent version from Ialdabaoth's original thread but with the KSPAddon fix.

Share this post


Link to post
Share on other sites

OK, OP _actually_ finally updated.

Starwaster, thanks for that! Also, good point about the radiators. Should we just model heat dissipation ourselves?

Dragon01, I didn't miss your post about Hybrid Solids. But I can't take that on right now. If you want to come up with some alternate configs for SRBs, go right ahead--They have modular engines now, so... ^_^

Also NOTE: If you want to use the new StretchyTanks I'm about to release (and I think you will--much better texture support) then you need v3.1 of this.

Share this post


Link to post
Share on other sites

Did any one have a chance to look at my output log that i posted in relation to the bug i am having?I am unable to access tanks and engines after reentering the VAB.

Share this post


Link to post
Share on other sites
OK, OP _actually_ finally updated.

Starwaster, thanks for that! Also, good point about the radiators. Should we just model heat dissipation ourselves?

.

I've been having that thought myself. KSP's handling of heat is even more bizarre than you might think it is unless you actually have paid close attention and tracked it as it changes. It changes abruptly and more rapidly than it should be. It should take minutes rather than seconds. I put a full array of radiators on a 3.75 and when I shut them off it takes about 20ish seconds to go from -250 to full local ambient temp.

orientation helps a lot with cooling as you might expect but not always consistently.

some odd behavior I've noticed is sudden increases when occulted from the sun by the planet. Other strangeness is that it matters if I point prograde or retrograde but also whether it's before or after 'midnight'. I.e. if I have not yet reached the ,

mid point of the darkside I will see heat increase in the tank if I am prograde. I lose heat if I reverse orientation to retrograde. That reverses if I cross the midnight line. Leaving planetary orbit to Sun SOI results in more normal behavior.

Just ditching the radiator heat increase probably will help a little because then you're not fighting heat trying to get back into the tank from the radiator. Just for giggles I turned the radiator rate to 1000 heatTransfer. turned them on, turned timewarp on then watched radiators start exploding like pop corn.

Share this post


Link to post
Share on other sites

I add one part that includes engine and tank to engines.cfg and create a modularFuelTanks.cfg,but only the tank editing works,the engine is still like before.Here is the the engines.cfg,what's the problem?

@PART[AtlasVCCB]

@mass = 50

@maxTemp = 1800

@MODULE[ModuleEngines]

{

@maxThrust = 4152

@heatProduction = 149

@atmosphereCurve

{

@key,0 = 0 340

@key,1 = 1 310

}

@PROPELLANT[LiquidFuel]

{

@name = LiquidFuel

@ratio = 0.39

}

@PROPELLANT[Oxidizer]

{

@name = LiquidOxygen

@ratio = 0.61

}

}

@MODULE[ModuleGimbal]

{

@gimbalRange = 1

}

MODULE

{

name = ModuleEngineConfigs

origMass = 50

techLevel = 5

origTechLevel = 5

engineType = L

configuration = LiquidFuel+LiquidOxygen

modded = false

CONFIG

{

name = LiquidFuel+LiquidOxygen

maxThrust = 4152

heatProduction = 149

PROPELLANT

{

name = LiquidFuel

ratio = 0.39

DrawGauge = True

}

PROPELLANT

{

name = LiquidOxygen

ratio = 0.61

}

IspSL = 0.99

IspV = 0.99

}

}

}

Share this post


Link to post
Share on other sites
Did any one have a chance to look at my output log that i posted in relation to the bug i am having?I am unable to access tanks and engines after reentering the VAB.

I'll take a look at it right now.

I add one part that includes engine and tank to engines.cfg and create a modularFuelTanks.cfg,but only the tank editing works,the engine is still like before.Here is the the engines.cfg,what's the problem?

You're missing at least one brace in there. Should be on the second line right after the line that starts with @PART

It's easier to spot these things if you use proper indentation.

Also, old programmer tip: when you do add a left brace immediately close it with the right brace then move your cursor in between them and add whatever needs to go between them.

Share this post


Link to post
Share on other sites

This is what I'm seeing a lot of in Miller's log:


165x
NullReferenceException: Object reference not set to an instance of an object
at DeadlyReentry.ModuleAeroReentry.SetDamageLabel () [0x00000] in <filename unknown>:0

at DeadlyReentry.ModuleAeroReentry.AddDamage (Single dmg) [0x00000] in <filename unknown>:0

at DeadlyReentry.ModuleAeroReentry.CheckForFire (Vector3 velocity) [0x00000] in <filename unknown>:0

at DeadlyReentry.ModuleAeroReentry.FixedUpdate () [0x00000] in <filename unknown>:0

(Filename: Line: -1)

I'm guessing that's before you enterered the VAB.

The only other error I'm really seeing that might be in the editor itself is a lot of renderer errors....

This one appears a whopping 25,631 times..... no idea where this is coming from... unless you alt-tabbed out a lot in this area.... that can cause rendering device errors but re-entering the game usually makes it stop until you alt-tab out again...


Skipped rendering frame because GfxDevice is in invalid state (device lost)

(Filename: Line: 1385)

HandleD3DDeviceLost
HandleD3DDeviceLost: still lost
Skipped rendering frame because GfxDevice is in invalid state (device lost)

(Filename: Line: 1385)

So the only error I can actually trace to anything specific is from Deadly Re-entry.... so you probably want to make sure you have the latest one... and maybe try running without it and see if it stops....

Aaaaaaand I am actually starting to pass out as I'm typing this. I just had to delete a line of sssssssss all across the screen so I'm gonna hit the sack... I'll look at it more closely tomorrow.

Share this post


Link to post
Share on other sites

yeah I'm pretty sure it only happens when you revert to VAB after DRE exploded your vessel

Share this post


Link to post
Share on other sites

Could someone explain what's going on with nuclear engines? With H2/LOX they have like 300m/s dV.

Actually, I think I get it. It just needs to be gigantic but not necessarily heavier than before..

Share this post


Link to post
Share on other sites

This one appears a whopping 25,631 times..... no idea where this is coming from... unless you alt-tabbed out a lot in this area.... that can cause rendering device errors but re-entering the game usually makes it stop until you alt-tab out again...


Skipped rendering frame because GfxDevice is in invalid state (device lost)

(Filename: Line: 1385)

HandleD3DDeviceLost
HandleD3DDeviceLost: still lost
Skipped rendering frame because GfxDevice is in invalid state (device lost)

(Filename: Line: 1385)

Yes i did alt-tab, so that's definitely the cause of that error.

Share this post


Link to post
Share on other sites

Has anyone experienced this issue?

wM71yLLl.png

I can't auto-fill my stretchy tanks :/

Share this post


Link to post
Share on other sites

Starwaster: thanks for hunting that down. Miller, try without DRE and let us know if the problem goes away.

AbeS: Aw, crap. The fuel list is longer than your screen height. I didn't notice that problem because I run very high-res. Must be from the new fuels I added. I'll add a scrollbar.

Share this post


Link to post
Share on other sites
ok I'm not seeing this on my end. using latest ICS aka dev release 4.

Ioncross's modification of the clamp is via ModuleManager; just adds a stock ModuleGenerator that adds oxygen and subtracts CO2. Do other ModuleManager files work ok? Are you also using Sarbian's MM extensions? If so, try using this version of MM: https://www.dropbox.com/s/dr3wd3up88yizra/ModuleManager.dll

It's the most recent version from Ialdabaoth's original thread but with the KSPAddon fix.

OK, I've found where the problem lies. The pump only refuels modular tanks, and I was using a normal one.

Also, could you add Synthin and baloon tank type in the next update? Oh, and a tank type that doesn't change the original mass would be useful.

Edited by Dragon01

Share this post


Link to post
Share on other sites

1. Ah, I see.

2. Doh, I was supposed to add Synthin. But as AbeS was pointing out, the tanks listings are already too long and I need to add as scrollbar.

Balloon tanks...I can add the tank type, but being able to switch MFS tank types in ST will take a bit of work.

3. That's been in since forever. Check the readme for details, but here's a quick overview.

When you add a ModuleFuelTanks {} to a part, you can set a custom basemass. That will override the tanktype basemass. If you set it to -1, no mass changes are made to the part's dry mass.

Heck, you could simulate a balloon tank by making a copy of a SuperStretchy and set basemass to something like basemass = 0.00008 * volume or even 0.0000000001 for practically no basemass whatsoever (a true balloon tank).

Also, in each MFT module, you can add TANK overrides. Anything inside a TANK {} inside the MFT module declaration will override what's in the TANK {} in the MFT tanktype. Like in a MFT {} you could do TANK { name = LiquidFuel mass = 0.00002 } to cut the mass per volume of RP-1 in half.

Share this post


Link to post
Share on other sites
Starwaster: thanks for hunting that down. Miller, try without DRE and let us know if the problem goes away.

After uninstalling DRE the problem doesn't appear to happen anymore.

Edited by Miller

Share this post


Link to post
Share on other sites

That's why I asked for Synthin in the next update. Once you have a scrollbar, you could add it in.

2. Doh, I was supposed to add Synthin. But as AbeS was pointing out, the tanks listings are already too long and I need to add as scrollbar.

Balloon tanks...I can add the tank type, but being able to switch MFS tank types in ST will take a bit of work.

Why do want to make the type switchable? I see no need for that. Simply create a new part. One for a regular baloon tank and one for cryo. Perhaps they could use a different model, a round top and bottom with a lattice structure for attachment, sort of like KOSMOS tanks.

Share this post


Link to post
Share on other sites

Not sure if it's more of MFSC issue or Stretchy Tanks, but there seems to be a limit on how long the stage can be - I hit the limit when I was trying to build an all-KeroLOx mega-SHLV. But the one with HyrdoLOx core and uppper stages work:

qZwPk1i.png

1xRD-0120 in the upper stage, 4xRD-0120 in the core stage, and four strapon KeroLOx boosters powered by 1xRD-180 each. 100 tonnes to LEO :)

Edited by asmi

Share this post


Link to post
Share on other sites
Not sure if it's more of MFSC issue or Stretchy Tanks, but there seems to be a limit on how long the stage can be - I hit the limit when I was trying to build an all-KeroLOx mega-SHLV. But the one with HyrdoLOx core and uppper stages work:

qZwPk1i.png

1xRD-0120 in the upper stage, 4xRD-0120 in the core stage, and four strapon KeroLOx boosters powered by 1xRD-180 each. 100 tonnes to LEO :)

.Craft? That looks like it would be really useful for my space station.

Share this post


Link to post
Share on other sites

asmi, I'll check. I do seem to recall AG put a limit on vertical stretch which you're probably hitting. Now that we need bigger stuff I'll turn it off.

Share this post


Link to post
Share on other sites

Make sure you're using RF or RFRM. Go to Action editor mode in VAB. Click on engine. Click plus or minus buttons.

Share this post


Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this