Sign in to follow this  
Nemrav

-Suggestion- reduce terrain footprint

Recommended Posts

Well after playing ksp since late v0.21 on a laptop (2.2ghz duo-core, intel hd graphics) on minimal settings, I have come to a conclusion as to what would guarantee 30 fps instead of 5-10..

1. if not already implemented multi core support.. sorry for being too lazy to see if the latest updates have it....

2. and foremost-- less terrain footprint...

I see many ways it could possibly be done.. mainly by reducing the fov and have anything outside it not be simulated..

another thing for space and high atmosphere would be to simply decimate vertices that don't add detail (anything except mountains and in some cases large hills/shoreline)..

add the option to lower to terrain detail levels at shorter intervals is another little solution

To make my point clear, a friend of mine who has a 3.3ghz quad core desktop has just about the exact same problem, just on setting a bit above minimal..

If this has already been suggested, I checked the already posted thread and didn't see it, so sorry.

Thankyou for looking at this :wink:

Share this post


Link to post
Share on other sites

1. Is on the do not suggest list since Squad does not control multi-threading support (the unity devs do)

2. You are using intel hd graphics and a low speed cpu, you need to get a new computer because most games do not support such low speed hardware. Anyways, you can "change" your fov by zooming and you can just simply look at the sky while launching craft until you get high enough where terrain is not rendered. Also it doesnt matter if your friend has 32 cores as terrain is by the gpu not the cpu.

Share this post


Link to post
Share on other sites

Try this for Kerbin, for other planets with oceans modify accordingly :)

Change:

PLANET

{

name = KerbinOcean

minDistance = 4

minSubdivision = 1

maxSubdivision = 6

To:

PLANET

{

name = KerbinOcean

minDistance = 2

minSubdivision = 1

maxSubdivision = 6

Share this post


Link to post
Share on other sites

duo-core...intel "hd graphics... although the newer intel hd graphics are decent the one on the duo is pathetic.

Share this post


Link to post
Share on other sites

Thanks sal_vager. And yes I know, I don't have the gratest machine.

The quad core desktop was just to give you guys an idea that it was a good computer (gaming pc) and that it had similar probs.

Now I know what multi threading is, didn't know it was the same thing as multi core.

WAIT.... sal, where is that text found... is it in the settings config or the save file ?

Share this post


Link to post
Share on other sites

In the settings.cfg, scroll down to the planet parameters :)

You'll need to edit it for all three graphics levels, low default and high, for every planet you are suffering lag with.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this