Raptor831

Stockalike RF Engine Configs v3.2.3 [8/23/17][RF v12]

Recommended Posts

Stockalike Real Fuels Engine Configs

For Real Fuels v12.x

After playing with Real Fuels, I got hooked. But, many of my part mods' engines were not included. I decided to fix that, and this is the result.

Latest Release

GitHub Repository

Config generator found at http://bit.ly/rfstockalike

NOTICE: Some engines have "lost" their effects. This is a known issue, and a result of moving fully to a new engine MODULE in RealFuels.

As a result, Real Plume is highly recommended. Configs are included in the RF Stockalike download.

Available on CKAN

Updated on August 23, 2017

 

 
Changelog:

v3.2.4
* Various improvements, fixes. See commits.

v3.2.3
* Fix RCS persistent effects in release (thanks Alexical)
* Ion and NTR effects updates (thanks Blowfish)

v3.2.2
* Various community fixes. See commits for details.

v3.2.1
* Add Cormorant Aeronology
* Add SpaceX Launchers Pack
* Bugfix to resourceFlowMode (Starwaster)
* Add Sounding Rockets (Canis Dirus Leidy)
* Pull RealPlume configs out of that mod's folder

v3.2.0
* I goofed, not a real release.

v3.1.0
* New Plumes from Svm420
* New Squad engines config
* Tantares bug fix from nwtest
* SDHI/TAC/Stockalike conflict resolved

v3.0.1
* Works with KSP 1.1.2 and RF v11
* Updates by bfrobin446 and blowfish

v3.0.0
Lots of stuff, installation changes. See commit log on GitHub for details.

v2.1.8
[LIST]
[*]Various bug fixes for RF v10
[*]Added Cryo Engines
[/LIST]

v2.1.7
[LIST]
[*]Update ModuleRCSFX to v4.1
[*]SpaceY updates (Frimi_2)
[/LIST]

v2.1.6
Hotfix for RF 10+/CRP v4+

v2.1.4
[LIST]
[*]Final update before KSP v1.0 and CRP v1.0. As long as RF keeps working for 1.0, this should work as well.
[/LIST]

v2.1.3
[LIST]
[*]New engines, various fixes
[*]Catch-all file to try and make sure all tanks and engines at minimum use the proper fuels
[/LIST]

v2.1.0
[LIST]
[*]Switched to a new config generator
[*]Updated various mods with new engines
[*]Configs for Atomic Age and Stock Revamp (lurkaholic)
[*]Config for SpaceY OMS/RCS combo (Tellion)
[*]Tantares help from Niemand303
[*]Updated Mono_to_Hydrazine.cfg to be a more generic fuel tank catch-all (sippyfrog)
[*]Updated ModuleRCSFX to v3.5
[/LIST]

v2.0.6
[LIST]
[*]Added new engines from SpaceY 0.2.1
[*]Updated ModuleRCSFX to v3.3
[/LIST]

v2.0.5
[LIST]
[*]Added SpaceY engines
[*]Fixed a conflict with HotRockets
[/LIST]

 

Installation

Install everything inside /GameData/ to your <KSPRoot>/GameData/.

*NOTE*: You must have Module Manager installed for this to work, but you should have that already if you are running Real Fuels (which is obviously required).

Description

This is a stockalike setup for you engines to work with Real Fuels. All of the stock (or part-pack's "stock") numbers for thrust remain the same. Meaning, the Mainsail still pushes the same kN as before. But, the masses are reduced to be in-line with realistic numbers (according to the calculations anyway).

There is also an RCS config to make the RCS thrusters work with the appropriate fuels. These have followed the original thrusts but will change given the fuel used. So, a hydrazine RCS will have better thrust than an HTP one, but an MMH/N2O4 bipropellant RCS will have greater thrust still. And yes, bipropellants are set up.

This was originally done with the help of Chestburster's XLS that I found in the Real Fuels thread (link here). Since then, I've added mod parts I've either used in the past or use currently. I've also added some variations in the fuel mixture used for each manufacturer (i.e mod). So if you swap out a KW engine for a NovaPunch one, be sure you've got the right mix in the tanks. This adds to the variation in my opinion, as it gives you a reason to switch things up.

This is also a continual work in progress. Any suggestions or help is encouraged. I don't have every mod in this file, so if you feel so inclined to add your favorite that's missing, please do. Let me know of the edits and I'll continue to compile a running config. Also, if you'd like to add your thoughts on balancing, please do that as well. I've not rigorously tested every engine, since I don't play with all of these installed and I'd rather simply play than test. So, I may have missed something or goofed some numbers.

Current Mods Working

  • KW Rocketry
  • NovaPunch2
  • FASA
  • KOSMOS
  • Aerojet Kerbodyne
  • AIES
  • B9 Aerospace
  • Klockheed Martian (i.e. Space Shuttle Engines Mod)
  • RLA Stockalike
  • SXT (by Lack)
  • aWolf's Escape Towers and sepratrons
  • KSPX launch towers
  • kommit's Nuclear pack (formerly FTmN)
  • Home Grown Rockets (beta version)
  • SDHI (LV909 Fairingless)
  • LazTek SpaceX Launch Pack v3
  • Kerbal Stock Launcher Overhaul
  • KSP Interstellar
  • Modular Rocket System
  • SpaceY
  • NearFuture Propulsion
  • Tantares
  • BahaSP
  • Atomic Age
  • Stock Revamp
  • Cryogenic Engines
  • Vanguard
  • Cormorant Aeronology
  • Launchers Pack - SpaceX

Known Issues

RCS thrusters show an "Unknown Thrust" in the VAB/SPH part list. They work properly on the pad, and do show correct thrust for the initial fuel config (which is hydrazine).

Configs released under the CC Attribution-ShareAlike 4.0 International License.

Edited by Raptor831
new version
  • Like 6

Share this post


Link to post
Share on other sites

Thanks very much. I found myself adding to the stockalike file but didn't have the time to do a very good job of it. I really appreciate the time you put into this.

Share this post


Link to post
Share on other sites
Thanks very much. I found myself adding to the stockalike file but didn't have the time to do a very good job of it. I really appreciate the time you put into this.
Awesome! Thanks for taking this on! :)

You're welcome. Hope it works as intended. :)

Share this post


Link to post
Share on other sites

Just added the FASA Apollo engines to the config, and a NovaPunch engine I missed. As always, let me know if I missed anything else.

Share this post


Link to post
Share on other sites
Oh nice :D Good work

Thanks!

And, again, another quick update. Found a "bug" in the XLS (if you can call it that) that I fixed. It was adding a "TRUE" or "FALSE" line into the tank config if present. Don't think this was affecting anything, but you never know. Also added a "Dedicated" option for boosters or any other Tank/Engine hybrid. Thanks to swamp_ig for pointing that one out. Just make that column not blank and you'll ensure that any time your engine changes fuel mixture, the tank will follow.

Share this post


Link to post
Share on other sites

Hi,

Another thing you might consider is doing something like:


@PART[someId]:FOR[RealFuels_StockEngines] {}

That way any MM patch that wants to know if that config is present or not present can do so.

You could also consider doing :AFTER[RealFuels] instead of :FINAL for all the configs I guess.

At some stage I'll do some changes to MM to ensure that mods with patches that depend on other mods get called in the right order, then you could combine both of them.

Share this post


Link to post
Share on other sites
Hi,

Another thing you might consider is doing something like:


@PART[someId]:FOR[RealFuels_StockEngines] {}

That way any MM patch that wants to know if that config is present or not present can do so.

You could also consider doing :AFTER[RealFuels] instead of :FINAL for all the configs I guess.

That's a good idea. I've updated the config with the :FOR[RealFuels_StockEngines] instead of :Final. Should help going forward.

Also, I think the dedicated = true option broke a few things when used with RF 5.3, so until the new RF improvements become "official" I'll leave those out.

Share this post


Link to post
Share on other sites

Just a heads up, there's a shift that somehow works it's way into the "MM Formula" column in the spreadsheet you currently have linked (see row 19 and row 20 for example). You should just need to copy the formula from the top cell all the way down again to fix it.

And thanks for putting this all together! You made my life tons easier today since I was about to try and do it myself. Being able to start from this meant all I had to do was tweak the things I wanted tweaked.

Share this post


Link to post
Share on other sites
Just a heads up, there's a shift that somehow works it's way into the "MM Formula" column in the spreadsheet you currently have linked (see row 19 and row 20 for example). You should just need to copy the formula from the top cell all the way down again to fix it.

And thanks for putting this all together! You made my life tons easier today since I was about to try and do it myself. Being able to start from this meant all I had to do was tweak the things I wanted tweaked.

Those shifts are killing me... :) Thanks for the heads up. One of these days I'll have to learn the finer points of Excel and be able to understand all that's going on.

Configs should be correct either way. OP has been updated with a new XLS file.

And you're welcome. The spreadsheet wasn't mine originally, so I can't take credit for that. But, it does make life so much easier when you tweak the engines or add new ones!

Share this post


Link to post
Share on other sites

Well now I'm having trouble with the SRB's. Whenever I put an SRB on a craft:

1) The activate engine icon doesn't show on the side tab

2) The engine appears at the bottom of the screen and is turned on IN the VAB

3) When I revert to VAB after a launch (after right click and activate engine), the game can't ID my previous craft and has "vessel name" in top, wrong flag, AND most of my parts have disappeared. This ONLY happens with the SRB's.

I'll post a pic to show.

Where is the SRB icon on the side stage icons?

7rJsBnP.png

Oh NOW it appears on the pad.

PvJlUyL.png

EsuO2TV.png

Look at the name and the side icons

oNZv35r.png

dtdezGP.png

This last one is the clue it's either a real fuels or stockalike problem.

n2vp27i.png

Edited by TeeGee

Share this post


Link to post
Share on other sites
Well now I'm having trouble with the SRB's. Whenever I put an SRB on a craft:

1) The activate engine icon doesn't show on the side tab

2) The engine appears at the bottom of the screen and is turned on IN the VAB

3) When I revert to VAB after a launch (after right click and activate engine), the game can't ID my previous craft and has "vessel name" in top, wrong flag, AND most of my parts have disappeared. This ONLY happens with the SRB's.

I'll post a pic to show.

..snip..

I tested this on my setup and I'm not getting that issue at all. The config shouldn't really mess with anything but adding the appropriate RF engine module and/or tank module to each part, so I don't know what could be causing the errors. Are you getting errors in the debug console in-game (Alt-F12) or in the log file?

Share this post


Link to post
Share on other sites
I tested this on my setup and I'm not getting that issue at all. The config shouldn't really mess with anything but adding the appropriate RF engine module and/or tank module to each part, so I don't know what could be causing the errors. Are you getting errors in the debug console in-game (Alt-F12) or in the log file?

Hmmm. Let me check because I'm trying to isolate the reason why this is happenning, so far I know none of the other mods I use bother to touch the engines or boosters other than Real Fuels and stockalike. Could it be coolrockets? Tweakable? Engine ignitor?

dEEz5K4.png

I don't see anything wrong..

Edited by TeeGee

Share this post


Link to post
Share on other sites
Hmmm. Let me check because I'm trying to isolate the reason why this is happenning, so far I know none of the other mods I use bother to touch the engines or boosters other than Real Fuels and stockalike. Could it be coolrockets? Tweakable? Engine ignitor?

Coolrockets is a possibility, but I don't recall how they add the effects. It's based on the same idea as HotRockets, which alters the engine module to change the effects. Engine ignitor might also be something to look at, but the stockalike config should work with EI since it adds EI modules to each engine/SRB.

Which leaves us Tweakable Everything. I've heard of that mod conflicting with a few things, and since your tweakable menu has data missing in your last screenshot, I'd check there. You may need to get the latest versions of those mods as well, since the new procedural mods and Tweakables are using a new .dll to make the magic happen.

Easiest way to see is to just remove the mod and repeat your steps. If your log file gives you any clues, that'd be helpful too. And any mod author will need to see that file to debug any issues.

Share this post


Link to post
Share on other sites
Coolrockets is a possibility, but I don't recall how they add the effects. It's based on the same idea as HotRockets, which alters the engine module to change the effects. Engine ignitor might also be something to look at, but the stockalike config should work with EI since it adds EI modules to each engine/SRB.

Which leaves us Tweakable Everything. I've heard of that mod conflicting with a few things, and since your tweakable menu has data missing in your last screenshot, I'd check there. You may need to get the latest versions of those mods as well, since the new procedural mods and Tweakables are using a new .dll to make the magic happen.

Easiest way to see is to just remove the mod and repeat your steps. If your log file gives you any clues, that'd be helpful too. And any mod author will need to see that file to debug any issues.

Yeah I just downloaded all of these mods yesterday so I don't think they are outdated.

1) It's not tweakables.

2) Not coolrockets

When I removed real fuels, ALL MY PARTS disappeared. Sigh. Im going to start over again.

I have no idea what's going on.

Edited by TeeGee

Share this post


Link to post
Share on other sites

Sorry, it IS stockalike.

I started vanilla KSP, put in each mod 1 by one by priority and started game to see if problem happened, and reached yours and there it was.

As SOON as I put in your file into the Real Fuels folder, the SRB problem was there.

Here is the mod list I have to check compatibility issues:

Atmospheric sound enhancment

FAR

Chatterer

DistantObjects

KerbQuake

Real Fuels

Kerbal Alarm clock

Module Manager 2.1.5

Those are the ONLY other mods I installed before getting to yours.

SRB's also firing from the sides in VAB.

Edited by TeeGee

Share this post


Link to post
Share on other sites

Ok, if they're shooting flame out of the side, I know what caused that for me once. Check your stockalike config and see if it has the line dedicated = true for the SRBs. Also, check the new NASA addition 2.5m liquid booster and see if it does it as well. If it's that, use the latest config here: http://cl.ly/code/311Y0u2F2S3Z

That line is a new feature coming to Real Fuels but I don't believe it's in the 5.3 version available for download. So that line breaks those parts.

If you still get that error with the above link, let me know.

Share this post


Link to post
Share on other sites
Ok, if they're shooting flame out of the side, I know what caused that for me once. Check your stockalike config and see if it has the line dedicated = true for the SRBs. Also, check the new NASA addition 2.5m liquid booster and see if it does it as well. If it's that, use the latest config here: http://cl.ly/code/311Y0u2F2S3Z

That line is a new feature coming to Real Fuels but I don't believe it's in the 5.3 version available for download. So that line breaks those parts.

If you still get that error with the above link, let me know.

Ok Ill try!

Thanks for your help! Ill let you know if it's fixed.

Share this post


Link to post
Share on other sites
SOLVED!

Well done my friend!!! Thanks SOOOOO much!

Well, good! :) Sorry again, I must have used an old XLS to make that last config. Thanks for helping out.

Also, to everyone, I've added the LazTek SpaceX Launch pack engines (Merlin 1D, Merlin 1D Vacuum, SuperDraco Nacelles, and Separation Engine). This new version includes all the fixes from above, so the config won't make your SRBs spit fire randomly... :wink:

Share this post


Link to post
Share on other sites

Thanks to your efforts, I was finally able to build my 3 kerbal spacecraft!

hCnNwCL.png

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now