NathanKell

Realism Overhaul Discussion Thread

Recommended Posts

Suppose I could always cfg hack a set of fairings to be lighter if that was the case. But what I really need to know before I even get to that point is what's the easiest way to calculate the fuel to oxy ratio with a given fuel type and engine?

Share this post


Link to post
Share on other sites
I think the ancient KSP Silisko Version was the granfather of RO. Might.

http://forum.kerbalspaceprogram.com/threads/2685-v1-2-KSP-Silisko-Edition/page14

And? It's a nice share, but ever since people found out that KSP had a toy solar system with ridiculous abstractions to compensate they've wanted more.

Share this post


Link to post
Share on other sites

Quick question, would it be possible to create your own KSC Switcher locations? I'm thinking of putting one on Cape Cod for an alternate history playthrough.

Share this post


Link to post
Share on other sites

Yep! That's how they all got made in the first place...that's the point of KSC Switcher, it just reads in cfg data.

Share this post


Link to post
Share on other sites

I've started looking at realism overhaul just recently and am completely new to it. When doing some test launches I've been finding that something had been grabbing my throttle and dropping it, sometimes to zero. With no restarts this is fairly terminal, but I'm doing some testing with a non ro mod engine(looking at adding the ro config for it), and got to orbit, and the effect seems to stop once out of the atmosphere. I have no idea what's causing it.

Share this post


Link to post
Share on other sites
Mechjeb's "limit acceleration" function, most likely.

Ah, OK. That would make sense. I've been messing with atmospheric effects for Orions (much higher thrust in an atmosphere than out), and it was cutting thrust with every pulse.

Thanky.

And you were correct. I didn't realize Mechjeb did that sort of thing when the autopilot isn't engaged.

Edited by TiktaalikDreaming
updated confirmation

Share this post


Link to post
Share on other sites

My plane is overheating on the runway. I have no idea what's causing this. When it spawns in, the parts already have the temperature indicator and are glowing orange. They die soon after. :(

Share this post


Link to post
Share on other sites
My plane is overheating on the runway. I have no idea what's causing this. When it spawns in, the parts already have the temperature indicator and are glowing orange. They die soon after. :(

Actually, I have a question about heat/temperature/etc in RO as well.

From the point of view of writing modules and adjusting parts for RO, how is heat handled differently in RO? Things seem to overheat faster, or possibly cool down slower. Some parts are like mentioned, overheating at the start. And the module I'm working with adds heat directly to part.skinTemperature, and this seems to cause an impressively dramatized version of how it works in vanilla. The added heat is based off a part value, so I can adjust in the RO_.cfg, but it'd help to know what's going on.

Share this post


Link to post
Share on other sites

If you're adding directly to part.skinTemperature, your changes will be overridden in analytic anyway, in 1.0.4.

As to RO's changes--we lower conduction and convection values to things closer to real, but that's about it.

Share this post


Link to post
Share on other sites

Hi

There is a problem with the explosion of components from overheating during the warp after loading a save.

I tried this with and without radiators radiators constantly explodes after launch conservation.

In many such expeditions it leads to disaster.

rF0yJESrQvg.jpg

Share this post


Link to post
Share on other sites
If you're adding directly to part.skinTemperature, your changes will be overridden in analytic anyway, in 1.0.4.

As to RO's changes--we lower conduction and convection values to things closer to real, but that's about it.

It doesn't *seem* to be overridden, but not sure.

The differences are a matter of mild scale, so the conduction/convection changes are probably all it is. The values I'm using in stock are ~150-250 per pulse, but NASA/GeneralAtomic numbers were of the order of 0.8F per pulse. You really have to crank heat values in stock to see any affect.

Share this post


Link to post
Share on other sites

Hey, I might have a bug. I am not sure, but whenever I launch something (any rocket) it spins out of control for no reason after some time. I was using the mod earlier, but never had such a problem. I may be doing something wrong, I am not sure. I use spin stabilization.

Share this post


Link to post
Share on other sites

Are there any good engine packs for low-thrust, upper-stage engines? Because the only ones that I have either give a TWR of 7 or .05.

Share this post


Link to post
Share on other sites

Yes. Add a Realchute conic chute and adjust its size using the same way (action group mode, click on chute, choose resize) you adjust anything else.

Share this post


Link to post
Share on other sites

Was the boiloff rate for liquid oxygen adjusted in the last update? Previously I had no boiloff with a Kerolox engine using a normal tank, now I need a cryogenic for anything later than an orbital insertion stage. Using procedural tanks, cryogenic is fairly late in the tech tree (it comes with the 5.6m diameter upgrade node I believe) - is there a way to get better insulation for the launch period in early tech? I use hypergolics for long duration flights anyways, but some kerolox engines have better performance especially early in the tech tree.

Share this post


Link to post
Share on other sites
I've found a few issues in my latest play. Not sure if this is the right thread to post all of them but it seems my best option... please tell me if I should report any of these problems somewhere else :)

1. MechJeb can't calculate dv anymore. I used MJ quite normally for a while, then all of the sudden the dv window disappeared (I don't even see it in the MJ options anymore). I tried resetting all MJ config to defaults but still doesn't work. I was able to create a custom window that shows dv but it only works in flight mode, not in VAB/SPH. Any ideas what's wrong?

2. Since MJ doesn't work, I installed Kerbal Engineer Redux. In the editor it works fine but in flight mode it can't calculate the current's stage dv. The next stage(s) show up fine but whenever I activate a new stage it just shows "0/1234 m/s". Same for TWR, it will actually show my TWR as "0/1.42", as if the engine wasn't enabled. I just updated all my mods via ckan and the problem didn't go away. Any clues?

3. My Kerbals switch professions! Whenever I hire a pilot I can only send him for a single flight, upon recovering him he'll switch to being an engineer. Also I think my pilots are not providing SAS, but maybe that's because they switch to being engineers as soon as I launch, I haven't checked again.

4. My MK1 pod is crazy! I put just a pod in orbit, no sas. If I turn RCS on it will start spinning randomly. No trimming involved.

5. Reentry from LEO requires no ablator. If I don't use a heatshield some parts do explode, but if I use one it consumes at most 3 or 4 points of the ablator coming back from LEO. I'm using DR with default settings. Is this reasonable?

Share this post


Link to post
Share on other sites
One thing - Titan does not have an "in space low" biome. The atmosphere starts at 600km (my probe cut it close to burning up at a PE of about 500km) and that is still in the "in space high" range.

Should titans atmosphere really stretch that high?

Share this post


Link to post
Share on other sites
[quote name='MaxL_1023']One thing - Titan does not have an "in space low" biome. The atmosphere starts at 600km (my probe cut it close to burning up at a PE of about 500km) and that is still in the "in space high" range.

Should titans atmosphere really stretch that high?[/QUOTE]Titan has a CRAZY atmosphere. Its haze starts around 500km, but the main haze that make the photos so awesome starts at like 250km I think? It actually has more mass in its atmosphere than Earth has in ours, but since Titan has a lot less gravity it goes up super high. This is why for a long time Titan was thought to be larger than Ganymede.

But there should be some low space above it. I could have sworn I read someone had noticed and fixed that. It may have been in RP-0 however. Not sure.

Share this post


Link to post
Share on other sites
I am using RP-0 0.40. I was getting "in space high" when actually inside the atmosphere, as when you are on a hyperbolic trajectory it apparently does not let you collect atmospheric science.

I would suggest setting in space low at ~2000 km, and for Saturn it should be anywhere inside the rings.

Share this post


Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.