pjf

The Comprehensive Kerbal Archive Network (CKAN) Package Manager; v1.18.0 [19 June 2016]

Recommended Posts

4 minutes ago, Steven Mading said:

Am I correct in assuming that the only way to find the netkan.exe file that the modders' instructions talk about is to compile CKAN from source?  It seems like if you install the release without source, all you get is CKAN.EXE.

 

 

Downloads for ckan.exe and netkan.exe are linked here in the "quick downloads" section: https://github.com/KSP-CKAN/CKAN/wiki/Adding-a-mod-to-the-CKAN

Share this post


Link to post
Share on other sites
4 minutes ago, phoenix_ca said:

Downloads for ckan.exe and netkan.exe are linked here in the "quick downloads" section: https://github.com/KSP-CKAN/CKAN/wiki/Adding-a-mod-to-the-CKAN

Okay thanks.  It might be a good idea to mention that in the place in the readme for modders where it talks about executing netkan.exe.  Netkan.exe doesn't appear in the recent release and it's a bit unclear that it's actually okay to dig down deeper into the release list and use an older one that does mention it.

Edited by Steven Mading

Share this post


Link to post
Share on other sites
5 hours ago, Steven Mading said:

Okay thanks.  It might be a good idea to mention that in the place in the readme for modders where it talks about executing netkan.exe.  Netkan.exe doesn't appear in the recent release and it's a bit unclear that it's actually okay to dig down deeper into the release list and use an older one that does mention it.

I know what you mean. I actually got sucked down a rabbit hole thinking new metadata files were supposed to be merged with the CKAN-meta repo. If you see any place for improvement on the wiki, I'm sure people would appreciate it.

Share this post


Link to post
Share on other sites

Historian-expanded doesn't seem to be updating for me properly. I've refreshed the modlist to no avail. And the correct metadata file is available, so I'm at a loss. :huh: Anyone else having this issue? The CKAN app is reporting that 1.2.4.12 is the latest version. O.o

Share this post


Link to post
Share on other sites

Uhh, Larinax Solar System is no longer being maintained by me, so what is it doing on CKAN???

Share this post


Link to post
Share on other sites
On 16/06/2016 at 6:43 PM, RA3236 said:

Uhh, Larinax Solar System is no longer being maintained by me, so what is it doing on CKAN???

It's still on CKAN because you selected the CKAN option when you put it on Spacedock, and it's still there (on Spacedock). Also, the forum thread for it still shows it as being an active mod (though WIP), and that you are seeking a replacement maintainer. Why would we make it unavailable through CKAN when it is still available through Spacedock?

Share this post


Link to post
Share on other sites
Just now, politas said:

It's still on CKAN because you selected the CKAN option when you put it on Spacedock, and it's still there (on Spacedock). Also, the forum thread for it still shows it as being an active mod (though WIP), and that you are seeking a replacement maintainer. Why would we make it unavailable through CKAN when it is still available through Spacedock?

Good point, although I accidentally selected as marked on CKAN on SpaceDock. Keep it on there for now I suppose.

Share this post


Link to post
Share on other sites
2 minutes ago, RA3236 said:

Good point, although I accidentally selected as marked on CKAN on SpaceDock. Keep it on there for now I suppose.

Well, obviously, we have no way to know why or how you selected that option, only that you did.

It's worth remembering also that not selecting the CKAN option on Spacedock does not mean that the mod won't be listed on CKAN. If a CKAN user asks for a given mod to be listed, we will generally do so, barring some legal block. Since you have licensed Larinax under CC-BY-SA-NC, you've given us irrevocable permission to distribute it.

Share this post


Link to post
Share on other sites
22 minutes ago, politas said:

Well, obviously, we have no way to know why or how you selected that option, only that you did.

It's worth remembering also that not selecting the CKAN option on Spacedock does not mean that the mod won't be listed on CKAN. If a CKAN user asks for a given mod to be listed, we will generally do so, barring some legal block. Since you have licensed Larinax under CC-BY-SA-NC, you've given us irrevocable permission to distribute it.

Okay, thanks :).

Share this post


Link to post
Share on other sites

There is new mod released recently: LaserDist. It is under GPL v3 licence. Reason why not is on CKAN is, I belive, lack of free time to go trough ckan documentaion and make it available. But can't hurt to ask @Steven Mading about it if you are in doubt.

This small mod is usable to regular users, not to mention one that also use kOS.

Share this post


Link to post
Share on other sites
12 minutes ago, kcs123 said:

There is new mod released recently: LaserDist. It is under GPL v3 licence. Reason why not is on CKAN is, I belive, lack of free time to go trough ckan documentaion and make it available. But can't hurt to ask @Steven Mading about it if you are in doubt.

This small mod is usable to regular users, not to mention one that also use kOS.

I already made a PR for it on NetKan when I first released it.  It's still awaiting a merge.

 

Share this post


Link to post
Share on other sites
20 hours ago, Steven Mading said:

I already made a PR for it on NetKan when I first released it.  It's still awaiting a merge.

Merged now. Thanks for submitting!

Share this post


Link to post
Share on other sites

Aww yis!

CKAN v1.18.0 aka Star Tram released!

 

68747470733a2f2f75706c6f61642e77696b696d


Changes since v1.16.1:

Bugfixes

  • [Core] In certain cases a NullReferenceException could be produced inside error handling code when processing the registry. (#1700 by: keyspace, reviewed: dbent)
  • [GUI] Fix typo in export options. (#1718 by: dandrestor, reviewed: plague006)
  • [GUI] Fix unit of measure for download speed. (#1732 by: plague006, reviewed: dbent)
  • [Linux] Better menu integration of the CKAN launcher. (#1704 by: reavertm; reviewed: pjf)

Features

  • [Core] install stanzas can have an as property allowing directories and files to be renamed/moved on installation. (#1728 by: dbent; reviewed: techman83)
  • [GUI] Added "filter by description" search box. (#1632 by: politas; reviewed: pjf)
  • [CLI] compare command now checks positive and negative rather than -1/+1 (#1649 by: dbent; reviewed: Daz)
  • [GUI] In windows launch KSP_x64.exe by default rather than KSP.exe. (#1711 by plague006; reviewed: dbent)
  • [Core] Unlicense added to CKAN as an option for mods. (#1737 by plague006; reviewed: techman83)
  • [Core] CKAN will now read BuildID.txt for more accurate KSP versions (#1645 by: dbent; reviewed: techman83)

Internal

  • [Multiple] Removed various references and code for processing mods on KerbalStuff. Thank you, Sircmpwn, for providing us with such a great service for so long. (#1615 by: Olympic1; reviewed: pjf)
  • [Spec] Updated Spec with the kind field which was introduced in v1.6. (#1662,#1597 by: plague006; reviewed: Daz)
  • [Spec] ckan.schema now enforces structure of install directives (#1578 by: Zane6888; reviewed: pjf, Daz)
  • [Spec] Documented the x_netkan_github and use_source_archive options in NetKAN files. (#1774 by dbent; reviewed: plague006)
  • [Spec] Clarified the install_to directive. (#1771 by: politas; reviewed: plague006)
  • [Spec] Clarified example of a complete metanetkan file (#1753 by: plague006; reviewed: politas)
  • [Spec] Removed stray comma (#1736 by: plague006; reviewed: politas)
  • [NetKAN] Catch ValueErrors rather than printing the trace (#1648 by: techman83; reviewed: Daz )
  • [NetKAN] Catch ksp_version from SpaceDocks newly implemented game_version (#1655 by: dbent; reviewed: -)
  • [NetKAN] Allow specifying when an override is executed (#1684 by: dbent; fixes: #1674)
  • [NetKAN] Redirects to the download file are now resolved when using HTTP $krefs (#1696 by: dbent, reviewed: techman83)
  • [NetKAN] Remote AVC files will be used in preference to ones stored in the archive if they have the same version (#1701 by: dbent, reviewed: techman83)
  • [NetKAN] Sensible defaults are used when fetching abstract and homepage from github. (#1726,#1723 by: dbent; reviewed: politas)
  • [NetKAN] Add Download Attribute Transformer (#1710 by: techman83; reviewed: dbent)
  • [NetKAN] Add ksp_version_strict to property sort order (#1722 by: dbent; reviewed: plague006)
  • [Docs] Updated CONTRIBUTING.md and README.md documentation. (#1748 by plague006; reviewed: politas)
  • [Build] Support for mono 3.2.8 deprecated (#1715 by dbent; reviewed: techman83)
  • [Build] Added support for building the CKAN client into a docker container. (#1747 by mathuin; reviewed: pjf)
  • [Build] Continuous integration is less susceptible to third-party network errors. (#1782 by pjf; reviewed: techman83)
  • [Core] Defend against corrupted KSP version numbers in old registries. (#1781 by pjf; reviewed: politas)
  • [Core] Support for upcoming download hash functionality in client. (#1752 by plague006; reviewed: pjf)
  • [GUI] Fixed spurious build warning (#1776 by politas; reviewed: pjf)

Notes

  • Windows users must have .NET 4.5 installed.
  • Linux users, please oh please apt-get install libcurl4-openssl-dev (Debian/Ubuntu/Mint) or yum install libcurl-devel (RedHat/Fedora) if you have not already done so.
  • Mac/Linux/Mono users: please mozroots --import --ask-remove if you're a new user, to update mono's certificate store.
  • Congratulations to Daz on the engagement! :D

Release image public domain, courtesy NASA.

Share this post


Link to post
Share on other sites

Hmm having issues with new version, when I try to launch it, it gives error with "Could not find KSP version in readme.txt" Nvm! Fixed it by moving CKAN.exe to KSP folder <.<

Edited by Prismaa

Share this post


Link to post
Share on other sites

I am getting a 404 error when updating 2 mods:

  • KSP interstellar extended
  • SpaceX Landing Legs

The error shows this: 

Failed to download "https://spacedock.info/mod/172/KSP Interstellar Extended/download/1.8.28" - error: Error in remote server: (404) Not found.

This was happening to me even before updating to this new version. I have tried installing new mods and it works.

Share this post


Link to post
Share on other sites
3 hours ago, Winderfo said:

I am getting a 404 error when updating 2 mods:

  • KSP interstellar extended
  • SpaceX Landing Legs

The error shows this: 


Failed to download "https://spacedock.info/mod/172/KSP Interstellar Extended/download/1.8.28" - error: Error in remote server: (404) Not found.

This was happening to me even before updating to this new version. I have tried installing new mods and it works.

Can you download the mods from SpaceDock directly? SpaceDock has had specific geographical issues with its CDN before:

 

Share this post


Link to post
Share on other sites
Quote

Can you download the mods from SpaceDock directly? SpaceDock has had specific geographical issues with its CDN before

 

I see that Spacedock direct download throws me another 404 error. 

Not Found

The requested URL /svendii_2817/SpaceX_Landing_Legs/SpaceX_Landing_Legs-1.3.zip was not found on this server.

Apache/2.4.7 (Ubuntu) Server at cdn.spacedock.info Port 80

So... Can I do anything to solve this? Maybe bypass this CDN to make it work with another?

Edited by Winderfo

Share this post


Link to post
Share on other sites
15 minutes ago, Winderfo said:

 

I see that Spacedock direct download throws me another 404 error. 


Not Found

The requested URL /svendii_2817/SpaceX_Landing_Legs/SpaceX_Landing_Legs-1.3.zip was not found on this server.

Apache/2.4.7 (Ubuntu) Server at cdn.spacedock.info Port 80

So... Can I do anything to solve this? Maybe bypass this CDN to make it work with another?

Report it in the Spacedock thread. They'll need to make space on the relevant server.

Share this post


Link to post
Share on other sites

I'm getting this error regularly in Windows on random mods:

wan6Xcn.png

Checking the CKAN\downloads folder in my KSP directory shows no files. I've tried clearing my cache beforehand too - It seems like CKAN is trying to open the zip file before it's downloaded, which is weird.

Edited by Rohaq

Share this post


Link to post
Share on other sites
4 minutes ago, Rohaq said:

I'm getting this error regularly in windows on random mods:

*snip*

Checking the CKAN\downloads folder in my KSP directory shows no files. I've tried clearing my cache beforehand too - It seems like CKAN is trying to open the zip file before it's downloaded, which is weird.

Educated guess at the problem: Windows won't let CKAN download stuff to a location in Program Files.

It's generally not a good idea to mod your steam install anyway (because steam auto-updates can suddenly break mods without warning).  My advice would be to copy the entire "Kerbal Space Program" folder to somewhere outside of Program Files and mod it there.  Some other stuff ends up being messed up from having KSP in Program Files too.

Alternate, bad, ugly solution that will let you use everything where it is but I highly do not recommend:

Spoiler

Run CKAN as an administrator every time (i.e. right click -> "run as administrator"

 

Share this post


Link to post
Share on other sites

Ok, I'm in the "trying to use CKAN to install a non-updated metadata thing MOD. 

Used the search button here and got a post going here:

https://github.com/KSP-CKAN/CKAN/pull/1499

And now I don't know what to do with that... O.o 

 

PS: I DID try to change the version number from 1.1.2 to 1.1.0 in readme.txt Kerbal folder....

but it still doesn't let me. 

 

Edited by gobolinno

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.