Jump to content

[1.8-1.9] Modular Fuel Tanks v5.13.1


Recommended Posts

The previous Modular Fuel System has split into Modular Fuel Tanks (taken care of by myself) and Real Fuels (taken care of by NathanKell).

Modular Fuel Tanks allows any supported tank to be filled with exactly how much or how little fuel you want, of whatever type you want (though different tanks may allow or disallow certain fuels; jet fuel tanks won't take oxidizer for instance).

Download: MFT v5.13.1

Source: github repository

Note: Module Manager is required.

From the top of the readme:

***Modular Fuel Tanks***

by taniwha, based on work by NathanKell, Swamp Ig, and ChestBurster for Modular Fuel Systems Continued.

ialdabaoth (who is awesome) created Modular Fuels, and we're maintaining it in his absence.

License remains CC-BY-SA as modified by ialdabaoth.

See the following post for recent changes.

Edited by taniwha
Link to comment
Share on other sites


  • Update for KSP 1.8-1.9


  • Update for KSP 1.8 (@arthurp I presume (Arthur Peters on github))


  • Add 5m (Making History) and 3.75m nose cones
  • Fix missing v2 of the 2.5m cone (and correct its volume)


  • Update for KSP 1.7
  • Add TVR adapters (bin/quad/tri)
  • Add ADTP-2-3
  • Add FL-A10 and FL-A5 adapters
  • Unmanaged resource support (starwaster)


  • Fix loading craft/vessels. Good grief.


  • Update for KSP 1.6
  • Resource manipulation doesn't spam the log or mess up up stock delta-v calculations (not confirmed that it actually did, though).
  • Cloning a tank part clones the current tank configuration, as expected.


  • Really update for KSP 1.5.
  • Fix "part already contains resource" log spam.
  • Probably fix incorrect delta-v readouts for vessels with edited tanks.


  • Update for KSP 1.5 (should be ok for 1.4 still)


  • Update for KSP 1.4.[0-1]
  • Tweak tank patches to reflect new capacities.
  • Add patches for Making History.


  • Fix NRE when looking for the module filter (again :/)
  • Add a function filter.
  • Update for KSP 1.3.1


  • Fix broken PAW when cloning a modified tank. Many thanks to Flow for the report and detailed reproduction steps.
  • Fix NRE when looking for the module filter.


  • Update for KSP 1.3
  • Avoid a PAW NRE when loading in the flight scene.
  • Avoid NRE when whether pumps should be available.
  • Fix the resource mix buttons not showing when a ship is first loaded.


Older versions:



  • Update for KSP 1.2.2


  • Update for KSP 1.2.1
  • Add configs for the tanks (including the tank-bearing engines) in porkjet's parts overhall.


  • Fix an NRE when updating fuel tanks while loading.


  • Update for KSP 1.2


  • Correct LiquidFuel percentage for ServiceModule.
  • Fix bogus in-flight dry-mass for tanks that change it (eg, ElectricCharge)
  • New, much more readable GUI style (jwvanderbec).
  • Utilization volume changes more correct (NathanKell)
  • Available volume < 1mL rounded to 0.


  • Fix MFT messing with staging (NathanKell)


  • Don't set a wrong massDelta when basemass == -1.(NathanKell)


  • Recompile against KSP 1.1.2


  • Fix for Kerbing going boom when going from VAB to pad.


  • Fix a bug causing button spam when tank parts have both resources and available volume.
  • Fix a problem with tank volume when using Procedural Parts.


  • Update for KSP 1.1
  • Lots of other stuff I don't feel like sorting through (some for RF, some affects both, just don't know)


  • Update for KSP 1.0.5
  • Regenerate Squad_modularFuelTanks.cfg



  • Fix Mk2 rocket fuel tank configs so they have oxidizer.
  • Fix inaccurate base masses for many tanks.
  • Remove the RCSHighEfficiency tank type (it is now worse than most tanks) leaving only the RCS tank type.



  • More detail in numeric rounding.
  • Better base mass and cost calculations.
  • Support any case for 'Full' for tank amount
  • Make action editor gui draggable
  • Maybe others (interpreting the logs is a bit tricky due to RF stuff being interleaved)



  • Fix xenon tank capacities.



  • Tank overrides should be fixed.
  • Module info formatting tweaks.
  • GUI speedups.
  • Configs for stock parts regenerated. Some structural parts that had tanks added in previous versions may have lost their tanks: if so, please report.
  • Duplicate SP+ configs removed.
  • Tweakscale support again.



  • Update for KSP 1.0.2


v5.5.0 (most changes by NathanKell):

  • Comply with IPartMassModifier.
  • Add TestFlight interop to MFT module.
  • add techRequired support for TANK, TANKDEF.
  • Tweak no-tech-for-resource layout.
  • Remove special case for pressurized, add GUI.
  • Don't die on duplicate TANKs.
  • Clamp utilization to 1%.
  • Unlock when GUI disappears.
  • Avoid crashing when no settings file is found.
  • Check for the overrides list being null.
  • Add IModuleInfo to the modular tanks. Also, replace the ? icon in the "filter by modules" part categorizer.
  • Update for KSP 1.0.



  • The "configure for connected engines" feature has been restored. Many apologies for both its disappearance and the delay in restoring it.



  • MFT now deletes only those resources that it manages. That is, if a resource is in any of the available tank types but not in the current one, it will be deleted. However, Resources that are not listed in any available tank type will not be deleted. This fixes the problem of pods' ElectricCharge and MonoPropellant being deleted when TAC-LS is installed.



  • Actually works this time. (new feature?)
  • The disappearing right-click menus have been fixed.
  • Tank type switching now works as intended: any resources not in the new type are removed automatically, and any resources with non-zero capacity in the new type are automatically added.



  • Major refactor of the code. There may be warts.
  • LiquidFuel and Oxidizer are no longer bogusly added to tanks that support multiple types and the current type has neither LF nor O.
  • Support most of the SP+/SPP tanks that are now stock.



  • Tank cost correctsions.
  • Default base cost is now 0.
  • Cost is shown in the MFT UI.
  • Unit lable now makes sense outside of RF (u instead of L).
  • Update for KSP 0.90.



  • Build and install Tweak Scale interaction dll.



  • Fix tweakscale resource doubling <NathanKell>
  • Stop GUI click-through. <NathanKell>
  • Make engine propellant ratios whole numbers. <taniwha>


v5.2.1: what do I do with this brown paper bag?

  • Fixed for TweakScale (NathanKell)
  • Compiled against the right version of KAE. (me, oops).


v5.2.0: KSP 0.25.

  • Refuel pump defaults to off.
  • TweakScale support.
  • Support RCS autofill, increase precision.
  • Move autofill buttons above tanks.
  • Update pump to respect FLOW and PUMP.
  • Procedural Cost.
  • B9 configs removed (now in B9).
  • Make refueling pumps respect resource costs. Is that a fuel pump, or a funds pump?
  • Fix OnLoad so it fires during MM database reload.
  • Disable the refueling pump if not at KSC.
  • Update for KSP 0.25.
  • Support for 64-bit Windows dropped: it is too unstable (even Squad has problems with it).


v5.1.1: KSP 0.24.2 and KAE 1.7.0 update

  • Compile against KAE 1.7.0
  • Update to 0.24.2
  • Allow local override of volume utilization


v5.1.0a: brown paper bag (again :/)

  • Recompile and zip with the correct version of KAE.


v5.1.0: KSP 0.24 update.

  • Made refueling pump toggleable (NathanKell)
  • Revert to displaying full-length volume for tanks (NathanKell)
  • Possibly fixed NRE in tank.maxAmount.set (NathanKell)
  • Update for KSP 0.24 (NathanKell)


v5.0.3: brown paper bag release (me)

  • Fixed a case&paste error causing a potential class name clash with EL.


v5.0.2: bugfix (mostly) release (Swamp Ig and NathanKell)

  • Engine Ignitor fixes.
  • Fixed issue with default tank discrepancy.
  • Fixed issue with cloning.
  • Fixed issue with phantom tanks appearing in flight.
  • Fixed issue with tank+engine combo parts


v5.0.1: bugfix release

  • Resources not managed by MFT are not automatically deleted (note that switching tank types may delete them anyway: UAYOR)
  • Setting tank amount fixed.
  • Display dry mass when basemass is ignored.


v5.0 (no particular order, much work by ialdabaoth, swamp-ig, and NathanKell)

  • Bugfixes
  • Major refactor
  • Ability to switch tank types.
  • Add Tiron's S2 6m body config.
  • Add hook for MM
  • Add tank volume conversion - required for MFT.
  • Add tweakable GUI
  • Utilization optionally tweakable
  • Update Size2LFB to have basemass = -1
  • Fixed loading from prefilled tanks
  • Fixed symmetry issue
  • Improve launch clamp refueling: does all parts.
  • Improvements for PP SRBs
  • Message passing for EPL
  • More ReSharper code cleanup
  • Removed a bunch of spurious log messages
  • Symmetry handling, Utilization



  • RealFuels dependent parts and configs removed (this includes the thermal fin). (taniwha)
  • New NASA LFO tanks added (taniwha)
  • Stretchy Tanks/Procedural Parts fixes (nathan)
  • Optimizations (ferram4)
  • Save tank info using doubles (nathan)
  • Version Checker. (nathah)
  • Other stuff I'm not sure of.



  • EI support (nathan)
  • Problem with MFT tanks on root parts fixed. (taniwha)
  • X%, full support for amount in config files, as for maxAmount (nathan)
  • Tanks for non-existent resources will no longer be presented. (taniwha)
  • Fixed KSPX Xenon tank. (nathan)



  • Allow tank amounts to be set to 0. This fixes the problem with non-fillable tanks (eg, Kethane).
  • Blank fields no longer reset to the previous amount and are treated as 0 when updating.
  • Overfull tanks now display the available volume in red.
  • Tanks placed using symmetry no longer invite the kraken (no more ship flying apart but still connected via fuel-lines)
  • Source code removed from the distribution zip.



Edited by taniwha
Link to comment
Share on other sites

I don't know whether this is a new version or basically the pre-release from the original thread. Just checked on another flight to the Mün and the Problem I described here is still the same. It is definately - as another user mentioned - connected to quicksave and quickload. I went for a flight to the Mün and had to quickload as the landing was somewhat dreadful. After the quickload to the place where I had just entered Müns SOI things went ballistic again.

If you need further info let me know.

Link to comment
Share on other sites

evilphish: did any of your tanks run dry? I have had trouble with MFS tanks running dry back in the 0.20.2 days because the tank's mass became 0 and everything went quite weird. There might be a mis-configured tank or a mass related bug.

Another thought: just when is everything going weird for you? Switching ships? Coming out of warp? ...

Link to comment
Share on other sites

Quick question Taniwha, where exactly is mass per volume calculated? In the dll or the modulartanks config? I only ask as I just tried adding Argon from Interstellar to the modular tanks config but ran into a slight mass problem. 6000 units of Argon weighing in at over 40 tons (the equivalent Xenon mass being less than a ton, even Interstellar's 2.5 meter Argon container @ 1080 units of Argon was less than 6 tons). I essentially copied over Xenon to a new tank config and changed its utilization to be fractionally proportional to Real Fuels (i.e. Xenon stored at 150 PSI via utilization and argon @ 200 PSI) which gave me a utilization value of 74.666 repeating (rounded to 74.667) compared to 56 with Xenon. Is it even something that MFT handles or am I barking up the wrong tree and I need to tweak the hell out of Interstellar's fuel density to get the mass correct?

Link to comment
Share on other sites

taniwha: No, all tanks on board the craft in question are still almost full. Problem is easily reproducible for me by:

- launching anything into orbit around kerbin

- plotting a course for a Mün encounter

- timewarp to just after entering Müns SOI

- quicksave

- quickload

-> things go ballistic

If I do not quickload after launch everything is fine.

Also, leaving to the space center and going back to the craft has the same effect as quicksaving / loading. Maybe something is messed up during the save/load of the craft?

Link to comment
Share on other sites

XenonGas has a utilization >1 in MFT because the same size tank that holds 12.5 units of LF or Oxidizer (Oscar-B) holds 700(!) units of Xenon. If Interstellar's argon tanks have similar volume to stock LF/Ox tanks, you shouldn't change utilization at all for argon, leave it at 1.

(This has nothing to do with RF's utilization figures; MFT was split off in part precisely so that it wouldn't deal with anything real-world, just KSP's wonky unit values which have little to do with the real world...)

Density is kept in the RESOURCE_DEFINITION for each resource, btw; Squad/Resources/ResourcesGeneric.cfg for Squad resources, a resource file in KSPI for argon.

Link to comment
Share on other sites

Thanks for the quick reply Nathan, I was basically trying to get Argon to behave somewhat like Xenon in that it's a pressurized gas (near as I can tell even in the stock game) and KSPI is treating its consumption as such (i.e. massive resource consumption rates for little to no DV) without chewing into Real Fuel's interpretation of LFO for NTR usage (Damn you Hydrolox and your low low fuel density interfering with my compact probe lander designs! lol). No biggie either way, as I always end up gravitating toward Real Fuel types anyhow. In the same vein, I want to thank all you folks for putting in the effort to make such an addictively fun game even more addictively fun.

Link to comment
Share on other sites

Shad0wCatcher: KSPI lists Argon's density as the same as LiquidFuel, so I think having utilization = 1 is probably correct. If you do go down the RF rabbit hole, you may be pleasantly surprised by Liquid Methane's performance: high Isp and nearly as dense as LOx.

You're most welcome! :)

Link to comment
Share on other sites

Yea I'm deep enough that I can't even see the light anymore; already had my space-helmet lamp ignited. I think I found my new love though; Ammonia or Water; I'm on the fence and can't decide which I prefer more. I need to post a possible error in the RF thread though with regards to naming conventions though. Back on topic here though thanks again for all the hard work taniwha, MFT works flawlessly on my very heavily modded install.

Link to comment
Share on other sites

I don't know whether this is a new version or basically the pre-release from the original thread. Just checked on another flight to the Mün and the Problem I described here is still the same. It is definately - as another user mentioned - connected to quicksave and quickload. I went for a flight to the Mün and had to quickload as the landing was somewhat dreadful. After the quickload to the place where I had just entered Müns SOI things went ballistic again.

If you need further info let me know.

If you create a new rocket from scratch (no using existing flights - no using existing craft files) can you still repro the problem?

I really think that needs to be established.

Link to comment
Share on other sites

If you create a new rocket from scratch (no using existing flights - no using existing craft files) can you still repro the problem?

I really think that needs to be established.

That's what I did yesterday. Designed a completely new Münar lander + lift stage and the same thing happened.

Link to comment
Share on other sites

Craft file in here http://phishtank.de/~evilphish/mftest.zip

It is just a basic lander. Shouldn't require more than KW Rocketry. I think I have an antenna and a Mechjeb / Engineer module on it. If that poses a problem I can strip it down for you. Kind of in a hurry as new years celebrations are in order. If it doesn't work give me a shout and I will cook something up.

Edited by evilphish
Link to comment
Share on other sites

Just reporting in that I have a similar issue as evilphish, and with a similar mod setup - though I'm not using MJ2 because I'm using FAR and DR. I had the issue in orbits of Mun and Minmus - and on Minmus it got really bad. There the problem actually included a fuel tank (a stock one) going in an opposite direction from the rest of the ship at speeds high enough for G forces (center of mass seems to be maintained, so the capsule is also moving) to kill the crew. To add more hilarity, there were fuel tanks connected to that tank. Unfortunately I don't have that ship anymore.

Currently I don't have anything on Minmus orbit, and trying to inspect my space station around Mun doesn't reveal much (it's a bit tricky, b/c it moves away from the camera focus rather quickly).

I also get a significant amount of "partmodule is null" in my log file. Can try to extract some details on request.

Link to comment
Share on other sites

I've also had this happen immediately after crossing kerbin-mun SOI. The only new mods I had installed were this, stretchy tanks and Tals spherical tanks. It happened immediately after right clicking on the stretchy service module after crossing the Mun's SOI. The ship zoomed off into the distance leaving a lovely yellow line behind. Also the values in two symmetrically attached service tanks seem to have changed, I noticed on the resource panel that my total electricity had dropped and mono had been added upon loading the savegame, hence the right click to check. The directly attached service tank is fine though.

Other mods installed are:

MJ2, Toolbar, Achievements, 6S Compartment Tubes, Crew Manifest, Enh Navball, EPL, FAR, KAS, Procedural fairings/wings,

KJR, Kethane, MSI, Docking port alignment, nothke's DROMOMAN, RT2, Scoopomatic, StationScience,

Targetron, TAC Fuel Balancer, Treeloader, Alternate Resource, Vanguard Parachutes some AEIS parts, and Interstellar.

Quite a list I know but if you do want a save file to look at I can produce one with a craft in orbit just after SOI change.


Javascript is disabled. View full album
Edited by Roberius
Link to comment
Share on other sites

Donziboy2: you are getting a lot of exceptions (Null, Key). I highly suspect MFT is not at fault here, even if nothing bad appears to happen when MFT is not installed. I just tested with just FAR+MFT and had no glitches. No exceptions, either.

There is another log file (Player.log in linux) that gives the locations of the exceptions.

So, until proven otherwise (no other mods (other than FAR as I've just cleared it), or exceptions occurring in MFT's code), I declare breaking ships to be not my problem.

Roberius: that does look like an MFT problem, because even with stretchy-tanks, electric charge should not turn into monoprop. However, you'll need to trim out most of the other mods as there's no way I'm going to install them all. Also, I'll need before SoI change rather than after, because that is too late to watch anything occur.

In the meantime, I'll try an SoI change with a minimal ship with LFO+Elec in the tanks.

[edit]Nope, still no problems. Here is my test craft. Yes, it gets into orbit, and even a Mun FRT, but you have to do a very good gravity turn. My orbit was 109x15 and I was still at 31km.

Edited by taniwha
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...