Search the Community

Showing results for tags 'remove'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • General
    • Announcements
    • The Daily Kerbal
  • Kerbal Space Program 2
    • KSP 2 Discussion
  • General KSP
    • KSP Discussion
    • Suggestions & Development Discussion
    • Challenges & Mission ideas
    • The Spacecraft Exchange
    • KSP Fan Works
  • Gameplay and Technical Support
    • Gameplay Questions and Tutorials
    • Technical Support (PC, unmodded installs)
    • Technical Support (PC, modded installs)
    • Technical Support (PlayStation 4, XBox One)
  • Add-ons
    • Add-on Discussions
    • Add-on Releases
    • Add-on Development
  • Community
    • Welcome Aboard
    • Science & Spaceflight
    • Kerbal Network
    • The Lounge
  • Making History Expansion
    • Making History Missions
    • Making History Discussion
    • Making History Support
  • Breaking Ground Expansion
    • Breaking Ground Discussion
    • Breaking Ground Support
  • International
    • International
  • KerbalEDU Forums
    • KerbalEDU
    • KerbalEDU Website

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


Website URL


Skype


Twitter


Location


Interests

Found 5 results

  1. KSPPartRemover v1.0 Removes parts from Kerbal Space Program crafts So I needed to remove about 750+ ladders from my orbital space station in order to perform my docking maneuvers with more than 5FPS After Whack-A-Kerbal-ing for over an hour and lots of backup-restore, I decided a dedicated application could do the job more efficiently. Links: Brief documentation and source-code: https://github.com/ChrisDeadman/KSPPartRemover Latest release: https://github.com/ChrisDeadman/KSPPartRemover/releases/download/v1.0/KSPPartRemover.v1.0.zip Example usage: Enjoy LICENSE: The MIT License (MIT) Copyright (c) 2016 ChrisDeadman Permission is hereby granted, free of charge, to any person obtaining a copy of this software and associated documentation files (the "Software"), to deal in the Software without restriction, including without limitation the rights to use, copy, modify, merge, publish, distribute, sublicense, and/or sell copies of the Software, and to permit persons to whom the Software is furnished to do so, subject to the following conditions: The above copyright notice and this permission notice shall be included in all copies or substantial portions of the Software. THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
  2. Ok. So I updated KSP and cleared my mods out to work out what was compatible and what was not ( add them one at a time ) My important ones were: Kerbal Engineer Redux X Science Docking Port Alignment Indicator Precise Node I thought I would add the mods one by one to see what works and what doesn't Loaded my sandbox game with no mods at all and instead of refusing to load because mods were missing it loaded the game and removed any ship with a missing part! So Now I have 3 missions that I was doing in Sandbox completely gone. I didn't have any quick saves .. just the main persistent one. And now my ships are gone! Is there a backup save directory?
  3. In my mod GTI MultiMode Intakes, I am allowing switching between different intake modes. When doing this, I'm also changing the resources associated with the intake, like intakeair or intakeatm. However, so far, I've relied on "part.Resources.Clear();". This removes all resources in the part, and then I can add the new resource I want back in. However, this have one mayor drawback, it removes all resources, and not just the ones I want it to, namely the ones I target. So in my latest try, I used the below methods to target only relevant resources. However, I cannot seem to get them to work. public bool Remove(PartResource res); public bool Remove(string resName); public bool Remove(int resID); I tried as follows (i merged the three overload methods directly into the example below, I do NOT run them at the same time, I comment out when testing). Debug messages says that I do indeed run the "Remove()" method where expected and on the expected resource. The remove methods return true!!! But my engine continues to consume IntakeAir even when switched away, so that the resource should have been removed. When I use "Clear()" the engine flameout immediately as it should. And listing all resources in the part after all show that the resource was not removed. bool preserveResource; PartResource partResourceDef; //Evaluated all resources in part for (int i = 0; i < currentPart.Resources.Count; i++) { preserveResource = true; GTIDebug.Log("Check for resource removal: " + currentPart.Resources[i].resourceName, iDebugLevel.DebugInfo); //compare all resources to the target resources for (int j = 0; j < modes.Count; j++) { //If it is a target resource, mark it for replacement if (modes[j].resourceName == currentPart.Resources[i].resourceName) { //Remove resources managed by this mod preserveResource = false; break; } } //Remove resource if it is marked for replacement if (!preserveResource) { GTIDebug.Log("Removing Resource: " + currentPart.Resources[i].resourceName, iDebugLevel.DebugInfo); //try 1 currentPart.Resources.Remove(currentPart.Resources[i].resourceName) //try 2 currentPart.Resources.Remove(PartResourceLibrary.Instance.GetDefinition(currentPart.Resources[i].resourceName).id) //try 3 partResourceDef = currentPart.Resources.Get(currentPart.Resources[i].resourceName); currentPart.Resources.Remove(partResourceDef) } } So my questions are, does Remove() work at all? if yes, then can anybody point me toward what could be wrong in my code?
  4. In KSP when trying to make engine clusters, sometimes you have to use the move gizmo to get them right. However, sometimes you can't move it all the way out otherwise the annoying top of the engine pokes out. What I'm suggesting is there to be a left click option on engines to remove this piece. (If even possible) This is what i'm taking about. Thanks -Banana
  5. Removed because Sigma88 already made the exact mod i had envisioned.