Nazari1382

[1.1.3] KSO (Kerbin Shuttle Orbiter) Legacy Packs & Development Updates

Recommended Posts

Ok, I must have put it together wrong.  I tried one of the .crafts you made for the beta tests way back, and it worked.  It flew like a drunk, but it made orbit.

Share this post


Link to post
Share on other sites
16 minutes ago, smotheredrun said:

Can you also send me what you have for your patches?  I want to take a look again at whatever your most recent changes are.

OK, I'll PM you a DB link tomorrow evening. I just realized that I don't have my recent changes for the SSME's and boosters cataloged and online.

16 minutes ago, smotheredrun said:

What I'm thinking is that I'll load the comm patches into 1.4.x and try them out this weekend.

They should work the same, I've haven't seen any issues with part mods and MM patches in the short time I've messed around with it. I won't do any serious playing until 1.4.3 drops and some of the more annoying bugs are squashed.

Share this post


Link to post
Share on other sites

ok so, when I install this mod (KSO) and the other ones that it needs, when I'm in game and I launch it there is no smoke and no plume/fire coming out the engines

if anyone knows what would be wrong and how to fix it,  it would be highly appreciated.

Thanks in advance.

Edited by Director Kerman

Share this post


Link to post
Share on other sites
14 hours ago, Director Kerman said:

ok so, when I install this mod (KSO) and the other ones that it needs, when I'm in game and I launch it there is no smoke and no plume/fire coming out the engines

if anyone knows what would be wrong and how to fix it,  it would be highly appreciated.

Thanks in advance.

Which shuttle are you using? 

Share this post


Link to post
Share on other sites
On 4/22/2018 at 8:11 AM, Director Kerman said:

ok so, when I install this mod (KSO) and the other ones that it needs, when I'm in game and I launch it there is no smoke and no plume/fire coming out the engines

if anyone knows what would be wrong and how to fix it,  it would be highly appreciated.

Thanks in advance.

And what game version?

Share this post


Link to post
Share on other sites
2 hours ago, Director Kerman said:

1.4.3 + expansion

That explains it.  1.4.x changed all kinds of stuff with smoke/plume effects.  They won't work for now.

If you're going to use them in 1.4.x you'll need to head over to the smokescreen thread and see what's new over there. 

There are a couple of us working on it, but speaking for myself, my time is very limited right now.

 

So to be clear, there is no official or unofficial support for the shuttles in 1.4..... yet.....

Edited by smotheredrun

Share this post


Link to post
Share on other sites
13 hours ago, smotheredrun said:

That explains it.  1.4.x changed all kinds of stuff with smoke/plume effects.  They won't work for now.

If you're going to use them in 1.4.x you'll need to head over to the smokescreen thread and see what's new over there. 

There are a couple of us working on it, but speaking for myself, my time is very limited right now.

 

So to be clear, there is no official or unofficial support for the shuttles in 1.4..... yet.....

thank you so much 

Share this post


Link to post
Share on other sites
14 hours ago, smotheredrun said:

That explains it.  1.4.x changed all kinds of stuff with smoke/plume effects.  They won't work for now.

If you're going to use them in 1.4.x you'll need to head over to the smokescreen thread and see what's new over there. 

There are a couple of us working on it, but speaking for myself, my time is very limited right now.

 

So to be clear, there is no official or unofficial support for the shuttles in 1.4..... yet.....

and do you know where I would put the KSO CONFIGS  files at.

 

Share this post


Link to post
Share on other sites

The fix for the plumes and exhaust fx are on this page. 

Change MODEL_MULTI_PARTICLE_PERSIST into MODEL_MULTI_SHURIKEN_PERSIST  is from Sarbian

8 hours ago, Director Kerman said:

and do you know where I would put the KSO CONFIGS  files at.

 

GameData/KSO/Parts/

Edited by shdwlrd

Share this post


Link to post
Share on other sites
23 hours ago, shdwlrd said:

The fix for the plumes and exhaust fx are on this page. 

Change MODEL_MULTI_PARTICLE_PERSIST into MODEL_MULTI_SHURIKEN_PERSIST  is from Sarbian

GameData/KSO/Parts/

thank you so much:)

Share this post


Link to post
Share on other sites
On ‎4‎/‎29‎/‎2018 at 7:13 PM, shdwlrd said:

The fix for the plumes and exhaust fx are on this page. 

Change MODEL_MULTI_PARTICLE_PERSIST into MODEL_MULTI_SHURIKEN_PERSIST  is from Sarbian

GameData/KSO/Parts/

and this is hopefully my last question lol.  where do I find MODEL_MULTI_PARTICLE_PERSIST cause I cant find it anywhere

Share this post


Link to post
Share on other sites
15 hours ago, Director Kerman said:

and this is hopefully my last question lol.  where do I find MODEL_MULTI_PARTICLE_PERSIST cause I cant find it anywhere

Since none of the patches touch the engine files, you'll have to edit the .cfg files directly. The files you are looking for are; omskso.cfg, thrustmaxkso.cfg, boosterkso.cfg, super25boosterkso.cfg, and super25enginekso.cfg. You can edit them with any text editor. But if you have something that can do search and replace, it makes it a lot quicker and easier. 

Share this post


Link to post
Share on other sites

Does anyone have a copy of the blank (nameless) Super 25 texture? I want to remake my old fleet of shuttles. :)

Thank you very much to all of you lovely people helping keep this thing alive. It is still one of the most beautiful mods for KSP, even after all this time.

Share this post


Link to post
Share on other sites
19 minutes ago, CommanderSmith said:

Does anyone have a copy of the blank (nameless) Super 25 texture? I want to remake my old fleet of shuttles. :)

Thank you very much to all of you lovely people helping keep this thing alive. It is still one of the most beautiful mods for KSP, even after all this time.

Here you go, I think this is the original file:

https://www.dropbox.com/s/1tzjj5vmpcoo65c/KSO_25Blank.tga?dl=0

I made a .PSD paintkit for it too, I would post it but I'm not sure that it would be allowed under the license.

Share this post


Link to post
Share on other sites
4 hours ago, Capt. Hunt said:

Here you go, I think this is the original file:

https://www.dropbox.com/s/1tzjj5vmpcoo65c/KSO_25Blank.tga?dl=0

I made a .PSD paintkit for it too, I would post it but I'm not sure that it would be allowed under the license.

Thank you for your help. I'm terribly sorry to be a pain, but it appears as though that's the file for the Reliant. If you can't find the blank file, don't worry about it. I'll have another search of my old files tomorrow and see if I can stumble across it. :)

Share this post


Link to post
Share on other sites

That's odd, I don't see any names on that texture.

 

Edited by Capt. Hunt

Share this post


Link to post
Share on other sites

Okay, that was weird. Turns out that the name "Reliant" appears when I open the file in GIMP, but not when I actually use the texture in-game. How interesting.

Anyway, thank you so much for your help, @Capt. Hunt. I can now have my old fleet of shuttles back ready to fly again. :)

Edited by CommanderSmith

Share this post


Link to post
Share on other sites

ok, I figured out what's going on, the alpha channel still has Reliant on it.  Somehow Gimp is showing that part of the texture.

Share this post


Link to post
Share on other sites
16 minutes ago, smotheredrun said:

@Capt. Hunt or @CommanderSmith,  do you know of a good "easy" way to turn *.tga into *.dds?  The texture threads in these forums are a bit too far over my head

DDS4KSP works
Get it here: (you dont need to grab the DDS Loader component any longer)
 

 

Share this post


Link to post
Share on other sites
5 hours ago, Stone Blue said:

DDS4KSP works
Get it here: (you dont need to grab the DDS Loader component any longer)
 

 

Thanks!  I'll give it a whirl

Share this post


Link to post
Share on other sites
On 6/18/2018 at 1:29 PM, Woodstar said:

Dead mod?

As in actively being developed and updated, yes it's dead. There are some users that are doing what they can without violating the licensing to keep the mod relevant and usable with the current versions of KSP.

Share this post


Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.