• 0
Palaceviking

How to change comms network settings

Question

Hi

I've transferred a save through several versions and now onto 1.2 pre release..

However as it is set to normal difficulty the whole comms network setup thingy isn't enabled in anyway, is there a way i can edit my save so that I have:

1:no other groundstation except ksc.

2:no control over probes out of range.

And any other general comms challenges cos my space program is quite well developed and ready for a 1.2 modfest, but if I can't do this I'll probably start again cos the comms thing is the biggest 1.2 feature for me by far.

Thanks in advance,

fly like a lunatic - land safe ;-) 

 

Share this post


Link to post
Share on other sites

4 answers to this question

Recommended Posts

  • 0

You're looking in your persistent.sfs file for this (this is the defaults, yours may be different)

		DIFFICULTY
		{
			AutoHireCrews = False
			MissingCrewsRespawn = True
			RespawnTimer = 7200
			BypassEntryPurchaseAfterResearch = False
			AllowStockVessels = False
			IndestructibleFacilities = False
			ResourceAbundance = 1
			ReentryHeatScale = 1
			EnableCommNet = True
		}
...
		CommNetParams
		{
			requireSignalForControl = False
			plasmaBlackout = False
			rangeModifier = 1
			DSNModifier = 1
			occlusionMultiplierVac = 0.9
			occlusionMultiplierAtm = 0.75
			enableGroundStations = True
		}

Both of those are near the very top of your save. I only included the DIFFICULTY one for it's last entry.

EDIT: It's probably obvious, but just for completeness you want "requireSignalForControl" to be True and "enableGroundStations" to be False.

Edited by 5thHorseman

Share this post


Link to post
Share on other sites
  • 0
3 hours ago, 5thHorseman said:

You're looking in your persistent.sfs file for this (this is the defaults, yours may be different)


		DIFFICULTY
		{
			AutoHireCrews = False
			MissingCrewsRespawn = True
			RespawnTimer = 7200
			BypassEntryPurchaseAfterResearch = False
			AllowStockVessels = False
			IndestructibleFacilities = False
			ResourceAbundance = 1
			ReentryHeatScale = 1
			EnableCommNet = True
		}
...
		CommNetParams
		{
			requireSignalForControl = False
			plasmaBlackout = False
			rangeModifier = 1
			DSNModifier = 1
			occlusionMultiplierVac = 0.9
			occlusionMultiplierAtm = 0.75
			enableGroundStations = True
		}

Both of those are near the very top of your save. I only included the DIFFICULTY one for it's last entry.

EDIT: It's probably obvious, but just for completeness you want "requireSignalForControl" to be True and "enableGroundStations" to be False.

Thank you, that was fast, just found out how much of my stuff is without control!  Truly kerbaled, gonna enjoy this:)

How do you rep here? 

Share this post


Link to post
Share on other sites
  • 0
1 hour ago, Palaceviking said:

How do you rep here? 

You already did, by "like"ing the post :)

Share this post


Link to post
Share on other sites
  • 0

Many commnet options are also available via the difficulty settings, accessible from the in-game mini menu for existing saves.

Just open the pause menu, click Settings, Difficulty Options, then Enable comm network.

On the Advanced page on that screen you can toggle the extra ground stations and the signal requirement.

This avoids having to edit the sfs directly.

Hope this helps.

Share this post


Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.