RoverDude

[1.7.x] - Modular Kolonization System (MKS)

Recommended Posts

1 minute ago, Rehpic said:

Is anyone having problems with the new update not showing up in CKAN?

 

Give it a few hours.  Or a day or two.  CKAN isn't always immediate, and may require some manual work in this case, since Ground Construction has been reconfigured.

Share this post


Link to post
Share on other sites
5 hours ago, gamerscircle said:

As I was streaming tonight, it would seem that there is a heat absorption issue?  Having enough heat control, the reactor and drills shut down, as they can't [the cooling ] seem to keep up with the the heat rising vs cooling.

What do you need from me to help look into this?

I am using the new Automated Drills x 4 , the 1.25 Reactor, using a Ranger Thermal and Thermal Panels Medium X2

I think this may be an issue with the new max cooling numbers claiming all of the available radiator capability, leaving some parts without any radiator access(even if the radiators are only actually cooling a small amount)

I saw this on an automated base I had previously set up.  Before, my 2 large radiators were plenty to run four medium pulse drills, two ore drills, ISRU, and a 2.5M nuclear reactor, now my ore drills shut down because they overheat.  The radiators only show 8% usage, but I suspect that only relates to cooling from ambient heat not active cooling of drills and such.

Edited by Terwin

Share this post


Link to post
Share on other sites
On 23-2-2017 at 7:10 PM, voicey99 said:

Assuming you know where your Kerbal Space Program folder is (if you installed MKS through CKAN and didn't have to find your KSP folder it to install it, CKAN will open if for you under the "file" tab in the top right), there should be a file inside that called "saves". Inside that folder should be files for all your savegames-look for the relevant one and open in. Inside that folder should be the file "persistent.sfs"-open that with notepad. Use control-F to bring up the search box, and now search for "grouchy" and click "next" with the typing cursor at the top of the page-this will bring you to a list of your kerbals (inc. applicants, KIA/MIA kerbs and those from non-accepted tourism and rescue contracts) and their lifesupport status. Now find Bill (name = Bill Kerman) and change the field "OldTrait" from "Tourist" to "Engineer". Now, go to almost the very bottom of the file and you will again find a list of all the kerbals, this time containing their core attributes. Find Bill again on this second list and change the "trait" field from "Tourist" to "Engineer". Bill should now be fixed after reloading the save (only the persistence mind you, if you want this to apply to quicksaves etc made before you fixed it then you will have to edit their .sfs files (in the same folder) in the same manner).

@voicey99 Thanks for the help. Glad to have bill back!

 

Share this post


Link to post
Share on other sites
12 hours ago, RoverDude said:
  • There are three new drills, one counterpart for each of the three existing MKS drills (with the added benefit of Ore drilling), optimized for remote operation.  They have been rebalanced to have the same mass, but will not have Kolony bonuses or specialty bonuses/penalties.
  • There are three new automated refineries suitable for unattended operations.  These come in 1.25, 2.5, and 3.75 form factors, and may also be used as efficiency parts for the larger MKS refinery.  Note that these only handle refining for Tier-1 materials (Ore->LF,Ox,MP, Metals, Chemicals, Polymers, and Fertilizer via Gypsum or Minerals).  One thing to note is that these modules feature redundant systems in the form of extra machinery and reduced machinery draw, resulting in significantly longer run-times without maintenance. 

Man, I just launched my 250K Gilly automated mining outpost. It's in a parking orbit so I'm going to have to either perform some major orbital surgery with KIS or just deorbit it and start again.

And @Wiseman That's been a bug for a while.

Edited by voicey99

Share this post


Link to post
Share on other sites

It looks like I have an issue with bases and Duna parts.  Whenever a base with Duna parts become active, the functions (reactors, purifiers, resource converters, etc.) are all turned off.  I can turn them back on and they seem to run in the background when other things are active, so it looks like it happens only when it's becomes active. Ranger and Tundra parts are not affected. Does anyone else have this issue?

Otherwise...all the nullrefs are gone, auto-maintenance is not hung, and the hab common multipliers are working again. Thanks.

Edited by Gilph
clarification

Share this post


Link to post
Share on other sites
4 minutes ago, Gilph said:

It looks like I have an issue with bases and Duna parts.  Whenever a base with Duna parts become active, the functions (reactors, purifiers, resource converters, etc.) are all turned off.

I had that problem several version ago with a Duna PDU. For some reason it fixed itself after I retracted the legs and then extended them again. Maybe it's worth a try. No idea why that would help, but it did for me.

Share this post


Link to post
Share on other sites
6 minutes ago, jd284 said:

I had that problem several version ago with a Duna PDU. For some reason it fixed itself after I retracted the legs and then extended them again. Maybe it's worth a try. No idea why that would help, but it did for me.

You are a genius...it worked.  Actually, the legs were retracted because I wanted to have it sit flat.  When I deployed all of the legs, it worked. Thanks very much.

Share this post


Link to post
Share on other sites
5 minutes ago, gowthamn said:

Why is this not available in CKAN suddenly for 1.2.2?

CKAN takes a while to update, give it a day or two. In the meantime, get it here and the new USITools to go with it here.

This same issue was raised earlier on this same page, maybe read or search the thread next time before double-posting?

Share this post


Link to post
Share on other sites
1 hour ago, jd284 said:

I had that problem several version ago with a Duna PDU. For some reason it fixed itself after I retracted the legs and then extended them again. Maybe it's worth a try. No idea why that would help, but it did for me.

Weird - can you log this to an issue with this note?

Share this post


Link to post
Share on other sites
7 hours ago, Terwin said:

I think this may be an issue with the new max cooling numbers claiming all of the available radiator capability, leaving some parts without any radiator access(even if the radiators are only actually cooling a small amount)

I saw this on an automated base I had previously set up.  Before, my 2 large radiators were plenty to run four medium pulse drills, two ore drills, ISRU, and a 2.5M nuclear reactor, now my ore drills shut down because they overheat.  The radiators only show 8% usage, but I suspect that only relates to cooling from ambient heat not active cooling of drills and such.

In my attempt to learn MKS, I came up with a basic drill setup:

2 Drills with all the correct power, etc.  and since I am not that good at this game, I rarely can land where I need to, so I attempt to assemble everything that I need into a rover system.

When I first got the Planetary Warehouse up and running on the Mun, I was using up chemical faster that would I can refine and mine them, so I changed from a 2 drill to a 4 drill just to cover the basics and If I had more, then I could package it up and ship it to Duna.  [long team goals]

With the new unmanned auto logistics drills, I decided to replace the mineral drill site with the following:

4X MEU-500-A which need 160ec a sec , [each drill is 40 ec a sec]
The Ranger Thermal ssytem needs 2.5ec a sec
Stock thermals radiators need 0.1ec a sec

Total ec needed 164 [rounded up]

The reactor I am using is the 1.25 [tall], this reactor outputs 230ec a sec

Unless I am missing something, that 1.25 reactor should be more than enough power..

The 1.25 reactor [tall] needs 400kw cooling
4X MEU-500-A needs 50kw cooling each [200 total]

The The Ranger Thermal provides 300 and the stock thermal [2x] panels are 250kw each that would be a total of 800

When it comes to ec a sec, I have a demand of 164 with a supply of 230
For the thermal, I have a demand of 600kw and have the ability to cool up to 800kw 

What happens.. is that the heating ramps up.. really really fast.. and the cooling can't keep pace..and end up shutting down the reactor. 

Hope this helps and makes some sense, as I not a professor of MKS or KSP. :)

Share this post


Link to post
Share on other sites
33 minutes ago, RoverDude said:

Weird - can you log this to an issue with this note?

I created #1175. Maybe @Gilph can add a savegame?

Share this post


Link to post
Share on other sites

@gamerscircle if you can provide a craft file I would be willing to test the rig and see why it's overheating.

Share this post


Link to post
Share on other sites
20 minutes ago, gamerscircle said:

<schnip>

Not sure how the heat pumps work with regards to placement or external temperature, so its contribution could vary from useful to inadequate. I've had a few problems with the 1.25m before, in that its temperature seems to very rapidly oscillate between ~800KK and ~1.3KK several times a second with output fluctuating accordingly (this is on a base with a large deployable TCS and only a few drills, so cooling isn't the limiting factor).

On a side note, if you're struggling with landing in the right spot, MJ and Trajectories both have landing prediction functions (MJ's gives you some landing site info and distance-to-target readout as well as higher precision, though it can be buggy sometimes).

Share this post


Link to post
Share on other sites
20 hours ago, ExavierMacbeth said:

Oh well will just spam some more inflatables lol. My base still looks pretty neat during the day. Took me almost 6 years to fully construct so far.

Quick question, To produce organics you need a seed crop. Is that just to start the process? Or if I burn through the organics down to zero by leaving the Colony Supply production on will it completely shut down organics production?

I didn't realize setting all 3 bays in the Assembly Plant didn't give me a button for each bay if they are all the same resource (I had nothing better to set on that module atm) so turning it on outstrips my current organics production massively lol

If you fill up the organics on your converter, and then hit the lock button next to the resource, other functions will not be able to take away that resource, allowing you to keep organic production at 100%

 

Same thing goes for machinery.  Keep them locked, and then the usage drain will pull from storage instead of from your converters.

Just make sure you have enough in storage to keep things going.

Share this post


Link to post
Share on other sites
1 hour ago, gamerscircle said:


4X MEU-500-A which need 160ec a sec , [each drill is 40 ec a sec]
The Ranger Thermal ssytem needs 2.5ec a sec
Stock thermals radiators need 0.1ec a sec

Total ec needed 164 [rounded up]

The reactor I am using is the 1.25 [tall], this reactor outputs 230ec a sec

Unless I am missing something, that 1.25 reactor should be more than enough power..

The 1.25 reactor [tall] needs 400kw cooling
4X MEU-500-A needs 50kw cooling each [200 total]

The The Ranger Thermal provides 300 and the stock thermal [2x] panels are 250kw each that would be a total of 800

When it comes to ec a sec, I have a demand of 164 with a supply of 230
For the thermal, I have a demand of 600kw and have the ability to cool up to 800kw 

What happens.. is that the heating ramps up.. really really fast.. and the cooling can't keep pace..and end up shutting down the reactor. 

Hope this helps and makes some sense, as I not a professor of MKS or KSP. :)

The stock thermal panels efficiency depend on their location on your craft.  They need to be attached to the part which needs cooling or its grandparent part.  Did you notice in RD's stream last night that he was very particular about where he put the stock thermal panels? The problem could simply be the stock panels or their placement.  For testing purposes, I would suggest removing the stock panels and placing 3 Ranger thermals on your miner and then test it on Kerbin.  If this works move down to two Ranger thermals to see if this works. Finally you can go down back to one Ranger thermal and experiment with the location of your stock thermal panels.  Doing this way will help you eliminate MKS as the culprit for your cooling problems.

The other possibility here is that the EC and Cooling requirements for the drills are for EACH separator.  I believe the 500 has 3. So that would actually be 120 ec per drill instead of 40 and 150kw cooling instead of 50kw.

Share this post


Link to post
Share on other sites
1 hour ago, jd284 said:

I created #1175. Maybe @Gilph can add a savegame?

Sure...will test an older save and post it shortly

59 minutes ago, Nergal8617 said:

@gamerscircle if you can provide a craft file I would be willing to test the rig and see why it's overheating.

same here

Share this post


Link to post
Share on other sites

Reported issue: https://github.com/BobPalmer/MKS/issues/1174

Looks like the 2.5 and 3.75 converters are currently making Chemicals when set to Fertilizer(G).  Looks like just a copy/paste error in the config.

Really liking the idea of the automated parts and looking forward to getting them deployed so I can test them out.

Not sure if it is worth sending out new base kits to Duna though, I'll probably try something faster to get to like Moho, not any bases there yet...

 

I also like how the inflatable workshop seems like the go-to part for building out your first base component.  I am hoping that the 300% workshop efficiency is not also a typo...

Question: does the level of Kolonists have any impact on colony rewards?  Anything else?

Edited by Terwin

Share this post


Link to post
Share on other sites
42 minutes ago, Gilph said:

Sure...will test an older save and post it shortly

same here

Thank you all, I did take of the stock thermal and replaced it with the MKS Ranger, here is link to the craft file:

https://drive.google.com/file/d/0B8bgPP0DpwZeNDZ6TWVpLVJxTk0/view?usp=sharing

I have uploaded an large [1gb] raw unedited video of the same craft on the Mun:

https://drive.google.com/file/d/0B8bgPP0DpwZeWktOd1MtbkpwQzA/view?usp=sharing

Edited by gamerscircle

Share this post


Link to post
Share on other sites
2 hours ago, RoverDude said:

Weird - can you log this to an issue with this note?

 

1 hour ago, jd284 said:

I created #1175. Maybe @Gilph can add a savegame?

Save file and steps updated in Github

Share this post


Link to post
Share on other sites
1 hour ago, gamerscircle said:

In my attempt to learn MKS, I came up with a basic drill setup:

2 Drills with all the correct power, etc.  and since I am not that good at this game, I rarely can land where I need to, so I attempt to assemble everything that I need into a rover system.

When I first got the Planetary Warehouse up and running on the Mun, I was using up chemical faster that would I can refine and mine them, so I changed from a 2 drill to a 4 drill just to cover the basics and If I had more, then I could package it up and ship it to Duna.  [long team goals]

With the new unmanned auto logistics drills, I decided to replace the mineral drill site with the following:

4X MEU-500-A which need 160ec a sec , [each drill is 40 ec a sec]
The Ranger Thermal ssytem needs 2.5ec a sec
Stock thermals radiators need 0.1ec a sec

Total ec needed 164 [rounded up]

The reactor I am using is the 1.25 [tall], this reactor outputs 230ec a sec

Unless I am missing something, that 1.25 reactor should be more than enough power..

The 1.25 reactor [tall] needs 400kw cooling
4X MEU-500-A needs 50kw cooling each [200 total]

The The Ranger Thermal provides 300 and the stock thermal [2x] panels are 250kw each that would be a total of 800

When it comes to ec a sec, I have a demand of 164 with a supply of 230
For the thermal, I have a demand of 600kw and have the ability to cool up to 800kw 

What happens.. is that the heating ramps up.. really really fast.. and the cooling can't keep pace..and end up shutting down the reactor. 

Hope this helps and makes some sense, as I not a professor of MKS or KSP. :)

Hi,

Specifically for the nukes, I am now using the large radiator surface panels attached directly to the nuke to good effect.  The are taller than the 1.25 and you may not like the looks, but I have never needed more than 2 on the 1.25 and 3 on the 2.5.  They dont stick out and interfere with anything.

Share this post


Link to post
Share on other sites
2 minutes ago, Gilph said:

Hi,

Specifically for the nukes, I am now using the large radiator surface panels attached directly to the nuke to good effect.  The are taller than the 1.25 and you may not like the looks, but I have never needed more than 2 on the 1.25 and 3 on the 2.5.  They dont stick out and interfere with anything.

Picture please?

Share this post


Link to post
Share on other sites
51 minutes ago, Tarheel1999 said:

The stock thermal panels efficiency depend on their location on your craft.  They need to be attached to the part which needs cooling or its grandparent part.  Did you notice in RD's stream last night that he was very particular about where he put the stock thermal panels? The problem could simply be the stock panels or their placement.  

I'm pretty sure that it varies by the type of radiator.  The fixed (unextendable) radiators are very location-sensitive and will only draw heat from "nearby" parts (whether that means the parent part + grandparent part, or is a range in meters, I'm not sure).  The extendable radiators, OTOH, will cool parts anywhere on the vessel.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.