Theysen

[1.7.3] Realism Overhaul v12.7.4 [23 November 2019]

Recommended Posts

Still getting negatives, but it seems to be only with very small tanks. The launchers I am using seem to be ok, at least.

 

MiUwclN.jpg

Share this post


Link to post
Share on other sites
1 hour ago, Gremillion said:

Still getting negatives, but it seems to be only with very small tanks. The launchers I am using seem to be ok, at least.

 

 

What about the normal MFT-A tank? Lander tank?

Share this post


Link to post
Share on other sites
11 minutes ago, Starwaster said:

What about the normal MFT-A tank? Lander tank?

This version of SSTU doesn't have the MFT-As, they're broken into I, II, etc types.

Here's an MFTIII showing negs:

FaDHzqD.jpg

Share this post


Link to post
Share on other sites

@Gremillion put the patch back in that I posted a few posts back: 

The problem is: that tank is a clone of the MFT-A and it's being cloned BEFORE SSTU patches any of the MFT parts

 

 

Share this post


Link to post
Share on other sites
1 minute ago, Starwaster said:

@Gremillion put the patch back in that I posted a few posts back: 

The problem is: that tank is a clone of the MFT-A and it's being cloned BEFORE SSTU patches any of the MFT parts

 

 

That patch is already there. It's in zzzTweaks. Should I move it to ___Tweaks so it loads first?

Share this post


Link to post
Share on other sites
4 minutes ago, Gremillion said:

That patch is already there. It's in zzzTweaks. Should I move it to ___Tweaks so it loads first?

No it has to run last or at least after all that cloning. (that's why I put :FINAL in there so it runs last no matter what)

Well crap then I have no idea. All I know is the SSTU RF compatibility patch runs in :FOR[SSTU] and the cloning of those parts happens in :FOR[RealismOverhaul] so the cloning takes precedence over the patching. SSTU ends up patching only its own parts. I'll see about getting someone to fix the timing of the RO patch or to do the patching oureselves

Share this post


Link to post
Share on other sites
1 minute ago, Starwaster said:

No it has to run last or at least after all that cloning. (that's why I put :FINAL in there so it runs last no matter what)

Well crap then I have no idea. All I know is the SSTU RF compatibility patch runs in :FOR[SSTU] and the cloning of those parts happens in :FOR[RealismOverhaul] so the cloning takes precedence over the patching. SSTU ends up patching only its own parts. I'll see about getting someone to fix the timing of the RO patch or to do the patching oureselves

 

For now, it works. I am not using tanks much smaller than 2.5m and they're positive at that size.

Also, I am contemplating the possibility that I just screwed up entirely during install. Tomorrow I may give it a go from fresh, see if that fixes anything.

Share this post


Link to post
Share on other sites

@Starwaster

I just tried this "patch" you posted for SSTU, and even tough it kinda fixes the negative mass issue for tanks, it doesn't fix the SSTU issue with pods losing added recources once you launch them. Right now the Orion capsules for instance do not contain TAC LS recources, you can add them in editor and all the numbers seem to check out, but once you launch you are left with the default recources. This is both in sandbox and career modes.

An issue was posted on github a few days back adressing this, and the answer was that it should work if you have the correct version of SSTU against which the RO configs were written.

Is there any way to see which version this was??? I scoured both the SSTU config files on github and in my game directory and simply cannot find any annotation or version number.

Would it be a good idea to have the mod version used added to the beginning of the config files to prevent version mismatch issues?

And is there ANY version of SSTU that creates usable capsules under the current RO version?

I'm using the 12.7.2 version of RO and the rp1 master branch.

Share this post


Link to post
Share on other sites

@RobK I’m not surprised that it didn’t fix any issues with parts losing resources. I don’t know what I might have said to make anyone think it would...

Share this post


Link to post
Share on other sites
Posted (edited)
16 hours ago, kraden said:

@Gremillion to what are you referring?

Multiple apoapses and stuff. Never seen those markers before. I have a better sense of what they mean now but it was weird. Is it a new feature?

Edited by Gremillion

Share this post


Link to post
Share on other sites

You have principia installed.  That adds n-body physics.  I'm guessing that is the cause.

Share this post


Link to post
Share on other sites

I'm fairly certain that is principia as well.  I have it installed on my RO install and I get the same thing.  If you open principia and change the reference frame to something else (ship I think) it'll look like you're used to.

Share this post


Link to post
Share on other sites
Posted (edited)

Hello guys! I am trying to get RSS/RO working on the last version of KSP, CKAN doesn't let me install the mods (incompatible) & no luck doing It mannualy. Does the mod is updated to date or I should get an older version of KSP?. (If that is the case, would you guys tell me which one do you recommend?) Thanks for reading!

 

Problem solved guys! I downloaded the 1.6.1 version and everything is working great

Edited by v44n

Share this post


Link to post
Share on other sites
On 8/24/2019 at 5:19 PM, AVaughan said:

You have principia installed.  That adds n-body physics.  I'm guessing that is the cause.

Huh. Prinicipia must have been broken before. Well, neat!

Share this post


Link to post
Share on other sites
7 hours ago, Gremillion said:

Huh. Prinicipia must have been broken before. Well, neat!

One easy way to check to see if it's working is to look at your apogee and perigee while on orbit.  If they are changing slightly without thrust, that's because pricipia is working and the moon, sun, Jupiter, etc are affecting your orbit.

Share this post


Link to post
Share on other sites

Is it just me or are all the parts scaled incorrectly? I tried creating an RO career save and all of the liquid engines are slightly wider than the fuel tanks and all claim to be 1 meter across regardless of how big they actually are.

Share this post


Link to post
Share on other sites
11 hours ago, Clockwork13 said:

Is it just me or are all the parts scaled incorrectly? I tried creating an RO career save and all of the liquid engines are slightly wider than the fuel tanks and all claim to be 1 meter across regardless of how big they actually are.

It's possible that the engines that use stock textures aren't resized correctly. As a solution I would recommend installing a mod called ROEngines which contains most of the engines you'll ever need. All the parts it has look almost identical to real life and their dimensions are also as accurate as possible.

Share this post


Link to post
Share on other sites
Posted (edited)

Real Fuels update. It should hit CKAN whenever it does indexing.

version 12.8.0

change log

  • Make MLI cost, mass and max layers configurable (in part config file)
  • Changed Show UI and Hide UI to Show Tank UI and Hide Tank UI (PAW text)
  • Unmanaged resources. ModuleFuelTanks can have UNMANAGED_RESOURCE node to declare a resource name, amount and maxAmount (same format as RESOURCE). Even if all tanks are removed, this unmanaged resource will always be present and all tank resource amounts are in addition to the unmanaged quantity.
  • tank type initializes with Default if no type is specified. (fixes edge case physics breaking bug)
  • GUI performance improvements by @yump
  • Fixed TANK_DEFINITION fallback system
  • Fixes and improvements for engine GUI and engine GUI symmetry handling
  • Fixed issue where selecting different MEC engine configurations would cause a tank PAW to fill with duplicate config buttons. by @todi
  • added new TANK_DEFINITION fields by @siimav
  • actually find a fallback MEC config instead of lying and saying we couldn't find one when we didn't look for one!
  • boiloff data available in PAW without spamming the log with debug data.
  • Stock Real Fuels now has MLI Tech Upgrades. Max layers will increase as you progress through fuel / construction nodes in career.
  • Certain procedural parts will correctly calculate tank surface area in editor. (by correct we mean it should match up with what you see in flight mode so costs and mass will be consistent). Does this for SSTU, Procedural Parts, B9 Procedural Wings and ROTanks
  • Boil-off of propellants will respect the infinite propellant cheat if it is turned on.
Edited by Starwaster

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.