Kobymaru

[1.3.1-1.7.2] Trajectories v2.2.3 (2019-06-17) : atmospheric predictions

Recommended Posts

21 hours ago, terminalmonky said:

I am having a similar issue to this guy.  I am running Trajectories 1.7.0 installed from CKAN on KSP 1.3 in a 64bit environment.  I will caveat that this is a highly modded playthrough, but I am unsure where to start looking for a conflict.  The trajectory line displays fine while warping and very briefly for less than a second when the display trajectory is toggled on.  

Here is the link to my log.  

https://drive.google.com/drive/folders/0B3tLMNmF1UxvQnFjNG1vNk5GajQ?usp=sharing

 

Thanks.

I see a wait line over the blue

As if no calc is done

If i turn tragectory off and on the wait line gets calcolyted corectly

Share this post


Link to post
Share on other sites

Getting bad flashing in Map view lately with this mod...

 

Not sure what's causing it.

 

Anyone else get this and find a remedy?

 

Really don't want to go without this mod!

Share this post


Link to post
Share on other sites

I get a crash sometimes in map view. I'm not entirely sure what causes it, because I cannot reliable trigger it. I suspect it may be related to the projected impact point crossing under the spacecraft in map view, but I'm not sure. It's an access violation, it is unrelated to memory usage.

Log: https://www.dropbox.com/s/qid50jqqc8q22c4/output_log.txt?dl=0
Dump: https://www.dropbox.com/s/ki7eibhkj0fhqvr/crash.dmp?dl=0
Screenshot: https://imgur.com/a/2jJyA

Edited by dlrk

Share this post


Link to post
Share on other sites
On 9/16/2017 at 8:50 AM, danielboro said:

I see a wait line over the blue

As if no calc is done

If i turn tragectory off and on the wait line gets calcolyted corectly

This is the behavior I am seeing as well.  Where in the code are you seeing the wait?  Forgive my ignorance.  Just learning this stuff.  Dug through the Github a little and could not find it.

 

 

Share this post


Link to post
Share on other sites

How does this work with spaceplanes?

Spaceplanes have drag based on the AoA. Basically it differs per orientation of AoA given a calculable trajectory. Can you make this mod calculate a trajectory based on the orientation of lifting surfaces? I can navigate spaceplanes manually. The very fact they can be used as controlled aerobraking negates the use of this mod. But when managing colonies repetition isn't as much fun so automation for spaceplanes using this or a similar mod is quite the luxury I would want.

So let's say it has the following option...

I want it to calculate trajectory based on all parts with a included digital input box where I could put the number "45" in and then the trajectory calculates based on that set orientation of AoA where I would land.

Rather then handling every vessel purely as a capsule.
Just a thought...
Reading all reactions it seems this mod needs some fixes here and there as a first, so I'll see when further ambitions are presented. I hope this one gets included.

Share this post


Link to post
Share on other sites

@Helmetman

You can set AoA for four different altitude regimes. It works very well. This mod is excellent, the only issue I have is an access violation issue that doesn't seem to be common for others

Share this post


Link to post
Share on other sites
16 hours ago, terminalmonky said:

This is the behavior I am seeing as well.  Where in the code are you seeing the wait?  Forgive my ignorance.  Just learning this stuff.  Dug through the Github a little and could not find it.

 

 

sorry

cant sepal in English if my life depended on it

and writing from the phone wer i dont have a spellchecker makes it wors

my intent was
a waite colored line of trajectory prediction over laid on the blue colored line of KSP orbit
after turning on and off it get calculated correctly and the waite colored line is displayed in the correct place

Share this post


Link to post
Share on other sites
19 hours ago, Helmetman said:

How does this work with spaceplanes?

Spaceplanes have drag based on the AoA. Basically it differs per orientation of AoA given a calculable trajectory. Can you make this mod calculate a trajectory based on the orientation of lifting surfaces? I can navigate spaceplanes manually. The very fact they can be used as controlled aerobraking negates the use of this mod. But when managing colonies repetition isn't as much fun so automation for spaceplanes using this or a similar mod is quite the luxury I would want.

So let's say it has the following option...

I want it to calculate trajectory based on all parts with a included digital input box where I could put the number "45" in and then the trajectory calculates based on that set orientation of AoA where I would land.

Rather then handling every vessel purely as a capsule.
Just a thought...
Reading all reactions it seems this mod needs some fixes here and there as a first, so I'll see when further ambitions are presented. I hope this one gets included.

if you wish to have automation you can use

KOS- write your oune landing code. it can get some data from tragetoris

karmax autopilot. autolands an aircraft on a runway

AtmosphereAutopilot

 

Share this post


Link to post
Share on other sites
On 9/17/2017 at 10:30 PM, dlrk said:

I get a crash sometimes in map view. I'm not entirely sure what causes it, because I cannot reliable trigger it. I suspect it may be related to the projected impact point crossing under the spacecraft in map view, but I'm not sure. It's an access violation, it is unrelated to memory usage.

Log: https://www.dropbox.com/s/qid50jqqc8q22c4/output_log.txt?dl=0
Dump: https://www.dropbox.com/s/ki7eibhkj0fhqvr/crash.dmp?dl=0
Screenshot: https://imgur.com/a/2jJyA

It seems to be triggered when reversing over Kerbin with KSC targeted and behind the spacecraft. I'll test a couple more times, but looks like I'll have repro steps!

Share this post


Link to post
Share on other sites
On 9/17/2017 at 0:27 PM, Kilo60 said:

Getting bad flashing in Map view lately with this mod...

 

Not sure what's causing it.

 

Anyone else get this and find a remedy?

 

Really don't want to go without this mod!

Producing an output log file might be helpful because I too have encountered this bug but since then I have uninstalled this mod. I might put it up again and see if I can reproduce it though.

 

Share this post


Link to post
Share on other sites
20 hours ago, Assassinsat said:

Producing an output log file might be helpful because I too have encountered this bug but since then I have uninstalled this mod. I might put it up again and see if I can reproduce it though.

 

Reinstalling the Mod seemed to have fixed the problem...

Share this post


Link to post
Share on other sites
4 hours ago, Kilo60 said:

Reinstalling the Mod seemed to have fixed the problem...

For me as well. For a minute there it appeared to have come back but the past few hours have been bug free.

Share this post


Link to post
Share on other sites

Hey love the mod but I'm getting an issue where I'll set a node to get the perfect trajectory after an aerobrake, but as my ship turns around to do its usual alignment stuff the trajectory will start changing. I tried pressing the "Retro" button it still doesn't stop the trajectory from waving around while I change attitude.

Share this post


Link to post
Share on other sites
On 23/09/2017 at 6:12 AM, theSpeare said:

Hey love the mod but I'm getting an issue where I'll set a node to get the perfect trajectory after an aerobrake, but as my ship turns around to do its usual alignment stuff the trajectory will start changing. I tried pressing the "Retro" button it still doesn't stop the trajectory from waving around while I change attitude.

This is normal if your ship has steering fins: when you change attitude, they move, which changes the drag of the ship. Not sure that's the explanation, but maybe it is. If you have different results depending on your ship attitude, even when it is static (not steering, not rotating), then it's something else.

Share this post


Link to post
Share on other sites

@Kobymaru

@Dizor

Thx for your work and the mod. :) Do you have any idea, what could be the cause, that the trajectory prediction drawings / lines / markers are not drawn / shown anymore, when I activate navball ghost markers at the NavBallAdjustor mod?
Is there a maybe way to make this compatible? You can see this problem in this video. It's a highly modded install, too.

BR
Jebs

Share this post


Link to post
Share on other sites

 

On 8/24/2017 at 4:11 PM, sjbuggs said:

Relocated from the development thread.  Couldn't test for a while I ironed out things on a new system.  Running v1.7.0 under KSP 1.2.2.

Without airbrakes deployed, point of impact is close, <2 km deviation.

When airbrakes are deployed before planning the burn, I didn't catch the exact amount due to night landing and missing pausing before impact. However the deviation exceeded 300 km last I saw.  This was using stock airbrakes with the ignore max temperature set to eliminate the ablative brakes mod as a variable.  So brakes seem to be ignored completely.

The rocket re-enters facing retrograde, and the brakes are mounted with that facing in mind.  If you think it'd make a difference, I can throw something up something meant to re-enter prograde.

On 8/25/2017 at 9:48 AM, Kobymaru said:

Yeah, so that's clearly a bug, this is supposed to actually work. I'll take a look.

Were you able to take a look at this?  I'd be happy to test out a modified version if you have one.

 

 

Share this post


Link to post
Share on other sites
On 01/10/2017 at 5:05 PM, Jebs_SY said:

@Kobymaru

@Dizor

Thx for your work and the mod. :) Do you have any idea, what could be the cause, that the trajectory prediction drawings / lines / markers are not drawn / shown anymore, when I activate navball ghost markers at the NavBallAdjustor mod?
Is there a maybe way to make this compatible? You can see this problem in this video. It's a highly modded install, too.

BR
Jebs

I already tried to fix this glitch but i failed. Another strange thing is if you zoom out the camera, the trajectories lines appear back. My NavBallAdjustor just enables/disables visibility for markers when they are behind the navball, i have no idea why trajectory lines disappear. The only assumption i have is there is some event in KSP game code that fires on markers visibility change, and this event updates some public variables/flags that Trajectories mod checks before displaying trajectories.

Share this post


Link to post
Share on other sites

@Kobymaru, there's an issue of extreme lag spikes when a ship in atmosphere is changing attitude. Apparently, it is some interaction problem with FAR. I posted this in FAR topic, and they said to come here. Here's the log, it's full of errors:

https://ufile.io/stgnh

Share this post


Link to post
Share on other sites

New release is up!

While Kobymaru is busy I've put a new release together for 1.3.1

Version 1.7.1 for KSP v1.3.1.

Download from GitHub or Spacedock

Full Changelog:

Spoiler
## v1.7.1 for KSP 1.3.1
 - 2017-10-13
 
### Changes since the last release
 
 * In-Flight trajectory overlay now uses GLUtils from MechJeb2 for rendering.
 * Fixed In-Flight trajectory for non-atmospheric bodies
 
### For Developers
 
 * Added a Jupyter notebook for descent force analysis.
 * Added the Bug Reporting section to CONTRIBUTING.md file.
 

 

Edited by PiezPiedPy
Added Spacedock link ;)

Share this post


Link to post
Share on other sites
On 10/13/2017 at 9:16 PM, PiezPiedPy said:

New release is up!

 

Many thanks. At first it seemed to show a slight bug. A blue line was visible above the craft, but would disappear after resetting the trajectories display. However, it would reappear again after changing the view.

But then I installed the last Mechjeb dev and the line bug didn't come again. (Is mechjeb a soft dependency?) Also, happy to see that you can use both Mechjeb's and Trajectories's lines at the same time. Trajectories showed an almost perfect prediction (minus the heatshield mass loss and parachute opening, but that's normal), while Mechjeb was off by at least 10 km, as usual. 

Share this post


Link to post
Share on other sites
On 10/10/2017 at 12:00 AM, aluc24 said:

@Kobymaru, there's an issue of extreme lag spikes when a ship in atmosphere is changing attitude. Apparently, it is some interaction problem with FAR. I posted this in FAR topic, and they said to come here. Here's the log, it's full of errors:

https://ufile.io/stgnh

When using FAR, you can safely use Trajectories while in Orbit or when landing on non atmospheric bodies.

While in Orbit, the landing prediction will work ok until you hit the atmosphere. After that, it will arch up and mess around. But that seems to happen to Mechjeb's landing module as well. Still there are no errors until you reach around 8000m altitude. After that, the log gets flooded every milisecond with:

[ERR 00:12:28.372] [FAR] NaN Prediction Section Error: Inputs: AtmDen: 0.00426203 Mach: 0 Re: 0 Kn: NaN skin: Infinity vel: (0.0, 0.0, 0.0)

Turning the Line display off completely stops the error and restores the framerate.

 

If I were to suppose something, it would be that Trajectories doesn't read FAR's speed. I am usually going over 1 Mach when I hit 8000m, yet the log shows a 0 value. 

Edited by karamazovnew

Share this post


Link to post
Share on other sites

@karamazovnew Thanks for the info :wink:

I've noticed these bugs too but I've not looked at those areas of the code yet due to not having much spare time.

As it was Kobymaru who implemented the In-Flight trajectory he would be the one who could maybe fix the issue sooner than I can. I also have no idea when Kobymaru will be back, hopefully sooner than later. If I get the new Gui up and running before he comes back I'll take a look and see what I can do.

Also you can use Trajectories independent of MechJeb as the required code from MechJeb is implemented inside Trajectories.

The same goes with the errors with FAR, hopefully Kobymaru gets back soon and can take a look.

Share this post


Link to post
Share on other sites
5 minutes ago, PiezPiedPy said:

@karamazovnew Thanks for the info :wink:

I've noticed these bugs too but I've not looked at those areas of the code yet due to not having much spare time.

As it was Kobymaru who implemented the In-Flight trajectory he would be the one who could maybe fix the issue sooner than I can. I also have no idea when Kobymaru will be back, hopefully sooner than later. If I get the new Gui up and running before he comes back I'll take a look and see what I can do.

Also you can use Trajectories independent of MechJeb as the required code from MechJeb is implemented inside Trajectories.

The same goes with the errors with FAR, hopefully Kobymaru gets back soon and can take a look.

Aye aye. I ended up stopping to use FAR anyway, since it didn't work at all with one of my other mods. Just wanted to add that the "extra blue-line no calculation" error mentioned above did occur again during one recent Mun landing. No idea what triggered it. If it happens again, I'll post a log file.

Edited by karamazovnew

Share this post


Link to post
Share on other sites

If I may add a suggestion.
Not for the mod as such. Though the suggestion could be implemented there, also.
Would be helpful in the FAQ, though.

In map view, there's only so far I generally zoom out. When I tried the mod out for the first time, I saw nothing new in map view. I fiddle and diddle with my maneuver, nothing. I saw the comment about not predicting stuff after a stage in the FAQ and took that to include maneuvers yet to be executed.
I execute my maneuver and without further zooming out, or so I'm entirely certain, the white line appeared.
I had already started a thread in the gameplay section and a mod request to get some way of determining where my ship would come down on Kerbin even before executing the maneuver to get out of low Munar orbit. Told folk "Trajectories is great, but it won't do it before I execute the node ...", was informed of my error. And finally zoomed out even further and found the white line before the burn.

The suggestion:
Mention in the mod description that users should zoom out a bit further.
Perhaps specify in the FAQ that, yeah, not predicting future stages does not include future maneuvers, those only need some zooming out in map view.

I will now go on my way and play with the settings to see if I can get the white line to appear with more zoom in map view.
Thanks for a great mod!

Share this post


Link to post
Share on other sites

Why Are my landings so inaccurate? Landed about 1,000 Km show of where the Trajectories mod said I would land. I've used Travectories for a long time and it's never been accurate... Im just now asking.

JCmeDy0.png

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.