navot

[1.4.1] Control Surface Toggle

Recommended Posts

This mod is continued by @linuxgurugamer . You can find the thread for the new mod here:

____________________________________________________________________________________________________________

Features:

This mod disables and re-enables your control surfaces on atmosphere exit/ entry to stop your SSTOs pointlessly flapping their wings in space. You can also do this manually

Dependency: Module Manager

Download from Spacedock: https://spacedock.info/mod/1499/Control Surface Toggle

Sources:  https://github.com/nav0t/Control-Surface-Toggle

License: MIT

Edited by navot

Share this post


Link to post
Share on other sites

Hello, and welcome to the forums! :)

I've moved your post to "Add-on Releases", since this is a mod, not a "tool".

A couple of minor things to take care of:

  • Please mention in your OP, above, that the source code is included in the download (otherwise, someone looking at your post can't tell whether the source is available, or where to get it).
  • I note that your download does include a couple of .cs source files... but it doesn't actually have the full source including project files.  The source code needs to be complete and buildable, so that someone who downloads it would only need to press the "build" button in their IDE such as Visual Studio and have it generate the DLL for the mod.

So, can you please fix both of the above?  (That is, add a note to your forum post, and update your mod's downloadable .zip file so that it includes the complete source.)  Thank you.

Share this post


Link to post
Share on other sites

Welcome to the forums! I read somewhere that you could achieve the same on control surface parts using the stock air intake module.
I wanted to try this myself but you solved it in a more elegant manner.

Nice job!

Share this post


Link to post
Share on other sites

Bug report, the difficulty menu when starting a new game has a duplicated "advanced" entry, additionally, all items in these categories are duplicated and selecting one also selects the other.

Reproduction instructions, when starting a new save customise the difficulty.

This may be due to an interaction with another mod in my mod setup as I have not tested this with only this mod installed (It's bedtime so I can't test now, might later).

Edited by Lupus590

Share this post


Link to post
Share on other sites

 

13 hours ago, Lupus590 said:

Bug report, the difficulty menu when starting a new game has a duplicated "advanced" entry, additionally, all items in these categories are duplicated and selecting one also selects the other.

Reproduction instructions, when starting a new save customise the difficulty.

This may be due to an interaction with another mod in my mod setup as I have not tested this with only this mod installed (It's bedtime so I can't test now, might later).

Hello Lupus590,

I tried to reproduce the bug with a clean installation of KSP 1.3.1 and the latest version of my mod(1.2.1), but the difficulty options menu was fine.

Also, I'm not sure how my mod could cause your behavior, since it should not even be active at this stage of the game, since it only loads when you start a flight.

If you do manage to reproduce this bug with only this mod installed, could you tell me which version of KSP/ the mod you used, and providing the Log file might be useful. Thanks.

Share this post


Link to post
Share on other sites

KSP.log

Screenshots

Mod Version: 1.2.1 (installed via CKAN)

KSP Version: 1.3.1 (installed via Steam, folder copied out of SteamApps/Common)

Running the 64-bit version of KSP, the exe is launched directly as an external shortcut in steam (I'm not using the official KSP launcher)

Share this post


Link to post
Share on other sites
1 hour ago, Lupus590 said:

KSP.log

Screenshots

Mod Version: 1.2.1 (installed via CKAN)

KSP Version: 1.3.1 (installed via Steam, folder copied out of SteamApps/Common)

Running the 64-bit version of KSP, the exe is launched directly as an external shortcut in steam (I'm not using the official KSP launcher)

Thanks for the feedback!

I didn't realize my mod was on CKAN... I think I ticked the box on spacedock to automatically do CKAN things and forgot about that.

Turns out, CKAN installs my mod completely wrong(it copies the source folder instead of the GameData folder), so I'll try to fix that.

In the mean time, you can download the mod from spacedock and install it manually, and everything should be fine.

Also delete the current ControlSurfaceToggle subfolder of your current KSP install, to remove the duplicated options.

EDIT: The latest version of the mod now works when installed with CKAN!

Thank you Lupus590 for pointing out this bug

Edited by navot
status update

Share this post


Link to post
Share on other sites

Does anyone know if this is working for KSP v1.4.2?

Share this post


Link to post
Share on other sites
19 hours ago, GJNelson said:

Does anyone know if this is working for KSP v1.4.2?

I haven't test it in 1.4.2 yet, but it should probably work fine

Share this post


Link to post
Share on other sites
3 hours ago, navot said:

I haven't test it in 1.4.2 yet, but it should probably work fine

Cool, thanks for the reply! Might give it a try. If I do, I'll drop a line here of what I see.

Share this post


Link to post
Share on other sites

Hm, looks like it also disables gimbaling in 1.4.2 :sticktongue:

Share this post


Link to post
Share on other sites
15 hours ago, Gordon Dry said:

Hm, looks like it also disables gimbaling in 1.4.2 :sticktongue:

I have also not been able to replicate this. In case this is still happening, are you also running any other mods?

Share this post


Link to post
Share on other sites

Perhaps it was because of early career and not unlocked much and using KCT or something ...

Edited by Gordon Dry

Share this post


Link to post
Share on other sites
1 hour ago, navot said:

I have also not been able to replicate this. In case this is still happening, are you also running any other mods?

Most of his problems are self-inflicted, if you hadn't already noticed.

Share this post


Link to post
Share on other sites
23 minutes ago, leatherneck6017 said:

Most of his problems are self-inflicted, if you hadn't already noticed.

So you wanna P upon a tree? Why don't you just put me on the ignore list like all the others with the same common sense than you got?

Share this post


Link to post
Share on other sites
29 minutes ago, Gordon Dry said:

So you wanna P upon a tree? Why don't you just put me on the ignore list like all the others with the same common sense than you got?

I have no idea what you just said.

Share this post


Link to post
Share on other sites

I think CKAN is doing the source code install instead of compiled DLL install thing again.

 

I'm about to test my mod setup without your mod and see if I still have the issue, but having peaked at your mod's folder in gamedata I think whatever you fixed last time has broken again.

 

EDIT: I still have the issue so it might not be you, but the folder looked like your github.

Edited by Lupus590

Share this post


Link to post
Share on other sites

What version on KSP are you running? I checked with KSP 1.4.2 and it was installed correctly for me. However if you are installing an old version of the mod (< 1.2.2) it won't work correctly, since that is the version I fixed it. I just checked with KSP v1.3 and CKAN tried to install the wrong version.

I don't really know how to tell CKAN not to do this, apart from simply deleting the mod history on Spacedock, so I might do that

Edited by navot

Share this post


Link to post
Share on other sites

CKAN also tries to install an old version on KSP 1.3.1, so I deleted the version history on Spacedock and hope this stops CKAN from trying to install old versions (at the moment it hasn't change, but I hope that is because it takes a bit to update that information)

Share this post


Link to post
Share on other sites

Nice contribution.

I notice you do logic in OnUpdate() and Update(). Have you considered using a build in gameevent to only do logic when needed? I think you can use the "GameEvents.onVesselSituationChange", which fires only when the vessel situation changes. This would reduce your fingerprint.

Also, you can move setup() call to the OnStart() method which KSP calls when first creating the partmodule.

Share this post


Link to post
Share on other sites

@Warezcrawler Thank you for giving me some pointers! I updated my mod and tried running it in KSP 1.3, but it didn't work (not a big deal but it would have been nice if it ran). Did these functions change between 1.3 and 1.4 or is it something different in my mod that causes this?

Edited by navot

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.