Jump to content
  • 0

KerbalRoster.ValidateAssignments (.Game st)


Question

Hey, I'm 20 years into my career, I have one or two scanners around just about everything in the system... Okay, my eeloo scanner was on an efficient but very slow trajectory and is still a year from a coridor correction burn despite being roughly 17 years into its mission...  

 

Okay, I have this mission headed to Jool. It consisted of three launches, An alcor based lander for Vall (or failing that, Pol), a venerable old 3.75M tug that I first built in 2014, it's the biggest tug from that era that still survives, and a shuttle for 10 tons of "Kibbal" a Station Science resource intended to resupply a massive 500 ton rig that's currently trying to refuel itself at Dres. The flight plan was to use the tug to pull the kibbal shipment up to interplanetary velocity then cut it loose. The burn was about 17 minutes but it was successful and it looks like the tug will have enough to make it to vall, and at least start the return voyage with the lander after it does it's thing. 

 

The flight plan for the kibbal shipment was to do a direct insertion into Jool orbit in the parking zone (between Tylo and Bop) and camp until the big rig arrives. 

The lander was to perform a "Laythe Snag" then directly shunt over to Vall on the same orbit and insert at a high enough inclination to reach the ruins... 

 

So each mission needs to enter the jool system on it's own trajectory so each has to do a corridor correction burn at roughly the same instant.... So I execute one of these burns, immediately followed by the other, then this happens: 

[EXC 15:09:36.004] NullReferenceException: Object reference not set to an instance of an object
       KerbalRoster.ValidateAssignments (.Game st)
       Game.Updated ()
       PauseMenu.<draw>m__713 ()
       DialogGUIButton.OptionSelected ()
       DialogGUIButton.<Create>m__6FF ()
       UnityEngine.Events.InvokableCall.Invoke (System.Object[] args)
       UnityEngine.Events.InvokableCallList.Invoke (System.Object[] parameters)
       UnityEngine.Events.UnityEventBase.Invoke (System.Object[] parameters)
       UnityEngine.Events.UnityEvent.Invoke ()
       UnityEngine.UI.Button.Press ()
       UnityEngine.UI.Button.OnPointerClick (UnityEngine.EventSystems.PointerEventData eventData)
       UnityEngine.EventSystems.ExecuteEvents.Execute (IPointerClickHandler handler, UnityEngine.EventSystems.BaseEventData eventData)
       UnityEngine.EventSystems.ExecuteEvents.Execute[IPointerClickHandler] (UnityEngine.GameObject target, UnityEngine.EventSystems.BaseEventData eventData, UnityEngine.Eve
ntSystems.EventFunction`1 functor)
       UnityEngine.EventSystems.EventSystem:Update()
[LOG 15:09:36.320] Flight State Captured

I've seen this several times, I had thought it had something to do with the Wild Blue tourist contracts, dunno... 

When it goes into this state, it is impossible to switch to any other vessel or tracking station or space center, or anything. I have reloaded the game and tried to execute the burns in the reverse order. I've tried a number of different things but there doesn't seem to be any workaround this time.

My crewed flight roster is: 

The big station science rig, maybe two dozen kerbs, all my orange suits... 18 years MeT

a small "bigby" module that was spawned as a shipwreck with a rescue target abard, I took that guy off and used the same flight to dress it up as a space station, crew of 1 currently, it's in a 100km kerbin orbit, haven't visited in ages... MET is showing 6 years...

A slightly updated version of this: http://steamcommunity.com/sharedfiles/filedetails/?id=271121784 , I drove it around Duna to all the points of interest, and am now using it to build and support a Pathfinder base that was assembled on site. The site I'm on has no water so I'm a bit constrained with building, except for cheating... =P 

"Bad Rocket" , above mentioned mission to Vall, crew of 3

A rescue target near the sun, being used as a test for an ultra-high performance grabber...

Urk! The Pathfinder colony on Duna should have a crew of 6, consisting of four tourists and two engineers, but it's showing empty in the tracking station!!! this must be the smoking gun. =( 

 

 


 

 

 

Link to post
Share on other sites

11 answers to this question

Recommended Posts

  • 0

Squad had reported that they had fixed this problem later in the 1.4 series, but in 1.5 I'm noticing more than a few regressions, someone really messed up over there. =| Notice the inventory list isn't lined up anymore, it had been fixed in 1.4.5... So apparently 1.5 had been forked early in 1.4 and more than a few fixes were not back-ported. =0

 

Damnit, why doesn't the best game ever made have more careful developers?

Link to post
Share on other sites
  • 0

You mean the parts list in the VAB? So I'm not the only one who noticed...

By the way, I also can't use Kerbal Konstruct anymore - pressing Ctrl-K does nothing. IIRC I already had this problem, but I don't remember if that was also a fix in the main game. Do you use KK? Does it work?

About the ValidateAssignments problem: I noticed it is triggered by docking the ship containing the tourists to a space station. Let's see what happens if I don't do that... The space station ran out of supplies, which converted the Kerbals to Tourists. Docking to it brings supplies, converting them back to Kerbonauts. That seems to mess things up...

Link to post
Share on other sites
  • 0

My install is not even slightly sane right now, north of 20GB running 15+ minute load time, I think the planet packs I have right now are what's really killing it. I'm happy with the 3 launch sites provided by the DLC so I'm not using KK.

Link to post
Share on other sites
  • 0

It was fixed in 1.4.5 but the fixes from that release have never been ported to any later release, they forked 1.5.x off of 1.4.2 or something and never looked back. =((( So there are many regressions and Squad/TT are out to lunch on this issue. =( 

The current PM brags that he's been playing since 1.0, I've played since 0.23 so I out rank him and I want to take over this project. 

Link to post
Share on other sites
  • 0

For anyone with similar issue, this can happen when

1. You have a contract for multiple tourists.

2. You complete the contract for one of the tourist, so that Kerbal tourist appears to disappear from your game.

3. You recruit a Kerbal with the same name as the tourist that no longer exists and assign them to a mission.

4. As soon as you fully complete tourist contract, you get the roster verification error.

It seems the game gets confused because one of the tourists appears to be assigned to a mission so it isn't safe to continue.

To resolve, head into the relevant .sfs file prior to contract being completed (please take a back up!), find the tourist in the contracts section (just search for their first name) and change their first name to something unique - including in the contract parameters section. Do not change the crew member of the same name's first name! Reload your game, complete the contract and everything should still be dandy.

I got this error in v1.8 so it's probably still a live bug. I gave up trying to figure out how to log it with Squad but figured I'd log solution here as this is where my Googling brought me.

Edited by Smanders
Additional clarification
Link to post
Share on other sites
  • 0
2 hours ago, Smanders said:

I got this error in v1.8 so it's probably still a live bug. I gave up trying to figure out how to log it with Squad but figured I'd log solution here as this is where my Googling brought me.

Are you using Earn Your Stripes by any chance? There was a bug in that which caused that error - which is now fixed in the latest version.

Link to post
Share on other sites
  • 0

I'm having this same problem only for me it only seems to come up if I enter the Astronaut Complex. One in, there's no getting out. Observing the console reveals this error popping up each time I attempt to exit that building. The only way out is to force quit the game and go back to whatever is in the save. I've got no way to go back to a save prior to this since I've got no idea how far back this goes and from time to time I wipe out quick saves to save space. For me, the only option is to edit the persistent.sfs - but I've got no idea what I'm looking for. There are only 6 tourists in the save and none of them have names like any of my other kerbals.

Any ideas what to look for in the save file?

I'm running 1.9.1 BTW.

 

Link to post
Share on other sites
  • 0

SOLVED!

At least in may particular case under 1.9.1

While I'm not sure how this happened, I suspect it could somehow be related to my use of the Ship Manifest mod, which is how I create almost all of my kerbals; though that in part is also due to the very long span of time I've tolerated this issue which has previously meant that my only options for adding crew was to either rescue them or create them on the fly using that mod as entering the Astronaut Complex would always result in my being trapped there. It also might be related to my use of Custom Barn Kit, which allows you to set a fixed cost per Kerbal you hire (among other things); but I think I added that mod after I first observed this problem.

In any case, what I found when digging through all the 114 Kerbas listed in my persistent.sfs file was this:

Three kerbas who had a type of Applicant, but also had a state of Assigned (how can that be possible?)

One kerbal who had a type of Unknown and a state of Assigned (Seems pretty likely this was the cause or at least a contributing cause)

All other kerbals had type of either Crew or Applicant. All other Applicants had a state of Available. All Crew had a state of either Available or Assigned.

Upon changing the type to Crew for all the Assigned kerbals I was able to enter the Astronaut Complex, hire some more kerbals, and get back out!

So, bottom line, pretty easy to spot and fix in your save file if you know what to look for. As always, when editing your save file be sure to make a backup first!

Cheers!

 

Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...