m4v

[1.2] RCS Build Aid v0.9.1

Recommended Posts

Check that the button at the bottom says "Mode: TRANSLATION" and not rotation.

Yeah, I did that. But I'll double check.

Share this post


Link to post
Share on other sites
Yeah, I did that. But I'll double check.

If is not that then a screenshot or more information would be helpful.

Share this post


Link to post
Share on other sites
If is not that then a screenshot or more information would be helpful.

Well, it's working now. Glad to know that. I've really been missing this mod. Definitely should be stock :)

Share this post


Link to post
Share on other sites

Greetings M4V.

-For some unknown reason, the DeltaV and the Burn Time for RCS and the engine are not shown anymore in the VAB. I use the v0.23.5 of KSP and the v0.4.5 of RCS Build aid. I have tested it with stock and modded linear RCS as well as the block ones. No errors are shown in the Debug Console.

-Also, if i'm correct, on v0.23, when we pressed on the Center of Mass button on the lower left part of the screen in the VAB, the RCS Build Aid menu used to pop up automaticaly and displayed the red center of mass along and vice and versa. Now, the red center of mass is still shown after I pressed on the center of mass button down left of my screen. Could this be a ( very minor ) bug?

-I also noticed that the icon for Blizzy's toolbar has gone missing. It's now displaying the usual black square. What can I do to get it back?

I know that v0.24 is out soon and that it would make sense to wait for its release before taking care of those minor and unsignificant problems. Yet, I wanted to report them.

Respectfully.

Ben.

Edited by Benoît

Share this post


Link to post
Share on other sites

-Also, if i'm correct, on v0.23, when we pressed on the Center of Mass button on the lower left part of the screen in the VAB, the RCS Build Aid menu used to pop up automaticaly and displayed the red center of mass along and vice and versa. Now, the red center of mass is still shown after I pressed on the center of mass button down left of my screen. Could this be a ( very minor ) bug?

I too miss this very much.

I know that v0.24 is in Q&A phase and that it would make sense to wait for its release before taking care of those minor and unsignificant problems. Yet, I wanted to report them.

Where did you hear that? Certain .24 subsystems are undergoing some testing (as is normal during a development cycle), but I haven't heard anything at all about .24 as a whole being in testing.

Share this post


Link to post
Share on other sites
Where did you hear that? Certain .24 subsystems are undergoing some testing (as is normal during a development cycle), but I haven't heard anything at all about .24 as a whole being in testing.
Originally Posted by sidfu

.24 may be in 2 weekks( not likely there has to be a reason they split it into 2 patches) or its gonna be 2 months which is more than likely.

It's already in Q&A and since that was 2 weeks ago, probably testing. Barring a disaster there, it should be out SoonTM

I read that from the RemoteTech 2 thread. Now I realize that I should have searched for some deeper informations. My mistake everyone.

Correction done.

Edited by Benoît

Share this post


Link to post
Share on other sites
Greetings M4V.

-For some unknown reason, the DeltaV and the Burn Time for RCS and the engine are not shown anymore in the VAB. I use the v0.23.5 of KSP and the v0.4.5 of RCS Build aid. I have tested it with stock and modded linear RCS as well as the block ones. No errors are shown in the Debug Console.

ah yes, this is because MonoPropellant now uses a flow mode different than ALL_VESSEL. Since that is the only flow mode for which the dV algorithm is accurate, is a rather dumb and simple one after all, but I can fix (not sure when).
-Also, if i'm correct, on v0.23, when we pressed on the Center of Mass button on the lower left part of the screen in the VAB, the RCS Build Aid menu used to pop up automaticaly and displayed the red center of mass along and vice and versa. Now, the red center of mass is still shown after I pressed on the center of mass button down left of my screen. Could this be a ( very minor ) bug?

When you have the toolbar, the CoM button only enables/disables the CoM marker and nothing else, not disabling the DCoM was intentional but I suppose it would be useful if it to disabled both markers.
-I also noticed that the icon for Blizzy's toolbar has gone missing. It's now displaying the usual black square. What can I do to get it back?
Try deleting and reinstalling the plugin, probably there's something wrong with your install, the icon is missing or the path is wrong.

Share this post


Link to post
Share on other sites
*SNIP*-I also noticed that the icon for Blizzy's toolbar has gone missing. It's now displaying the usual black square. What can I do to get it back?

If you happen to be using the aggressive package of Texture Management, that too can cause such issues with buttons. It's been happening to a few mods that get updated and don't have a config setup in ATM for them with certain screens/icons. I use the basic one, so thankfully that hasn't been a problem for toolbar icons.

Share this post


Link to post
Share on other sites

An idea for stage / action group for engine/rcs thrust calculations and com/dcom/acom centering.

For example, i had designed engines in two stages (jets and rockets) in SPH. It would be useful to make this plugin aware that they have separate thrusts and thus separate effects on vehicle.

I could assign engine disable/enable function to action group key 0-9, and (with action group editor selected) plugin would detect my keypresses of keys 0-9 and show new thrust/torque vectors.

Similar for mass centers : if it could be possible to click on 1 or 2 construction elements (fairing/stack decouplers or ports) that define separable payload, that way i can review how centers look with and without payload (even better when this get taken into account with above engine forces).

Share this post


Link to post
Share on other sites

Noted. However action groups are annoying because they break every time you move a part around, so you usually only use them when the design is finished and not while designing.

Edited by m4v

Share this post


Link to post
Share on other sites

just to be clear, this mod doesn't work when you're outside of the VAB/SPH right? I just balanced out a rocket but I know that as the mission progresses and I burn fuel the CoM will change and I'll start getting rotation during translation. However, I played around with the fuel load of the various tanks and found that I can always rebalance fuel to get the CoM back where I need it prior to doing any RCS translation. Problem is, if I can't see the aid arrows while in flight I won't be able to do this!

Share this post


Link to post
Share on other sites
just to be clear, this mod doesn't work when you're outside of the VAB/SPH right?
That's correct.

Share this post


Link to post
Share on other sites
just to be clear, this mod doesn't work when you're outside of the VAB/SPH right? I just balanced out a rocket but I know that as the mission progresses and I burn fuel the CoM will change and I'll start getting rotation during translation. However, I played around with the fuel load of the various tanks and found that I can always rebalance fuel to get the CoM back where I need it prior to doing any RCS translation. Problem is, if I can't see the aid arrows while in flight I won't be able to do this!

One solution is to balance them around the average CoM so it's neither balanced for full or empty tanks, but is a happy medium between the two.

Share this post


Link to post
Share on other sites
One solution is to balance them around the average CoM so it's neither balanced for full or empty tanks, but is a happy medium between the two.

True, but it is a bit disappointing to know that I can do better if only I could see the aid while in flight... is that just not possible or not implemented?

What I will prob end up doing is using the Notepad mod to take down notes of various fuel balances to use as a rough guide during flight

Share this post


Link to post
Share on other sites

A trick is to use the right-click menu on the RCS tank to drain it and see how the COM moves.

Alternatively, leave the RCS tanks off, build the thing, find the COM, and then place symmetrical radial RCS tanks around the COM - that way the COM won't move as the tanks drain!

Share this post


Link to post
Share on other sites
True, but it is a bit disappointing to know that I can do better if only I could see the aid while in flight... is that just not possible or not implemented?

Is not going to be implemented. In part because I don't want to increase the maintenance burden of the plugin (23.5 has been out for almost 2 weeks and I still haven't been able to do a release with fixes for it, is a good thing that the plugin didn't break!) and in part because is meant to be a building aid tool, not a flying one.

I believe there are plugins for deal with that problem.

Share this post


Link to post
Share on other sites
..is meant to be a building aid tool, not a flying one.

Well then you should change the name to something that... Oh wait :D

I didn't even know there were any bugs with it. Works fine for me. Better than fine.

What I like the best is that I can get COM and dry COM markers at the same time, so I can find different ways to get the 2 close to each other.

Share this post


Link to post
Share on other sites
This is true, but thinking about it, have you considered TAC Fuel Balancer? It'll automatically help keep the CoM where you want it.

I have it but never used it so didn't want to assume it would do what I wanted. We'll see

Is not going to be implemented. In part because I don't want to increase the maintenance burden of the plugin (23.5 has been out for almost 2 weeks and I still haven't been able to do a release with fixes for it, is a good thing that the plugin didn't break!)

I understand.

Actually what I ended up doing was just seeing how my fuel was distributed after I was on my slow RCS approach (where I'm only thrusting forward/back and don't need to worry about translation yet) and go back to the space port, load the vehicle up in the VAB, balance everything and then go back to the craft in flight and applying the fuel balance changes with the default In/Out. Worked great, shoulda thought of that from the get go

Edited by Gaiiden

Share this post


Link to post
Share on other sites

Version 0.4.6
-------------

* FIX: RCS dV reading not showing in 0.23.5
* FIX: new massless parts weren't recognized as such.
* Marker scaling for the CoT and CoL markers.

only fixes, I have no time.

Share this post


Link to post
Share on other sites
FIX: RCS dV reading not showing in 0.23.5

Thanks for the fix release!

But I'm not sure as to why, but my dV is still not showing in the VAB with my existent ships and with new ships. Should I change something in the config file?

drycom_AblativeShielding = True

drycom_ExtraTons = False

drycom_LiquidFuel = False

drycom_Oxidizer = False

drycom_SolidFuel = False

drycom_Food = True

drycom_Water = True

drycom_Oxygen = True

drycom_CarbonDioxide = False

drycom_Waste = False

drycom_WasteWater = False

drycom_MonoPropellant = True

com_reference = 1

rcs_mode = 0

direction = 5

window_x = 280

window_y = 207

window_state = 1

marker_scale = 1

Share this post


Link to post
Share on other sites

It only works for stock MonoPropellant, so if you're using Real Fuels / RO and using a different fuel, no dice.

Share this post


Link to post
Share on other sites

All right, it was my fault.

I just overwritten the new files of 0.4.6 onto the old ones... that is a bad habit. By deleting the whole folder and decompressed the new ones, it's now perfectly working.

My mistake.

Share this post


Link to post
Share on other sites

Hey M4V.

I noticed that with Procedural Parts, RCS Build aid doesnt recognize the difference between wet and dry mass of the new formed tanks. Could this come from this mod?

Share this post


Link to post
Share on other sites
Hey M4V.

I noticed that with Procedural Parts, RCS Build aid doesnt recognize the difference between wet and dry mass of the new formed tanks. Could this come from this mod?

What do you mean? the values seem to match:

HsEGI1A.png

Share this post


Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.