Jump to content

[0.22] UbioZur Welding Ltd. 2.0 Dev STOPPED


Recommended Posts

May I recommend a new thread for your version, referenced from here to there and with this one essentially getting killed? I have fans who are being introduced to welding on my YT channel but when they come looking for it they don't realize the top post is not the correct DL link. A new thread that you could maintain and keep up to date with proper links would help new fans of welding a lot. :)

I really agree with this proposal, but sadly we still heard nothing from Ubio, so unless we get some official permission, it has to stay in this thread.

PS. nice episode of Odyssey :), good to see some assets are rescued.

Link to post
Share on other sites
May I recommend a new thread for your version, referenced from here to there and with this one essentially getting killed?
New thread ... great idea!
I really agree with this proposal, but sadly we still heard nothing from Ubio, so unless we get some official permission, it has to stay in this thread.

Indeed, even leaving aside the author's opinion on such action, the main problem here is the uncertainty of the UbioZur's license:

All rights reserved. Do not redistribute.

Contact me for exception.

Considering my lack of time and internet connection to currently work on the mod, I do allow for redistribution of working version for .23 (and futur if I can't connect until then)

Perhaps this text with some stretch of imagination can be interpreted as permission to our with Alewx current activity, but I can't imagine a new thread which will be started with the links to such license (let me remind you that the current forum rules explicitly require you to specify the type of license).

In principle, an acceptable solution would be to rewrite the entire mod as a whole. This task seems to me quite feasible, but still a few ambitious at the moment.

@Alewx: About license and a new thread. Perhaps you could write to any of the moderators and ask for their opinion on this issue? At least you are reasonably fluent in English. Unfortunately, for me the prospect to engage in such extensive correspondence is no less severe than to rewrite the whole mod from the scratch :wink:

Link to post
Share on other sites
@Alewx: About license and a new thread. Perhaps you could write to any of the moderators and ask for their opinion on this issue? At least you are reasonably fluent in English. Unfortunately, for me the prospect to engage in such extensive correspondence is no less severe than to rewrite the whole mod from the scratch :wink:

Thanks for the compliment, ok I will ask around.

Rewriting from scratch sounds really really bad to me, we, especially you have already put quite some effort into the maintenance of this pretty tool.

I will inform you about the respond I get from the moderators.

Link to post
Share on other sites

ok what the plugin seems to be doing is when it rebuilds the catalog when it welds X parts it unloads some other parts from mods, i.e. extra-planetary launchpads (e.g. survey station) and remote tech (e.g. Reflectron DP-10) and also after welding it shows all parts in the VAB need to be purchased (even though im on a science career) but this purchase bug is fixed by leaving the VAB and re-entering it however in the act of doing this due to the other parts mentioned before being unloaded, whatever ships or bases i have that contain said parts gets unloaded by the game, the only way i have found to prevent this is to weld the parts i want welded then hit alt+f4 to close the game and reopen it before any active crafts get unloaded. When welding TAC LS parts (i.e. containers) the models seems to resize larger than the original (not tweakscaled) on the welded part but still shows the correct resource amounts.

apart from the issues im having i do really like the welding mod.

Link to post
Share on other sites
... the only way i have found to prevent this is to weld the parts i want welded then hit alt+f4 to close the game and reopen it before any active crafts get unloaded.

there is a simpler way - just disable "Database autoreload" in mod's settings, then comfortably exit the game when you like to after welding.

When welding TAC LS parts (i.e. containers) the models seems to resize larger than the original (not tweakscaled) on the welded part but still shows the correct resource amounts.

A few days ago I discovered that problem with scaling of models was appeared in 0.25 again. The fix is ready and is in testing.

Link to post
Share on other sites

I thought I should mention this...

A few pages back it was mentioned that turning PhysicsSignificance to 0 was the way to make physics-less parts. That is actually not entirely accurate, though it would make more sense if it was that way. The accurate way is to set the parameter to 1 to make it ignore physics... or rather physics ignore it. That's all I've got for y'all.

Link to post
Share on other sites
I thought I should mention this...

A few pages back it was mentioned that turning PhysicsSignificance to 0 was the way to make physics-less parts. That is actually not entirely accurate, though it would make more sense if it was that way. The accurate way is to set the parameter to 1 to make it ignore physics... or rather physics ignore it. That's all I've got for y'all.

I had two post about PhysicsSignificance before my eyes (and was provided links to them!) but I managed to pervert their meaning in few words. I take off my hat to your vigilance!

Link to post
Share on other sites

License wise, judging from what was said and that permission has been given for "maintenance" purposes. I do not see any reason a new "maintenance" thread could not be made as long as you link back to both the OP and the unofficial builds where permission to make it work was given. Base on what he did post he did give permission...limited as it is.

The other path would be to start an open source project and create a brand new welding tool that the community can maintain and add to. This would eliminate this gray area and create a more permanent solution. UbioZur could then later join that effort assuming a return to active modding. Just an opinion.

Link to post
Share on other sites

I made a little how-to:

Edit:

I have a new suggestion for the mod. A slightly different version, which only creates the part.cfg without making the craft into one part.

If you watched my video, you see we are only able to rescale the welded part. I would like to rescale the original, pre-welded craft, making it bigger. When I just change the rescale factor in the part.cfg, only the individual parts get bigger, but the positon points/connection between them doesn't change. I need a way to edit these position coordinates.

Can anyone here make such a mod?

Edit 2: Wow the Twakscale mod just updated and added this freature I suggested. Look here.

Edited by Space Scumbag
Link to post
Share on other sites
.

thanks scumbag you gave me a great idea for fixing a problem with my project now. i can just rescale the whole thing with all the parts that dont play nice removed!

speaking of parts that dont place nice, can i get full functionality out of welded retractable ladders, docking ports, nozzles, seats, wheels?

also i have came by to ask YOU ubiozur :D how is development coming now that your summer has settled down? it would be awesome to see you make a comeback update. best of luck!

Link to post
Share on other sites

speaking of parts that dont place nice, can i get full functionality out of welded retractable ladders, docking ports, nozzles, seats, wheels?

In general you will have problems if you will weld more that one instance of such part together. But you can combine, for example, one ladder, docking port an one landing leg in one part - it will work perfectly.
also i have came by to ask YOU ubiozur :D how is development coming now that your summer has settled down? it would be awesome to see you make a comeback update. best of luck!

Unfortunately, UbioZur's last post in this thread was on 24th July 2014. Last activity on forum was on 16 Jct 2014. He also did not respond to PM.

Usually it does not promise anything good. However, let's hope for his return.

At the moment, we along with Alewx are trying to keep the mod in minimal working condition as is allowed by the license.

Link to post
Share on other sites

Can anyone shed light as to why after I have welded my ship together and I launch the ship and leave it to go to the space centre it then disappears completely? I have read somewhere that it has something to do with it reloading the database in game or something? But I'm not entirely sure.

Link to post
Share on other sites
Can anyone shed light as to why after I have welded my ship together and I launch the ship and leave it to go to the space centre it then disappears completely? I have read somewhere that it has something to do with it reloading the database in game or something? But I'm not entirely sure.

Ummm...you welded your ship? Just the tanks and inert parts or everything including the engines? My thought is that IF you welded it ALL the engines could be thrusting inside the hit box of the part. And if they are doing that it is not disappearing...it is exploding.

Basically...you do not weld a ship. You weld parts of similar function to reduce part count. Like tanks or trusses so you can take a 20 part collection of pieces and make it one rigid body. But yeah...an image of what you did would help.

Link to post
Share on other sites
Can anyone shed light as to why after I have welded my ship together and I launch the ship and leave it to go to the space centre it then disappears completely? I have read somewhere that it has something to do with it reloading the database in game or something? But I'm not entirely sure.

Like SyberSmoke said, Images and partfile would be nice to give some help.

Did you really weld the whole ship?

Link to post
Share on other sites
Can anyone shed light as to why after I have welded my ship together and I launch the ship and leave it to go to the space centre it then disappears completely? I have read somewhere that it has something to do with it reloading the database in game or something? But I'm not entirely sure.

I know the answear. You have to right-click your ship and rename/change the typ of ship. On default it is classified as debirs, that's why it gets deleted after loading. You have to set it to another class, like Ship or Station. After that change, the ship will be saved and you can load a save.

Link to post
Share on other sites

Hey guys,

Sorry I have not been able to be on the forum, work on the mod nor as a moderator nor play KSP for such a long time, and it is not finish for me, I have big IRL project coming my way.

I am modifying the licence to open it to everyone who want to follow it, create you own mod based on mine, continue this one.

I will pop back on the forum when I will get more IRL time (probably wont be able to pop back in the mod creation however).

Make me proud, keep flying and have lot of fun.

Edit:

Here is the code of the last version I was working on (still heavily WIP), I tried to make it as a API for future integration with fairing etc...

And also offer several ways to weld parts.

It's a completely different way to approach the merging of the config file, so feel free to have look and use that code too.

https://drive.google.com/file/d/0Bwou6bewBq0uM2J3VnFqMFRKRWs/view?usp=sharing

Edited by UbioZur
Link to post
Share on other sites

Hey UbioZur,

nice to hear from you. I hope everything is going well in your RL.

Me and many other people are using this mod. We have really much fun with it. :D

I'm sure the other guys will be glad to continue your work and will have a look at the new code you provided. You probably already saw, the fixes some of us did.

Looking forward to see you on the forum and game.

And again, thank you for this awesome mod! It really changed the way we play KSP. :cool:

Link to post
Share on other sites
Hey guys,

Sorry I have not been able to be on the forum, work on the mod nor as a moderator nor play KSP for such a long time, and it is not finish for me, I have big IRL project coming my way.

I am modifying the licence to open it to everyone who want to follow it, create you own mod based on mine, continue this one.

I will pop back on the forum when I will get more IRL time (probably wont be able to pop back in the mod creation however).

Make me proud, keep flying and have lot of fun.

Edit:

Here is the code of the last version I was working on (still heavily WIP), I tried to make it as a API for future integration with fairing etc...

And also offer several ways to weld parts.

It's a completely different way to approach the merging of the config file, so feel free to have look and use that code too.

https://drive.google.com/file/d/0Bwou6bewBq0uM2J3VnFqMFRKRWs/view?usp=sharing

I wish you all the best for your project :)

We will honor your work, thank your for responding.

Link to post
Share on other sites
I wish you all the best for your project :)

We will honor your work, thank your for responding.

I really hope this work gets continued and fixed.

It was such a huge performance boost for using large sections of boosters and the like.

It made the game completely playable and smooth for 1000 part builds and even more, once welded.

Is it compatible with Dark Multiplayer?

Please say yes. lol

Edited by B15hop
Link to post
Share on other sites
Is it compatible with Dark Multiplayer?

Please say yes. lol

Actually I would say "no". The welded parts have to be pushed into the gamedatabase, requiring a restart and a syncing of the databases of all players connected to the server.

But asking the DM guys might give a better result, if it works or not.

Link to post
Share on other sites

Guys, I have a problem, everytime I save a thing with the welding mod (with or without a capsule or probe), the database reloads, but almost all the parts disappear, then I see that all the asteroids and other ships I collected and built in Kerbin orbit have been deleted. I have the following mods installed B9 parts, BD armory, KAS, IF, Pro Props, UbioZur, HangerExtender, HullcamVDS, TweakScale, Banana plane part, TextureReplacer, KerbPaint, ActiveTextureManagment, and Time control. Yet after I reload the Database, only B9 and BD armory remain. All of the mods are updated to 0.25, yet the game says there are incompatable mods, is this the reason Ubiozur is failing? If so, which mod is it and why? I'm really tired of spending hours to get my asteroid cluster back around Kerbin, so how do I fix this?

Link to post
Share on other sites
Guys, I have a problem, everytime I save a thing with the welding mod (with or without a capsule or probe), the database reloads, but almost all the parts disappear, then I see that all the asteroids and other ships I collected and built in Kerbin orbit have been deleted. I have the following mods installed B9 parts, BD armory, KAS, IF, Pro Props, UbioZur, HangerExtender, HullcamVDS, TweakScale, Banana plane part, TextureReplacer, KerbPaint, ActiveTextureManagment, and Time control. Yet after I reload the Database, only B9 and BD armory remain. All of the mods are updated to 0.25, yet the game says there are incompatable mods, is this the reason Ubiozur is failing? If so, which mod is it and why? I'm really tired of spending hours to get my asteroid cluster back around Kerbin, so how do I fix this?

My best guess is that the database reload is causing a problem with some of the mods, so best choice is: disable the database reload in the welding window, weld the parts you like together, and then restart the game.

Link to post
Share on other sites

First of all, many thanks to the creator and maintainers of this mod! Its awesome and changes everything regarding stations and such.

All of the mods are updated to 0.25, yet the game says there are incompatable mods, is this the reason Ubiozur is failing? If so, which mod is it and why? I'm really tired of spending hours to get my asteroid cluster back around Kerbin, so how do I fix this?

Have the same problem sometimes, my computer can't handle database reloads, so it can't be that. I think it happens if there is an incompatible part, could be any mod. Altough until now (5 welded things) it only happened when i tried stuff that's generally not working anyway (in my case: several station science parts together). My guess is, that its messing up the savegame when it tries to write the new (broken) part into it.

Best way to circumvent this is to backup the savegame (persistent.sfs) before you weld stuff together, or reload the quicksave. The welded part won't vanish, so at best you lose just a few seconds.

Link to post
Share on other sites

Friends, I can only join to Alewx.

If you have any problems with database reloading - disable it in settings (button in Welder main window)!

Reloading is incompatible with some mods (as mentioned in OP) - PartCatalog for example! Perhaps it will not be compatible with them ever.

Best way to circumvent this is to backup the savegame (persistent.sfs) before you weld stuff together...

Always, always do it before welding (and do it always anyway :))! You can backup persistent.sfs manually or save game from SpaceCenter.

EDIT: By the way, I usually weld in another (minimal) copy of KSP - only mods with parts, nothing more.

Edited by girka2k
Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...