Starwaster

[1.5.1] Deadly Reentry v7.7.1, Jan 27, 2019 (The Rachel Edition)

Recommended Posts

Thanks. I do need that modlist *with* versions: you've got an awful lot of other mods that are erroring out before DRE even loads. Including some that are known to not be compatible with .24.

Please try a *clean* install with just DRE. If it works fine, I would be quite willing to bet it's not the source of your issue. Then try adding other mods one by one and *check the log* (the output log). Actually see which mod is throwing errors; it will tell you.

Share this post


Link to post
Share on other sites
Thanks. I do need that modlist *with* versions: you've got an awful lot of other mods that are erroring out before DRE even loads. Including some that are known to not be compatible with .24.

Please try a *clean* install with just DRE. If it works fine, I would be quite willing to bet it's not the source of your issue. Then try adding other mods one by one and *check the log* (the output log). Actually see which mod is throwing errors; it will tell you.

i did the one by one thing and when i got to dre it worked without dre. this is only with your last build btw, older builds worked fine.

all the mods below are either updated to 0.24.2, .24.1 or .23.5 whichever one is the latest one for each particular mod. they all boot up and the game works fine, except for the latest build of dre.

mod list:

-MP_Nazari

- SmokeScreen

- EnvironmentalVisualEnhancements

- CustomAsteroids

- DebRefund

- KittopiaSpace

- 000_Toolbar

- CoherentContracts

- TextureReplacer

- laztek

- ActiveTextureManagement

- CoolRockets

- SoundtrackEditor

- MechJeb2

- NavBallTextureExport

- KSPScienceLibrary

- TriggerTech

- Chatterer

- BoulderCo

- DistantObject

- Klockheed_Martian

and Deadly Reentry :)

Share this post


Link to post
Share on other sites

I have a request:

Could it be possible to reassign reentry heat values to all of the stock parts to be more realistic? I don't think it's possible for a solar panel (for example) to have a 1600 degree reentry heat tolerance... same with the crew pods without heat shields.

If anybody already HAS done something like this (revalue all of the reentry heating numbers realistically) I would be very grateful!

Share this post


Link to post
Share on other sites

I have a mk1 pod and two radial mounted parachutes. I'm descending from KEO orbit, but when I re-enter the atmosphere the parachutes burn up and get blown up, even though I have the pod pointed towards retro so that the heat shield is pointing into prograde. What's up with that? How am I supposed to survive re-entries if my parachutes get burned away?

Share this post


Link to post
Share on other sites

Has heat from Kerbol ever been discussed for DRE? Would be interesting!

Share this post


Link to post
Share on other sites

Really sad to see the strobing/flashing reentry effects are still present. And even after all this time.. not one person other then myself has experienced these problems? Im really ready to switch over to a hyper realism setup, but this is just putting the brakes on that ideal. What in the hell could I be doing differently then everyone else? Its.. very frustrating. It seems the problem goes away when I cap the game at 30fps.. but anything above that and its like a broken record. So... everyone here running DRE with ksp pegged at 60fps.. is experiencing no trouble? I am truly the only one in the entire community of DRE users experiencing this problem?

Edited by Motokid600

Share this post


Link to post
Share on other sites

justhearit: quoting myself.

Please try a *clean* install with just DRE. If it works fine, I would be quite willing to bet it's not the source of your issue. Then try adding other mods one by one and *check the log* (the output log). Actually see which mod is throwing errors; it will tell you.

TeeGee: yes, it's possible. :P

For a more serious answer, I'm not sure anyone has done that, although RO does it somewhat. That's probably more a question for the RO thread. If I make DRE too close to RO standards, although the people who like "stock KSP hardmode" will scream... :]

guitarxe: Pics of your pod, then pics during reentry, with the navball showing.

WololoW: you will need to add a temperatureCurve to Kerbol. RSS can do that for you, if you write one for it. DRE doesn't change bodies' temperatureCurves.

Motokid600: this really sounds like vsync might not be getting enabled properly for you. The reentry FX *do* flicker some, both in stock KSP and with DRE (to me, the same amount). They're flames; they're supposed to flicker.

Share this post


Link to post
Share on other sites

Well.. as you no dout know Nathan this issue has been goin on a long time. And if you've seen my videos I've posted then you should know it's severity. The problem isn't just visual its audio as well which is the worst of the problem. And its bad. Real bad. At this point I'm just asking to see if maybe over 5 months later someone else has experienced this bug as well.

As for the vsync being enabled properly.. idk. My 670s drivers are up to date. I've tried every type of vsync both in the application and in Nvidia control. The only thing that works is "every other v-blank" or half hz vsync. Both cap fps at 30 which fixes the problem. But 30fps is no bueno.

Are there any gpu experts here? Can someone maybe point me in the right direction as to whether or not this may be a hardware issue? I only experience this in ksp with DRE installed.. I gotta start trying something else here because I'm out if ideas. Why is it the reentry effects ( sound included ) are fine at 30fps yet at 60 they skip horrendously?

Edited by Motokid600

Share this post


Link to post
Share on other sites
Well.. as you no dout know Nathan this issue has been goin on a long time. And if you've seen my videos I've posted then you should know it's severity. The problem isn't just visual its audio as well which is the worst of the problem. And its bad. Real bad. At this point I'm just asking to see if maybe over 5 months later someone else has experienced this bug as well.

As for the vsync being enabled properly.. idk. My 670s drivers are up to date. I've tried every type of vsync both in the application and in Nvidia control. The only thing that works is "every other v-blank" or half hz vsync. Both cap fps at 30 which fixes the problem. But 30fps is no bueno.

Are there any gpu experts here? Can someone maybe point me in the right direction as to whether or not this may be a hardware issue? I only experience this in ksp with DRE installed.. I gotta start trying something else here because I'm out if ideas. Why is it the reentry effects ( sound included ) are fine at 30fps yet at 60 they skip horrendously?

You said 670s? As in, plural? That might be the issue. Even though your drivers are up to date, SLI can still be very stuttery for certain games.

I'd try disabling 1 670 and seeing if that helps.

Share this post


Link to post
Share on other sites

How can you get this to work for re-entry with spaceplanes?

Share this post


Link to post
Share on other sites
How can you get this to work for re-entry with spaceplanes?

It should already work nicely with spaceplanes, you just have to be more careful with your profile because if you come in too steeply your wings will overheat and explode.

Share this post


Link to post
Share on other sites

I also had KSP crash on me, output_log.txt said it crashed while 'compiling' the 1.25m heatshield. But after I removed DRC, it crashed on another Part, somthing from HGR, so I'm still investigating.

Oh, with HGR removed and DRC 5.2, it crashes on the .625m heatshield. Hmm. I will continue removing/adding mods until I'm reasonably sure which causes the crashes and post my findings.

EDIT: should propably have mentioned, I'm running the windows x64 build with a ton of other mods.

EDIT2: It appears to be this: http://forum.kerbalspaceprogram.com/threads/87049-x64-crashing-due-to-access-violation-error

Edited by Garek

Share this post


Link to post
Share on other sites

Hm... I'm working with RSS and I can't seem to have anything survive.

Share this post


Link to post
Share on other sites
justhearit: quoting myself.

TeeGee: yes, it's possible. :P

For a more serious answer, I'm not sure anyone has done that, although RO does it somewhat. That's probably more a question for the RO thread. If I make DRE too close to RO standards, although the people who like "stock KSP hardmode" will scream... :]

guitarxe: Pics of your pod, then pics during reentry, with the navball showing.

WololoW: you will need to add a temperatureCurve to Kerbol. RSS can do that for you, if you write one for it. DRE doesn't change bodies' temperatureCurves.

Motokid600: this really sounds like vsync might not be getting enabled properly for you. The reentry FX *do* flicker some, both in stock KSP and with DRE (to me, the same amount). They're flames; they're supposed to flicker.

Hi Nathan,

It's easy to blame it on the other modders. I installed vanilla, then I kept installing mods one by one. Game boots fine and works perfectly with every single mod. Lastly I install DRE. Game crashes (and I posted the link to my log in a previous post).

Share this post


Link to post
Share on other sites
Hi Nathan,

It's easy to blame it on the other modders. I installed vanilla, then I kept installing mods one by one. Game boots fine and works perfectly with every single mod. Lastly I install DRE. Game crashes (and I posted the link to my log in a previous post).

So...did you do as requested? Did you install DRE *FIRST* on a clean install?

Share this post


Link to post
Share on other sites

Sparker: moved your post to the appropriate thread.

justhearit: What you say about "easy to blame it on other modders" is quite true. That's why I'm asking you to verify the problem is actually in Deadly Reentry, so you aren't doing that very thing.

Share this post


Link to post
Share on other sites

I use RSS heatshields, but how would you use it for spaceplanes?

Share this post


Link to post
Share on other sites

Mostly you use high altitude aerobraking maneuvers. There are a couple of different approaches that might work for your plane, and Scott Manley demonstrates them both (with normal scale Kerbin):

I tend to use a combination of both. Just remember most space plane parts already include active heatshields that are effective when your angle of attack is 45 degrees.*

*Usually. I seem to remember reading that some of the mod parts out there are set to 90 degrees.

Share this post


Link to post
Share on other sites

As spaceplanes aren't yet supported by RO, we don't really have working RO-class shielding for them yet. For now, just turn up the reflectivity to .99 or so.

Share this post


Link to post
Share on other sites

hey guys. Testing out the Mk1-2 capsule in my role play and after getting it into 100km orbit I plan a steep re-entry to simulate a direct return from Mun. Any suggestions for the kind of angle I should be going for?

Share this post


Link to post
Share on other sites

Well Im ignoring the problem im having for now. It seems once you load the game up with enough graphical mods it slows my fps down so that its not really noticeable. Question. Is is normal for the mk1-2 heatshield to receive little heating coming from a direct entry from the Mun? I noticed little reentry effects and the shield itself was acting like it was a balloon. Im use to screaming through the cloud layers, but this shield had my probe falling straight down at 150m/s at 10km with no chutes.

Share this post


Link to post
Share on other sites
Well Im ignoring the problem im having for now. It seems once you load the game up with enough graphical mods it slows my fps down so that its not really noticeable. Question. Is is normal for the mk1-2 heatshield to receive little heating coming from a direct entry from the Mun? I noticed little reentry effects and the shield itself was acting like it was a balloon. Im use to screaming through the cloud layers, but this shield had my probe falling straight down at 150m/s at 10km with no chutes.

You're on stock Kerbin? You're only receiving about 1/3rd of the reentry heat that you would on Earth. From that perspective, yes it's normal. The first post has instructions for increasing the difficulty if you want a harder time.

Or install Real Solar System. That should be dangerous enough for you.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now