Sign in to follow this  
stephm

Rear landing Gear to complete stock part, need useful information recent information

Recommended Posts

Hi everybody !!

(I'm French and very bad in English, my whole post is in French forum)

I want to present you a almost finished Rear landing Gear, why almost because

I need serious information concerning this part.

Part work in Ksp but I'm not satisfied ...

the landing gear (to complete the stock part)

0ibL4r3.jpg

it's a full animated model , with flag, status light, maintenance light, light are all animated (retractable and directional)

(hydraulic system follow the actuator like real thing !), and all suspension part work.

(two model use same textue with bumpmap, and fake emissive for the gear light

it's a rendered blender picture, bumpmap is better in unity)

But I need some information about this :

Eoobqq1.png

I'm not enough good in English to find useful information !!

my setting work but I'm not sure .

And my last problem is the directional light based on module steering.

work perfect for the left model.

but the right model suffert an inversion on the steering axis

I have try everything, axis inversion, on target name and movers Name

even try to change the axis of the whole model, light stay inverted !!!!

in module "ModuleSteering" i have try the tag invertSteering it's have absolutely

no effect on part !!!!

For now The unique soluce I have find it's to do the thing manually, in KSP

by right clicking on part, but I want this part already configured on start.

if you have serious and fresh information for this type of part .........

Thank you very much by advance, (and sorry for my bad English, I'm very bad in French too lol)

steph

bye !

Edited by stephm

Share this post


Link to post
Share on other sites

Hello

Nice work!

Ignore the rigidybody error message, it's a unity thing. Every WheelCollider does that in KSP, even stock parts.

The units for the spring stiffness seem to be arbitrary. I'd suggest maybe a value of 5?

Weight is in tons, I believe. Though I'm not sure if KSP even pays any attention to it...

Could you post your part.cfg so I can have a look at that? KSP isn't really set up for handed parts, so sometimes a little fiddling is needed.

No need to apologise for bad English, most of us can't even speak a second language! :)

Share this post


Link to post
Share on other sites

hi !

thk , this part was originally intended for tuto purpose, but I'm a fresh

user of blender, and face after face it's become à real model !

For the 3d part all is good but not for the ksp side, information are old !!

(if I have time I make a simpliest model for tuto thing, for now my info setup

are very limited so is not good for a tuto part and model part !)

for lo-fi:

PART

{

// --- general parameters ---

name = TrainARDt45

module = Part

author = Steph

// --- asset parameters ---

MODEL

{

model = SmallGearBayAR/modelD

}

scale = 1

rescaleFactor = 1.126

// definition format is Position X, Position Y, Position Z, Up X, Up Y, Up Z, size

//node_stack_bottom = x, y, z, angx, angy, angz, size

//node_stack_top = x, y, z, angx, angy, angz, size

//node_attach = x, y, z, angx, angy, angz, size

node_attach = 0.0, 0.11438, -0.10883, 0.0, -1.0, 0.0

// symmetry rules: 0=1x, 1=2x, 2=3x, 3=4x and so on...

//stackSymmetry =

// --- editor parameters ---

TechRequired = advancedMotors

entryCost = 1000

cost = 30000

category = Utility

subcategory = 0

title = Train Arriere Droit Angulaire

manufacturer = Kerbal.Space.Industrie.Inc

description = Alliant force et élégance, ce train permet d'avoir une garde au sol non négligeable. 30 tonnes Max

// attachment rules: stack, srfAttach, allowStack, allowSrfAttach, allowCollision

//stack - Can your part be stacked on others?

//SrfAttach - Can your part be placed onto a surface?

//allowStack - Will you allow other parts to be stacked on your part?

//allowSrfAttach Can other parts be placed on the surface of yours?

//allowCollision - A special one: Can your part be placed if part of it is intersecting another part?

attachRules = 1,1,1,1,0

// --- standard part parameters ---

mass = 0.5

dragModelType = default

maximum_drag = 0.4

minimum_drag = 0.2

angularDrag = 0.05

crashTolerance = 50

breakingForce = 50

breakingTorque = 50

maxTemp = 1600

//------- module par defaut de KSP --------

MODULE

{

name = ModuleLandingGear

animationName = Train_AniD

suspensionParentName = sus_Deplacement

wheelName = Wheel

wheelRotationAxis = 1,0,0

deployedDragMax = 0.6

deployedDragMin = 0.3

}

// gestion triangle de suspension

MODULE

{

name = FXModuleLookAtConstraint

trackingModeString = FixedUpdate

CONSTRAINLOOKFX

{

targetName = Look_AT_Trsup

rotatorsName = Triangle_SUP

}

CONSTRAINLOOKFX

{

targetName = Look_AT_Trinf

rotatorsName = TriangleInf

}

}

MODULE

{

name = ModuleLight

lightName = Phare_diode

useAnimationDim = true

useAutoDim = false

lightBrightenSpeed = 2.5

lightDimSpeed = 2.5

animationName = phare_AniD

resourceAmount = 0.02

useResources = true

}

// gestion orientation light

MODULE

{

name = ModuleSteering

controlAxisType = Forward

steeringAxis = 0, 0, 1

steeringTransformName = Phare_Controle

steeringLocked = false

steeringCurve

{

key = 0 16

key = 10 9

key = 30 2

key = 100 1

}

}

MODULE

{

name = FXModuleConstrainPosition

matchRotation = true

matchPosition = false

CONSTRAINFX

{

targetName = Phare_Controle

moversName = Phare

}

}

// PUB

MODULE

{

name = FlagDecal

textureQuadName = Flag_Decal

}

}

The two part work very well (left and right) except the light inversion for right model

@+

Edited by stephm

Share this post


Link to post
Share on other sites

Ah, I think I know what's going on. Could you post a screen shot of the left and right hand Unity scene with the root gameobject selected in each please?

I've had this while experimenting myself, it is almost certainly to do with orientation in Unity before the part is exported. Should be easy to fix :)

Share this post


Link to post
Share on other sites

hi !

I' ve already tested that in unity and blender, inversed axe on concerned part, on the game object itself, but you are right

it's certainly that source of this problem is in unity !!!

I prepare à screenshot !

bye !

edit : jeudi 31/07/14

lo-fi about the rigid body look at this picture :

3Ejd1pC.jpg

it's just stock part, no mods stock install, they are problems, we have the possibility to inverse steering by KSP action (right click)

in game, that work fine even if the model it's not symmetrical oriented, I have already tested that with the left and right of my gear model.

we have this function in module steering (invertSteering), and configured in cfg part take no effect !!!!

I'm thinking this module don't recognize the symmetry in the model like module ModuleWheel, because I have passed 3 hours of tweaking all axis of the

right part, changing orientation to have the exact opposite model, changed orientation of wheelcollider, tested symmetry of movers light

each time for the right model the movement is inverted, if I turn left the light turn right.

I prepare for you screenshot in blender and unity for axe (demand little work be patient !)

bye!

Edited by stephm

Share this post


Link to post
Share on other sites

hi ! and we have picture :

here for blender :

wWbVj20.gif

for Unity

4AwAZKX.gif

and this is the game object tree :

5VNp6TW.jpg

as you can see, i have study all option with :

two axes in opposite side in this case i manage

the x and z axe, tested ( x, y), and (y , Z)

tested x pointing front it the same thing.

For me it's module problem's , don't recognise

the symetrie in model !

the invertsteering method is here to correct that i thing

but don't work in cfg file .................. ;.;

if you have tip

it's not a major problem.

solution is launch plane and tweak manualy the right

gear with invertsteering option that all !!, but I'm not

happy about that :D !

@+

Share this post


Link to post
Share on other sites

I planned to do this but didn't actually got to do it so here's a question because I planned it to be this: Does it fit if it is on the side of the Mk2 Parts? Because Mk2 parts need to have some lateral gears since they are slightly slant.

Share this post


Link to post
Share on other sites

Ok, you may not like this fix, but as far as I know, this will be the only way:

Make a new GameObject in exactly the same position as the root GO of the right hand part. Move all children of the root into the new GO, then rotate it 180 degrees around the Y axis. Move all children back to the original root GO.

It makes sense to rig in unity as you have, but KSP does not work like that. So rather than being symmetrical in the X axis, it mirrors in the Z. I _think_ that will do it, but I'm working from memory.

Why have steering on rear wheels, though?

Share this post


Link to post
Share on other sites

hi !

@Tommygun:

Merci ! thank .

@MightyDarkStar:

This is my problem release this type of part is not evident because the whole thing is a wild guess

how this type of part work, and all information are not clear or old so it's seem to be fully functional

but I'm sure they are some parameter need to be reworked !!

@blackheart612:

Not test tested for MK2 part, since I try to debug the light problem test are conduct on MK1 part

but it's possible to tweak the scale of the part by the rescale in CFG file, I'm looking for mk2 part :wink:

If you have the possibility to make this type of part for MK2 do it because it's lot of work especially when

things goes wrong.......

@lo-fi :

Why have steering on rear wheels, though?

:D it's a French special feature (Citroën car exactly), the landing light are base animated on the plane steer, when you are

on ground rolling if you turn right the light turn right too !

So it's my last try, because it's a worst thing to do each time, the part is complex and is broken fast in unity.

I make to other copy to attempt you idea !

I try and back for info thank !

steph

Share this post


Link to post
Share on other sites

I would say it has to much details (polys) for KSP

Share this post


Link to post
Share on other sites
.......much details (polys) for KSP

hi ! totally agree with you , it's also possible to keep only the main part

I mean no actuator, and hydraulic, for the moving element, but if you look in

my French post, it's a LOW poly modeling (box modeling) it's 20182 tri model's !!

Without the whole hydraulic animation the part are more reliable in term off size !

but less interesting :wink:

May be a fully part for 64bit owner and a simplified part for 32bit users .

@+

Share this post


Link to post
Share on other sites

i guess both. as long as he gets all the needed infos to complete this. i need this soooo hard! :D

Share this post


Link to post
Share on other sites
hi ! totally agree with you , it's also possible to keep only the main part

I mean no actuator, and hydraulic, for the moving element, but if you look in

my French post, it's a LOW poly modeling (box modeling) it's 20182 tri model's !!

Without the whole hydraulic animation the part are more reliable in term off size !

but less interesting :wink:

May be a fully part for 64bit owner and a simplified part for 32bit users .

@+

Yeah, sounds nice. It's a good looking part anyway :)

Share this post


Link to post
Share on other sites

hi !

@Cpt-Kipard:

the origin of this part was made for tuto purpose (like my whole post in French forum), but I have not enough information to make this

type of tutorial at this moment, it's a do-it-yourself (in French bricolage) based on old picture !

and by the challenge to learn thing in blender it's became a real part !!!!

And for now it's absolutely not a tutorial, but an heavily demand of information about landing gear part :blush: !!!

For tuto purpose see in my French post .

@lo-fi :

i'm back for lo-fi testing !

so :

1- made the new empty game object at the center of part G0

2- Moving the TrainARD_S3_final (look at the picture ) in the new game object

3- Rotate on Y axe 180 degres the new empty game object

4- replacing TrainARD_S3_final in original game object TrARD45

And the result ......

Not working, and i have some mistake appear in SPH

YjBJsSP.jpg

I'm loosing my cfg reference, not a big problem, but the icon representation

is broken, i don't like at all !!!

i have made a test with the new compiled part (white light), as you see on picture

and to show you this useless feature lol but funny !!

0wyt4gR.gif

I have correct the problem by right clicking the invertsteering option !

And I think it's the best solution at this moment lol !!

lo-fi, :blush: in my first first attempt I'm pretty sure I have already tested this type of tweak !

but voilà you have the result of the manipulation.

you know it's not an important problem the gear work (need just some tweak concerning the

physic Wheel Collider).

We need a real SDK information about this type of part..................

is the fact, but the are so many module, each module have it's own reference, it's lots of work

to compile information for modding !!!

even so for now I'm focuse on the Wheel Collider setup in unity, the gear is very strong in braking !

to much brake !!!

lo-fi big thank to follow me and if you have another idea about the light orientation I keep a debug model

under the hood to test strange thing :D !

@+

Edit tested with MK2 part :

9kGkgad.jpg

Edited by stephm

Share this post


Link to post
Share on other sites
hi ! totally agree with you , it's also possible to keep only the main part

I mean no actuator, and hydraulic, for the moving element, but if you look in

my French post, it's a LOW poly modeling (box modeling) it's 20182 tri model's !!

Without the whole hydraulic animation the part are more reliable in term off size !

but less interesting :wink:

May be a fully part for 64bit owner and a simplified part for 32bit users .

@+

Nice model, quite over complex (especially small details) and 64 or 32b is the same, as poly (triangles in fact) goes as-is to GPU, so it would make more sense to make a high-poly version for people who own a big GPU (which spend most of its time "à se tourner les pouces", = doing nothing :P) and the less detailed one for those who play on small GPU and/or low-mem Gfx boards.

Share this post


Link to post
Share on other sites

You might want to take a look at the Squad landing gear and lower the susspension's stiffness on yours to below the Squad ones. That way they will let the rear sit below the rest of the aircraft and help with take-off. or perhaps get a plugin coder and make a tweakable stiffness slider?

Share this post


Link to post
Share on other sites

hi every body !!

And thank all for feedback !!!

@Justin-Kerbice:

:D

.............. "à se tourner les pouces", = doing nothing

yeah notice that too héhé ..

For hight poly version I keep that in my mind but demand lot of rework, and remapping, if I do that it's will

be on the main object, main object (the landing gear case) is a very very low poly object, and is aspect look

very angular on some view angle (hard too explain my English is poor ...)

@Galacticruler:

Yes I'm seriously look at the smallgearbay cfg's part, I'm conduct test on a heavily modified AERIS4

modified to 20 t.

With à plane of mass 20t the gear is completely compressed so I have upgraded the spring parameter to 40

and now the gear suspention is return on middle position.

This is the aeris :

Lc5iIIH.png

I have corrected some graphic and animation bug on the landing gear (see French post for tuto info !!).

nWBP0R9.png

As I said in French forum, I'm continue to tweaking the wheelCollider physics, testing the stiffness factor

and I have to resolve strong breaking too, may be it's linked with the stiffness factor I don't know

the unity doc is very frugal (en francais succinct not sure for the englis word)

For next i want to make a little logo (perhaps the birds on the picture presentation on the first post)

and create a manufacturer

In cfg file i use this : Kerbal.Space.Industrie.Inc.

I have to verify if is free or not !!

For a release, I'm thinking to release here for testing the actual part, and after the people

reaction made a final product, consisting of a low model resolution and high detailed model !

You have to consider too, it's probably my first and last part for KSP, we all have problem in life

and i have problem too.... but they have no place here to discuss that :wink:.

I don't have uploader, i use this Putfile it's good for you ?

voilà

@+

EDIT : 1/08/14

Tempted to make 2048 texture pack not in MBM or TGA format (too big)

but in PNG, it's seem they are problem in space with the 2048 png texture, appear

very black, I'm starting looking forum to see the exact compilation format, for PNG

and BumpMap, the Bummap texture as a weird coloration in png !!!!!!!

both texture are compiled in DXT5 !

Edited by stephm

Share this post


Link to post
Share on other sites

hello !

@MightyDarkStar:

Merci thank, yep they are bug, visual bug concerning the bumpmap :blush: !!!

Today I have planified a second release to add a pack of png texture in 2048 size.

But in fact at this stade it's not possible why :

I can't manage the way to create a proper and decent normal Map.

I have tool Photoshop cs3 license, and NVidia filter, superpngplugin, but no I 'can't.

- starting to a grayscale map -> convert with the NIvidia tool result a normal map with not enought height, in

ksp, the bump is ridiculous and practically absent !!!

- Starting a grayscale map in unity whoa it's beautiful , in render view -> convert to MBM ok (I'm not sure here for the format ! dxt ???)

- 1 work but you have to manage the resolution of you're bumpmap to catch the result

- 2 my case : Main template 4096 convert to 1024 you have a mess in KSP if you have download

the part, the bump is ugly du to the reduce map, I'm in the impasse at this stade ......

- trying to produce a png normal with Unity give simplified normal map, in KSP it's awful!!

- trying to convert MBM to png :confused:.

I don't understand the state of the MBM normal map, information is stocked on transparency ?

here this a sample of my normal map made with photoshop :

zLr216i.png

in KSP the effect is almost null..., may be my map is wrong somewhere ....

but they look good for me no !!!

I take a pose, for today I'm looking this problem tomorrow !!

thank

steph @+

Edited by stephm

Share this post


Link to post
Share on other sites

For your normal map:

1. does the unity setting are correct ? A normal map should be named something_NRM.<format>, also unity editor ask for fixing it usually when you first start using a texture as normal/bump map. Is the material set right ? (KSP/Bump-something, specular, or other)

2. to add more bump, gimp have some nice settings of depth, level, etc, does PS have such settings ? If not, too bad (or maybe through an expensive dedicated plug-in).

One example here.

Share this post


Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this