[b]Do you use the [u]Desaturated Texture Pack?[/u][/b]  

270 members have voted

  1. 1. [b]Do you use the [u]Desaturated Texture Pack?[/u][/b]

    • Yes, the grey textures are more stock-like
      134
    • No, the green-orange textures are fine
      39


Recommended Posts

1 hour ago, TheKurgan said:

-snip-

@allista By the way the Configurable Containers included in Hangar 3.3.1 has no parts folder in it... the Configurable Containers as a separate download from SpaceDock does have a Parts folder... not sure if this was a mistake?

 

I'm sure @allista did not do this on purpose, I seen that too *refers to my previous posts* (parts is required for proper working I think)

Edited by LatiMacciato

Share this post


Link to post
Share on other sites
1 hour ago, LatiMacciato said:

I'm sure @allista did not do this on purpose, I seen that too *refers to my previous posts* (parts is required for proper working I think)

This was always the case, actually. At least for 4 months:

https://github.com/allista/hangar/commit/a9a3072127eb1c479e171cf3070d00ac3a5c9051

Hangar does not require the patches, so it does not include them. Especially taking into account the conflicts they cause with other fuel switchers.

Share this post


Link to post
Share on other sites
4 hours ago, jjjaaayyy said:

oh no.... Where is spaceport?

The last I checked (2 seconds ago) it's in the archive where it should be. So probably and installation problem.

Share this post


Link to post
Share on other sites
On 2017. 2. 25. at 10:26 PM, allista said:

The last I checked (2 seconds ago) it's in the archive where it should be. So probably and installation problem.

So, What can I do? 

Share this post


Link to post
Share on other sites

Just wondering, do kerbonauts that are in vessels that have been stored in hangars gain experience during the time that they are in the hangar? (wondering because I have a Jool mission with a lander ship planned , and I'm wondering whether I have to cart the whole lander all the way to Jool loaded outside a hangar, or whether the crew will gain EXP in the hangar)

Share this post


Link to post
Share on other sites
On 3/2/2017 at 1:33 AM, NexusLink said:

Just wondering, do kerbonauts that are in vessels that have been stored in hangars gain experience during the time that they are in the hangar? (wondering because I have a Jool mission with a lander ship planned , and I'm wondering whether I have to cart the whole lander all the way to Jool loaded outside a hangar, or whether the crew will gain EXP in the hangar)

Kerbonauts are not placed into the hangar in any special way: they're just transferred to vacant seats of available crewable parts of the receiving ship. So they continue to exist in a normal way, receiving experience as any other kerbals do.

Share this post


Link to post
Share on other sites

Hi Allista,

I've been having lots of crashes in the SPH lately. The last thing in the log right before the crash is:

Autogen thumbnail for C:/Program Files (x86)/Steam/steamapps/common/Kerbal Space Program/KSP_x64_Data/../thumbs/Holistic Space Exploration_SPH_Minmus Rover.png from C:\Program Files (x86)\Steam\steamapps\common\Kerbal Space Program\saves\Holistic Space Exploration\Ships\SPH\Minmus Rover.craft
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

File 'C:\Program Files (x86)\Steam\steamapps\common\Kerbal Space Program\GameData\000_AT_Utils\Plugins\..\000_AT_Utils.user' does not exist
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

Crash!!!

(Emphasis by me)

Is this an installation problem? I can upload the entire log if you need.

Share this post


Link to post
Share on other sites
9 minutes ago, FirroSeranel said:

Hi Allista,

I've been having lots of crashes in the SPH lately. The last thing in the log right before the crash is:

Autogen thumbnail for C:/Program Files (x86)/Steam/steamapps/common/Kerbal Space Program/KSP_x64_Data/../thumbs/Holistic Space Exploration_SPH_Minmus Rover.png from C:\Program Files (x86)\Steam\steamapps\common\Kerbal Space Program\saves\Holistic Space Exploration\Ships\SPH\Minmus Rover.craft
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

File 'C:\Program Files (x86)\Steam\steamapps\common\Kerbal Space Program\GameData\000_AT_Utils\Plugins\..\000_AT_Utils.user' does not exist
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

Crash!!!

(Emphasis by me)

Is this an installation problem? I can upload the entire log if you need.

This is not an installation problem and this message is harmless: it just informs that AT_Utils tried to load a config file and failed because it does not exist. This is part of the normal operation.

The cause of the crash is somewhere else. And as CTDs go, you'll probably find nothing related in the logs, because the logs are written by a living Unity instance, while at the moment of the "crash" it is terminated by the OS. So only native stack traces or core dumps could help to debug here.

Share this post


Link to post
Share on other sites
2 minutes ago, allista said:

This is not an installation problem and this message is harmless: it just informs that AT_Utils tried to load a config file and failed because it does not exist. This is part of the normal operation.

The cause of the crash is somewhere else. And as CTDs go, you'll probably find nothing related in the logs, because the logs are written by a living Unity instance, while at the moment of the "crash" it is terminated by the OS. So only native stack traces or core dumps could help to debug here.

how to collect them? (might also be helpful in my particular case with the grabber)

Edited by LatiMacciato

Share this post


Link to post
Share on other sites
13 minutes ago, allista said:

This is not an installation problem and this message is harmless: it just informs that AT_Utils tried to load a config file and failed because it does not exist. This is part of the normal operation.

The cause of the crash is somewhere else. And as CTDs go, you'll probably find nothing related in the logs, because the logs are written by a living Unity instance, while at the moment of the "crash" it is terminated by the OS. So only native stack traces or core dumps could help to debug here.

 
 

I have core dumps, but I don't know how to read them. Obviously they're in code of some kind... is there an app that can make sense of them?

I did a total delete, CKAN cache wipe, and reinstall of AT_Utils and everything dependent on it (Hangar, TCA, Ground Construction, Configurable Containers, MKS), and it seems to have solved it... so far, anyway. Keeping fingers crossed.

Edit: Nope, crashed again as soon as I went back into the game after posting this. D:

Edited by FirroSeranel

Share this post


Link to post
Share on other sites
7 minutes ago, FirroSeranel said:

I have core dumps, but I don't know how to read them. Obviously they're in code of some kind... is there an app that can make sense of them?

I did a total delete, CKAN cache wipe, and reinstall of AT_Utils and everything dependent on it (Hangar, TCA, Ground Construction, Configurable Containers, MKS), and it seems to have solved it... so far, anyway. Keeping fingers crossed.

Edit: Nope, crashed again as soon as I went back into the game after posting this. D:

My long-term KSP experience is that there are times where whatever combination of mods you have installed makes the game unstable with no obvious cause. My current installation with ~100 mods crashes somewhat frequently and literally never closes properly. If I try to exit the game, I get the "stopped working" dialog box; the game never closes gracefully. 

Usually the only way this stops is either with game and mod updates it randomly goes away, or when I start a new career with a different mod list it sometimes stops. I have a high-end gaming system btw. 

Some people never see problems, and try to tell the people who DO have problems that it's their system. Even with heavily modded installs. Some people can't even get a stock game to stop crashing in the VAB/SPH. Wish I had concrete advice but really, this is a long-time issue with KSP.

Share this post


Link to post
Share on other sites
3 hours ago, drhay53 said:

My long-term KSP experience is that there are times where whatever combination of mods you have installed makes the game unstable with no obvious cause. My current installation with ~100 mods crashes somewhat frequently and literally never closes properly. If I try to exit the game, I get the "stopped working" dialog box; the game never closes gracefully. 

Usually the only way this stops is either with game and mod updates it randomly goes away, or when I start a new career with a different mod list it sometimes stops. I have a high-end gaming system btw. 

Some people never see problems, and try to tell the people who DO have problems that it's their system. Even with heavily modded installs. Some people can't even get a stock game to stop crashing in the VAB/SPH. Wish I had concrete advice but really, this is a long-time issue with KSP.

 

Yeah, I never close gracefully either with my mod list, which I currently have trimmed down to about 60 mods. I'd love to keep running with 100+, but the load times are just mind-numbing. If I could be sure it would load once and then stay up for a few days, fine, but it doesn't stay stable that long, and with crashes, it's just not worth it, so I keep parts mods to a reasonable level.

Anyway, I narrowed it down to a conflict between JSI Advanced Transparent Pods, and Feline Utility Rovers' latest update. Posted in both places, so hopefully one of them will be able to figure out what's up.

Share this post


Link to post
Share on other sites
32 minutes ago, FirroSeranel said:

Yeah, I never close gracefully either with my mod list, which I currently have trimmed down to about 60 mods. I'd love to keep running with 100+, but the load times are just mind-numbing. If I could be sure it would load once and then stay up for a few days, fine, but it doesn't stay stable that long, and with crashes, it's just not worth it, so I keep parts mods to a reasonable level.

Anyway, I narrowed it down to a conflict between JSI Advanced Transparent Pods, and Feline Utility Rovers' latest update. Posted in both places, so hopefully one of them will be able to figure out what's up.

Typically what happens with me is I will crash relatively quickly after starting the game, and then after that it will last quite a while.

Anyway, I don't have either of those mods installed, and I still crash and don't exit gracefully :/

Share this post


Link to post
Share on other sites
On 3/8/2017 at 0:59 AM, nascarlaser1 said:

hanger is not on the newest version of ckan :(.

I'm seeing it just fine:

cMhFERc.png

Share this post


Link to post
Share on other sites
On ‎3‎/‎9‎/‎2017 at 5:41 AM, allista said:

I'm seeing it just fine:

cMhFERc.png

huh... it says AD next to it on my list :( (my orginal problem of it not appear was caused by my own fault of forgetting to let CKAN auto update the list :P).

Share this post


Link to post
Share on other sites
2 hours ago, nascarlaser1 said:

huh... it says AD next to it on my list :( (my orginal problem of it not appear was caused by my own fault of forgetting to let CKAN auto update the list :P).

That's because you've installed it manually. If you delete the folder and refresh CKAN, the AD should go away.

Share this post


Link to post
Share on other sites
1 hour ago, 0111narwhalz said:

That's because you've installed it manually. If you delete the folder and refresh CKAN, the AD should go away.

oh ok. I must of messed up the manual install because there were no parts in game.

Share this post


Link to post
Share on other sites

Why are my solar panels deploying from ground and inline hangars when I launch a vessel? It fits fine with them stowed but when they deploy it causes everything to flip out and explode. The payload fairing hangar doesn't do this (and is something I don't ever want to play without now, it's amazing.)

Share this post


Link to post
Share on other sites
On 3/14/2017 at 6:37 AM, oniontrain said:

Why are my solar panels deploying from ground and inline hangars when I launch a vessel? It fits fine with them stowed but when they deploy it causes everything to flip out and explode. The payload fairing hangar doesn't do this (and is something I don't ever want to play without now, it's amazing.)

Didn't quite catch the situation. You launch a vessel with solar panels that were stowed at the moment of docking into the hangar, but when it is launched, the panels appear deployed again, correct? :0.0:

Have you stored this vessel in the editor, or in flight?

Are the panels stock or from a mod?

I myself have launched the stock "ion probe" microsatellite from the inline hangar without problems, so this should be something trickier.

 

Share this post


Link to post
Share on other sites

Also: If you're running MechJeb, check your MechJeb utilities settings.  Make sure it isn't auto-deploying for you.

Share this post


Link to post
Share on other sites

Panels were stowed when put in the hangar in the editor. The ones in particular I was using at the time were from Near Future, but I got some different but also kind of weird behavior with stock 2x3 panels where they were deployed but the graphics didn't reflect that, they stayed in the stowed position but still generated electricity and rotated around to track the sun

Mechjeb's auto deploy was turned off.

I'll do some more testing and see if I can figure it out.

Share this post


Link to post
Share on other sites

Hey, what mod is the radial engines attached to the Mk3 fuel tanks from that video? I don't believe it is this mod but I am seeing it everywhere coming from this mod. Help please?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.