magico13

[1.4.1] Kerbal Construction Time 1.4.0.69 (2018-03-24) - Unrapid Planned Assembly

Recommended Posts

Am I correct in assuming, that, with the part inventory gone, I will have no benefits of using stage recovery in a science only career?

Share this post


Link to post
Share on other sites
18 minutes ago, Manimal said:

Am I correct in assuming, that, with the part inventory gone, I will have no benefits of using stage recovery in a science only career?

Unless you are also using it to recover Kerbals and/or science then you are correct, it won't be that beneficial in a science only career.

Share this post


Link to post
Share on other sites
9 hours ago, magico13 said:

Unless you are also using it to recover Kerbals and/or science then you are correct, it won't be that beneficial in a science only career.

Thanks for the clarification. But maybe the feature will come back in future versions of KCT? It was a nice feature to be honest, it rewarded proper resource handling with faster build times.

Share this post


Link to post
Share on other sites

This may be moot since you're working on a new version anyway, but one thing I'm running into a lot with 1.3.4 on 1.1.3 is the game stopping over and over when I 'warp to complete' because some ship is changing SOI.  The thing is, it's the same ship, and it's claiming it's changing SOI every few minutes, even though it's currently orbitting the Sun (playing RO/RP0) on a very long transfer orbit from earth to venus.

Share this post


Link to post
Share on other sites
1 hour ago, Maxsimal said:

This may be moot since you're working on a new version anyway, but one thing I'm running into a lot with 1.3.4 on 1.1.3 is the game stopping over and over when I 'warp to complete' because some ship is changing SOI.  The thing is, it's the same ship, and it's claiming it's changing SOI every few minutes, even though it's currently orbitting the Sun (playing RO/RP0) on a very long transfer orbit from earth to venus.

I had the same problem. Not sure if it's a KCT issue or a stock one.

Share this post


Link to post
Share on other sites
6 hours ago, Maxsimal said:

This may be moot since you're working on a new version anyway, but one thing I'm running into a lot with 1.3.4 on 1.1.3 is the game stopping over and over when I 'warp to complete' because some ship is changing SOI.  The thing is, it's the same ship, and it's claiming it's changing SOI every few minutes, even though it's currently orbitting the Sun (playing RO/RP0) on a very long transfer orbit from earth to venus.

 

5 hours ago, garwel said:

I had the same problem. Not sure if it's a KCT issue or a stock one.

I get this issue a lot with just Kerbal Alarm Clock mis-reading SOI changes, or forgetting to delete old SOI change notifications. Are wither of you using Alarm Clock mod?

Share this post


Link to post
Share on other sites
11 minutes ago, vardicd said:

 

I get this issue a lot with just Kerbal Alarm Clock mis-reading SOI changes, or forgetting to delete old SOI change notifications. Are wither of you using Alarm Clock mod?

I sure do. They don't look like KAC standard notifications though and they are not marked in KAC event list. Anyway, they don't seem to be related to KCT.

Share this post


Link to post
Share on other sites
8 minutes ago, garwel said:

I sure do. They don't look like KAC standard notifications though and they are not marked in KAC event list. Anyway, they don't seem to be related to KCT.

They actually are a KCT thing. They were added in prior to me taking over the mod in January of 2014 and I think I've seen it pop up like once since then. I generally forget it exists. They come up when you're warping and a vessel reports that it's SOI changed, so it stems from a Stock issue of mis-reporting an SOI change. I can just disable that code because Kerbal Alarm Clock can also stop KCT's warp code and if you care about an SOI change you should be using alarms.

Share this post


Link to post
Share on other sites
8 hours ago, magico13 said:

They actually are a KCT thing. They were added in prior to me taking over the mod in January of 2014 and I think I've seen it pop up like once since then. I generally forget it exists. They come up when you're warping and a vessel reports that it's SOI changed, so it stems from a Stock issue of mis-reporting an SOI change. I can just disable that code because Kerbal Alarm Clock can also stop KCT's warp code and if you care about an SOI change you should be using alarms.

I've been wondering what it was that caused those.  

Looking forward to using your work in 1.2.  I'm finally going to start playing again using 1.2, once you deliver KCT.  I know it is just another way to play "let's pretend," and I can fudge it all on my own with a little bit of work anyway, but man, I just feel like KCT adds so much to the game.  Thank you for your efforts, magico.  I appreciate it.

Share this post


Link to post
Share on other sites
15 hours ago, magico13 said:

They actually are a KCT thing. They were added in prior to me taking over the mod in January of 2014 and I think I've seen it pop up like once since then. I generally forget it exists. They come up when you're warping and a vessel reports that it's SOI changed, so it stems from a Stock issue of mis-reporting an SOI change. I can just disable that code because Kerbal Alarm Clock can also stop KCT's warp code and if you care about an SOI change you should be using alarms.

That'd be great.  Usually they don't bother me - I just close the popup and go on with life - but this constant misreporting means that now I can't really use the 'warp to complete' anymore.  Of course I can work around it, accelerating time normally while in space center works, but it'd be nice to have back!.   Thank you!

Share this post


Link to post
Share on other sites

Started a brand new career last night and when I went to open the window to upgrade the facilities, only part of the window appeared....like just the top.  I found the ksp log and it had a ton of NREs in it. I exited KSP, started it again, and no problems.  Just an FYI...I don't have any log to share because I just had too much fun playing and forgot about the problem until now....

Fantastic mod....I'm already a half year in and haven't even reached orbit yet, unlike my first career game where that was like in the first week....

Share this post


Link to post
Share on other sites
15 hours ago, Cetera said:

-Snip-
I know it is just another way to play "let's pretend," and I can fudge it all on my own with a little bit of work anyway, but man, I just feel like KCT adds so much to the game.  Thank you for your efforts, magico.  I appreciate it.

This^ I've been using this mod for so long, base KSP is just unplayable without it.

Share this post


Link to post
Share on other sites

True, true. This is the very last mod I need updated to restart my career game...

Share this post


Link to post
Share on other sites
4 hours ago, beelzerob said:

Started a brand new career last night and when I went to open the window to upgrade the facilities, only part of the window appeared....like just the top.  I found the ksp log and it had a ton of NREs in it. I exited KSP, started it again, and no problems.  Just an FYI...I don't have any log to share because I just had too much fun playing and forgot about the problem until now....

This is a known bug, related to new games only. Have you had any problems with a KCT window in editor?

Share this post


Link to post
Share on other sites
1 hour ago, Astraph said:

True, true. This is the very last mod I need updated to restart my career game...

same here, FeelsBadMan, the wait is giving me extra chromosomes.

Share this post


Link to post
Share on other sites

Agreed.  I tried to play without it but I'm hooked.   XD

(No pressure.   Just sincere appreciation of the mod.)

Share this post


Link to post
Share on other sites
1 hour ago, garwel said:

This is a known bug, related to new games only. Have you had any problems with a KCT window in editor?

No other problems.

Share this post


Link to post
Share on other sites
5 hours ago, Chainsaw Expert said:

same here, FeelsBadMan, the wait is giving me extra chromosomes.

Made my evening. And then I saw your nick. Signing off, I've had enough Interwebz for today. XD

Share this post


Link to post
Share on other sites
20 hours ago, Chainsaw Expert said:

same here, FeelsBadMan, the wait is giving me extra chromosomes.

That's because @magico13 put all his points into R&D and only a couple into the VAB.  ;-)  The worst part is once the 1.2-compatible construction is complete, there's still rollout and conditioning before we get to use it.

 

Seriously, though - take your time, dude.  We're all eager, but most of all we're all super stoked and appreciative of all the effort you've taken to provide this awesome mod.

Share this post


Link to post
Share on other sites
1 hour ago, cnhorn said:

So did I miss something...downloaded the pre-release from Github (https://github.com/magico13/KCT/releases/tag/v1.3.4.1) unzipped and dropped in the game folder...Still says its the wrong version,  KickA mod by the way!!!  I feel like it adds to the Lifesupport mod making time actually matter!

You're doing more than I could....I DL'd it and nothing even happened....

Share this post


Link to post
Share on other sites
1 hour ago, cnhorn said:

So did I miss something...downloaded the pre-release from Github (https://github.com/magico13/KCT/releases/tag/v1.3.4.1) unzipped and dropped in the game folder...Still says its the wrong version,  KickA mod by the way!!!  I feel like it adds to the Lifesupport mod making time actually matter!

Check out the dev thread. There are two links: @JeffreyCor's compilation (in a zip) and a new DLL (1.2_2). Combine them in your GameData folder and it should work.

Share this post


Link to post
Share on other sites
1 hour ago, cnhorn said:

So did I miss something...downloaded the pre-release from Github (https://github.com/magico13/KCT/releases/tag/v1.3.4.1) unzipped and dropped in the game folder...Still says its the wrong version,  KickA mod by the way!!!  I feel like it adds to the Lifesupport mod making time actually matter!

What they said :)

After installing the starter kit, create a folder called Plugins under KerbalConstructionTime (As Magico has specifically directed it to go there now. Dobby does as master says :wink: ) Download the 1.2_2 DLL into the Plugins folder. Then delete the 1.2_1 DLL from KerbalConstructionTime. You should be good to go then :)

Share this post


Link to post
Share on other sites
2 hours ago, JeffreyCor said:

What they said :)

After installing the starter kit, create a folder called Plugins under KerbalConstructionTime (As Magico has specifically directed it to go there now. Dobby does as master says :wink: ) Download the 1.2_2 DLL into the Plugins folder. Then delete the 1.2_1 DLL from KerbalConstructionTime. You should be good to go then :)

It doesn't have to go under plugins, but that's where it goes normally. It doesn't actually matter as long as you don't have duplicates.

 

I also had uploaded a base .zip in the same directory as the .dlls that can be used

Edited by magico13

Share this post


Link to post
Share on other sites
9 hours ago, JeffreyCor said:

What they said :)

After installing the starter kit, create a folder called Plugins under KerbalConstructionTime (As Magico has specifically directed it to go there now. Dobby does as master says :wink: ) Download the 1.2_2 DLL into the Plugins folder. Then delete the 1.2_1 DLL from KerbalConstructionTime. You should be good to go then :)

ummm, where would i download this 1.2_1 dll...... and what do i do about magic core? i have done all i can think of with what i can find, and no result.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.