Jump to content

[1.2.2] B9 Aerospace | Release 6.2.1 (Old Thread)


Recommended Posts

How would I do that? I landed my craft and then hit escape and return to spaceplane hangar. Are you talking about the stuff that shows when you crash?

If it's in one of the crashlog folders, then yeah, though sometimes it doesn't put the output log in there for some reason. If it's not in there (and you've just crashed from the problem), then just go to KSP main directory > KSP data folder and in the KSP data folder is the output log, zip that (the output log, not the whole folder), and put it up on a file hosting place of your choice.

Link to post
Share on other sites
Is it normal that all the parts have buggy textures (as if there is another copy of the part inside a part and it clips through differently with camera angle)

It's not normal. Are the mesh/fuel switch features working? If not, then firespitter.dll is not working - reinstall it from the 5.2.8 download (or snjo's github page) and make sure there aren't any older versions lurking in GameData somewhere.

Link to post
Share on other sites

The HX parts seem to have some issues with radial decouplers in that they (or anything radially attached to them) will just get stuck on whatever they're radially attached to.

Haven't had the chance to test without KJR because my test without it with the ship I'm using led to instant disassembly of it, even struts didn't help.

Link to post
Share on other sites

Guys dunno if this is the place to report a problem or not but here i go. when i launch my ship some parts suddenly unstick from each other and fall on the ground. Anything like lights and rcs etc still works and action groups also work. even the struts stretch out to the ground. When i time ward at-least x2 the parts go back to their original place but when i unwarp they fall again. Anyone know this issues and how to deal with it? Should i just reinstall all my mods>

Link to post
Share on other sites
Are there updated versions of ResGen and KineTech? Don't seem to be having any problems, but the version checker popup every time kind of bugs me.

Not as far as I know. Several modders (okay, two, maybe three) that I've talked to have expressed concern about KineTech throwing exceptions, so I've removed that. All KineTech does is a bunch of animations, so it shouldn't break anything by removing it.

The AVC also says that B9 itself was meant for 0.25, so yeah it's popping up about that as well.

Link to post
Share on other sites

Soooooo. I've been skimming through the thread all the way back to December. That fuel mesh switch thing just isn't working for me. I've verified there's just one firespitter.dll in gamedata. I've tried the one that comes with B9 (R5-2-8 is the latest in github). I've tried the newest dll from the firespitter website (March 1 version). And just to be sure i've launched the craft with a tank set to LFO, and it is definitely not full of fuel. Is there a particular version of firespitter.dll i should be using?

I have a dunce cap handy if there's another obvious solution.

Link to post
Share on other sites
Soooooo. I've been skimming through the thread all the way back to December. That fuel mesh switch thing just isn't working for me. I've verified there's just one firespitter.dll in gamedata. I've tried the one that comes with B9 (R5-2-8 is the latest in github). I've tried the newest dll from the firespitter website (March 1 version). And just to be sure i've launched the craft with a tank set to LFO, and it is definitely not full of fuel. Is there a particular version of firespitter.dll i should be using?

I have a dunce cap handy if there's another obvious solution.

So wait. You can see the fuel switch options in the VAB/SPH, but they don't carry over in-flight? If firespitter wasn't working outright, you wouldn't see them at all, so this would seem to be more complicated. 1) Do the tanks show up as empty or do the tanks not show up at all and 2) Could you post output_log.txt?

Link to post
Share on other sites

Ahhh, B9. My favorite mod, and IMO the one that adds the most. Just IMO.

I'm a huge fan of the HX Parts, I love building capital ships, carriers, and stations. That said I'd personally love to see more HX parts, and specifically an HX cockpit.

Also, the 3 sided hub, the HX1-S-H3 for some reason WILL NOT connect to part's when the cut corners are aligned with other parts that have that cut angle, but you can attach stuff to it just fine. Kinda make's it useless in that regard...

If there's a proper place to report a bug I'd like to know. Also, if i should so desire, how would one go about making their own part's for this mod?

Link to post
Share on other sites

I commented about the fuel changing texture but not adding the tanks a few weeks back with no response. Nice to see someone else getting one lol. I only get fuel in them if I have modular fuel tanks enabled

Link to post
Share on other sites
Ah, the tanks do not show up at all, but the names and textures do. And here's the output_log.txt.

DaMichelsFuselage mod is telling ModuleManager that RealFuels is installed. You should report this in the thread for that mod. The patches should be @PART[Whatever]:NEEDS[RealFuels but instead they're @PART[Whatever]:FOR[RealFuels]. The FOR keyword tells MM that that mod is installed, hence all of the B9 patches for RF are activating even though RF isn't actually installed.

- - - Updated - - -

Also, the 3 sided hub, the HX1-S-H3 for some reason WILL NOT connect to part's when the cut corners are aligned with other parts that have that cut angle, but you can attach stuff to it just fine. Kinda make's it useless in that regard...

Try it with the stock 6 way hub, and you'll get the same result. The only option is to (a) rotate it until it attaches, which probably ruins symmetry, or (B) enable part clipping. Not much B9 can do to fix it...

Link to post
Share on other sites
I deleted the RF patch from the B9 folder and I now have fuel in each of my tanks again :) thanks for pointing out it was a MM patch issue!

It looks like DaMichel fixed the issue recently. Probably best to update in case you run into other mods with RF patches.

Link to post
Share on other sites
i have no idea who DaMichael is or wha

- - - Updated - - -

i have no idea who DaMichael is or what he does.

Ah, sorry, confused you with achroma, who's issue was coming from the DaMichelsFuselage mod. If you don't have this mod, then there's something else in your install telling MM that RF or MFT is installed even though it isn't. You've deleted the B9 patch, but there are plenty of other mods this could cause a problem for if you don't figure out what it is.

Link to post
Share on other sites
Guest
This topic is now closed to further replies.
×
×
  • Create New...