Jump to content

[KSP v1.1.3] Stock Bug Fix Modules (Release v1.1.3b.1 - 10 Jul 16)


Recommended Posts

Thanks, again, for the "LargeCraftLaunchFix.dll" fix.

No problem! Thanks for the feedback. It's great to hear it's all working nicely together. :D

More importantly, as you have discussed with others, it is more in keeping with another aim of this bugfix pack: to provide examples of how the stock game should work.

Thanks for what you said. And this snippet right here is probably why I've been slow to finish this particular fix. The handling of the main pool is sort of a hack job at the moment, since I'm still trying to work within the rest of the resource code. I will try to get this into a user workable state and release, probably separate from the other fixes, so that I can get some other eyeballs on it for feedback.

Thanks,

~Claw

Link to post
Share on other sites

I've found a bug/incompatibility with these - if AnchoredDecouplerFix.dll is present, the fairings in the KW Rocketry mod don't work properly: they fall inwards instead of outwards. Also, symmetry appears to break: I trigger my fairings with the action groups, and each press of the action group key triggers only each individual fairing half (or third for the biggest ones).

Link to post
Share on other sites
I've found a bug/incompatibility with these - if AnchoredDecouplerFix.dll is present, the fairings in the KW Rocketry mod don't work properly: they fall inwards instead of outwards. Also, symmetry appears to break: I trigger my fairings with the action groups, and each press of the action group key triggers only each individual fairing half (or third for the biggest ones).

Hmm. I'll try to look into this. I haven't used KW Rocketry at all, but I can't imagine why the decoupler fix would interfere with action groups. It seems more likely that the symmetry fix would be more problematic, but I'll take your word for it until I can test it.

Cheers,

~Claw

Link to post
Share on other sites

I looked at the code - it definitely has something to do with ModuleAnchoredDecoupler. KW fairings use it - the other fairings I use (PF and AIES) do not. It also has a negative value for the ejectionForce.

I have noticed some oddities with the staging with and other parts involving anchored decouplers... when I get back home I'll see if I can reproduce it consistently before I report it here.

Link to post
Share on other sites

Yeah, KW decouplers tend to act a little.. annoyingly at times. I can confirm the fairing decoupler bug (probably because they, for some reason, use a negative force. I don't think it's related to ModuleAnchoredDecoupler as I have a MM config that changes all those to ModuleDecouple and it still happens) and the stack decouplers never seem to decouple - they fire, smoke puffs out, but all that happens is the icon moves to the current stage. Nothing is decoupled and then I end up with a big expensive rocket heading back down towards Kerbin with no hope of recovery or reverting.. just as an example..

I will note that the stack decoupler problems have been around for me as long as KWR has, but the fairing decoupler problems appear to be related to Claws fixes. No worries, pFairings are cheaper and lighter on part count anyway.

Link to post
Share on other sites
I looked at the code - it definitely has something to do with ModuleAnchoredDecoupler. KW fairings use it - the other fairings I use (PF and AIES) do not. It also has a negative value for the ejectionForce.

I can certainly fix the negative ejection force in my code (easily), but I'm hesitant to do it blindly without knowing why the KW fairings have it set that way. Perhaps the KW fairings are set up that way in an attempt to fix the existing stock problem? I do use the existing EjectionForce in my code rather than applying a set value (so that tweakscale works correctly).

I'll probably go ahead and fix the negative ejection force as an error check, in case other add-ons have done something similar.

I'm still unsure what would cause the action group problems.

and the stack decouplers never seem to decouple - they fire, smoke puffs out, but all that happens is the icon moves to the current stage. Nothing is decoupled and then I end up with a big expensive rocket heading back down towards Kerbin with no hope of recovery or reverting.. just as an example..

Is this a KW problem or are you saying it's something with my bug fixes? You said it's been around "for you as long as KWR," but I just wanted to make sure.

Cheers,

~Claw

Link to post
Share on other sites

Just found this mod and already looking forward to using it tonight. Was getting fed up of my rover pilots falling asleep at the wheel - and as for the number of times my boosters have taken my main engine off despite separatrons and tailfins and setting them as far down as possible and ohdeargodwhy?!? Only had the chutes thing happen once, but man it'll be nice to know it won't happen again.

Thanks for working on this, I'm sure many many players will find it of benefit :)

Link to post
Share on other sites

Yes, thank you. I've found benefit from them as well. I'm using the EVA and Decoupler fixes, solved all the issues I was having with such. Is there anything in the works regarding the undocking of the Clamp-o-tron Sr? I hit a snag with that yesterday and today (mentioned in the 'What did you do today?' thread)... I couldn't get them to undock, and I'm not wanting to use the suggestions posted regarding exiting out and editing the files.

Link to post
Share on other sites
Thanks for working on this, I'm sure many many players will find it of benefit :)

You are quite welcome. I'm glad it's been helpful for people. :D

Is there anything in the works regarding the undocking of the Clamp-o-tron Sr?

I have looked into this and it's in my list of possible things to fix. It's actually pretty easy to do the fixing part. The really hard part is detecting when it's broke. Imagine applying a "fix" to something that isn't actually broken. It has potential to cause a lot of problems. I could probably build something that has a "Press this to reset at your own risk." button, but that still seems problematic to me since the idea is to reduce bugs, not make them worse. I have built quite the extensive "self help" thread that covers fixing docking port problems, but I also understand the reluctance to get into the save and start messing with things.

Claw I'm experiencing the same issue as Obsessed as well as symmetrical staging not staging symmetrically and I'm also using Tweakable Everything so it is most likely a conflict between the two.

My AnchoredDecouplerFix is going to have some incompatibility with Tweakable Everything due to how each of our mods are mechanized. My mod must take over the ejection force from the main Anchored Decoupler Module (and the Module's ejection force is set to zero). Tweakable Everything looks at that value in flight. It's been reported that with TE and my mod, TE will show negative values inflight. I tried to do what I could to ensure that the tweaked values from the VAB are used, but I haven't tested TE myself.

If I'm misunderstanding and an incompatibility with TE is causing this problem, then please let me know. I might be able to dig into TE a little and see if I can make my mod more compatible. What I really don't understand is why the symmetrical staging would be broken. My AnchoredDecouplerFix doesn't use or even look at action groups or staging. Unless there is some error checking in TE that is confused by what I've done.

Cheers,

~Claw

Link to post
Share on other sites
*Snip* My mod must take over the ejection force from the main Anchored Decoupler Module... TE will show negative values inflight. I tried to do what I could to ensure that the tweaked values from the VAB are used, but I haven't tested TE myself. *snip*

I can attest to the negative values, in the VAB without your fixes but with TE, decouplers show a default ejection value of 250 which is mid-level on the slider. With your fixes it defaults at -400 and the slider is maxed.

As for the symmetrical staging, it's weird. The stage icons drop off one by one with each press of the spacebar, parts are ejected with zero velocity and when they're all gone, an empty stage is left.

Example:

Stage 1: 2x SRBs

Space

Stage 1: 1x SRB

Space

Stage 1: Empty

Space

Stage 2: Active

Link to post
Share on other sites

I can't remember where I read this, but isn't there some issue when removing mods that either have flags, or agencies where you've completed a contract, that afterwards you cannot enter the VAB and the Space Center locks up? Would there be some way to 'clean up' after that?

I know this may not fall in the realm of a stock bug fix but if you're wanting to go back to stock I know this is an issue. Any way to fix that issue?

(EDIT) FYI I figured this out. Delete whatever mod you want, fire up the game and on the Space Center screen go into the Debug Menu. Under contracts you can clear the history, do that. I also cleared the current offer list and regenerated a new list. After that I was able to enter all the buildings with no issues.

Edited by Eleven
Link to post
Share on other sites

Claw, you seem to know your way about. I'd like to offer you a challenge. Perhaps, it is too deeply embedded in the KSP code, but here it is.

EVA rotation.

Currently, Kerbals can translate left-right, up-down, and forward-backward. Kerbals can rotate about the Y-axis (the axis going from head downward). I would like Kerbals on EVA to tilt forward-backwards (X-axis, the axis going left-right through their hips).

Might that be possible? I understand that EVAs are handled like vessels. Yet, vessels have six degrees of freedom; kerbals have four. Why Squad failed to implement this is a question.

Edited by Apollo13
Link to post
Share on other sites

There's an issue with the 1-to-n (where n is 2, 3 or 4) adapters. I first noticed it with this project where I had to figure out the order for the missile staging off the bottom of the 1-to-4 adapter. If I didn't put the stages in that order, the missile engines would not activate with the decouplers.

Even when staging all together off the bottom of those, with some rockets it appears that only one decopuler actually releases while the others just explode from the next stage exhaust.

For extra weirdness, with the Kerbodyne sized decoupler having physics significance set to 1 (behaving as zero mass in flight) and flipped upside down to stage the decopuplers and tanks off the top of stacks mounted to the sides of stacks attached below a 1-to-n decoupler - all kinds of crazy shiznit would happen.

A huge amount of force would be directed downward (from the normal top side of the large decoupler) destroying whatever was directly below the decopupler, and not all of the large decouplers in that stage would go off. Delete the physics significance line or change the 1 to 0 and they'd work normally when used upside down. Right side up with no in-flight mass and they'd also work.

I initially thought it could be an artifact of scaling up those adapters to Kerbodyne size so (this was before I found the physics line in the large decouplers, a line none of the others have ever had) so I built all stock test rockets with Kerbodyne stacks attached onto small ones under the multi adapters. Bug perfectly duplicated.

It was only after that I had a look at the decoupler cfgs. Here's a test rocket with the large decouplers upside down. http://pastebin.com/93j5GJpY

Launch it as is, it works. Add PhysicsSignificance = 1 to the size3decoupler cfg in the parts folder under NASA mission to see how the weirdness with the 1-to-4 adapter affects it. Then flip the TR-38-D's upright.

But the oddity persists with the 1-to-n adapters. Try my Armed Camp rocket and re-arrange the stage order of the four missiles.

Link to post
Share on other sites
Claw, you seem to know your way about. I'd like to offer you a challenge. Perhaps, it is too deeply embedded in the KSP code, but here it is.

EVA rotation.

Currently, Kerbals can translate left-right, up-down, and forward-backward. Kerbals can rotate about the Y-axis (the axis going from head downward). I would like Kerbals on EVA to rotate forward-backwards (X-axis, the axis going left-right through their hips).

Might that be possible? I understand that EVAs are handled like vessels. Yet, vessels have six degrees of freedom; kerbals have four. Why Squad failed to implement this is a question.

A mod already exists to address that, it's called FreeEVA

Link to post
Share on other sites
EVA rotation.

...

Might that be possible?

Yes. Actually I think I could do this. In fact, I think I could add keybindings so you can select which keys you want to use too (though I'd have to verify that).

A mod already exists to address that, it's called FreeEVA

FreeEVA does help. It dosen't actually do anything to how EVA works, but it does allow you to switch EVA types on-the-fly (at least, last time I checked). Each mode has times when it's handy.

Cheers,

-Claw

Link to post
Share on other sites
A mod already exists to address that, it's called FreeEVA

thank you. Forum rep point to you for that. I tested it just now, and allows me to tilt forward-backwards, rotating about the hips-axis. I can then hit W-key to go in that direction.. That mod ought to be stock. I can even rotate about the axis going through the navel, out the backside. This mod is now one of my MUST-HAVE mods (such as kdata, SelectRoot, Kerbal Alarm Clock, and Claw's fixes). Now, if Claw comes-up with something even more intuitive...

Edited by Apollo13
Link to post
Share on other sites
Now, if Claw comes-up with something even more intuitive...

So I did look into this. As I was thinking, it's easy to be able to spin and turn the kerbal however I want. Unfortunately, the code to do it properly (i.e. control the RCS and animations) is buried a bit deeper. I will keep this in mind to work on as I dive deeper, but I think it'll be a while before I end up with anything more useful than FreeEVA that looks descent.

Cheers,

-Claw

Link to post
Share on other sites
So I did look into this. As I was thinking, it's easy to be able to spin and turn the kerbal however I want. Unfortunately, the code to do it properly (i.e. control the RCS and animations) is buried a bit deeper. I will keep this in mind to work on as I dive deeper, but I think it'll be a while before I end up with anything more useful than FreeEVA that looks descent.

@Claw: thanks for looking into this. FreeEVA-0.2.0 and FirstPersonEVA satisfy my request perfectly. So, no need to waste your efforts there.

I do have another EVA challenge (far simpler, I imagine). When a Kerbal is on EVA and hovering about a station or vessel, I'm constantly tinkering with the WASD keys to stay in place in relation to that vessel. That's because WASD/Shft/Ctrl is clumsy which cannot be fine-tuned, such as with RCS in docking mode.

My suggestion is to provide a toggle whereby the kerbals X/Y/Z velocity vector match those of the vessel. Thus, the kerbal isn't moving in relation to the vessel. When the player pushes the WASD/Shft/Ctrl keys, the Kerbal translates in that direction. Upon release of the key, the kerbal's X/Y/Z velocity vectors are then set to those of the vessel again.

This assumes the vessel's roll/pitch/yaw (X/Y/Z rotation velocity vectors) are 0. It's incumbent upon the player to ensure that. It's a bit much to ask of you to take those in consideration as well.

If there are two or vessels in the vicinity, it would be nice if the player can select the vessel. Perhaps a simple solution is to match whatever vessel the kerbal was last in or attached to (via a ladder)

As I mentioned, this functionality should be a toggle in the kerbal's context menu, so the kerbal can fly about without limitations, when necessary.

Now, when/why would I use this? EVERY EVA I would go on. I would toggle the thing on as a default (maybe add that to a CFG file?) I use KAS's functionality a lot to relocate and replace equipment on vessels. So I currently have to tinker with the WASD keys while trying to place the item precisely. Your function would ease that pain tremendously. I also transfer kerbals between station parts and habitats via EVA instead of KSP v0.25 EVA Transfer function (yeah, I'm old school. Using the Transfer function between modules that are not directly connected seems like "cheating" to me.)

thanks, again, for all your work to fix Squad's failures. I wish is that Squad would do a release whereby they concentrated ONLY on bug fixes (As Space Engineers and Prison Architect do). Players would be far happier to be able to play with the game they've got instead of the bug-ridden PoS that Squad wants. In both SE and PA, players have universally applauded bug-squash/no-new-features releases.

Edited by Apollo13
Link to post
Share on other sites
My suggestion is to provide a toggle whereby the kerbals X/Y/Z velocity vector match those of the vessel. Thus, the kerbal isn't moving in relation to the vessel. When the player pushes the WASD/Shft/Ctrl keys, the Kerbal translates in that direction. Upon release of the key, the kerbal's X/Y/Z velocity vectors are then set to those of the vessel again.

This is an interesting proposal. Although it might be a bit straying from my original purpose of trying to track down and fix some of the more problematic bugs. I will also keep this in mind, although I imagine that it'll be a bit before I get to this. It might also be a worthy suggestion for the add-on public at large.

I could definitely see this as being useful.

Cheers,

~Claw

Link to post
Share on other sites

Hi claw,

I don't know if it has been mentioned yet, but is there a possibility to make a fix to the fuel flow logic -like CrossFeedEnabler does- that does not require a separate MODULE node? It seems to be a stock problem...

Thanks in advance,

Regards

Link to post
Share on other sites
is there a possibility to make a fix to the fuel flow logic -like CrossFeedEnabler does-

Hmm. I don't use CrossFeedEnabler. Perhaps you can tell me more details about the problem you're referring to?

Cheers,

~Claw

Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...