shaw

[1.6.x--1.7.x] TextureReplacer 3.7 (25.1.2019)

Recommended Posts

[Nevermind]Hmmm, 2.2.4 seems to make reflectan parts even less clickable :P

Will have to disable real reflections :/[/Nevermind]

EDIT: Now they work :P

Cheers!

Share this post


Link to post
Share on other sites
I came acrose a set of 8K planet textures but they were from the old Universe replacer mod, so I was wondering what the file setup needs to look like in the default file so texture replacer will recognize them as planet textures. Thanks Brian

Look in the README file for TextureReplacer. Right near the top, All the texture names/file setup (plus a lot of other useful information) can be found there.

Share this post


Link to post
Share on other sites
Same issue for me. It's like Jeb dropped some acid...

http://imgur.com/a/Bs2Ql

Everything works just fine in-game, though. Just makes me think I'm having a flashback. :confused:

Was it working correctly in 2.2.3?

Share this post


Link to post
Share on other sites
Was it working correctly in 2.2.3?

Yep. I've just swapped the DLL from 2.2.3 back in for now. Everything's back to normal.

Oh, and I'm also using Astronomer's pack. Don't know if that matters, though.

To me it looks like the textures are being loaded somewhat randomly. Some of them look like normal maps, and the first time I noticed this, uhh, undocumented psychedelic feature, the moon had a black and yellow stripe round the equator - looked like it was wearing a decoupler texture. Didn't get a screenie of that, though.

Share this post


Link to post
Share on other sites
Yep. I've just swapped the DLL from 2.2.3 back in for now. Everything's back to normal.

Oh, and I'm also using Astronomer's pack. Don't know if that matters, though.

To me it looks like the textures are being loaded somewhat randomly. Some of them look like normal maps, and the first time I noticed this, uhh, undocumented psychedelic feature, the moon had a black and yellow stripe round the equator - looked like it was wearing a decoupler texture. Didn't get a screenie of that, though.

I've reverted immediate texture unloading in 2.2.5, it should be fixed now.

Share this post


Link to post
Share on other sites
I've reverted immediate texture unloading in 2.2.5, it should be fixed now.

Indeed it is. Works a treat.

I'm constantly amazed by this community. Better customer service here than many companies - quick fixes and helpful people. And all for something people do in their free time for fun.

The people on these forums turn a fun game into a fantastic one. :)

Share this post


Link to post
Share on other sites

So I am interested in adding reflections to windows of some stock parts, or maybe other mods for my own use much like the reflections on several parts in Vens Stock Parts Revamp. My question is, how do you figure out what the mesh name is that you need to put in the .cfg file? Using Vens as an example, not all of the parts have the same mesh name for reflective surfaces, so I am curious how to figure that out.

Share this post


Link to post
Share on other sites
So I am interested in adding reflections to windows of some stock parts, or maybe other mods for my own use much like the reflections on several parts in Vens Stock Parts Revamp. My question is, how do you figure out what the mesh name is that you need to put in the .cfg file? Using Vens as an example, not all of the parts have the same mesh name for reflective surfaces, so I am curious how to figure that out.

`logReflectiveMeshes` in `@Default.cfg`.

- - - Updated - - -

Thanks shaw, it works. :)

Here's some awesome pics.

http://imgur.com/a/YFEvp

So which one of those options solved the problem?

Share this post


Link to post
Share on other sites
Same issue for me. It's like Jeb dropped some acid...

Just makes me think I'm having a flashback. :confused:

Use In-A-Gadda-Da-Vida menu music and you've got yourself a mod pack!

Share this post


Link to post
Share on other sites
`logReflectiveMeshes` in `@Default.cfg`.

- - - Updated - - -

So which one of those options solved the problem?

I disabled mipmap generations.

Share this post


Link to post
Share on other sites

New version not working with A.T.M.. Helmet refection is turned into a white square.

EDIT: Never mind, I fixed it :sticktongue:

Edited by Eskandare

Share this post


Link to post
Share on other sites
Er, that's the stock suits pack in that link.

So it is. Sorry for being so late fixing it. https://www.dropbox.com/s/n87igxtafslcdnm/GregroxMun%27s%20CrappySuits.zip?dl=0

Shaw, if you would please note in the OP that I fixed the link to CrappySuits? :)

- - - Updated - - -

Shaw, would it be possible to give the Kerbal a different model? If so, would it be by any means easy to get the right rigging in a custom-made model? If so, then this opens up a huge new range of possibilities for mods. Starting with the obvious: Human astronauts in RSS. Not to mention that people could make revamps of the Kerbal model and use them in-game.

Would it be possible? If so, practical?

Share this post


Link to post
Share on other sites
So it is. Sorry for being so late fixing it. https://www.dropbox.com/s/n87igxtafslcdnm/GregroxMun%27s%20CrappySuits.zip?dl=0

Shaw, if you would please note in the OP that I fixed the link to CrappySuits? :)

- - - Updated - - -

Shaw, would it be possible to give the Kerbal a different model? If so, would it be by any means easy to get the right rigging in a custom-made model? If so, then this opens up a huge new range of possibilities for mods. Starting with the obvious: Human astronauts in RSS. Not to mention that people could make revamps of the Kerbal model and use them in-game.

Would it be possible? If so, practical?

No need to fix the link in OP, it doesn't link directly to the file but to the post.

Changing the model is theoretically possible, but practically impossible. The new model should match the old one with all nodes, bones, animations, probably even mesh and texture names ...

Share this post


Link to post
Share on other sites

I seem to remember some discussion about some seemingly magical images of clouds in the new visor reflections. Some people had them, others didn't. I did some experimentation with a kerbal on EVA and hyperedit and found that it is altitude related, and for kerbin you must be above 160 KM for clouds to appear (161 is what I put into hyperedit, to ensure I stay above 160). I also found that the visor reflections do not show drop shadows on parts....That might be asking a little much though....

https://www.dropbox.com/s/ym0tc4a70khj3aw/Screenshot%202015-02-07%2019.28.36.png?dl=0

https://www.dropbox.com/s/eauslbqhizfr1iw/Screenshot%202015-02-07%2019.32.35.png?dl=0

Share this post


Link to post
Share on other sites

I got some problem when using this mod along with Ven's Stock Revamp, specifically the Gigantor XL Solar panel. It cause black screen, throwing "Look rotation viewing vector is zero" errors in the log, and usually ends with a crash. Tested with texture replacer 2.2.5 and 2.2.4, both causes this problem.

Share this post


Link to post
Share on other sites
I got some problem when using this mod along with Ven's Stock Revamp, specifically the Gigantor XL Solar panel. It cause black screen, throwing "Look rotation viewing vector is zero" errors in the log, and usually ends with a crash. Tested with texture replacer 2.2.5 and 2.2.4, both causes this problem.

What about 2.2.3?

Share this post


Link to post
Share on other sites

A couple posts back I asked about how to figure out what meshes names are on individual parts in order to add reflections. I was told to enable the reflective logs which I did, but I don't see anywhere in the logs that would indicate a list of meshes for a part. Could someone offer an example? Or another way of identifying part meshes. I would like to add reflections to the cupola part for instance.

Share this post


Link to post
Share on other sites
A couple posts back I asked about how to figure out what meshes names are on individual parts in order to add reflections. I was told to enable the reflective logs which I did, but I don't see anywhere in the logs that would indicate a list of meshes for a part. Could someone offer an example? Or another way of identifying part meshes. I would like to add reflections to the cupola part for instance.

Meshes are printed only for parts with TRReflection module.

Share this post


Link to post
Share on other sites
2.2.3 did not crash! Yay!

I know what's wrong then; the method for hiding mesh while reflections are rendered. So one method makes airlocks non-clickable and the other one this. And I'm afraid there's no other way to hide a mesh.

- - - Updated - - -

OK, so if I apply the TRReflection module to a part, without specifying a mesh, will it then give a list of the meshes?

It prints all meshes for all parts with TRReflection, no matter whether they have "meshes" option.

Share this post


Link to post
Share on other sites
I know what's wrong then; the method for hiding mesh while reflections are rendered. So one method makes airlocks non-clickable and the other one this. And I'm afraid there's no other way to hide a mesh.

It's alright, I will just comment out the solar panel from the TR cfg for Ven's part. That seems to make it works with 2.2.5.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.