pellinor

[1.3] TweakScale v2.3.6(May-28)

1189 posts in this topic

Yep, still experiencing problems with TweakScale. The behavior now is with craft files. If the craft files were saved before 1.52.1, the part costs on tweakable parts are zeroed. This means that crafts will need to be rebuilt with the parts from the part catalog in order to experience costs. Not sure if I can word this better, but I will try to edit it if this is unclear.

Share this post


Link to post
Share on other sites
Yep, still experiencing problems with TweakScale. The behavior now is with craft files. If the craft files were saved before 1.52.1, the part costs on tweakable parts are zeroed. This means that crafts will need to be rebuilt with the parts from the part catalog in order to experience costs. Not sure if I can word this better, but I will try to edit it if this is unclear.

Not near my game to test, but try remove and replace, or reroot, that may be enough of a rebuild to make it work.

Share this post


Link to post
Share on other sites

My guess is that this only affects parts that were added while using v1.52, and that you need to delete the part and take a new one to fix it.

Share this post


Link to post
Share on other sites

Hey, I'm getting significant breakage here. I'm trying to create a tower of 10M tanks for life support resources. Ok... I had to edit defaults config... The version that was briefly out, worked great for 10m, previously and now I'm back to editing the config file myself... Anyway, I get the design in the VAB... good, put it on the pad (or EL construct it) and it rezes up normal, then switch away or the game crashes and I come back, and it is completely and utterly glitched out. On the EL construction site, only the lower of the two tanks is glitched, on the launchpad I have just a single tank hovering, all of the decorations and secondary equipment is gone. =\

Share this post


Link to post
Share on other sites

All scaletypes use scaleFactors now, max/minScale is obsolete.

Could you please give some example how to use the new features.

I like to create a high grained freescale part, how to do it?

Share this post


Link to post
Share on other sites

One question: by "max/minScale is obsolete" do you mean that it is now simply not necessary or that it is now not even functional? I worry about older configs not responding as expected... not that it's happening just yet, but then again I have yet to test all of my parts that have a tweakable scalability setting on them.

Share this post


Link to post
Share on other sites

The DefaultScales.cfg file provides examples how I would do it. Define the scaleFactors just like you would before for a discrete scaleType, these are the numbers you can reach without using the slider. Highly grained means large steps? You can do this with the slider increment, either globally or separately for each interval. For example the default stack config snaps to 0.1m increments for the largest sizes to allow for round numbers.

If you have any configs that do not give the result you want, I'll gladly look through them.

Share this post


Link to post
Share on other sites

After Updating from 1.50 to 1.52.1 on a mod heavy install I get this error and loading stops:

IndexOutOfRangeException: Array index is out of range.
at TweakScale.GoodspeedTweakScale.Setup () [0x00000] in <filename unknown>:0

at TweakScale.TweakScale.OnLoad (.ConfigNode node) [0x00000] in <filename unknown>:0

at PartModule.Load (.ConfigNode node) [0x00000] in <filename unknown>:0

at Part.AddModule (.ConfigNode node) [0x00000] in <filename unknown>:0

at PartLoader.ParsePart (.UrlConfig urlConfig, .ConfigNode node) [0x00000] in <filename unknown>:0

at PartLoader+.MoveNext () [0x00000] in <filename unknown>:0

(Filename: Line: -1)

IndexOutOfRangeException: Array index is out of range.
at TweakScale.GoodspeedTweakScale.Setup () [0x00000] in <filename unknown>:0

at TweakScale.TweakScale.OnStart (StartState state) [0x00000] in <filename unknown>:0

at Part.ModulesOnStart () [0x00000] in <filename unknown>:0

at Part+.MoveNext () [0x00000] in <filename unknown>:0

Share this post


Link to post
Share on other sites

Would it be possible for the FX scaling of engines to support smokescreen?

Share this post


Link to post
Share on other sites
One question: by "max/minScale is obsolete" do you mean that it is now simply not necessary or that it is now not even functional? I worry about older configs not responding as expected... not that it's happening just yet, but then again I have yet to test all of my parts that have a tweakable scalability setting on them.

At the moment min/max values are still used if TweakScale does not find any scaleFactors. So everything is still backwards compatible. (Maybe ksp 1.0 will be a good point do drop obsolete stuff like this)

Share this post


Link to post
Share on other sites
After Updating from 1.50 to 1.52.1 on a mod heavy install I get this error and loading stops:

IndexOutOfRangeException: Array index is out of range.
at TweakScale.GoodspeedTweakScale.Setup () [0x00000] in <filename unknown>:0

at TweakScale.TweakScale.OnLoad (.ConfigNode node) [0x00000] in <filename unknown>:0

at PartModule.Load (.ConfigNode node) [0x00000] in <filename unknown>:0

at Part.AddModule (.ConfigNode node) [0x00000] in <filename unknown>:0

at PartLoader.ParsePart (.UrlConfig urlConfig, .ConfigNode node) [0x00000] in <filename unknown>:0

at PartLoader+.MoveNext () [0x00000] in <filename unknown>:0

(Filename: Line: -1)

IndexOutOfRangeException: Array index is out of range.
at TweakScale.GoodspeedTweakScale.Setup () [0x00000] in <filename unknown>:0

at TweakScale.TweakScale.OnStart (StartState state) [0x00000] in <filename unknown>:0

at Part.ModulesOnStart () [0x00000] in <filename unknown>:0

at Part+.MoveNext () [0x00000] in <filename unknown>:0

Exchanging GoodspeedTweakScale with TweakScale helps to eliminate the problem:

@PART[*]:HAS[@MODULE[GoodspeedTweakScale]]:FIRST
{
@MODULE[GoodspeedTweakScale]
{
%name = TweakScale
}
}

Share this post


Link to post
Share on other sites

When I use a scaled up part it's fine on launch but when I reload the scene with that vessel the rescaled parts have all reverted to their originial size. Is there a fix for that?

Share this post


Link to post
Share on other sites
Exchanging GoodspeedTweakScale with TweakScale helps to eliminate the problem

I'm surprised that this legacy module is still in use. Which mod does that config come from?

Would it be possible for the FX scaling of engines to support smokescreen?

Any idea what would be needed to support that? If it can be done with a simple config then I'll gladly include it.

When I use a scaled up part it's fine on launch but when I reload the scene with that vessel the rescaled parts have all reverted to their originial size. Is there a fix for that?

For the root part there is no fix (this is a KSP bug). For other parts, I can't reproduce any reverting.

Edited by pellinor

Share this post


Link to post
Share on other sites
For the root part there is no fix (this is a KSP bug). For other parts, I can't reproduce any reverting.

Ok thx for the reply.

Share this post


Link to post
Share on other sites

Is their a config for making the science experiments tweakscaleable.

(procedural parts/fairings works w/ tweakscale if you install them together at the same time - just so you guys know.)

Share this post


Link to post
Share on other sites
Is their a config for making the science experiments tweakscaleable.

(procedural parts/fairings works w/ tweakscale if you install them together at the same time - just so you guys know.)

You could make science experiments tweakable, but there's no point - nothing in the science experiment will change with size, I don't think.

Share this post


Link to post
Share on other sites
You could make science experiments tweakable, but there's no point - nothing in the science experiment will change with size, I don't think.

Some (all?) of Dmagics science stuff can be tweakscaled, and yeah, changing the size only affects the weight of the part, the science is unaffected.

Share this post


Link to post
Share on other sites

I know, but I just want them to be smaller for missions that involve sending certain experiments to other worlds and to certain orbits.

Share this post


Link to post
Share on other sites

Hello,

First let me say I wish I knew beforehand that TS has TSE which scales rates; I have to look at my resource rates for the size in question of my model now; luckily I havnt got to bogged down with to many rates on too many parts; the whole reason I am using this is to save valuable game memory; at least this will come in handy for storage parts and module generators with resource rate changes being a little more advanced isnt such a big deal; I finally had to read the manual to understand rate effects and how to control them; I will be fixing my parts hopefully to look as good as they work now; that is whenever I get them to work (!) they keep breaking !

I am in total agreement that MODS should have their own TS-data; this is probly gonna be one of the best MODS out there; I got one part that has 7 or so versions; now with this and fuelswitch I have 1 part with 7 versions + 3 sizes each (!); well just ALOT more flexibility.

As for Science; effects; it gets more technical probly. One can always write a module generator in the Science part and reflect a rate change (!); maybe.

Cmdr Zeta

Share this post


Link to post
Share on other sites
I'm surprised that this legacy module is still in use. Which mod does that config come from?

At least Goodspeed Aerospace Parts for one, from which TweakScale originated I believe. The current status is that it works with 0.90 but you have to use a patch to deal with the mild texture rearrangement of 0.25 KSP; I just modified my copy of that patch as suggested by Kolago to deal with this issue with modern TweakScale support and KSP started loading again. (I just posted over in that thread Kolago's fix for the problem.) I'm still testing the results before starting up my new career game.

Share this post


Link to post
Share on other sites

oh sweet jesus thanks for the update, though you should definitively update the old thread to point people here!

I've had this damn problem for a while http://webmup.com/RxWkU/vid.webm (attachment note not scaling down), but as far as I can see this version fixed it :)

Share this post


Link to post
Share on other sites

I'm having an issue where a part keeps reverting to default size, in this case 1.25m. I've tried changing the values on the parts Tweakscale module, with no effect. The part is mechanically still 3.75, at least in capacity, so it's maybe just a visual bug? I've reproduced it, by reverting to a backup and launching again, too.

Save, craft file, persistant.sfs: https://www.dropbox.com/sh/7wex0e3g10w0ly0/AADkDgUG-f2q62OgZ9UauznXa?dl=0

Image: http://i.imgur.com/AX49DPA.png

Share this post


Link to post
Share on other sites

I can't check, but was that the root part? If so, don't do that. It's a stock KSP bug that's triggered by rescaling the root part.

Share this post


Link to post
Share on other sites

There is 2 mods I would love to see added to TweakScale compatability. K.Yeon's OPT and PolecatEZ's D12 Aerotech, namely its the wings I am hoping can become rescalable. I know that I COULD write my own config but as I am not a coder or a programmer it is beyond the scope of my capabilities, I have tried but it is too confusing for me.

Share this post


Link to post
Share on other sites

Anyone else seeing there parts revert to their original scale when they scene change?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now